В руководстве использованы материалы сайта OSzone.net. Применение материалов данного руководства в печатных или электронных изданиях, включая электронные статьи, должно сопровождаться указанием адреса сайта OSzone.net и имени автора.

  • Компьютерные статьи
  • Компьютерный форум
  • Каталог программного обеспечения

FAQ по Microsoft Windows XP (версия 2.0)

Введение

Автор: Blast
Последнее обновление: 22.11.2006
Версия: 2.0

Что нового

  • Обновлены все разделы
  • Добавлено 35 новых вопросов

Полезные ссылки:

  • FAQ по Windows XP
  • FAQ по Windows 2000/2003
  • Статьи по Windows XP
  • Статьи по Windows 2003
  • Форум по Windows XP
  • Форум по Windows 2000/2003
  • Статьи компьютерной тематики
  • Компьютерный форум
  • Каталог программного обеспечения

Если у вас есть пожелания, советы, полезные данные по наполнению данного FAQ просьба обращаться по этому адресу.

Если вы не нашли ответа на свой вопрос, то можете задать его на нашем форуме: http://forum.oszone.net.

Также можете ознакомиться с материалами нашего сайта: http://www.oszone.net

Внимание: Применение материалов данного руководства в печатных или электронных изданиях, включая электронные статьи, должно сопровождаться указанием адреса сайта OSzone.net и имени автора.

Перейти к перечню всех вопросов FAQ по Microsoft Windows XP

Все вопросы вы можете задать на нашем форуме. Последнюю версию FAQ вы можете найти здесь (онлайн версия).

© Все права защищены OSzone.net 2001-2007


Полный перечень вопросов FAQ по Microsoft Windows XP (версия 1.0)

  • Каталог программного обеспечения

    версия 2.0

FAQ по Microsoft Windows XP

Полный перечень вопросов FAQ по Microsoft Windows XP

  • Установка/Загрузка/Выключение

  1. При установке некоторых приложений (например MS Office 2000) другой пользователь на этом компьютере должен эту программу установить повторно. Как сделать установку для всех пользователей компьютера.

  2. Как переустановить Windows XP поверх, то есть без удаления параметров и программ

  3. Как убрать "Приветствие" при загрузке компьютера.

  4. Как отредактировать boot.ini для загрузки двух версий Windows с разных разделов.

  5. Вместо выключения компьютер перезагружается.

  6. При загрузке ошибка: файл hal.dll повреждён или отсутствует.

  7. Как восстановить повреждённый загрузчик Windows XP.

  8. Как выбрать нужную версию ядра и HAL ещё при установке.

  9. Как добавить и отредактировать сообщение, которое будет выводить при загрузке компьютера.

  10. Как изменить ядро системы

  11. Какие параметры можно применять в boot.ini

  12. Как произвести установку в режиме обновления с Windows XP Home RUS на Windows XP Professional ENG

  13. Установлена Windows XP, на другом разделе была Windows 2000, которая теперь удалена. Как избавиться от меню выбора ОС при загрузке.

  14. Как выполнить «чистую» загрузку в Windows XP

  15. Использование «чистой» загрузки для устранения неполадок в Windows XP

  • Настройка

  1. Как отключить автоматическое распознавание диска (CD-Rom).

  2. Как перейти от файловой системы NTFS к FAT32.

  3. Какую файловую систему лучше выбрать FAT32 или NTFS.

  4. Как переключиться с тонального набора на импульсный?

  5. Как изменить букву локального диска или CD.

  6. Как отключить сообщение о том, что недостаточно свободного места на диске.

  7. Как настроить систему на запрос пароля при выходе из ждущего режима.

  8. В меню "Установка компонентов Windows" Windows XP нет некоторых программ. Как их удалить.

  9. Где можно задать количество времени после которого не отвечающая на запросы программа считается системой зависшей.

  10. Правда ли, что служба QoS ограничивает скорость сети? Как ее отключить.

  11. При попытке добавить пользователя в группу выдается ошибка "Служба сервер не запущена".

  12. При установке некоторых программ выдается ошибка: "вы не имеете достаточных прав для создания файлов или папок в вашей временной папке"

  13. Установка и удаление программ: скрыть программу в списке установленных

  14. Установка и удаление программ: оснастка не отвечает на запросы после удаления обновления системы безопасности KB840374

  15. Установка и удаление программ: Отключение ограничений

  16. Установка и удаление программ: Отображение всех программ и компонент

  17. Установка и удаление программ: Удаление некорректных записей

  18. Установка и удаление программ: Ошибка 1719. Нет доступа к службе установки Windows

  19. Установка и удаление программ: включение ограничений использования оснастки

  20. Установка и удаление программ: Сообщение об ошибке синтаксиса при удалении SP1 (в строке 472) или SP2 (в строке 521)

  21. Открытие приложения через Пуск - Выполнить без указания полного пути к исполняемому файлу

  22. Автозаполнение: Internet Explorer не сохраняет имени пользователя и пароля

  23. Автозаполнение: Ветви реестра в которых сохраняются значения

  24. Добавление оснастки управления пользователями в стиле Windows 2000 (Control UserPasswords2) в панель управления

  25. Автоматическое завершение не отвечающих на запросы программ при выключении компьютера

  26. Как удалить медиа файл (*.avi) если при попытке удаления появляется сообщение об ошибке совместного доступа

  27. Восстановление значений по умолчанию для EXE и REG файлов

  28. Восстановление значений по умолчанию для LNK файлов

  • Железо

  1. После установки драйвера на видеокарту NVidia в свойствах монитора в настройках видеокарты появились непонятные символы.

  2. Не устанавливается драйвер для сканера Mustek. При установке драйвера выдается информация о том, что у драйвера нет цифровой подписи.

  3. Во время работы компьютера появляется синий экран с ошибкой BSOD ссылаясь на ошибку в драйвере.

  4. Внешний модем подключенный к COM-порту не определяется системой после загрузки если не был включен до включения компьютера.

  5. Привод CD-ROM постоянно переходит в режим PIO.

  6. При выключении компьютера появляется надпись "Теперь питание компьютера можно отключить".

  7. Windows не определяет привод CD-ROM хотя в BIOS`е привод определяется нормально.

  8. После установки Service Pack 2 компьютер не загружается.

  9. Система не распознает CD-RW как записывающее устройство.

  10. Функции автозапуска не срабатывают при вставке компакт-диска в дисковод.

  11. Не удается установить устройство Bluetooth после установки SP2

  12. При печати появляется сообщение об ошибке: «Приложение подсистемы спулера — обнаружена ошибка. Приложение будет закрыто»

  13. При установке принтера появляется сообщение об ошибке: «Невозможно завершение операции»

  14. Пропадает доступ к дисководу компакт-дисков, а в сообщениях упоминаются ошибки с кодами 19, 31, 32 или 39

  15. Устранение конфликтов устройств с помощью диспетчера устройств

  • Интернет и сети

  1. Как заставить Windows XP Home Edition регистрироваться в домене.

  2. Как организовать доступ между двумя удаленными компьютерами используя модемное соединение.

  3. Как можно вывести компьютер из спящего режима по сети.

  4. При входе в сеть Windows долго опрашивает ее на предмет наличия назначенных заданий на других машинах.

  5. Как настроить соединение двух компьютеров по через модем для игр.

  6. Можно ли использовать несколько модемов для одного соединения для увеличения общей скорости передачи данных.

  7. Как увеличить пропускную способность для сетевых подключений. Или как отключить QoS.

  8. Как перезагрузить компьютер по сети.

  9. Как убрать сообщение об ошибке при неудачном дозвоне.

  10. Что такое удаленный рабочий стол? Как его настроить.

  11. После установки SP2 перестала работать команда net send.

  12. Как в Windows XP настроить dial-up соединение на использование функции callback.

  13. Как сохранить настройки модемного соединения или перенести их на другой компьютер.

  14. Как правильно настроить службу факсов в Windows XP для работы с факсами.

  15. Создание и удаление скрытых и административных общих ресурсов (C$, D$, Admin$)

  16. Как увеличить количество одновременных закачек в Internet Explorer

  • Безопасность

  1. Как сделать недоступными для общего пользования определенные файлы и папки на одном компьютере при условии, что файловая система на диске FAT32.

  2. Как организовать запрет доступа к папкам (файлам) для локальных пользователей на одном компьютере.

  3. Как ограничить пользователя определенным перечнем программ разрешенных для запуска.

  4. Папка была зашифрована средствами Windows, но сертификат не сохранился после переустановки системы. Как получить доступ к зашифрованной папке.

  5. Как получить доступ к файлу или папке после переустановки системы.

  6. При подключении к Интернет появляется сообщение: "Система завершает работу, отключение вызвано NT\AUTHORITY SYSTEM. Перезагрузите Windows, поскольку произошла непредвиденная остановка службы Удалённый вызов процедур" и через минуту компьютер перезагружается.

  7. Как закрыть порты средствами Windows XP.

  8. Появляется окно службы сообщений с рекламным объявлением из Интернета.

  9. Что такое функция DEP и как проверить включена ли она.

  • Интерфейс

  1. Как настроить английскую версию Windows XP для нормального отображения кириллицы в программах

  2. Как настроить отображение вкладки Безопасность в свойствах файла/папки

  3. Как выборочно скрыть пользователей отображаемых в экране приветствия при загрузке

  4. Как настроить автоматический вход в систему без ввода пароля

  5. Как настроить в окне ввода пароля при загрузке системы английскую (русскую) раскладку по умолчанию

  6. При открытии диспетчера задач отсутствуют меню и вкладки

  7. При попытке открыть диспетчер задач появляется сообщение: "Диспетчер задач отключен администратором системы"

  8. Корзина не отображается на рабочем столе

  9. Как настроить систему для нормального отображения кириллицы в DOS-приложениях.

  10. Как изменить каталог открываемый по умолчанию при запуске Проводника

  11. Как изменить время задержки открытия меню Пуск и других

  12. Иконки файлов *.html и *.htm отображаются как неизвестный формат

  13. На рабочем столе надпись "Windows XP версия 0000. Только Для Тестов"

  14. После скринсейвера в экране приветствия (под картинкой пользователя) надпись "У вас N непрочитанных сообщений"

  15. Не отображаются эскизы графических файлов и эскизы web-файлов

  16. Не отображаются эскизы видео файлов, не показывается информация о файлах видео при наведении курсора

  17. Не запоминаются или искажаются параметры отображения или настройки внешнего вида папок

  18. Настройки рабочего для всех новых учетных записей компьютера

  19. Active Desktop - Включение, отключение, изменение настроек через реестр

  20. Добавление пункта Дефрагментация в контекстное меню дисков

  21. Отсутствует панель инструментов в Windows Explorer или Internet Explorer

  22. Восстановление всех вкладок в свойствах обозревателя Internet Explorer

  23. Отключение анимации в Windows XP

  24. Как отменить представление CAB-файлов в виде папок

  25. Как удалить некоторые пункты из контекстного меню в проводнике Windows

  • Разное

  1. При запуске большинства игр в ХР частота монитора устанавливается 60 гц

  2. Как в Windows ХР запустить скандиск

  3. Какую версию Windows лучше установить на домашний компьютер Windows XP Professional или Home Edition.

  4. Где находится папка SendTo

  5. За что отвечает файл pagefile.sys

  6. Для чего необходима папка System Volume Information

  7. Какие существуют способы восстановления поврежденных системных файлов и системы в целом

  8. Где хранится код активации Windows XP

  9. Для чего нужна вкладка "Совместимость" в свойствах исполняемых файлов и ярлыков

  10. Как задать пpиоpитет процесса пpи его запуске

  11. Как переписать консоль восстановления (recovery console) на жесткий диск

  12. Процесс зависшего приложения был снят через диспетчер задач, после чего в панели задач и в трее увеличился размер ярлыков

  13. Как открыть папку System Volume Information

  14. Где система сохраняет закачанные обновления, получаемые автоматически с WindowsUpdate

  15. Появление сообщения об ошибке «Файл подкачки отсутствует или слишком мал»

  16. Как настроить файл подкачки для оптимизации и восстановления Windows XP

  17. Как правильно настроить механизм восстановления в Windows XP

  18. Как произвести печать на сетевой принтер из программы MS-DOS

  19. Как скопировать данные из поврежденного профиля пользователя в новый

  20. Доступ запрещен: Сообщение об ошибке Windows Update

  21. Специальные возможности: сброс всех настроек на стандартные

  22. При запуске мастера активации Windows (WPA) страница «Активация Windows» отображается пустой

  23. После восстановления из архива Windows XP требует выполнить повторную активацию


FAQ по Microsoft Windows XP | Установка/Загрузка/Выключение

Перечень всех вопросов раздела Установка/Загрузка/Выключение

  1. При установке некоторых приложений (например MS Office 2000) другой пользователь на этом компьютере должен эту программу установить повторно. Как сделать установку для всех пользователей компьютера.

  2. Как переустановить Windows XP поверх, то есть без удаления параметров и программ.

  3. Как убрать "Приветствие" при загрузке компьютера.

  4. Как отредактировать boot.ini для загрузки двух версий Windows с разных разделов.

  5. Вместо выключения компьютер перезагружается.

  6. При загрузке ошибка: файл hal.dll повреждён или отсутствует.

  7. Как восстановить повреждённый загрузчик Windows XP.

  8. Как выбрать нужную версию ядра и HAL ещё при установке.

  9. Как добавить и отредактировать сообщение, которое будет выводить при загрузке компьютера.

  10. Как изменить ядро системы.

  11. Какие параметры можно применять в boot.ini?

  12. Как произвести установку в режиме обновления с Windows XP Home RUS на Windows XP Professional ENG

  13. Установлена Windows XP, на другом разделе была Windows 2000, которая теперь удалена. Как избавиться от меню выбора ОС при загрузке.

  14. Как выполнить «чистую» загрузку в Windows XP

  15. Использование «чистой» загрузки для устранения неполадок в Windows XP


Вместо выключения компьютер перезагружается

FAQ по Microsoft Windows XP | Установка/Загрузка/Выключение

Q: Вместо выключения компьютер перезагружается

Это может происходить как следствие программного сбоя.
Проверьте следующие настройки:
Панель управления -> управление питанием -> дополнительно -> при нажатии кнопки включения питания компьютера -> завершение работы.

Такая настройка может быть установлена при помощи Локальной политики, но "сама по себе" эта политика не могла включиться.


Как восстановить поврежденный загрузчик Windows XP

FAQ по Microsoft Windows XP | Установка/Загрузка/Выключение

Q: Как восстановить поврежденный загрузчик Windows XP

Загрузиться в Консоль Восстановления (Recovery Console) и выполнить команду
fixboot

Вывести параметры командой fixboot /?

Так же можно выполнить команду
fixmbr /device/harddisk0

Вывести параметры командой fixmbr /?

Подробнее о том что такое Консоль Восстановления и как ей пользоваться вы можете узнать из статей MS KB:
"Описание консоли восстановления Windows XP"
"Как установить и использовать консоль восстановления в Windows XP"


Как выбрать нужную версию ядра и HAL еще при установке

FAQ по Microsoft Windows XP | Установка/Загрузка/Выключение

Q: Как выбрать нужную версию ядра и HAL еще при установке

Чтобы указать вручную драйвер уровня аппаратных абстракций во время обновления или установки Windows XP, следует на текстовом этапе установки, обратить внимание на следующее сообщение в нижней части экрана:
"Нажмите F6, если Вам необходимо загрузить SCSI или Raid драйвер стороннего производителя."
При появлении данного сообщения нажмите клавишу "F5".
Теперь при просмотре параметров Вы можете выбрать необходимый Вам драйвер HAL.
Если будет нажата клавиша F7, то будет загружен драйвер HAL "Стандартный компьютер" и проверка на совместимость с ACPI будет пропущена.
После нажатия клавиши "F5" Вы увидите список типов компьютеров. Описание драйвера уровня аппаратных абстракций приведено ниже.

• Многопроцессорный компьютер с ACPI: Используется на многопроцессорных компьютерах с ACPI.
• Однопроцессорный компьютер с ACPI: Используется на многопроцессорных компьютерах с ACPI, но только с одним установленным процессором.
• Компьютер с ACPI: Используется для системных плат, позволяющих установить только один процессор.
• Многопроцессорный Compaq SystemPro или 100% совместимый: Используется для компьютера Compaq Systempro.
• Однопроцессорный компьютер с MPS: Используется на двухпроцессорных системных платах без поддержки ACPI и только с одним установленным процессором.
• Многопроцессорный компьютер с MPS: Используется на двухпроцессорных системных платах без поддержки ACPI с двумя установленными процессорами.
• Стандартный компьютер: Любой стандартный компьютер без поддержки ACPI или без MPS. Это может быть система, основанная на процессоре 386, 486, Pentium, Pentium II или Pentium III
• Стандартный компьютер I486 степпинг-С.
• Прочие

Более подробно вопрос рассмотрен в этой статье MSKB:
Как указать вручную драйвер уровня аппаратных абстракций во время установки или обновления Microsoft Windows XP
Так же посмотрите эту статью: Параметры HAL, доступные в Windows XP


Как добавить и отредактировать сообщение, которое будет выводить при загрузке компьютера

FAQ по Microsoft Windows XP | Установка/Загрузка/Выключение

Q: Как добавить и отредактировать сообщение, которое будет выводить при загрузке компьютера

Панель управления -> Администрирование -> Локальная политика безопасности -> Локальные политики -> Параметры безопасности -> Интерактивный вход в систему : текст сообщения для пользователей при входе в систему
(Control Panel -> Administrative Tools -> Local Security Policy -> Security Options -> Interactive logon: Message text for users attempting to log on).

Здесь указывается текст сообщения.
Рядом находится строка: "Интерактивный вход в систему : заголовок сообщения для пользователей при входе в систему" (Interactive logon: Message title for users attempting to log on).
Здесь указывается текст заголовка сообщения.


Как изменить экран загрузки на классический (как в Windows 2000)

FAQ по Microsoft Windows XP | Установка/Загрузка/Выключение

Q: Как изменить экран загрузки на классический (как в Windows 2000)

Панель управления -> Учетные записи пользователей -> Изменение входа пользователей в систему -> отключить опцию "Использовать страницу приветствия".


Как отредактировать boot.ini для загрузки двух версий Windows с разных разделов

FAQ по Microsoft Windows XP | Установка/Загрузка/Выключение

Q: Как отредактировать boot.ini для загрузки двух версий Windows с разных разделов

Содержимое boot.ini (пример):

[Boot Loader]
timeout=5
Default=C:\
[Operating Systems]
C:\="Microsoft Windows Millennium Edition" multi(0)disk(0)rdisk(0)partition(2)WINDOWS="Microsoft Windows XP Professional" /fastdetect

Последняя строка содержит физический адрес раздела, где установлен Windows XP (в данном примере есть два раздела - C:(FAT32) и D:(NTFS) - на C: стоит Windows ME, на D: Windows XP). Так же в корне диска C: должен находиться файл с именем bootsect.dos размером 512-байт, который содержит загрузочный сектор Windows 9x-ME.
Более подробно об установке нескольких операционных систем вы можете узнать из этой статьи: Установка нескольких Windows операционных систем

© Все права защищены OSzone.net 2001-2006


Как переустановить Windows XP поверх, то есть без удаления параметров и программ

FAQ по Microsoft Windows XP | Установка/Загрузка/Выключение

Q: Как переустановить Windows XP поверх, то есть без удаления параметров и программ

1. Скопировать файл C:\BOOT.INI (если у Вас установлено несколько систем) в какой-либо каталог для последующего его восстановления на месте начального расположения после завершения установки.

2. При проводящемся в результате установки восстановлении операционной системы Windows XP, будет запрошен пароль Администратора системы. Для его гарантированного ввода, необходимо изменить пароль Администратора на заведомо известный пользователю, проводящему установку. Для этого необходимо в среде Windows XP выполнить ярлык Пуск -> Настройка -> Панель управления -> Учетные записи пользователей, в результате чего появится соответствующее окно. Выбрать учетную запись Администратор и нажать кнопку Сменить пароль, для задания нового пароля Администратора системы, в результате чего появится окно смены пароля. Ввести в верхнем поле редактирования окна новый пароль Администратора, после чего продублировать его вводом с клавиатуры в нижнем поле редактирования окна.

3. Выполнить файл WINNT32.EXE с дистрибутивного диска Windows XP.

4. Выбрать в меню установки тип Новая установка.

5. Установить флажок Выбрать раздел для установки.

6. После перезагрузки компьютера в процессе установки в режиме DOS выбрать тип проводимой операции Восстановление существующей версии. Если будет задан вопрос о пароле Администратора системы, введите пароль Администратора, установленный вами в процессе выполнения п.2.

7. После завершения установки Windows XP, необходимо скопировать ранее сохраненный файл BOOT.INI (см. п. 1) в корневой каталог диска C: и провести перезагрузку.

Подробнее можно прочитать в статье MSKB: Как выполнить обновление (переустановку) Microsoft Windows XP


Как поменять ядро системы

FAQ по Microsoft Windows XP | Установка/Загрузка/Выключение

Q: Как поменять ядро системы

Ядро системы можно изменить в Диспетчере устройств - в свойствах устройства Компьютер.

Следует указать, что последствия установки неправильного ядра непредсказуемы. Скорее всего компьютер просто перестанет загружаться, во всех режимах. Предотвратить подобное можно подредактировав boot.ini. Нужно всего лишь продублировать рабочий пункт меню выбора ОС, например,

multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Professional" /fastdetect

и приписать после /fastdetect следующие опции:

/kernel=ntoskchk.exe /hal=halchk.dll

а также в директории WINDOWS\System32 сделать копии вашего ядра и HAL.
Скопировать ntoskrnl.exe в ntoskchk.exe и hal.dll в halchk.dll.

Кроме этого, необходимо учитывать одну тонкость. Видимо из за того, что при установке неправильного ядра XP просо виснет, теперь весь список доступных ядер не выводиться в окне смены драйвера. Таким образом, возможна ситуация, когда Вы точно знаете, что ядро поддерживается системой, но система не даёт его установить. В этом случае, придётся делать это вручную.
Для начала найдите в windows\inf файл под названием hal.inf. Изучите его, что бы выяснить, какие файлы и куда переписываются при смене ядра.
Обычно перезаписывается только hal.dll, названия какого hal какому ядру соответствуют, можно узнать из списка:

· Standard PC - hal.dll
· Advanced Configuration and Power Interface (ACPI) PC -halacpi.dll
· ACPI Uniprocessor PC - halaacpi.dll
· ACPI Multiprocessor PC -halmacpi.dll
· Compaq SystemPro Multiprocessor or 100% Compatible - halsp.dll
· MPS Uniprocessor PC -halapic.dll
· MPS Multiprocessor PC -halmps.dll

После этого остаётся извлечь соответствующий файл из Windows\DriverCache\i386\driver.cab, скопировать его в Windows\system32, и сослаться на него в boot.ini.
После загрузки, можно изменить, в списке это ядро появится.


Какие параметры можно применять в boot.ini

FAQ по Microsoft Windows XP | Установка/Загрузка/Выключение

Q: Какие параметры можно применять в boot.ini

Файл boot.ini отвечает за порядок загрузки ОС установленных в системе, и позволяет задать некоторые параметры загрузки этих систем.
Начинается этот файл разделом [boot loader] В этом разделе всего два параметра:

· Timeout - определяет время в секундах, которое ждёт система прежде чем начать загружать ОС по умолчанию, в случае если в системе установлено несколько ОС.
· Default - определяет систему которая грузится по умолчанию.

Второй раздел [operating system] - в котором находится список возможных к загрузке ОС. Для каждой ОС указывается её местоположение с использованием имен ARC (Advanced RISC Computer):

· scsi(*) или multi(*) - элемент scsi(*) используется в случае контроллера SCSI с отключенным BIOS. Элемент multi(*) используется для дисков всех остальных типов, включая IDE, EIDE, ESDI и SCSI с включенным BIOS. (*) - номер адаптера, с которого осуществляется загрузка. Адаптеры нумеруются с нуля, начиная с контроллера, расположенного ближе к слоту 0 на мат. плате.

· disk(*) - если (1) = scsi(*), то равен логическому номеру устройства (LUN), установленному для диска. Если (1) = multi(*), то всегда равен нулю.

· rdisk(*) - если (1) = multi(*), то равен номеру диска в цепочке, счет дисков начинается с 0. Если (1) = multi(*), то всегда равен нулю

· partition(*) - определяет дисковый раздел, содержащий файлы ОС. В отличие от всех остальных элементов имен ARC нумерация разделов начинается с 1, т.е. первый раздел обозначается partition(1), второй - partition(2) и т.д.

· path - определяет каталог (или подкаталог) раздела, в котором находятся файлы ОС. По умолчанию в XP используется путь windows. Кроме этого, в кавычках прописывается текст, который будет виден в пункте выбора этой ОС в стартовом меню. После этого текста могут быть ключи которые влияют на загрузки ОС. Для XP возможны следующие ключи:

· /basevideo - с этим ключом система будет использовать только стандартный VGA драйвер. Этот параметр может пригодится если Вы на коротко время ставите другую видеокарту, и Вам не хочется мучаться с перестановкой драйверов.

· /fastdetect - обычно ставится автоматически при инсталляции системы. При установке этого ключа система не определяет все Plug and Play устройства в процессе загрузки.

· /maxmem - определяет максимальный размер RAM, который может использоваться системой. Теоретически, может помочь если у Вас глючная оперативка.

· /noguiboot - При использовании этого ключа не будет рисоваться цветная заставка при загрузке. Может использоваться теми кто не желает смотреть на эту картинку в 60 герцах. Но надо учесть, что кроме этого не будут рисоваться BSOD при загрузке. Но виснуть система, если что-нибудь не в порядке, естественно не перестанет.

· /noserialmice=[com 1,2,3] - при использовании этого параметра не будет определяться мышь подключенная к COM порту для портов перечисленных в скобках. Если номера портов не указывать, то мышь не будет определяться на всех портах.

· /bootlog - при задании этого параметра система будет писать лог загрузки в %SystemRoot%\Nbtlog.txt Этот параметр можно использовать что найти причину почему система может загрузится только в safe mode.

· /safeboot - при его установке система загрузится в Safe mode. То же самое можно сделать нажав F8 в начале загрузки системы. Через двоеточие можно задать несколько параметров для /safeboot. Minimal - минимальная конфигурация. Network - с поддержкой сети. Dsrepair - доступна только в NET Server и позволяет восстановить Active Directory с заблаговременно сделанной резервной копии. Alternateshell - позволяет использовать альтернативные графические оболочки. По умолчанию с системой ставится только Explorer (стандартная оболочка) и Progman (осталась в наследство от Windows3.11 и NT 3.5).

· /sos - отображает на экране список загружаемых драйверов. Может помочь выяснить, на чём система спотыкается при загрузке.

· /baudrate - этот параметр указывает скорость с которой будет работать COM порт для отладки системы. Если не указать конкретную скорость, то будет 9600 для модема и 19200 для нуль-модемного кабеля. При включении этого параметра автоматически ставится параметр /debug

· /crashdebug - с этим флагом загружается отладчик, но остаётся в неактивном состоянии до тех пор пока не произойдёт ошибка ядра. Может использоваться разработчиками программного обеспечения.

· /debugport=com* - указывает номер COM порта (* должна быть номером порта) используемого при отладчиком. Автоматически включает ключ /debug

· /debug - загружается отладчик, который может быть активизирован другим компьютером через подключенным COM порт. Может использоваться разработчиками ПО.

· /nodebug - на экран не выводится отладочная информация.

· /hal - указывает имя файла, который должен использоваться как hal.dll после загрузки.

· /kernel - указывает имя файла, который должен использоваться как ntoskrnl.dll после загрузки.

За дополнительной информацией можете обратиться к этой статье MSKB: Редактирование файла Boot.ini в Windows XP


При загрузке компьютера появляется сообщение об ошибке: файл hal.dll поврежден или отсутствует

FAQ по Microsoft Windows XP | Установка/Загрузка/Выключение

Q: При загрузке компьютера появляется сообщение об ошибке: файл hal.dll поврежден или отсутствует

Возможные причины возникновения данной ошибки:

• Отсутствует или повреждено значение Default в разделе загрузчика операционной системы в файле Boot.ini.
• В расположении, указанном в файле Boot.ini., отсутствует установленная копия Windows XP.
• Отсутствует или поврежден файл Ntoskrnl.exe.
• Неверно указан путь к разделу в файле Boot.ini.
• Общий сбой оборудования.

Для решения проблемы можно использовать любой из следующих способов.

Способ 1
Восстановите или исправьте запись Default в файле Boot.ini и проверьте, что в других записях раздела [Operating Systems] в файле Boot.ini указан путь к соответствующим каталогам.

Способ 2
Воспользуйтесь служебной программой Bootcfg консоли восстановления для редактирования файла Boot.ini.
1. Запустите компьютер с компакт-диска с Windows XP.
2. При появлении приглашения нажать клавишу «R» для восстановления Windows с помощью консоли восстановления нажмите требуемую клавишу.
3. Выберите нужную систему Windows и при появлении запроса введите пароль администратора.
4. Введите команду bootcfg /rebuild и нажмите клавишу ВВОД.
5. После обнаружения копии Windows появляются следующие команды:
Добавить систему в список загрузки? [Y(да)/N(нет)/All(все)].
[Введите Y (да) в ответ на это сообщение]
Введите идентификатор загрузки:
[Название операционной системы. Введите Windows XP Professional или Windows XP Home Edition.]
Введите параметры загрузки операционной системы: [Оставьте поле пустым и нажмите клавишу ВВОД]. После выполнения перечисленных действий перезапустите компьютер и выберите первый вариант из меню загрузки. После этого система Windows XP должна загрузиться нормально.
После успешной загрузки Windows XP можно удалить неверную запись в файле Boot.ini.

Способ 3
1. Загрузите компьютер с компакт-диска Windows XP. Нажмите любую клавишу для загрузки с компакт-диска.
2. После загрузки установочных файлов нажмите клавишу «R» для запуска консоли восстановления.
3. В консоли восстановления выберите систему для входа (как правило, под номером 1) и нажмите клавишу ВВОД.
4. Воспользуйтесь учетной записью администратора, указав соответствующий пароль, и нажмите клавишу ВВОД.
5. В командной строке консоли восстановления введите следующую команду и затем нажмите клавишу ВВОД:

expandcd-rom:\i386\ntoskrnl.ex_ имя_диска:\Windows\system32;

cd-rom — имя дисковода компакт-дисков; имя_диска — это буква диска, на котором установлена система Windows.
6. При появлении предложения перезаписать файл нажмите Y (да).
7. Введите команду exit и нажмите клавишу ВВОД, чтобы выйти из командной строки.

Способ 4
Запустите компьютер с помощью консоли восстановления и выполните команду CHKDSK /r.
Примечание. Нет необходимости указывать в командной строке Chkdsk параметр /p, поскольку параметр /r служит для обнаружения служебной программой Chkdsk поврежденных секторов и восстановления считываемой информации. Эта команда включает в себя и функции параметра /p.

Более подробно о решении данной проблемы вы можете прочитать в этой статье MSKB: При запуске Windows появляется сообщение об ошибке: «Не удается запустить Windows из-за аппаратных ошибок настройки диска»


При установке некоторых приложений (например MS Office 2000) другой пользователь на этом компьютере должен эту программу установить повторно. Как сделать установку для всех пользователей компьютера

FAQ по Microsoft Windows XP | Установка/Загрузка/Выключение

Q: При установке некоторых приложений (например MS Office 2000) другой пользователь на этом компьютере должен эту программу установить повторно. Как сделать установку для всех пользователей компьютера

1. Установку программ, производящих, в частности, изменения ключа реестра HKEY_LOCAL_MACHINE, необходимо производить под профилем либо сетевого, либо локального администратора.

2. Обновление (доустановка компонентов) программ (по крайней мере для тех, инсталляционный пакет которых использует MS Installer) будет проводится безболезненно и в автоматическом режиме, если дать пользователям конкретной машины права локальных администраторов или (то есть или добавить к их списку каждого из пользователей на каждой из машин, либо создать рабочую группу и включить её в список локальных администраторов на каждом из компьютеров).

3. Чтобы избежать доустановки компонент (по крайней мере, для MS Office 2000 и MS Office 2002 (XP)), проводить установку программ в режиме выбора компонентов, причем устанавливать их сразу же, не допуская при этом возможности установки компонентов при первом запуске.
a. в п. 3 описан самый простой способ, но можно и иначе:
Установку можно запускать с ключом /jm , в этом случае доустановка компонент пойдет, но у пользователя будут права на установку.
Подробнее можно прочитать в этой статье MS: Assigning, publishing, or advertising Office


Установлена Windows XP Home RUS. Необходимо установить Windows XP Professional ENG. Как провести установку с сохранением настроек и программ

FAQ по Microsoft Windows XP | Установка/Загрузка/Выключение

Q: Установлена Windows XP Home RUS. Необходимо установить Windows XP Professional ENG. Как провести установку с сохранением настроек и программ

При переходе с Windows XP Home RUS на Windows XP Pro ENG система выдаёт ошибку невозможности сделать апгрейд из-за разных языков систем. Чтобы избежать этого нужно запустить установку с параметром /#U:ANYLOCALE

E:\winxp\i386\winnt.exe /#U:ANYLOCALE

где E - буква CD


Установлена Windows XP, на другом разделе была Windows 2000, которая теперь удалена. Как избавиться от меню выбора ОС при загрузке

FAQ по Microsoft Windows XP | Установка/Загрузка/Выключение

Q: Установлена Windows XP, на другом разделе была Windows 2000, которая теперь удалена. Как избавиться от меню выбора ОС при загрузке

Для того чтобы убрать одну из операционных систем в меню выбора системы для загрузки необходимо отредактировать файл boot.ini который находится в корне диска C и имеет системный (а значит и скрытый) атрибут.

Содержимое файла boot.ini при установленной ОС Windows XP Professional:

[boot loader]
timeout=30
default=multi(0)disk(1)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

Пример файла boot.ini с установленной ранее ОС Windows 2000 в отдельном разделе диска.

[boot loader]
timeout=30
default=multi(0)disk(1)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\WINNT="Windows 2000 Professional" /fastdetect

Как видите они отличаются только на одну строку, соответственно, для того чтобы убрать из меню выбора ОС для загрузки достаточно удалить из файла boot.ini строку запуска Windows 2000
Редактирование файла boot.ini можно выполнить в любом текстовом редакторе.

Так же избавиться от меню выбора ОС для загрузки можно из самой Windows:
Свойства системы (WinKey+Break) -> Дополнительно -> Параметры загрузки и восстановления -> Отображать список операционных систем [N сек.]


Как выполнить «чистую» загрузку в Windows XP

FAQ по Microsoft Windows XP | Установка/Загрузка/Выключение

Q: Как выполнить «чистую» загрузку в Windows XP

Чтобы устранить проблемы, при которых появляются сообщения об ошибках, или другие неполадки, причину которых не удается определить, можно отключить автозагрузку обычно используемых программ, параметров и драйверов с целью предотвращения возможных конфликтов программного обеспечения при запуске Microsoft Windows XP. Эта процедура называется «чистой» загрузкой. В этой статье описывается процедура «чистой» загрузки, запуска службы установщика Windows Installer и возврата в обычный режим загрузки системы.
Примечание. Выполнение инструкций по осуществлению «чистой» загрузки может сделать временно недоступными некоторые функциональные возможности. Если восстановить прежние настройки, будет восстановлена и функциональность системы, но при этом возможно повторное появление того же сообщения об ошибке или неправильное поведение системы.

Выполнение «чистой» загрузки Windows XP
Примечание. Для выполнения описанных ниже действий необходимо войти в систему как администратор или член группы «Администраторы». Если компьютер подключен к сети, выполнению этих действий могут помешать действующие параметры сетевой политики.
1. Нажмите кнопку Пуск, выберите команду Выполнить, введите msconfig в поле Открыть и нажмите кнопку OК.
2. На вкладке Общие выберите параметр Выборочный запуск и снимите флажки Обрабатывать файл System.ini, Обрабатывать файл Win.ini и Загружать элементы автозагрузки. Флажок Использовать оригинальный BOOT.INI снять нельзя.
3. На вкладке Службы установите флажок Не отображать службы Майкрософт и нажмите кнопку Отключить все.
4. Нажмите кнопку OК, а затем – Перезагрузка, чтобы перезагрузить компьютер.
5. После перезагрузки Windows определите, наблюдаются ли по-прежнему симптомы проблемы.
Примечание. Просмотрите содержимое вкладки Общие и убедитесь, что снятые флажки действительно сняты. Если это так, переходите к шагу 6. Если снят только флажок Загружать системные службы, «чистая» загрузка компьютера не была выполнена. Если дополнительные флажки сняты, а проблема не устранена, возможно, требуется обратиться за помощью к разработчику программы, которая обратно устанавливает флажок в программе Msconfig.
Если все флажки сняты, но проблема не устранена, попробуйте повторить шаги с 1 по 5, сняв также флажок Загружать системные службы на вкладке Общие. Это временно отключает службы Microsoft (такие как «Сетевые подключения», «Plug and Play», «Журнал событий» и «Отчет об ошибках») и безвозвратно удаляет все точки восстановления для средства «Восстановление системы». Не делайте этого, если нужно сохранить точки восстановления для средства «Восстановление системы» или использовать какую-либо службу Microsoft для диагностики проблемы.
6. Нажмите кнопку Пуск, выберите команду Выполнить, введите msconfig в поле Открыть и нажмите кнопку OК.
7. На вкладке Общие установите флажок Обрабатывать файл System.ini, нажмите кнопку OK, а затем нажмите кнопку Перезагрузка, чтобы перезагрузить компьютер. Если проблема появилась снова, ее причиной является запись в файле System.ini. Если проблема исчезла, повторите данный шаг, последовательно устанавливая флажки Обрабатывать файл Win.ini, Загружать элементы автозагрузки и Загружать системные службы, пока снова не столкнетесь с данной проблемой. Когда проблема появится снова, можно будет сделать вывод, что ее источником является соответствующий элемент, флажок для которого был установлен последним.
Примечание. Не рекомендуется использовать программу настройки системы (msconfig) для изменения файла Boot.ini на компьютере.

Запуск службы установщика Windows Installer
Примечание. Служба установщика Windows Installer не запустится, если снят флажок Загружать системные службы. В этом случае для использования службы Windows Installer необходимо запустить ее вручную.
1. В меню Пуск щелкните правой кнопкой мыши значок Мой компьютер и выберите пункт Управление.
2. На правой панели щелкните пункт Службы и приложения и выберите Службы.
3. На правой панели щелкните правой кнопкой мыши Windows Installer и выберите команду Пуск.
Если запустить программу установки какого-либо продукта, не запустив службу Windows Installer вручную, может появиться следующее сообщение об ошибке.
"Нет доступа к службе установки Windows. Обратитесь в свою службу поддержки для проверки регистрации службы установщика Windows Installer."

Восстановление обычного режима загрузки
1. Нажмите кнопку Пуск, выберите команду Выполнить, введите msconfig в поле Открыть и нажмите кнопку OК.
2. На вкладке Общие выберите вариант Обычный запуск – загрузка всех драйверов устройств и запуск всех служб.
3. Нажмите кнопку OK, а когда появится окно с приглашением перезагрузить компьютер, нажмите кнопку Перезагрузка.


Использование «чистой» загрузки для устранения неполадок в Windows XP

FAQ по Microsoft Windows XP | Установка/Загрузка/Выключение

Q: Использование «чистой» загрузки для устранения неполадок в Windows XP

Многие проблемы, возникающие при работе операционной системы Windows, связаны с использованием несовместимых программ, выполняющихся одновременно, или поврежденных программ. Чтобы определить, является ли причиной неполадок использование поврежденных или несовместимых программ, выполните «чистую» загрузку или загрузите Windows, не загружая программы, которые могут вызывать сбои.
В данной статье описано выполнение «чистой» загрузки, позволяющей определить, что является причиной проблемы — операционная система или одна из загружаемых программ.

Рассматриваемый в данной статье процесс устранения неполадок с помощью «чистой» загрузки включает следующие этапы.
1. Загрузка в безопасном режиме или в безопасном режиме с загрузкой сетевых драйверов
2. Удаление записей реестра.
3. Проверка профилей пользователей.

Загрузка в безопасном режиме или в безопасном режиме с загрузкой сетевых драйверов.
Для устранения возможных проблем, вызванных средой, необходимо перезапустить компьютер в безопасном режиме или в безопасном режиме с загрузкой сетевых драйверов. Если проблема связана с программой, которая не использует подключение к сети, можно использовать безопасный режим. Если проблема связана с сетевой программой и для подключения к сети используется сетевой адаптер, то работоспособность данной программы (включая взаимодействие с обозревателем) можно проверить в безопасном режиме с загрузкой сетевых драйверов.
Чтобы загрузить компьютер в безопасном режиме, выполните следующие действия.
1. Нажмите кнопку Пуск и выберите команду Завершение работы.
2. Выберите пункт Перезагрузка и нажмите кнопку OK.
3. Как только компьютер запустится, нажмите клавишу F8.
4. Выберите пункт меню Безопасный режим или Безопасный режим с загрузкой сетевых драйверов и нажмите клавишу ВВОД.
Если в безопасном режиме или в безопасном режиме с загрузкой сетевых драйверов операция, которая вызывала неполадку, выполняется нормально, то проблема, скорее всего, вызвана средой. Сведения о том, как определить программный компонент, вызывающий неполадку, см. в разделе «Удаление записей реестра» данной статьи.
Примечание. Так как в безопасном режиме и в безопасном режиме с загрузкой сетевых драйверов загружаются не все службы и драйверы, то, возможно, некоторые операции протестировать не удастся. Например, в безопасном режиме нельзя выполнять устранение неполадок, связанных со звуком, а также со спящим режимом или приостановкой. Кроме того, не будут работать программы, использующие RpcSS (Remote Procedure Call Subsystem), поскольку служба RpcSS не загружается в безопасном режиме с загрузкой сетевых драйверов.
Если после запуска компьютера в безопасном режиме или в безопасном режиме с загрузкой сетевых драйверов проблема возникает повторно, то такое поведение все равно может быть вызвано средой, так как многие функции и драйверы фильтров, установленные независимыми производителями, продолжают загружаться в этих режимах.
Поэтому для тестирования и удаления драйверов независимых производителей в безопасном режиме может потребоваться выполнить дополнительные действия.

Удаление записей реестра. Если программы в безопасном режиме функционируют надлежащим образом, то, по всей вероятности, проблемы возникают по вине программ, которые загружаются при запуске компьютера.
Программы, запускающиеся при загрузке Windows, как правило, перечислены в одном из следующих местоположений.
• Папка «Автозагрузка», находящаяся в меню Программы.
• Раздел реестра Run (для всех пользователей).
• Раздел реестра Run (для конкретного пользователя).
• Раздел реестра load (для всех пользователей)
Примечание. Поскольку в реестре Windows собраны все параметры конфигурации компьютера и программ, перед внесением изменений в реестр необходимо сделать архивную копию реестра или отдельных его разделов.
В папке «Автозагрузка» находятся значки из двух местоположений. Чтобы очистить папку «Автозагрузка», выполните следующие действия.
1. Нажмите кнопку Пуск и в меню Настройка выберите пункт Панель задач и меню «Пуск».
2. На вкладке Дополнительно нажмите кнопку Вручную
3. Откройте папку «Автозагрузка», находящуюся в профиле текущего пользователя, и выберите в меню Правка команду Вырезать.
4. Создайте папку SysDriversBak, создайте в ней папку UserStartup, откройте папку UserStartup и выберите в меню Правка команду Вставить.
5. Повторите шаги 1 и 2. Выберите папку «All Users\Главное меню\Программы\Автозагрузка».
6. Выберите в меню Правка пункт Вырезать, перейдите в папку SysDriversBak, создайте в ней папку AllUsersStartup и выберите в меню Правка команду Вставить.

Чтобы очистить в реестре раздел Run для всех пользователей, выполните следующие действия.
1. Выберите в меню Пуск пункт Выполнить, введите команду regedit и нажмите кнопку ОК.
2. Найдите следующий раздел реестра:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
3. Откройте найденный раздел.
4. Для всех параметров, кроме параметра Default, перечисленных в правой части окна, выполните следующие действия. Выделите очередной параметр, выберите в меню Реестр пункт Экспорт файла реестра, выберите папку SysDriversBak и сохраните файл, используя при формировании имени файла следующее правило:
HKLMRun_(имя_параметра)
где имя_параметра — имя текущего сохраняемого параметра.
5. В меню Правка выберите команду Удалить.
6. Повторите эти действия для остальных параметров данного раздела.
7. Проверьте разделы реестра RunOnce и RunOnceEx. В этих разделах хранятся ссылки на программы, установка которых не завершена. Для сохранения информации, содержащейся в этих разделах, повторите шаги 3-5, используя другое имя файла.

Чтобы очистить раздел реестра Run для текущего пользователя, выполните следующие действия.
1. Выберите в меню Пуск пункт Выполнить, введите команду regedit и нажмите кнопку ОК.
2. Найдите следующий раздел реестра:
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
3. Откройте найденный раздел.
4. Выделите первый параметр, расположенный под параметром Default (value not set), выберите в меню Реестр пункт Экспорт файла реестра, выберите папку SysDriversBak и сохраните файл, используя при формировании имени файла следующее правило:
HKCURun_(имя_параметра)
где имя_параметра — имя текущего сохраняемого параметра.
5. В меню Правка выберите команду Удалить.
6. Повторите эти действия для остальных параметров данного раздела.
7. Проверьте раздел реестра RunOnce. В этом разделе хранятся ссылки на программы, установка которых не завершена. Для сохранения информации, содержащейся в разделе RunOnce, повторите шаги 3-5, используя другое имя файла.

Чтобы очистить параметр реестра load, выполните следующие действия.
1. Выберите в меню Пуск пункт Выполнить, введите команду regedit и нажмите кнопку ОК.
2. Найдите следующий раздел реестра:
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows]
3. Если параметр load содержит данные, выберите в меню Реестр пункт Экспорт файла реестра, выберите папку SysDriversBak и сохраните файл под именем HKCUload.
4. Дважды щелкните параметр load и удалите данные из поля «Значение».
5. После выполнения всех описанных действий перезагрузите компьютер.

Если проблема не возникает повторно, удаленные параметры необходимо вернуть в следующем порядке.
1. Значки из папки «Автозагрузка» для всех пользователей и текущего пользователя.
2. Значения, сохраненные в файлах HKCURun_(имя_параметра).
3. Значения, сохраненные в файлах HKLMRun_(имя_параметра).
4. Значение, сохраненное в файле HKCUload.

Чтобы добавить значки в папку Автозагрузка, выполните следующие действия.
1. Нажмите кнопку Пуск и выберите команды Программы, Стандартные и Проводник.
2. Откройте созданную ранее папку SysDriversBak, затем — AllUsersStartup, выберите в меню Правка команду Выделить все, а затем выберите в меню Правка команду Копировать.
3. Откройте следующую папку и выберите в меню Правка команду Вставить:
\Documents and Settings\All Users\Главное меню\Программы\Автозагрузка
4. Перейдите в папку SysDriversBak\UserStartup и выберите в меню Правка команду Копировать.
5. Перейдите в следующую папку и выберите в меню Правка команду Вставить:
\Documents and Settings\имя_пользователя\Главное меню\Программы\Автозагрузка
где имя_пользователя — это имя, под которым пользователь вошел в систему.
6. Загрузите компьютер и проверьте, исчезла ли ошибка.

Проверка профилей пользователей
Возможна ситуация, когда повреждены сведения только об одном пользователе, а другие пользователи этого же компьютера не испытывают проблем при работе. Для проведения соответствующей проверки войдите в систему под другим именем или создайте новую учетную запись.
Примечание. В некоторых случаях программа работает правильно только после входа в систему с помощью созданной по умолчанию учетной записи «Администратор». Такое поведение характерно для устаревших программ.
Все сведения о конфигурации пользователя (содержатся в разделе реестра HKEY_CURRENT_USER) хранятся в файле Ntuser.dat, находящемся в папке \Documents and Settings\имя_пользователя.


FAQ по Microsoft Windows XP | Настройка

Перечень всех вопросов раздела Настройка

  1. Как отключить автоматическое распознавание диска (CD-Rom).

  2. Как перейти от файловой системы NTFS к FAT32.

  3. Какую файловую систему лучше выбрать FAT32 или NTFS.

  4. Как переключиться с тонального набора на импульсный?

  5. Как изменить букву локального диска или CD.

  6. Как отключить сообщение о том, что недостаточно свободного места на диске.

  7. Как настроить систему на запрос пароля при выходе из ждущего режима.

  8. В меню "Установка компонентов Windows" Windows XP нет некоторых программ. Как их удалить.

  9. Где можно задать количество времени после которого не отвечающая на запросы программа считается системой зависшей.

  10. Правда ли, что служба QoS ограничивает скорость сети? Как ее отключить.

  11. При попытке добавить пользователя в группу выдается ошибка "Служба сервер не запущена".

  12. При установке некоторых программ выдается ошибка: "вы не имеете достаточных прав для создания файлов или папок в вашей временной папке"

  13. Установка и удаление программ: скрыть программу в списке установленных

  14. Установка и удаление программ: оснастка не отвечает на запросы после удаления обновления системы безопасности KB840374

  15. Установка и удаление программ: Отключение ограничений

  16. Установка и удаление программ: Отображение всех программ и компонент

  17. Установка и удаление программ: Удаление некорректных записей

  18. Установка и удаление программ: Ошибка 1719. Нет доступа к службе установки Windows

  19. Установка и удаление программ: включение ограничений использования оснастки

  20. Установка и удаление программ: Сообщение об ошибке синтаксиса при удалении SP1 (в строке 472) или SP2 (в строке 521)

  21. Открытие приложения через Пуск - Выполнить без указания полного пути к исполняемому файлу

  22. Автозаполнение: Internet Explorer не сохраняет имени пользователя и пароля

  23. Автозаполнение: Ветви реестра в которых сохраняются значения

  24. Добавление оснастки управления пользователями в стиле Windows 2000 (Control UserPasswords2) в панель управления

  25. Автоматическое завершение не отвечающих на запросы программ при выключении компьютера

  26. Как удалить медиа файл (*.avi) если при попытке удаления появляется сообщение об ошибке совместного доступа

  27. Восстановление значений по умолчанию для EXE и REG файлов

  28. Восстановление значений по умолчанию для LNK файлов


Автозаполнение: Internet Explorer не сохраняет имени пользователя и пароля

FAQ по Microsoft Windows XP | Настройка

Q: Автозаполнение: Internet Explorer не сохраняет имени пользователя и пароля

Проверьте, запущена ли служба «Защищенное хранилище», если она запущена перезапустите службу. Тип запуска службы должен быть в положении Авто

Перерегистрируйте RSABase.dll
Пуск - Выполнить - в поле Открыть напишите следующую команду:
Regsvr32 /u RSABase.dll
Пуск - Выполнить - в поле Открыть напишите следующую команду:
Regsvr32 RSABase.dll


Автозаполнение: Ветви реестра в которых сохраняются значения

FAQ по Microsoft Windows XP | Настройка

Q: Автозаполнение: Ветви реестра в которых сохраняются значения

Данные применяемые при автозаполнении некоторых приложений сохраняются в следующих ветвях реестра:
Internet Explorer:
[HKEY_CURRENT_USER\Software\Microsoft\Protected Storage System Provider\S-1-5-21-839522115-1708537768-1343024091-1003\Data\e161255a-37c3-11d2-bcaa-00c04fd929db]

Outlook Express:
[HKEY_CURRENT_USER\Software\Microsoft\Protected Storage System Provider\S-1-5-21-839522115-1708537768-1343024091-1003\Data\220d5cc1-853a-11d0-84bc-00c04fd43f8f]

FTP, Front Page и пароли защищенных веб-страниц:
[HKEY_CURRENT_USER\Software\Microsoft\Protected Storage System Provider\S-1-5-21-839522115-1708537768-1343024091-1003\Data\5e7e8100-9138-11d1-945a-00c04fc308ff]

Outlook 2002: HKEY_CURRENT_USER\Software\Microsoft\Protected Storage System Provider\S-1-5-21-839522115-1708537768-1343024091-1003\Data\220d5cd0-853a-11d0-84bc-00c04fd43f8f]

Примечание: идентификатор начинающийся с S-1-5-21-839522........ может отличаться от того который прописан на вашем компьютере


Автоматическое завершение не отвечающих на запросы программ при выключении компьютера

FAQ по Microsoft Windows XP | Настройка

Q: Автоматическое завершение не отвечающих на запросы программ при выключении компьютера

[HKEY_USERS\.DEFAULT\Control Panel\Desktop]
Параметр: AutoEndTasks
Тип: REG_SZ
Значение: (0 = отключено, 1 = включено)


В меню "Установка компонентов Windows" Windows XP нет некоторых программ. Как их удалить

FAQ по Microsoft Windows XP | Настройка

Q: В меню "Установка компонентов Windows" Windows XP нет некоторых программ. Как их удалить

Чтобы удалить скрытые компоненты нужно открыть блокнотом файл sysoc.inf из C:\Windows\Inf.

В разделе [Components] в содержании некоторых строк стоит слово hide.

Например:
msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7
Слово hide необходимо удалить, при этом не трогая запятые, таким образом должно получиться так:
msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,,7
Теперь в меню "Установка компонентов Windows" будут отображены компоненты которых не было раньше


Восстановление значений по умолчанию для EXE и REG файлов

FAQ по Microsoft Windows XP | Настройка

Q: Восстановление значений по умолчанию для EXE и REG файлов

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.exe]
@="exefile"
"Content Type"="application/x-msdownload"

[HKEY_CLASSES_ROOT\.exe\PersistentHandler]
@="{098f2470-bae0-11cd-b579-08002b30bfeb}"

[HKEY_CLASSES_ROOT\exefile]
@="Application"
"EditFlags"=hex:38,07,00,00
"TileInfo"="prop:FileDescription;Company;FileVersion"
"InfoTip"="prop:FileDescription;Company;FileVersion;Create;Size"

[HKEY_CLASSES_ROOT\exefile\DefaultIcon]
@="%1"

[HKEY_CLASSES_ROOT\exefile\shell]

[HKEY_CLASSES_ROOT\exefile\shell\open]
"EditFlags"=hex:00,00,00,00

[HKEY_CLASSES_ROOT\exefile\shell\open\command]
@="\"%1\" %*"

[HKEY_CLASSES_ROOT\exefile\shell\runas]

[HKEY_CLASSES_ROOT\exefile\shell\runas\command]
@="\"%1\" %*"

[HKEY_CLASSES_ROOT\exefile\shellex]

[HKEY_CLASSES_ROOT\exefile\shellex\DropHandler]
@="{86C86720-42A0-1069-A2E8-08002B30309D}"

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers]

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\PEAnalyser]
@="{09A63660-16F9-11d0-B1DF-004F56001CA7}"

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\PifProps]
@="{86F19A00-42A0-1069-A2E9-08002B30309D}"

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\ShimLayer Property Page]
@="{513D916F-2A8E-4F51-AEAB-0CBC76FB1AF8}"

[HKEY_CLASSES_ROOT\regfile]
@="Registration Entries"
"EditFlags"=dword:00100000
"BrowserFlags"=dword:00000008

[HKEY_CLASSES_ROOT\regfile\DefaultIcon]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,72,00,65,00,67,00,65,00,64,00,69,00,74,00,2e,00,65,00,78,00,65,00,\
2c,00,31,00,00,00

[HKEY_CLASSES_ROOT\regfile\shell]
@="open"

[HKEY_CLASSES_ROOT\regfile\shell\edit]

[HKEY_CLASSES_ROOT\regfile\shell\edit\command]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,4e,00,4f,00,\
54,00,45,00,50,00,41,00,44,00,2e,00,45,00,58,00,45,00,20,00,25,00,31,00,00,\
00

[HKEY_CLASSES_ROOT\regfile\shell\open]
@="Mer&ge"

[HKEY_CLASSES_ROOT\regfile\shell\open\command]
@="regedit.exe \"%1\""

[HKEY_CLASSES_ROOT\regfile\shell\print]

[HKEY_CLASSES_ROOT\regfile\shell\print\command]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,4e,00,4f,00,\
54,00,45,00,50,00,41,00,44,00,2e,00,45,00,58,00,45,00,20,00,2f,00,70,00,20,\
00,25,00,31,00,00,00

[HKEY_CLASSES_ROOT\.lnk]
@="lnkfile"

[HKEY_CLASSES_ROOT\.lnk\ShellEx]

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{000214EE-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{000214F9-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{00021500-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellNew]
"Command"="rundll32.exe appwiz.cpl,NewLinkHere %1"

[HKEY_CLASSES_ROOT\lnkfile]
@="Shortcut"
"EditFlags"=dword:00000001
"IsShortcut"=""
"NeverShowExt"=""

[HKEY_CLASSES_ROOT\lnkfile\CLSID]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\lnkfile\shellex]

[HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers]

[HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers\Offline Files]
@="{750fdf0e-2a26-11d1-a3ea-080036587f03}"

[HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers\{00021401-0000-0000-C000-000000000046}]

[HKEY_CLASSES_ROOT\lnkfile\shellex\DropHandler]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\lnkfile\shellex\IconHandler]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\lnkfile\shellex\PropertySheetHandlers]

[HKEY_CLASSES_ROOT\lnkfile\shellex\PropertySheetHandlers\ShimLayer Property Page]
@="{513D916F-2A8E-4F51-AEAB-0CBC76FB1AF8}"

[HKEY_CLASSES_ROOT\CLSID\{00021401-0000-0000-C000-000000000046}]
@="Shortcut"

[HKEY_CLASSES_ROOT\CLSID\{00021401-0000-0000-C000-000000000046}\InProcServer32]
@="shell32.dll"
"ThreadingModel"="Apartment"

[HKEY_CLASSES_ROOT\CLSID\{00021401-0000-0000-C000-000000000046}\PersistentAddinsRegistered]

[HKEY_CLASSES_ROOT\CLSID\{00021401-0000-0000-C000-000000000046}\PersistentAddinsRegistered\{89BCB740-6119-101A-BCB7-00DD010655AF}]
@="{00021401-0000-0000-C000-000000000046}"
[HKEY_CLASSES_ROOT\CLSID\{00021401-0000-0000-C000-000000000046}\PersistentHandler]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\CLSID\{00021401-0000-0000-C000-000000000046}\ProgID]
@="lnkfile"

[HKEY_CLASSES_ROOT\CLSID\{00021401-0000-0000-C000-000000000046}\shellex]

[HKEY_CLASSES_ROOT\CLSID\{00021401-0000-0000-C000-000000000046}\shellex\MayChangeDefaultMenu]


Восстановление значений по умолчанию для LNK файлов

FAQ по Microsoft Windows XP | Настройка

Q: Восстановление значений по умолчанию для LNK файлов

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.lnk]
@="lnkfile"

[HKEY_CLASSES_ROOT\.lnk\ShellEx]

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{000214EE-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{000214F9-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{00021500-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellNew]
"Command"="rundll32.exe appwiz.cpl,NewLinkHere %1"

[HKEY_CLASSES_ROOT\lnkfile]
@="Shortcut"
"EditFlags"=dword:00000001
"IsShortcut"=""
"NeverShowExt"=""

[HKEY_CLASSES_ROOT\lnkfile\CLSID]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\lnkfile\shellex]

[HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers]

[HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers\Offline Files]
@="{750fdf0e-2a26-11d1-a3ea-080036587f03}"

[HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers\{00021401-0000-0000-C000-000000000046}]

[HKEY_CLASSES_ROOT\lnkfile\shellex\DropHandler]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\lnkfile\shellex\IconHandler]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\lnkfile\shellex\PropertySheetHandlers]

[HKEY_CLASSES_ROOT\lnkfile\shellex\PropertySheetHandlers\ShimLayer Property Page]
@="{513D916F-2A8E-4F51-AEAB-0CBC76FB1AF8}"

[HKEY_CLASSES_ROOT\CLSID\{00021401-0000-0000-C000-000000000046}]
@="Shortcut"

[HKEY_CLASSES_ROOT\CLSID\{00021401-0000-0000-C000-000000000046}\InProcServer32]
@="shell32.dll"
"ThreadingModel"="Apartment"

[HKEY_CLASSES_ROOT\CLSID\{00021401-0000-0000-C000-000000000046}\PersistentAddinsRegistered]

[HKEY_CLASSES_ROOT\CLSID\{00021401-0000-0000-C000-000000000046}\PersistentAddinsRegistered\{89BCB740-6119-101A-BCB7-00DD010655AF}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\CLSID\{00021401-0000-0000-C000-000000000046}\PersistentHandler]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\CLSID\{00021401-0000-0000-C000-000000000046}\ProgID]
@="lnkfile"

[HKEY_CLASSES_ROOT\CLSID\{00021401-0000-0000-C000-000000000046}\shellex]

[HKEY_CLASSES_ROOT\CLSID\{00021401-0000-0000-C000-000000000046}\shellex\MayChangeDefaultMenu]

[HKEY_CLASSES_ROOT\.exe]
@="exefile"
"Content Type"="application/x-msdownload"

[HKEY_CLASSES_ROOT\.exe\PersistentHandler]
@="{098f2470-bae0-11cd-b579-08002b30bfeb}"

[HKEY_CLASSES_ROOT\exefile]
@="Application"
"EditFlags"=hex:38,07,00,00
"TileInfo"="prop:FileDescription;Company;FileVersion"
"InfoTip"="prop:FileDescription;Company;FileVersion;Create;Size"

[HKEY_CLASSES_ROOT\exefile\DefaultIcon]
@="%1"

[HKEY_CLASSES_ROOT\exefile\shell]

[HKEY_CLASSES_ROOT\exefile\shell\open]
"EditFlags"=hex:00,00,00,00

[HKEY_CLASSES_ROOT\exefile\shell\open\command]
@="\"%1\" %*"

[HKEY_CLASSES_ROOT\exefile\shell\runas]

[HKEY_CLASSES_ROOT\exefile\shell\runas\command]
@="\"%1\" %*"

[HKEY_CLASSES_ROOT\exefile\shellex]

[HKEY_CLASSES_ROOT\exefile\shellex\DropHandler]
@="{86C86720-42A0-1069-A2E8-08002B30309D}"

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers]

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\PEAnalyser]
@="{09A63660-16F9-11d0-B1DF-004F56001CA7}"

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\PifProps]
@="{86F19A00-42A0-1069-A2E9-08002B30309D}"

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\ShimLayer Property Page]
@="{513D916F-2A8E-4F51-AEAB-0CBC76FB1AF8}"

[HKEY_CLASSES_ROOT\regfile]
@="Registration Entries"
"EditFlags"=dword:00100000
"BrowserFlags"=dword:00000008

[HKEY_CLASSES_ROOT\regfile\DefaultIcon]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,72,00,65,00,67,00,65,00,64,00,69,00,74,00,2e,00,65,00,78,00,65,00,\
2c,00,31,00,00,00

[HKEY_CLASSES_ROOT\regfile\shell]
@="open"

[HKEY_CLASSES_ROOT\regfile\shell\edit]

[HKEY_CLASSES_ROOT\regfile\shell\edit\command]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,4e,00,4f,00,\
54,00,45,00,50,00,41,00,44,00,2e,00,45,00,58,00,45,00,20,00,25,00,31,00,00,\
00

[HKEY_CLASSES_ROOT\regfile\shell\open]
@="Mer&ge"

[HKEY_CLASSES_ROOT\regfile\shell\open\command]
@="regedit.exe \"%1\""

[HKEY_CLASSES_ROOT\regfile\shell\print]

[HKEY_CLASSES_ROOT\regfile\shell\print\command]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,4e,00,4f,00,\
54,00,45,00,50,00,41,00,44,00,2e,00,45,00,58,00,45,00,20,00,2f,00,70,00,20,\
00,25,00,31,00,00,00


Где можно задать количество времени после которого не отвечающая на запросы программа считается системой зависшей

FAQ по Microsoft Windows XP | Настройка

Q: Где можно задать количество времени после которого не отвечающая на запросы программа считается системой зависшей

В реестре в ветке
HKEY_CURRENT_USER\Control Panel\Desktop
параметр: HungAppTimeout
значение: время после которого приложение будет считаться зависшим в миллисекундах (по умолчанию значение составляет 5000 мс)

В этой же ветке есть параметры WaitToKillServiceTimeout и WaitToKillAppTimeout, определяющие время ожидания до закрытия зависшей службы и приложения соответственно (значения по умолчанию 20000 мс).

Еще в этой ветке есть параметр AutoEndTasks, если установить его значение 1 (по умолчанию 0), можно разрешить системе автоматически закрывать зависшие приложения.


Добавление оснастки управления пользователями в стиле Windows 2000 (Control UserPasswords2) в панель управления

FAQ по Microsoft Windows XP | Настройка

Q: Добавление оснастки управления пользователями в стиле Windows 2000 (Control UserPasswords2) в панель управления

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\CLSID\{98641F47-8C25-4936-BEE4-C2CE1298969D}]
@="Учетные записи пользователей 2"
"InfoTip"="Консоль "Учетные записи пользователей" в стиле Windows 2000"

[HKEY_CLASSES_ROOT\CLSID\{98641F47-8C25-4936-BEE4-C2CE1298969D}\DefaultIcon]
@="%SystemRoot%\System32\netplwiz.dll,-102"

[HKEY_CLASSES_ROOT\CLSID\{98641F47-8C25-4936-BEE4-C2CE1298969D}\Shell]

[HKEY_CLASSES_ROOT\CLSID\{98641F47-8C25-4936-BEE4-C2CE1298969D}\Shell\Open]

[HKEY_CLASSES_ROOT\CLSID\{98641F47-8C25-4936-BEE4-C2CE1298969D}\Shell\Open\command]
@="rundll32.exe netplwiz.dll,UsersRunDll" //здесь можно использовать просто команду Control Userpasswords2//

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace\{98641F 47-8C25-4936-BEE4-C2CE1298969D}]
@="Добавляет Учетные записи пользователей 2 на панель управления"


Как изменить букву локального диска или CD

FAQ по Microsoft Windows XP | Настройка

Q: Как изменить букву локального диска или CD

Панель управления -> Администрирование -> Управление компьютером -> Управление дисками -> Правая клавиша мыши -> Изменить букву диска


Как настроить систему на запрос пароля при выходе из ждущего режима

FAQ по Microsoft Windows XP | Настройка

Q: Как настроить систему на запрос пароля при выходе из ждущего режима

В реестре в ветке
HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\System\Power
параметр PromptPasswordOnResume (если его нет, то создайте)
тип DWORD
значение 1


Как отключить автоматическое распознавание диска (CD-Rom)

FAQ по Microsoft Windows XP | Настройка

Q: Как отключить автоматическое распознавание диска (CD-Rom)

В реестре в ветке

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CDRom
паpаметp: Autorun
тип: REG_DWORD
значение: 0=отключено, 1=включено

Примечание: если проделать это для пишущего привода, то можно потерять возможность писать и стирать диски средствами Windows. На работу сторонних программ для записи это влияет.

© Все права защищены OSzone.net 2001-2006


Как отключить сообщение о том что недостаточно свободного места на диске

FAQ по Microsoft Windows XP | Настройка

Q: Как отключить сообщение о том что недостаточно свободного места на диске

В реестре в ветке
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
создать параметр NoLowDiskSpaceChecks
тип DWORD
значение 1.


Как перейти от файловой системы NTFS к FAT32

FAQ по Microsoft Windows XP | Настройка

Q: Как перейти от файловой системы NTFS к FAT32

Конвертация отличается от форматирования тем, что все файлы остаются там, где они и были, целыми и невредимыми.

Способы конвертации FAT в NTFS:
Вы можете выбрать опцию конвертации в процессе установки Windows XP. Программа установки начнёт проверять текущую файловую систему. Если это - NTFS, конвертировать раздел, естественно, не нужно. Если это - FAT или FAT32, программа установки даст вам возможность преобразования в NTFS.
В случае если вам не нужно сохранять ваши данные и у вас файловая система диска FAT32, рекомендуется полное форматирование а не конвертация раздела. (Форматирование стирает все данные с раздела.

Конвертация в NTFS и вычисление объема таблицы MFS

Чтобы преобразовать диск с FAT или FAT32 в NTFS, воспользуйтесь утилитой командной строки Convert (Start -> Run -> cmd). Синтаксис у неё такой:

convert d:/fs:ntfs
где d - буква нужного диска.

Утилита Convert может работать и в Windows, если выбранный диск не используется. Если же вы хотите преобразовать системный диск или диск, на котором размещён файл подкачки, в ответ будет выведено сообщение об ошибке. В таком случае вам придётся отложить начатое до следующего запуска Windows. После перезагрузки компьютера появится сообщение о том, что сейчас начнётся преобразование диска. У вас будет 10 секунд на то, чтобы отменить его. Если вы не прервёте операцию, Windows запустит утилиту Chkdsk, после чего проведёт автоматическую переразметку диска. Во время этого процесса компьютер перезагрузиться дважды.
Чтобы улучшить производительность системы, запустите команду Convert с ключом /Cvtarea. При этом основная таблица файлов (Master file table), содержащая информацию обо всех файлах и папках данного диска, будет создана в непрерывном свободном участке (без фрагментации). Хотя программа Дефрагментация диска, входящая в состав WindowsXP, работает с MFS, она не в состоянии переместить первый фрагмент. По сути, это ограничение гарантирует фрагментацию MFT, если только вы не будете следовать приведённым ниже рекомендациям по преобразованию диска в NTFS.

1. Дефрагментируйте диск, который вы хотите преобразовать, с помощью программы WindowsXP Дефрагментация диска.

2. Вычислите размер таблицы MFT. По умолчанию размер этой таблицы равен 12,5 % от размера раздела. На разделе в 10 Гбайт под таблицу будет отведено около 1,25 Гбайт.

3. С помощью команды Fsutil создайте новый непрерывный файл, равный по размеру таблице MFT. Этот файл должен находиться в корневой папке диска, подлежащего преобразованию. В нашем примере команда должна быть такой:
Fsutil file createnew c:\testfile.txt 1250000000

4. Вы можете указать любое имя файла. Объём файла (последний параметр) указывается в байтах.

5. Запустите команду Convert (Start -> Run -> cmd) со следующим синтаксисом:
convert c:/fs:ntfs /cvtarea:testfile.txt

6. Не забудьте указать нужную букву диска.

7. При необходимости перезагрузите компьютер.

Вы так же можете использовать Partion Magic (последняя версия 8.0), разработанную PowerQuest.

Способы конвертации NTFS в FAT : Хотя Microsoft официально не подтверждает возможность такой конвертации, это возможно.
Здесь вам поможет утилита, упомянутая выше - Partion Magic 7.0 Pro, 8.0 (не более ранних версий!).


Как переключиться с тонального набора на импульсный

FAQ по Microsoft Windows XP | Настройка

Q: Как переключиться с тонального набора на импульсный

Для этого отметьте опцию в свойствах подключения "Использовать правила набора номера"

Вместо этого можно перед номером поставить латинскую букву "p".


Как удалить медиа файл (*.avi) если при попытке удаления появляется сообщение об ошибке совместного доступа

FAQ по Microsoft Windows XP | Настройка

Q: Как удалить медиа файл (*.avi) если при попытке удаления появляется сообщение об ошибке совместного доступа

Закройте все приложения
Пуск - Выполнить - cmd - перейдите в каталог в котором необходимо удалить файлы
Откройте диспетчер задач и завершите процесс explorer.exe
Теперь перед вами осталось только окно командной строки и диспетчера задач
Воспользуйтесь командой DEL для удаления (DEL *.mpg, DEL mus*.avi, DEL test.wmv, etc.)
После удаления файлов в диспетчере задач войдите в меню Файл - Новая задача (выполнить) - напишите explorer.exe и нажмите OK

Вы также можете воспользоваться программой Unlocker, которая поможет вам легко снять блокировку с файлов.


Какую файловую систему лучше выбрать FAT32 или NTFS

FAQ по Microsoft Windows XP | Настройка

Q: Какую файловую систему лучше выбрать FAT32 или NTFS

Всё зависит от того, с какой целью вы используете компьютер, и сколько у вас оперативной памяти. Следует учесть, что NTFS работает несколько медленнее, чем FAT, из-за дополнительно загружаемых сервисов и её системы безопасности. Если у вас мало оперативной памяти, и вы решили поставить себе XP, то вам однозначно нельзя ставить себе NTFS. Если у вас 128MB или больше, то можно уже подумать об NTFS. Следует взвесить преимущества и недостатки NTFS для простого пользователя и решить, что вам нужно.

К преимуществам FAT32 можно отнести то, что она быстрее и требует меньше памяти для работы. Если система работает только с FAT32, то в память не грузятся драйвера и сервисы, необходимые NTFS. Кроме этого, при использовании FAT32 имеется возможность доступа к диску при загрузке с загрузочного диска Windows 9x.

Преимущества NTFS для простого пользователя можно описать одним ёмким словом: нерушимый. На полном серьёзе, вышибить NTFS чрезвычайно сложно, хоть и возможно. Для опыта запускалась куча различных приложений, оптимизаторы диска, и в самые неподходящие моменты жалась кнопка reset. Повторение этого садизма добрый десяток раз никакого впечатления на систему не произвело, она продолжала работать без ошибок. Кроме этого, NTFS обладает встроенными средствами шифрования файлов, что обеспечивает определённую уверенность в сохранности данных. Конечно, при условии что система не будет переустанавливаться.

Оба FAT32 и NTFS используют таблицу, в которой определено местонахождение каждого файла. Это служит как индекс: когда запрашивается той или иной файл, в таблице проверяется же физически этот файл лежит на жёстком диске. Если система рухнет в тот момент записи файла, таблица может повредиться, что влечёт за собой потерю данных. NTFS в качестве дополнительной подстраховки использует transaction log. Если крах происходит при записи файла, потерявшаяся информация может быть извлечена через этот лог. И восстановление данных с помощью лога происходит автоматически; никакое участие пользователя не потребуется.

С NTFS, Windows NT/2000/XP может использовать разделы от 200 MB до 256 TB (1 TeraByte = 1024 GB).
Из-за 64- битовой адресации, в NTFS размеры кластеров меньше. Жесткий диск должен быть поделён на кластеры, чтобы иметь доступ к файлу. Каждый кластер требует уникальный адрес:

NTFS имеет 264 (64) (18,446,744,073,709,551,616) возможных адресов
FAT32 всего 232 (32) (4,294,967,296)
Поскольку один кластер может быть использован только одним файлом, много места может быль просто потеряно, если файл не заполняет полностью тот кластер, который он использует. С увеличением количества возможных адресов, уменьшается размер каждого кластера сводя к минимуму объём потерянного места.

C учётом всех факторов: если ваш компьютер отвечает сегодняшним стандартам, использование NTFS будет для вас только выигрышно.


Открытие приложения через Пуск - Выполнить без указания полного пути к исполняемому файлу

FAQ по Microsoft Windows XP | Настройка

Q: Открытие приложения через Пуск - Выполнить без указания полного пути к исполняемому файлу

Для этого вам нужно внести следующие изменения в реестр:
1. [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\App Paths]
Создайте подраздел с именем равным имени исполняемого файла программы с расширением, например для Far Manager название подраздела должно быть таким:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\Far.exe]

2. Создайте два параметра в новом подразделе:
а.
Параметр: (По умолчанию)
Тип: REG_SZ
Значение: "C:\Program Files\Far\Far.exe" (путь к исполняемому файлу программы)
б.
Параметр: Path
Тип: REG_SZ
Значение: "C:\Program Files\Far" (путь к каталогу программы)


Правда ли, что служба QoS ограничивает скорость сети? Как ее отключить

FAQ по Microsoft Windows XP | Настройка

Q: Правда ли, что служба QoS ограничивает скорость сети? Как ее отключить

В некоторых публикациях и группах новостей заявлялось, что Windows XP всегда резервирует под нужды механизма QoS 20% доступной полосы пропускания.

Данное утверждение неверно.

В Windows XP, как и в Windows 2000, программы используют механизмы QoS посредством интерфейсов API QoS. Если отсутствуют программы, требующие приоритетного доступа к сети, то программы сообща используют всю пропускную способность сети.
Если программа, «зарезервировала» пропускную способность, но не передает данные, то эта пропускная способность также может использоваться остальными программами.

По умолчанию на конечном компьютере программа может резервировать до 20% суммарной пропускной способности каждого интерфейса. Если программа, зарезервировавшая пропускную способность, использует ее не полностью, то неиспользуемая часть доступна для других программ.

За дополнительной информацией по данному вопросу вы можете обратиться к этой статье MSKB:
Механизм качества обслуживания (QoS) в Windows XP


При попытке добавить пользователя в группу выдается ошибка "Служба сервер не запущена"

FAQ по Microsoft Windows XP | Настройка

Q: При попытке добавить пользователя в группу выдается ошибка "Служба сервер не запущена"

Проблема
Когда вы пытаетесь добавить пользователя в группу, вы получаете следующее сообщение об ошибке и пользователь не добавляется в группу:

Локальные пользователи и Группы
Ошибка изменения свойств для пользователя UserName:
Служба Сервер не запущена.

Причина
Это может происходить в случае если служба Сервер не запущена или не установлена.

Решение
Для решения данной проблемы воспользуйтесь одним из следующих способов, в том порядке, в котором они представлены, проверяя не решена ли проблема после применения каждого способа.

Способ 1
Запустите службу Сервер, для этого проделайте следующее:
1. Нажмите Пуск, выберите Выполнить, введите services.msc в открывшемся окне, и нажмите OK.
2. В списке Служб выберите службу Сервер.
3. В открывшемся окне нажмите кнопку Пуск для запуска службы.

Способ 2
Если служба Сервер отсутствует в списке служб, установите службу доступа к файлам и принтерам для сетей Microsoft.
Следуйте следующим инструкция что бы сделать это:
1. Нажмите Пуск, выберите Выполнить, в открывшемся окне напишите ncpa.cpl и нажмите OK.
2. На ярлыке Подключение по локальной сети нажмите правую кнопку мыши и выберите Свойства.
3. Выберите вкладку Общие и нажмите Установить.
4. Выберите Служба и нажмите Добавить.
5. В списке Сетевые Службы выберите Службу доступа к файлам и принтерам сетей Microsoft и нажмите OK.
6. Нажмите Закрыть.

Способ 3
Если Службу доступа к файлам и принтерам для сетей Microsoft не удается установить в сетевом окружении, добавьте пользователя в соответствующую группу вручную.
Для этого проделайте следующее:
1. Нажмите Пуск, выберите Выполнить, введите compmgmt.msc в открывшемся окне, и нажмите OK
2. Раскройте Управление компьютером (локальным), раскройте Служебные программы, раскройте Локальные Пользователи и Группу и выберите Группы.
3. На правой панели, нажмите правой кнопкой мыши на соответствующей группе в которую вы хотите добавить пользователя и выберите Добавить в Группу.
4. Нажмите Добавить, напишите имя учетной записи которую вы хотите добавить в группу и нажмите OK.


При установке некоторых программ выдается ошибка: "вы не имеете достаточных прав для создания файлов или папок в вашей временной папке"

FAQ по Microsoft Windows XP | Настройка

Q: При установке некоторых программ выдается ошибка: "вы не имеете достаточных прав для создания файлов или папок в вашей временной папке"

Чаще всего это происходит из-за того, что путь к временной папке (Temp) содержит кириллические символы. Инсталляторы некоторых программ не могут корректно работать с такими символами.

По умолчанию переменная пользователя располагается по пути %UserProfile%\Local Settings\Temp\

Что бы назначить каталог для временных файлов по другому пути выполните следующие действия:

1. Зайдите в Панель управления и откройте ярлык Система
2. Перейдите на вкладку Дополнительно
3. Нажмите Переменные среды
4. Выберите переменную Temp в разделе Переменные среды пользователя Имя_Пользователя и нажмите Изменить
5. Измените путь например на C:\Temp
Примечание: каталог который назначается в качестве переменной Temp должен быть создан вручную, система не создаст его.
6. Проделайте процедуру из п.5 для переменной Tmp

Наглядно вышеперечисленные действия показаны на скриншоте.

Если предоставленной информации оказалось недостаточно для решения вашей задачи вы можете
задать вопрос в этой теме форума OSZone.net.


Установка и удаление программ: включение ограничений использования оснастки

FAQ по Microsoft Windows XP | Настройка

Q: Установка и удаление программ: включение ограничений использования оснастки

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
Параметр: NoAddRemovePrograms (Отключает запуск Установка и удаление программ)
Тип: REG_DWORD
Значение: (0 = ограничение отключено, 1 = ограничение включено)
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
Параметр: NoRemovePage (Отключает возможность изменения или удаления программ)
Тип: REG_DWORD
Значение: (0 = ограничение отключено, 1 = ограничение включено)
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
Параметр: NoAddPage (Отключает возможность добавления программ)
Тип: REG_DWORD
Значение: (0 = ограничение отключено, 1 = ограничение включено)
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
Параметр: NoWindowsSetupPage (Отключает раздел Компоненты Windows)
Тип: REG_DWORD
Значение: (0 = ограничение отключено, 1 = ограничение включено)
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
Параметр: NoAddFromCDorFloppy (Отключает возможность добавления программы с CD)
Тип: REG_DWORD
Значение: (0 = ограничение отключено, 1 = ограничение включено)
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
Параметр: NoAddFromNetwork (Отключает возможность добавления программы с сетевого ресурса)
Тип: REG_DWORD
Значение: (0 = ограничение отключено, 1 = ограничение включено)
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
Параметр: NoServices (Открывает сразу мастер установки Компонент Windows)
Тип: REG_DWORD
Значение: (0 = ограничение отключено, 1 = ограничение включено)
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
Параметр: NoSupportInfo (Скрывает информацию о поддержке)
Тип: REG_DWORD
Значение: (0 = ограничение отключено, 1 = ограничение включено)


Установка и удаление программ: оснастка не отвечает на запросы после удаления обновления системы безопасности KB840374

FAQ по Microsoft Windows XP | Настройка

Q: Установка и удаление программ: оснастка не отвечает на запросы после удаления обновления системы безопасности KB840374

Для решения проблемы используйте утилиту Spuninst.exe для удаления этого исправления. Утилита располагается в папке %Windir%\$NTUninstallKB840374$\Spuninst


Установка и удаление программ: Отключение ограничений

FAQ по Microsoft Windows XP | Настройка

Q: Установка и удаление программ: Отключение ограничений

  • Отключение запрета использования оснастки
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
    Параметр: NoAddRemovePrograms
    Тип: REG_DWORD
    Значение: 0
  • Отключение ограничений ранее примененных к оснастке
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall]
    "NoAddRemovePrograms"=dword:00000000
    "NoRemovePage"=dword:00000000
    "NoAddPage"=dword:00000000
    "NoWindowsSetupPage"=dword:00000000
    "NoAddfromCDorFloppy"=dword:00000000
    "NoAddfromInternet"=dword:00000000
    "NoAddfromNetwork"=dword:00000000
    "NoServices"=dword:00000000
    "NoSupportInfo"=dword:00000000


Установка и удаление программ: Отображение всех программ и компонент

FAQ по Microsoft Windows XP | Настройка

Q: Установка и удаление программ: Отображение всех программ и компонент

Windows XP отображает не все компоненты установленные по умолчанию в апплете Установка и удаление программ, например таких как игры, messenger и т.п.
Перейдите в каталог %windir%\Inf и найдите в нем файл sysoc.inf и в нем найдите секцию [Components]
[Components]
NtComponents=ntoc.dll,NtOcSetupProc,,4
WBEM=ocgen.dll,OcEntry,wbemoc.inf,hide,7
Display=desk.cpl,DisplayOcSetupProc,,7
Fax=fxsocm.dll,FaxOcmSetupProc,fxsocm.inf,,7
NetOC=netoc.dll,NetOcSetupProc,netoc.inf,,7
iis=iis.dll,OcEntry,iis.inf,,7
com=comsetup.dll,OcEntry,comnt5.inf,hide,7
dtc=msdtcstp.dll,OcEntry,dtcnt5.inf,hide,7
IndexSrv_System = setupqry.dll,IndexSrv,setupqry.inf,,7
TerminalServer=TsOc.dll, HydraOc, TsOc.inf,hide,2
msmq=msmqocm.dll,MsmqOcm,msmqocm.inf,,6
ims=imsinsnt.dll,OcEntry,ims.inf,,7
fp_extensions=fp40ext.dll,FrontPage4Extensions,fp40ext.inf,,7
AutoUpdate=ocgen.dll,OcEntry,au.inf,hide,7
msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7
WMAccess=ocgen.dll,OcEntry,wmaccess.inf,,7
RootAutoUpdate=ocgen.dll,OcEntry,rootau.inf,,7
IEAccess=ocgen.dll,OcEntry,ieaccess.inf,,7
OEAccess=ocgen.dll,OcEntry,oeaccess.inf,,7
WMPOCM=ocgen.dll,OcEntry,wmpocm.inf,,7

Games=ocgen.dll,OcEntry,games.inf,,7
AccessUtil=ocgen.dll,OcEntry,accessor.inf,,7
CommApps=ocgen.dll,OcEntry,communic.inf,HIDE,7
MultiM=ocgen.dll,OcEntry,multimed.inf,HIDE,7
AccessOpt=ocgen.dll,OcEntry,optional.inf,HIDE,7
Pinball=ocgen.dll,OcEntry,pinball.inf,HIDE,7
MSWordPad=ocgen.dll,OcEntry,wordpad.inf,HIDE,7
ZoneGames=zoneoc.dll,ZoneSetupProc,igames.inf,,7

Удалите слово "HIDE" в тех строках которые вы хотите отобразить в Установке и удалении программ, но при этом оставьте команды и запяты в этих строках
Для вступления в силу изменений сохраните отредактированный файл и перезагрузите компьютер.

Дополнительная информация:
Как добавить или удалить стандартные игры в Microsoft Windows XP


Установка и удаление программ: Ошибка 1719. Нет доступа к службе установки Windows

FAQ по Microsoft Windows XP | Настройка

Q: Установка и удаление программ: Ошибка 1719. Нет доступа к службе установки Windows

Способ 1. Перерегистрируйте установщик Windows
Для этого проверьте размещение файла Msiexec.exe на жестком диске и в реестре Windows и перерегистрируйте установщик:
1. Проверьте размещение файла Msiexec.exe на жестком диске. Для этого выполните следующие действия:
a. Нажмите кнопку Пуск и выберите пункт Найти.
b. Щелкните ссылку Файлы и папки.
c. В поле Часть имени файла или имя файла целиком введите msiexec.exe и нажмите кнопку Найти.
d. Запомните расположение файла Msiexec.exe.
Расположение файла Msiexec.exe должно быть схожим с тем, которое приведено в следующем примере, в котором Drive соответствует диску, на который установлена Windows, а %Windir% — установочной папке Windows:
Drive:\%Windir%\System32
Пример: C:\Windows\System32.

2. Проверьте размещение файла Msiexec.exe в реестре Windows. Для этого выполните следующие действия:
a. Нажмите кнопку Пуск и выберите пункт Выполнить.
b. В поле Открыть введите команду regedit и нажмите кнопку OK.
c. Откройте следующий раздел реестра:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer]
d. Дважды щелкните на правой панели параметр ImagePath.
e. В появившемся диалоговом окне Изменение строкового параметра убедитесь, что указанный в поле Значение путь к файлу Msiexec.exe на жестком диске совпадает с путем, определенным в действии 1.
Если в поле Значение указан неправильный путь, внесите необходимые изменения и нажмите кнопку ОК.

3. Запустите компьютер в безопасном режиме и зарегистрируйте файл Msiexec.exe командой
msiexec /regserver

4. Перезагрузите компьютер в обычном режиме.
Если ошибка повторяется и по-прежнему появляется сообщение об ошибке способом 2

Способ 2. Заново установите установщик Windows

Переименуйте поврежденные файлы установщика и заново установите компонент. Для этого выполните следующие действия:
1. Нажмите кнопку Пуск и выберите пункт Выполнить.
2. В поле Открыть введите команду cmd и нажмите кнопку ОК.
3. Введите следующую строку и нажмите клавишу ВВОД (в этой строке диск — буква диска, на котором установлена Windows, а %Windir% — папка, в которой установлена Windows):
attrib -r -s -h диск:\%Windir%\system32\dllcache

4. Введите следующие команды, нажимая после каждой из них клавишу ВВОД:
ren msi.dll msi.old
ren msiexec.exe msiexec.old
ren msihnd.dll msihnd.old
5. В командной строке введите exit и нажмите клавишу ВВОД.
6. Перезагрузите компьютер.
7. Установите установщик Windows 3.1 версии 2 (3.1.4000.2435)
8. Перезагрузите компьютер в обычном режиме.


Установка и удаление программ: скрыть программу в списке установленных

FAQ по Microsoft Windows XP | Настройка

Q: Установка и удаление программ: скрыть программу в списке установленных

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall]
Перейдите в подраздел отвечающий программе и в правой панели нажмите правую клавишу мыши на параметре DisplayName и выберите Переименовать
Добавьте к имени параметра слово Quiet, у вас должно получиться:
QuietDisplayName
Для включения отображения программы произведите обратное переименование параметра DisplayName убрав слово Quiet


Установка и удаление программ: Сообщение об ошибке синтаксиса при удалении SP1 (в строке 472) или SP2 (в строке 521)

FAQ по Microsoft Windows XP | Настройка

Q: Установка и удаление программ: Сообщение об ошибке синтаксиса при удалении SP1 (в строке 472) или SP2 (в строке 521)

Ошибка может возникать если вы используете Style XP.
Зайдите в Свойства экрана - Темы - выберите тему Windows XP - попробуйте удаление снова
Переименуйте файл uxtheme.dll и восстановите оригинальный файл с дистрибутива Windows XP


Установка и удаление программ: Удаление некорректных записей

FAQ по Microsoft Windows XP | Настройка

Q: Установка и удаление программ: Удаление некорректных записей

Примечание: обязательно сделайте резервную копию ветви реестра до внесения изменений, с помощью резервной копии вы сможете восстановить исходные значения если вами будет допущена ошибка при редактировании или удалении параметров реестра.
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall]
Каждая программа отображаемая в списке Установка и удаление программ добавляет свой подраздел в эту ветку реестра.
Для удаления записи удалите соответствующий подраздел отвечающий программе.

Другие конторольные точки которые необходимо проверить при некорректном удалении программы.
  • Проверьте наличие пути к исполняемым файлам программы в следующих ветвях реестра:
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run]
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
  • Проверьте наличие исполняемых файлов программы в отключенных элементах автозапуска
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\MSConfig\startupfolder]
    Удалить все отключенные элементы автозапуска вы можете при помощи этого скрипта: msconfigdisabled.vbs
  • Проверьте "остатки" программы в ассоциациях типов файлов
    Панель управления - Свойства папки - Типы файлов - удалите или измените ассоциации файлов с удаленной программой
  • Откройте ветвь реестра HKEY_CLASSES_ROOT\Applications - если в ней есть подразделы соответствующие удаленной программе удалите их.
  • Откройте ветви реестра [HKEY_CURRENT_USER\Software] и [HKEY_LOCAL_MACHINE\SOFTWARE]
    Если в них есть подразделы соответствующие удаленной программе удалите их.
  • В редакторе реестра нажмите Ctrl+F и введите в окно поиска запрос соответствующий пути к исполняемому файлу удаленной программы, найдите и удалите все параметры отвечающие программе.
  • Воспользуйтесь утилитой Windows Installer Clean Up для удаления параметров конфигурации установщика Windows для установленных программ.
  • Воспользуйтесь сторонними утилитами для удаления программы, например: http://superwin.swmirror.com/adrmpro2.exe


FAQ по Microsoft Windows XP | Железо

Перечень всех вопросов раздела Железо

  1. После установки драйвера на видеокарту NVidia в свойствах монитора в настройках видеокарты появились непонятные символы.

  2. Не устанавливается драйвер для сканера Mustek. При установке драйвера выдается информация о том, что у драйвера нет цифровой подписи.

  3. Во время работы компьютера появляется синий экран с ошибкой BSOD ссылаясь на ошибку в драйвере.

  4. Внешний модем подключенный к COM-порту не определяется системой после загрузки если не был включен до включения компьютера.

  5. Привод CD-ROM постоянно переходит в режим PIO.

  6. При выключении компьютера появляется надпись "Теперь питание компьютера можно отключить".

  7. Windows не определяет привод CD-ROM хотя в BIOS`е привод определяется нормально.

  8. После установки Service Pack 2 компьютер не загружается.

  9. Система не распознает CD-RW как записывающее устройство.

  10. Функции автозапуска не срабатывают при вставке компакт-диска в дисковод.

  11. Не удается установить устройство Bluetooth после установки SP2

  12. При печати появляется сообщение об ошибке: «Приложение подсистемы спулера — обнаружена ошибка. Приложение будет закрыто»

  13. При установке принтера появляется сообщение об ошибке: «Невозможно завершение операции»

  14. Пропадает доступ к дисководу компакт-дисков, а в сообщениях упоминаются ошибки с кодами 19, 31, 32 или 39

  15. Устранение конфликтов устройств с помощью диспетчера устройств


Windows не определяет привод CD-ROM хотя в BIOS`е привод определяется нормально

FAQ по Microsoft Windows XP | Железо

Q: Windows не определяет привод CD-ROM хотя в BIOS`е привод определяется нормально

Способ 1. Удаление записи реестра
1. Нажмите кнопку Пуск и выберите команду Выполнить.
2. В поле Открыть введите команду regedit и нажмите кнопку ОК.
3. Перейдите к следующему подразделу реестра:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control/Class\{4d36e965-e325-11ce-bfc1-08002be10318}
4. В меню Файл выберите команду Экспорт.
5. В поле Имя файла введите имя savedkey и нажмите кнопку Сохранить.
6. Для параметра UpperFilters задайте тип данных REG_MULTI_SZ, а затем в меню Правка выберите пункт Удалить.
Примечание. Если тип данных не отображается, используйте способ 2.
7. Для параметра LowerFilters задайте тип данных REG_MULTI_SZ, а затем в меню Правка выберите пункт Удалить.
8. Закройте редактор реестра и перезапустите компьютер.

Способ 2. Замена существующего драйвера
1. Нажмите кнопку Пуск и выберите пункт Панель управления.
2. Если панель управления имеет стандартный вид, дважды щелкните значок Система.
3. На вкладке Оборудование нажмите кнопку Диспетчер устройств.
4. Выберите диск, рядом с которым отображается знак вопроса.
5. В меню Действие выберите команду Удалить. Нажмите кнопку OK для подтверждения операции.
6. Для всех остальных дисководов, отмеченных знаком вопроса, повторите шаги 4 и 5.
7. В меню Действие выберите команду Обновить конфигурацию оборудования

Более подробно о данной проблеме вы можете прочитать в этой статье MSKB

© Все права защищены OSzone.net 2001-2006


Внешний модем подключенный к COM-порту не определяется системой после загрузки если не был включен до включения компьютера

FAQ по Microsoft Windows XP | Железо

Q: Внешний модем подключенный к COM-порту не определяется системой после загрузки если не был включен до включения компьютера

Путей решения этой проблемы несколько:

1. Включать модем до включения компьютера

2. После загрузки заходить в Панель управления -> Система -> Оборудование -> Диспетчер устройств -> нажать Обновить, модем будет найден и установлен.

3. Использовать утилиту rescan.exe которая делает то же что и 2-й вариант.
а. Или использовать более функциональную утилиту Devcon

4. Установить не PnP версию драйвера для модема (указать при установке что драйвера будут ставится вручную, и показывать все устройства, а не только совместимые). Если такого модема нет, то установить стандартный.

5. Иногда может помочь установка одного модема дважды, тогда если система не находит один она может обнаружить второй (оба должны быть указаны в свойствах соединения).


Во время работы компьютера появляется синий экран с ошибкой BSOD, ссылаясь на ошибку в драйвере

FAQ по Microsoft Windows XP | Железо

Q: Во время работы компьютера появляется синий экран с ошибкой BSOD, ссылаясь на ошибку в драйвере

В Windows ХР есть средство позволяющее выявить проблемные драйвера.
Пуск -> Выполнить -> verifier.exe

покажет некорректно работающие драйвера, а так же драйвера не имеющие цифровой подписи.

Более подробно о том как работать с утилитой вы можете узнать прочитав статью MSKB:
Использование средства проверки драйверов для устранения неполадок в работе драйверов Windows

Если вам не удалось решить проблему заменой или переустановкой драйверов, вы можете посмотреть возможные пути решения проблемы на этом ресурсе: bsod.oszone.net

В случае если и там вы не смогли найти решения вашей проблемы вы можете задать вопрос в этой теме форума:
BSOD (синие экраны смерти), Перезагрузки, Ошибки системы


Не удается установить устройство Bluetooth после установки SP2

FAQ по Microsoft Windows XP | Железо

Q: Не удается установить устройство Bluetooth после установки SP2

Проблема
  • Не удается установить устройство Bluetooth, и наблюдаются следующие признаки:
    Внешне установка выполняется успешно, однако устройство неправильно идентифицируется в категории Радиоприемники Bluetooth диспетчера устройств.
  • При попытке настроить устройство появляется следующее сообщение об ошибке:
    Устройство не найдено
  • Если обновление операционной системы до версии Windows XP с пакетом обновления 2 (SP2) выполнялось с установочного диска Windows XP, содержащего файлы пакета обновления 2 (SP2) для Windows XP, и если для запуска обновления использовался файл Winnt32.exe, существующие устройства Bluetooth могут работать ненадлежащим образом. Например, могут перестать работать некоторые функции Bluetooth.

Причина

  • Пакет обновления 2 (SP2) для Windows XP устанавливается на компьютере, на котором установлен адаптер Bluetooth, но еще не установлены драйверы адаптера стороннего производителя. На компьютере, оснащенном адаптером Bluetooth и использующем драйвер стороннего разработчика, было выполнено обновление операционной системы до версии Windows XP с пакетом обновления 2 (SP2) с установочного диска Windows XP, включающего файлы пакета обновления 2 (SP2) для Windows XP.
  • Адаптер Bluetooth имеет идентификатор поставщика (VID) или идентификатор продукта (PID), который совпадает как со стеком Bluetooth стороннего производителя, так и со стеком Bluetooth из состава Windows XP с пакетом обновления 2 (SP2).
Проблема возникает из-за того, что вместо нужного драйвера стороннего производителя автоматически устанавливается драйвер устройства из состава Windows XP с пакетом обновления 2 (SP2). В процессе обновления с установочного диска Windows XP с пакетом обновления 2 (SP2) вместо существующего драйвера адаптера Bluetooth, выпущенного сторонним разработчиком, устанавливается драйвер, поставляемый в составе Windows XP.

Решение

Чтобы установить драйвер адаптера Bluetooth, выпущенный сторонним разработчиком, воспользуйтесь одним из представленных ниже способов.

Способ 1. Переименование файла Bth.inf

Перед установкой стека или устройства стороннего производителя переименуйте файл %WINDIR%\inf\Bth.inf в Bth.bak. После этого данный файл INF не будет использоваться операционной системой для установки драйвера Bluetooth из состава Windows XP с пакетом обновления 2 (SP2). Чтобы переименовать данный файл, выполните следующие действия.

  1. Выберите в меню Пуск пункт Выполнить, введите в поле Открыть команду %windir%\inf и нажмите кнопку ОК
  2. Щелкните правой кнопкой мыши файл Bth.inf и выберите команду Переименовать.
  3. Присвойте файлу имя Bth.bak и нажмите клавишу ВВОД.
  4. Установите драйвер Bluetooth производителя.

Способ 2. Обновление драйвера Bluetooth в диспетчере устройств

Чтобы заменить стек Bluetooth, установленный Windows XP с пакетом обновления 2 (SP2), обновите соответствующий драйвер в диспетчере устройств, указав при этом нужный драйвер стороннего производителя. Для обновления драйвера в диспетчере устройств выполните следующие действия.

  1. Выберите в меню Пуск пункт Выполнить, введите в поле Открыть команду devmgmt.msc и нажмите кнопку ОК.
  2. Найдите нужное устройство.
  3. Щелкните данное устройство правой кнопкой мыши и выберите команду Обновить драйвер.
  4. Следуйте инструкциям мастера обновления оборудования и укажите для адаптера Bluetooth требуемый драйвер.

Дополнительная информация

За исключением случаев выполнения обновления с установочного диска Windows XP, содержащего файлы пакета обновления 2 (SP) для Windows XP, установка пакета обновления 2 (SP2) для Windows XP не приводит к перезаписи установленного на компьютере драйвера адаптера Bluetooth, выпущенного сторонним разработчиком. Однако, если выполняется обновление с использованием подобного установочного диска или если пакет обновления 2 (SP2) для Windows XP устанавливается на компьютере, на котором нет драйвера от стороннего производителя, для адаптера Bluetooth будет установлен драйвер из состава пакета обновления.

Установить драйвер стороннего производителя в этом случае не удастся, поскольку драйвер для адаптера Bluetooth из состава Windows XP подписан и имеет преимущество перед неподписанным драйвером стороннего производителя.


Не устанавливается драйвер для сканера Mustek. При установке драйвера выдается информация о том, что у драйвера нет цифровой подписи

FAQ по Microsoft Windows XP | Железо

Q: Не устанавливается драйвер для сканера Mustek. При установке драйвера выдается информация о том, что у драйвера нет цифровой подписи

Подобное сообщение выдается в 2/3 случав, но это никогда не мешало эти драйвера установить. Причем как правило в случае с Mustek подходят драйверы от Windows 2000, но для их установки нужно изменить в реестре в ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
параметры "ProductName"="Microsoft Windows XP" и "CurrentBuildNumber"="2600" на "ProductName"="Microsoft Windows 2000" и "CurrentBuildNumber"="2195".
После установки вернуть в исходное состояние.

Другой способ воспользоваться утилитой FixWinXP.

Так же можно попробовать запускать установку при отключенном сканере. Если будет выдано сообщение об отсутствии Digital Signature нажмите "Все равно установить"
Для этого в свойствах системы -> Оборудование -> Подписывание драйверов -> Предупреждать - каждый раз предлагать выбор действия.


После установки Service Pack 2 компьютер не загружается

FAQ по Microsoft Windows XP | Железо

Q: После установки Service Pack 2 компьютер не загружается

Если есть резервная копия старых файлов, автоматически созданная при установке Service Pack 2, то попробуйте сделать следующее.
Загрузитесь с компакт-диска Windows XP, в тот момент, когда на экране появится строка Welcome to Setup, выберите R для запуска консоли восстановления, следуя запросам программы, выберите нуждающуюся в восстановлении инсталляцию Windows и введите пароль администратора. Находясь в консоли восстановления, введите команды:

cd $NtServicePackUninstall$\Spuninst
batch spuninst.txt
exit

После выполнения команд перегрузитесь. После загрузки введите команды:
CD %SystemRoot%\$NtServicePackUninstall$\Spuninst
spuninst.exe

Тем самым вы удалите все файлы Service Pack 2, то есть деинсталлируете его.

Так же описание решения проблемы с зависанием после установки SP2 изложено в этой статье MSKB:
Компьютер зависает при перезагрузке в процессе установки Windows XP с пакетом обновления 2 (SP2)


После установки драйвера на видеокарту NVidia в свойствах монитора в настройках видеокарты появились непонятные символы

FAQ по Microsoft Windows XP | Железо

Q: После установки драйвера на видеокарту NVidia в свойствах монитора в настройках видеокарты появились непонятные символы

Попробуйте удалить файл nvrsru.dll в этом случае все надписи в настройках драйвера будут на английском языке. Либо установите английскую версию драйвера.

Либо установите русскую версию драйвера.

© Все права защищены OSzone.net 2001-2006


При выключении компьютера появляется надпись "Теперь питание компьютера можно отключить"

FAQ по Microsoft Windows XP | Железо

Q: При выключении компьютера появляется надпись "Теперь питание компьютера можно отключить"

Этап 1. Включите поддержку автоматического управления питанием
1. В меню Пуск выберите пункт Панель управления, а затем дважды щелкните значок Электропитание.
2. Откройте вкладку АУП.
3. Установите флажок Задействовать автоматическое управление питанием и нажмите кнопку ОК.

Этап 2.
Если компьютер поддерживает интерфейс ACPI, выполните следующие действия.
1. Нажмите кнопку Пуск, выберите пункт Панель управления, а затем дважды щелкните значок Установка и удаление программ. 2. Проверьте, установлена ли хотя бы одна из следующих программ.
• Драйвер мыши Logitech
• Программное обеспечение Adaptec или Roxio
• Средство Zone Alarm
3. Если установлена хотя бы одна из перечисленных программ, обратитесь к ее производителю, чтобы получить обновленную версию программы, или временно удалите такую программу.
4. Попробуйте завершить работу компьютера, чтобы проверить, удалось ли решить проблему.
5. Если решить проблему не удалось, с помощью диспетчера задач определите список программ, которые в данный момент запущены на компьютере. Вручную завершите работу каждой из программ, указанных в окне диспетчера задач, и перезапустите компьютер, чтобы убедиться, что проблема решена. Для этого выполните следующие действия.
Примечание. Список запущенных на компьютере программ, который отображается на вкладке Приложения диспетчера задач может быть неполным.
a. Нажмите сочетание клавиш CTRL+ALT+DELETE, а затем — кнопку Диспетчер задач.
b. Перейдите на вкладку Приложения.
c. В столбце Задача выберите программу, работу которой требуется завершить, и нажмите кнопку Снять задачу.
d. Закройте окно диспетчера задач.
e. Завершите работу компьютера.

Более полную информацию по данной проблеме вы можете получить прочитав эту статью MSKB


При печати появляется сообщение об ошибке: «Приложение подсистемы спулера — обнаружена ошибка. Приложение будет закрыто»

FAQ по Microsoft Windows XP | Железо

Q: При печати появляется сообщение об ошибке: «Приложение подсистемы спулера — обнаружена ошибка. Приложение будет закрыто»

Проблема

При попытке запустить или остановить службу диспетчера очереди печати или при нажатии кнопки Пуск и выборе команды Принтеры и факсы может появиться следующее сообщение об ошибке:

Приложение подсистемы спулера — обнаружена ошибка. Приложение будет закрыто.

или
Spooler SubSystemApp - обнаружена ошибка

При попытке начать печать может появиться следующее сообщение об ошибке:
Невозможно завершение операции.

Причина

Эта проблема может возникнуть в том случае, если на правильную установку и функциональные возможности вновь установленного принтера повлияли драйвер или служба, разработанные независимым производителем.
Например, эта проблема может возникнуть, если перед установкой другого принтера на компьютере уже был установлен драйвер принтера LexBCE компании Lexmark.

Решение

1. Запустите компьютер в безопасном режиме.
2. Запустите проводник, а затем удалите все файлы и папки в следующих двух папках.
• c:\windows\system32\spool\printers
• c:\windows\system32\spool\drivers\w32x86

3. Выберите в меню Пуск пункт Выполнить, введите в поле Открыть команду regedit и нажмите клавишу ВВОД.
4. Найдите следующий раздел реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environment\Windows NT x86

Просмотрите список подразделов. Там должны находиться только следующие подразделы:
• Drivers
• Print Processors

5. Если кроме разделов, указанных на шаге 4, существуют и другие разделы, выполните следующие действия.
a. В меню Файл выберите команду Экспорт.
b. В поле Имя файла введите описательное имя данного раздела, например WindowsNTx86regkey и нажмите кнопку Сохранить.

Таким образом мы создадим резервную копию раздела реестра которую можно применить для восстановления этого раздела при возникновении неполадок после выполнения описанных действий.
 c. Удалите все разделы за исключением тех, которые приведены на шаге 4.

6. Найдите раздел реестра
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
Просмотрите список подразделов. Там должны находиться только следующие подразделы:
• BJ Language Monitor
• Local Port
• PJL Language Monitor
• Standard TCP/IP Port
• USB Monitor

7. Если кроме разделов, указанных на шаге 6, существуют и другие разделы, выполните действия описанные нв шаге 5.
8. Отсоедините кабель принтера от компьютера, а затем перезапустите компьютер.
9. Подключите кабель принтера к компьютеру, установите принтер в соответствии с инструкциями производителя, а затем попытайтесь напечатать тестовую страницу.


При установке принтера появляется сообщение об ошибке: «Невозможно завершение операции»

FAQ по Microsoft Windows XP | Железо

Q: При установке принтера появляется сообщение об ошибке: «Невозможно завершение операции»

Проблема

При установке принтера (как локального, так и сетевого) с помощью мастера установки принтера появляется следующее сообщение об ошибке:

Невозможно завершение операции. Подсистема печати недоступна.

Причина
Данная ошибка возникает, если служба «Диспетчер очереди печати» не была запущена или была остановлена. Чтобы запустить данную службу, выполните следующие действия.

1. Нажмите кнопку Пуск и выберите пункт Панель управления.
2. Дважды щелкните значок Администрирование, а затем — значок Службы.
3. Дважды щелкните службу Диспетчер очереди печати и установите для параметра «Тип запуска» значение Авто. Это предписывает операционной системе автоматически запускать данную службу при загрузке компьютера.
4. Чтобы запустить службу «Диспетчер очереди печати», нажмите кнопку Пуск, находящуюся ниже поля Состояние.

Чтобы запустить службу «Диспетчер очереди печати», можно также выбрать в меню Пуск пункт Выполнить и выполнить команду net start spooler.


Привод CD-ROM постоянно переходит в режим PIO

FAQ по Microsoft Windows XP | Железо

Q: Привод CD-ROM постоянно переходит в режим PIO

Это может происходить, если Windows XP обнаруживает, что CD-ROM работает нестабильно в режиме UDMA. Возможно это определяется по количеству ошибок чтения, получаемых с привода. Совет, данный ниже не гарантирует 100% эффективности, а так же не гарантирует того, что не произойдёт каких-либо ошибок или сбоев.
Для отключения режима отслеживания ошибок можно попробовать установить значение 0 параметра ErrorControl в ветке реестра
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdfs
После этого для установки режима UDMA удалите и заново установите IDE контpоллеp в диспетчере устройств.


Пропадает доступ к дисководу компакт-дисков, а в сообщениях упоминаются ошибки с кодами 19, 31, 32 или 39

FAQ по Microsoft Windows XP | Железо

Q: Пропадает доступ к дисководу компакт-дисков, а в сообщениях упоминаются ошибки с кодами 19, 31, 32 или 39

После удаления программного обеспечения для записи компакт-дисков (или другого программного обеспечения) возникают следующие проблемы.
• Нет доступа к проигрывателю компакт-дисков через значок «Мой компьютер».
• В диспетчере устройств каждое установленное на компьютере устройство для чтения компакт-дисков сопровождается следующим сообщением:
Это устройство работает неправильно, поскольку не удалось загрузить для него драйверы (код 31).
• Диспетчер устройств выводит на экран следующее сообщение об ошибке:
Для этого устройства не требовался драйвер и он был отключен (код 32 или 31).
Также возможно появление сообщения об ошибке с кодом 39. Это означает, что драйвер поврежден.
• Диспетчер устройств выводит на экран следующее сообщение об ошибке с кодом 19 (реестр вернул неизвестное значение):
Возможно, реестр поврежден. (Код 19).
• Также может быть получено следующее сообщение об ошибке:
Драйвер для этого устройства успешно загружен, но само устройство не обнаружено. (Код 41)

Для решения проблемы выполните следующие действия.
1. Запустите редактор реестра (программа Regedit32.exe).
2. В разделе реестра [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}]
удалите параметр UpperFilters.
3. В том же разделе реестра [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}]
удалите параметр LowerFilters.
4. Перезагрузите компьютер.

Внимание! Создайте архивную копию реестра перед внесением в него изменений.


Система не распознает CD-RW как записывающее устройство

FAQ по Microsoft Windows XP | Железо

Q: Система не распознает CD-RW как записывающее устройство

Проблема
Отсутствует возможность отправить данные на дисковод компакт-дисков при попытке записать диск CD-R или CD-RW.
Отсутствует вкладка Запись в окне свойств CD-дисковода.

Решение
Сделаем резервную копию ветви реестра отвечающую за параметры CD-RW
1. Откройте следующий раздел реестра:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CD Burning\Drives
2. В меню Файл выберите команду Экспорт.
3. В поле Имя файла введите backup of drives key и нажмите кнопку Сохранить.
Примечание. В дальнейшем для восстановления этого раздела достаточно дважды щелкнуть сохраненный файл backup of drives key.reg.
4. В левой части окна редактора реестра выделите папку Volume{GUID} в разделе Drives, где GUID — 32-разрядный глобальный уникальный идентификатор в шестнадцатеричном формате. Примечание. Если на компьютере установлено несколько дисководов компакт-дисков, каждому из них сопоставлена отдельная папка Volume{GUID}.
5. В правой части окна редактора реестра щелкните два раза параметр Drive Type.
6. В поле Значение введите 1 или 2, в зависимости от типа установленного дисковода, и нажмите кнопку OК.
Дисководы CD-R имеют тип 1, а дисководы CD-RW — тип 2.
7. В проводнике выберите пункт Свойства в контекстном меню CD-RW. 8. Если в открывшемся окне имеется вкладка Запись, значит, Windows распознает дисковод в качестве записывающего устройства.
Примечание. Если на компьютере установлено несколько дисководов CD-ROM, DVD-ROM или CD-RW и вкладка Запись отсутствует, то, возможно, в качестве записывающего был настроен не тот дисковод. Для решения проблемы необходимо выполнить следующие действия.
a. Выполните действия 1-6 для изменения параметра Drive Type в ранее отредактированной папке Volume{GUID}.
b. В поле Значение введите 3 и нажмите кнопку ОК.
Тип 3 указывает на то, что это стандартный дисковод компакт-дисков, не поддерживающий записи.
c. В левой части окна редактора реестра выделите следующую папку Volume{GUID}.
d. Выполните действия 5-6, указав в поле Значение цифру 1 или 2 в зависимости от типа дисковода.
e. Закройте редактор реестра и выполните действия 7-8, чтобы убедиться, что в окне свойств дисковода CD-R или CD-RW отображается вкладка Запись.

Так же описание решения проблемы изложено в этой статье MSKB:
Дисковод CD-R или CD-RW не распознается как записывающее устройство


Устранение конфликтов устройств с помощью диспетчера устройств

FAQ по Microsoft Windows XP | Железо

Q: Устранение конфликтов устройств с помощью диспетчера устройств

В статье рассматривается использование диспетчера устройств для устранения неполадок, вызванных конфигурацией оборудования. Диспетчер устройств позволяет проверять работу настраиваемых программно устройств и изменять их конфигурацию. Устройства с перемычками или микропереключателями настраиваются вручную.
• Если в работе устройства возникли проблемы, то в списке оборудования рядом с названием проблемного устройства будет отображаться соответствующий значок.
• Черный восклицательный знак (!) на желтом фоне означает, что устройство находится в проблемном состоянии (такое устройство, тем не менее, может работать).
• Для устройства отображается код возникающей проблемы.
• Символ «Х» красного цвета отображается рядом с отключенными устройствами. Такие устройства физически присутствуют в системе и потребляют ее ресурсы, однако для них не загружен драйвер защищенного режима.
• Синий символ «i» на белом фоне для ресурса устройства в свойствах компьютера означает, что для устройства не включена функция Автоматическая настройка, и ресурс был выбран вручную (это не является признаком отключения или проблемного состояния).
• Знак вопроса (?) зеленого цвета в окне диспетчера устройств означает, что для устройства установлен совместимый драйвер, однако он, возможно, поддерживает не все функции устройства (только в Windows Millennium Edition).

Примечание. Отдельные звуковые карты и видеоадаптеры сообщают операционной системе не обо всех используемых ими ресурсах. По этой причине в диспетчере устройств может отображаться только одно конфликтующее устройство (или вообще ни одного). В подобных случаях попробуйте отключить звуковую карту или используйте стандартный драйвер видеоадаптера VGA и проверьте, приводит ли это к устранению конфликта. Такая проблема наблюдается с видеоадаптерами S3 и 16-разрядными звуковыми картами Sound Blaster, а также звуковыми картами, которые эмулируют Sound Blaster для совместимости с Sound Blaster.
• Если в диспетчере устройств дважды щелкнуть какое-либо устройства, появится окно свойств этого устройства. В этом окне имеется вкладка Общие.
Примечание. Наряду со вкладкой Общие для некоторых устройств отображаются и другие вкладки (структура окна свойств зависит от выбранного устройства; в данном окне могут присутствовать вкладки Ресурсы, Драйвер и Параметры или любая их комбинация).
В верхней части окна свойств представлено описание устройства. В окне, находящемся в средней части вкладки Ресурсы, перечислены типы ресурсов, которые доступны для выбранного устройства.
В нижней части данной вкладки находится Список конфликтующих устройств, в котором содержатся сведения о конфликте с указанием кода ошибки.
• Обратите внимание на флажок Автоматическая настройка. Если данный флажок установлен, значит, Windows удалось обнаружить устройство, и оно, скорее всего, функционирует правильно. С другой стороны, если параметры ресурсов основаны на стандартной конфигурации (где — цифра от 0 до 9), то, возможно, придется выбрать в списке другую стандартную конфигурацию. Если желаемая конфигурация отсутствует среди стандартных конфигураций, нажмите кнопку Изменить, чтобы вручную указать требуемые параметры ресурсов.

Например, чтобы настроить диапазон ввода-вывода, выполните следующие действия.
1. Снимите флажок Автоматическая настройка.
2. Нажмите кнопку Изменить.
3. Выберите нужный диапазон ввода-вывода для устройства.

Примечание. Чтобы отключить устройство, откройте Диспетчер устройств, щелкните требуемое устройство правой кнопкой мыши и выберите пункт Отключить.
Если проблема не исчезает, обратитесь к производителю компьютера или материнской платы для получения инструкций по обновлению версии BIOS компьютера


Функции автозапуска не срабатывают при вставке компакт-диска в дисковод

FAQ по Microsoft Windows XP | Железо

Q: Функции автозапуска не срабатывают при вставке компакт-диска в дисковод

Проблема
При вставке компакт-диска в привод CD-ROM не работают или недоступны функции автоматического запуска и воспроизведения.
В остальном дисковод для компакт-дисков работает корректно.

Причина
• На компьютере установлена версия программы Easy CD Creator компании Roxio, предшествующая версии 5.02d.
• Функция автозапуска отключена в системном реестре.
• Для устройства чтения компакт-дисков используется устаревший драйвер.
• Устройство чтения компакт-дисков не совместимо с Windows XP.
• Включен параметр безопасности Разрешить доступ к дисководам компакт-дисков только локальным пользователям.

Решение
1. Если программа "Easy CD Creator" не установлена на компьютере, переходите сразу к третьему шагу. Если данная программа установлена, то ее следует удалить.
2. Проверьте, удалось ли устранить данную проблему. Если описанная проблема не возникает повторно, пропустите последующие действия. Если первым способом решить проблему не удается, перейдите к шагу 3.
3. Убедитесь, что функция автозапуска включена в системном реестре: Для этого выполните следующие действия.
a. В реестре в ветке

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom
• Если значение параметра Autorun равно 1, переходите к шагу 3-b.
• Если значение параметра Autorun равно 0, правой кнопкой мыши щелкните параметр Autorun и выберите команду Изменить. В поле Значение введите 1 и нажмите кнопку ОК.
b В реестре в ветке
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
Обратите внимание на значение параметра NoDriveTypeAutoRun. Значение 0xb5 отключает функцию автоматического запуска для дисководов компакт-дисков.
Для включения функции автозапуска щелкните правой кнопкой мыши параметр NoDriveTypeAutoRun, выберите команду Изменить, введите 91 в поле Значение, выберите шестнадцатеричное представление и нажмите кнопку OK.
4. Убедитесь, что параметр безопасности Разрешить доступ к дисководам компакт-дисков только локальным пользователям отключен.
a. В реестре в ветке
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
b. Если значение параметра allocatecdroms в правой области в группе Данные равно 0, переходите к шагу 5.
c. Если значение параметра allocatecdroms в правой области в группе Данные равно 1, щелкните правой кнопкой мыши параметр allocatecdroms и выберите команду Изменить. В поле Значение введите 0 и нажмите кнопку ОК.
5. Если в реестре функция автозапуска включена, то следует убедиться, что для дисковода для компакт-дисков не используется устаревший драйвер. a. В свойствах системы на вкладке Оборудование выберите Диспетчер устройств.
b. В диспетчере устройств раскройте ветвь DVD/CD-ROM дисководы и правой кнопкой мыши щелкните дисковод для компакт-дисков, который хотите обновить. Нажмите кнопку Обновить драйвер, чтобы запустить мастер обновления оборудования, и следуйте указаниям на экране, чтобы установить последнюю версию драйвера для используемого дисковода для компакт-дисков.
Так же описание решения проблемы изложено в этой статье MSKB:
Не работают функции автозапуска после вставки компакт-диска в дисковод

Так же возможной причиной по которой не срабатывает автозапуск CD может быть то, что файл Autorun.inf и программы, для которых предназначен файл Autorun.inf, могут не запуститься, если вы вышли в операционную систему Windows XP в качестве пользователя без прав «Опытного пользователя» или «Администратора».
По умолчанию устанавливать программное обеспечение могут только пользователи, которые вошли в систему Windows XP с правами «Опытного пользователя» или «Администратора».
В Windows XP файлы с расширением .inf рассматриваются как установочные файлы. В результате файл Autorun.inf не запустится, если у вас нет прав «Опытного пользователя» или «Администратора».


FAQ по Microsoft Windows XP | Безопасность

Перечень всех вопросов раздела Безопасность

  1. Как сделать недоступными для общего пользования определенные файлы и папки на одном компьютере при условии, что файловая система на диске FAT32.

  2. Как организовать запрет доступа к папкам (файлам) для локальных пользователей на одном компьютере.

  3. Как ограничить пользователя определенным перечнем программ разрешенных для запуска.

  4. Папка была зашифрована средствами Windows, но сертификат не сохранился после переустановки системы. Как получить доступ к зашифрованной папке.

  5. Как получить доступ к файлу или папке после переустановки системы.

  6. При подключении к итернет появляется сообщение: "Система завершает работу, отключение вызвано NT\AUTHORITY SYSTEM. Перезагрузите Windows, поскольку произошла непредвиденная остановка службы Удалённый вызов процедур" и через минуту компьютер перезагружается.

  7. Как закрыть порты средствами Windows XP.

  8. Появляется окно службы сообщений с рекламным объявлением из Интернета.

  9. Что такое функция DEP и как проверить включена ли она.

© Все права защищены OSzone.net 2001-2006


Как закрыть порты средствами Windows XP

FAQ по Microsoft Windows XP | Безопасность

Q: Как закрыть порты средствами Windows XP

В Windows XP SP2 есть встроенная система сетевой защиты - Брандмауэр подключения к Интернет (Internet Connection Firewall, ICF).

Чтобы включить брандмауэр для Интернет-соединений, выполните следующие действия:

Откройте Панель управления -> Сетевые подключения

Выделите соединение, которое требуется защитить брандмауэром -> Свойства -> Дополнительные параметры -> Брандмауэр подключения к Интернет -> установите флажок Защитить мое подключение к Интернет - брандмауэр будет включен.

Подробнее о настройках брандмауэра в составе Windows XP SP2 вы можете узнать из этой статьи MS:
Manually Configuring Windows Firewall in Windows XP Service Pack 2


Как ограничить пользователя определенным перечнем программ разрешенных для запуска

FAQ по Microsoft Windows XP | Безопасность

Q: Как ограничить пользователя определенным перечнем программ разрешенных для запуска

Вариант 1:
Зайдите в учетную запись пользователя которому необходимо сделать ограничения и в реестре в ветке

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
параметр DisallowRun
значение 1
создать подраздел с таким же именем, в котором нужно создать строковые параметры, свой для каждой программы разрешенной для запуска, именуя их числами по возрастанию.

Например:
Параметр 1
значение C:\Windows\Regedit.exe
Параметр 2
C:\Program Files\Microsoft Office\Office11\Winword.exe

Не забудьте указать файл Regedit.exe, иначе Вы сами не сможете больше запустить в этом аккаунте редактор реестра.

Вариант 2:
Пуск -> Выполнить -> Secpol.msc -> Политики ограниченного использования программ -> Дополнительные правила -> Правый клик в правом поле -> Создать правило для хэша -> Обзором задаём требуемый экзешник -> Применить -> Затем снова Политики ограниченного использования программ -> в правом поле вызываем свойства объекта "Принудительный" (выделяем правым кликом), верхний чекбокс на ...кроме DLL, нижний на ...кроме локальных администраторов.


Как организовать запрет доступа к папкам (файлам) для локальных пользователей на одном компьютере

FAQ по Microsoft Windows XP | Безопасность

Q: Как организовать запрет доступа к папкам (файлам) для локальных пользователей на одном компьютере

В свойствах нужной папки -> Безопасность. Здесь каждому пользователю можно назначить права на данную папку. Это справедливо для Windows XP Professional, но не для Windows XP Home.


Как получить доступ к файлу или папке после переустановки системы

FAQ по Microsoft Windows XP | Безопасность

Q: Как получить доступ к файлу или папке после переустановки системы

Чтобы получить доступ к файлу или папке, не имея на это соответствующих разрешений, необходимо стать владельцем такого файла или папки. Это позволяет компенсировать отсутствие разрешений на доступ.

Статья MSKB которая содержит сведения о том, как стать владельцем файла или папки, в том случае, если необходимые права доступа отсутствуют:
Как стать владельцем файла или папки в Windows XP (та же статья in english)


Как сделать недоступными для общего пользования определенные файлы и папки на одном компьютере при условии, что файловая система на диске FAT32

FAQ по Microsoft Windows XP | Безопасность

Q: Как сделать недоступными для общего пользования определенные файлы и папки на одном компьютере при условии, что файловая система на диске FAT32

Это возможно только для ограничения доступа к ресурсам по сети. Для локальных пользователей это возможно только при файловой системе на диске NTFS.
Конвертировать файловую систему диска с FAT32 в NTFS можно с помощью команды

convert [буква диска]: /FS:NTFS

Примечание: Выбор файловой системы лучше производить во время установки системы. Конвертация файловой системы не всегда проходит нормально при наличии данных на конвертируемом разделе.


Папка была зашифрована средствами Windows, но сертификат не сохранился после переустановки системы. Как получить доступ к зашифрованной папке

FAQ по Microsoft Windows XP | Безопасность

Q: Папка была зашифрована средствами Windows, но сертификат не сохранился после переустановки системы. Как получить доступ к зашифрованной папке

Снять с папки шифрование можно только при условии, что компьютер на момент шифрования и после переустановки системы являлся членом домена

Дополнительно просмотрите эти статьи MSKB в которых рассматривались способы снятия шифрования с файлов:
Как отменить шифрование файла в Microsoft Windows XP
Как отметить зашифрованные файлы в Microsoft Windows XP


Появляется окно службы сообщений с рекламным объявлением из Интернета

FAQ по Microsoft Windows XP | Безопасность

Q: Появляется окно службы сообщений с рекламным объявлением из Интернета

В качестве временного решения проблемы можно отключить службу сообщений. Для этого выполните следующие действия.

1. Нажмите кнопку Пуск и выберите пункт Панель управления (или Настройки, а затем – Панель управления).
2. Дважды щелкните значок Администрирование.
3. Дважды щелкните значок Службы.
4. Дважды щелкните запись Служба сообщений.
5. В поле Тип запуска выберите значение Отключено.
6. Нажмите кнопку Стоп, а затем – ОК.

Более подробное описание вы можете прочитать в этой статье MSKB


При подключении к Интернет появляется сообщение: "Система завершает работу, отключение вызвано NT\AUTHORITY SYSTEM. Перезагрузите Windows, поскольку произошла непредвиденная остановка службы Удалённый вызов процедур" и через минуту компьютер перезагружается.

FAQ по Microsoft Windows XP | Безопасность

Q: При подключении к Интернет появляется сообщение: "Система завершает работу, отключение вызвано NT\AUTHORITY SYSTEM. Перезагрузите Windows, поскольку произошла непредвиденная остановка службы Удалённый вызов процедур" и через минуту компьютер перезагружается.

Вероятнее всего система заражена вирусом lovesan (msblast), для решения проблемы выполните следующие действия:

1. Скачать утилиту для поиска и удаления червя. Например, утилиту от Лаборатории Касперского или от Symantec.

2. Сразу после удаления необходимо защитить Интернет соединение межсетевым экраном (фаерволом). Достаточно включить встроенный в ХР брэндмауэр в свойствах подключения. Можно воспользоваться межсетевым экраном сторонних производителей. Если этого не сделать, то новое заражение произойдет сразу после подключения к сети Интернет.

3. Скачать обновление для операционной системы с сайта Microsoft, предотвращающее повторное заражение.

Если у вас все еще остались вопросы, то прочитайте эту тему на форуме: Oстановка службы RPC, перезагрузка при подключении к Интернету (AUTHORITY\SYSTEM), a также lsass.exe.
Если после этого все-таки вопросы остались, то задайте их в вышеупомянутой теме.


Что такое функция DEP и как проверить включена ли она

FAQ по Microsoft Windows XP | Безопасность

Q: Что такое функция DEP и как проверить включена ли она
Предотвращение выполнения данных (DEP) — это набор программных и аппаратных технологий, позволяющих выполнять дополнительные проверки содержимого памяти и предотвращать запуск вредоносного программного кода.

Аппаратная функция DEP помечает все области памяти процесса как области, которые не содержат исполняемого кода, если иное не указано явным образом. Существуют атаки, основанные на помещении исполняемого кода в области памяти, не содержащие исполняемого кода, и последующем запуске этого кода. Функция DEP предотвращает подобные атаки, перехватывая их и вызывая исключение.

Чтобы убедиться, что аппаратная функция DEP работает в Windows, воспользуйтесь одним из следующих способов.

Способ 1. Использование средства командной строки Wmic

С помощью средства командной строки Wmic можно проверить параметры DEP. Чтобы определить, доступна ли аппаратная функция DEP, выполните следующие действия:
1. В меню Пуск выберите пункт Выполнить, введите в поле Открыть команду cmd и нажмите кнопку ОК

2. В командной строке введите следующую команду

wmic OS Get DataExecutionPrevention_Available
Если в результате будет получено значение TRUE, аппаратная функция DEP включена.

Чтобы определить текущую политику поддержки DEP, выполните следующие действия:
1. В меню Пуск выберите пункт Выполнить, введите в поле Открыть команду cmd и нажмите кнопку ОК

2. В командной строке введите следующую команду

wmic OS Get DataExecutionPrevention_SupportPolicy

В результате выполнения команды будет возвращено значение 0, 1, 2 или 3. Эти значения соответствуют политикам поддержки DEP, описанным в приведенной ниже таблице.

DataExecutionPrevention_SupportPolicy
Значение свойства | Уровень политики | Описание
2 | OptIn (конфигурация по умолчанию) | Функция DEP включена только для системных компонентов и служб Windows
3 | OptOut | Функция DEP включена для всех процессов. Администратор может вручную создать список приложений, для которых функция DEP отключена
1 | AlwaysOn | Функция DEP включена для всех процессов
00 | AlwaysOff | Функция DEP отключена для всех процессов

Примечание. Чтобы убедиться в том, что аппаратная функция DEP включена в Windows, проверьте свойство DataExecutionPrevention_Drivers класса Win32_OperatingSystem. В некоторых конфигурациях аппаратную функцию DEP можно отключить с помощью параметра /nopae или /execute в файле Boot.ini. Чтобы проверить это свойство, введите в командной строке

wmic OS Get DataExecutionPrevention_Drivers

Способ 2. Использование графического интерфейса пользователя

Чтобы с помощью графического интерфейса пользователя определить, доступна ли аппаратная функция DEP, выполните следующие действия:

  1. В меню Пуск выберите пункт Выполнить, в поле Открыть введите команду wbemtest и нажмите кнопку ОК.
  2. В диалоговом окне Тестер инструментария управления Windows нажмите кнопку Подключиться.
  3. В поле в верхней части окна Подключение введите root\cimv2 и нажмите кнопку Подключиться.
  4. Нажмите кнопку Экземпляры...
  5. В диалоговом окне Сведения о классе в поле Введите имя суперкласса введите Win32_OperatingSystem и нажмите кнопку OK.
  6. В диалоговом окне Результат запроса дважды щелкните верхний элемент. (Этот элемент начинается с Win32_OperatingSystem.Name=Microsoft...)
  7. В диалоговом окне Редактор объектов найдите в группе Свойства пункт DataExecutionPrevention_Available.
  8. Дважды щелкните свойство DataExecutionPrevention_Available.
  9. В диалоговом окне Редактор свойств проверьте значение в поле Значение.

Если это значение TRUE, аппаратная функция DEP включена.

Дополнительная информация

  • Чтобы определить режим, в котором работает функция DEP, проверьте значение свойства DataExecutionPrevention_SupportPolicy класса Win32_OperatingSystem. Значения, соответствующие каждой политике поддержки, перечислены в таблице, приведенной в конце способа 1.
  • Чтобы определить, включена ли аппаратная функция DEP в Windows, проверьте значение свойства DataExecutionPrevention_Drivers класса Win32_OperatingSystem. В некоторых конфигурациях аппаратную функцию DEP можно отключить с помощью параметра /nopae или /execute в файле Boot.ini.

Более подробное описание вы можете прочитать в этой статье MSKB


Перечень всех вопросов раздела Интернет и Сеть

FAQ по Microsoft Windows XP | Сеть

Перечень всех вопросов раздела Сеть

  1. Как заставить Windows XP Home Edition регистрироваться в домене.

  2. Как организовать доступ между двумя удаленными компьютерами используя модемное соединение.

  3. Как можно вывести компьютер из спящего режима по сети.

  4. При входе в сеть Windows долго опрашивает ее на предмет наличия назначенных заданий на других машинах.

  5. Как настроить соединение двух компьютеров по через модем для игр.

  6. Можно ли использовать несколько модемов для одного соединения для увеличения общей скорости передачи данных.

  7. Как увеличить пропускную способность для сетевых подключений. Или как отключить QoS.

  8. Как перезагрузить компьютер по сети.

  9. Как убрать сообщение об ошибке при неудачном дозвоне.

  10. Что такое удаленный рабочий стол? Как его настроить.

  11. После установки SP2 перестала работать команда net send.

  12. Как в Windows XP настроить dial-up соединение на использование функции callback.

  13. Как сохранить настройки модемного соединения или перенести их на другой компьютер.

  14. Как правильно настроить службу факсов в Windows XP для работы с факсами.

  15. Создание и удаление скрытых и административных общих ресурсов (C$, D$, Admin$)

  16. Как увеличить количество одновременных закачек в Internet Explorer


Как в Windows XP настроить dial-up соединение на использование функции callback

FAQ по Microsoft Windows XP | Сеть

Q: Как в Windows XP настроить dial-up соединение на использование функции callback

Для настройки ответного вызова при создании удаленного соединения в Windows XP выполните следующие действия:

1. В меню "Пуск" выберите пункт "Панель управления" и щелкните по ссылке "Сеть и подключения к Интернету".

2. В окне "Сеть и подключения к Интернету" щелкните по ссылке "Сетевые подключения".

3. В меню "Дополнительно" выберите пункт "Параметры удаленного доступа".

4. Перейдите на вкладку "Ответный вызов сервера" и выберите переключатель, соответствующий Вашим требованиям, из следующего списка:
• "Иногда. Выдавать запрос при подключении к серверу".
• "Всегда выполнять ответный вызов по указанным номерам". При установке данного переключателя выберите из списка модем, на который будет выполняться ответный вызов, нажмите кнопку "Изменить" и проверьте номер телефонной линии, подключенной к данному модему.

5. Нажмите кнопку "ОК".

6. Для использования функции ответного вызова необходимо включить в системе поддержку расширений протокола LCP (Link Control Protocol). Для установки данного параметра в свойствах удаленного соединения перейдите на вкладку "Сеть", нажмите кнопку "Параметры" и в окне "Параметры PPP" установите флажок "Включить расширения LCP"..

Более подробно c данным вопросом вы можете ознакомиться в этой статье MSKB:
Как настроить и использовать ответный вызов при удаленном соединении в Microsoft Windows XP


Как можно вывести компьютер из спящего режима по сети

FAQ по Microsoft Windows XP | Сеть

Q: Как можно вывести компьютер из спящего режима по сети

Нужно открыть "Диспетчер устройств" и в свойствах сетевой карты "управление электропитанием" поставить галочку "разрешить устройству вывод компьютера из спящего режима".
Также на некоторых материнских платах этот параметр контролируется из BIOS, разрешить адаптеру LAN вывод компьютера из спящего режима.


Как настроить Windows XP Home Edition для регистрации в домене

FAQ по Microsoft Windows XP | Сеть

Q: Как настроить Windows XP Home Edition для регистрации в домене

Это невозможно. Одним из отличий Windows XP Home Edition от Professional Edition является отсутствие сетевых настроек (хотя в параметрах выбора они присутствуют).

Один раз за сеанс логинится к сетевому ресурсу (например сетевому принтеру) в любом случае придется, в дальнейшем, в рамках одного сеанса Windows будет помнить его.


Как настроить соединение двух компьютеров через модем для игр

FAQ по Microsoft Windows XP | Сеть

Q: Как настроить соединение двух компьютеров через модем для игр

В вашей игре должна быть возможность игры по модему. Именно по модему, а не по Интернету. Обычно такая игра сводится к следующему.
Играют двое. Первый является хост-компом, второй - слэйв-компом. Первый работает в режиме ожидания. Второй вводит в своей игре номер хоста и коннектится к нему.
Происходит взаимный обмен информацией и коннект.
Если хочешь играть с другом, по телефону, то в самой игре надо выставить параметры модема и один из ПК сделать сервером и с него запустить ведущие настройки, на втором ПК просто указать адрес сервера и имя и пароль доступа на сервер.
Необходимые компоненты: 2 компьютера удалённых 2 модема 1 установочный диск с Windows
соединение использует протокол TCP/IP. Но что ему мешает использовать протокол IPX/SPX? А ничего не мешает, его надо заставить

Итак настройка операционной системы (на примере WinME) :

1) Панель управления -> Сеть -> Конфигурация -> Добавить -> Клиент -> Microsoft -> Клиент для сетей Microsoft
2) Панель управления -> Сеть -> Конфигурация -> Добавить -> Протокол -> Microsoft -> IPX/SPX-совместимый протокол
3) Панель управления -> Сеть -> Конфигурация -> Добавить -> Служба -> Служба доступа к фалам и принтерам сетей Microsoft
4) Панель управления -> Сеть -> Конфигурация -> Идентификация -> заполняйте все поля (обязательно запомните имя своего компьютера)
5) Для этих настроек может понадобиться диск с Windows. Также смело соглашайтесь со всеми перезагрузками.
6) На рабочем столе должна появиться пиктограмма Сетевое окружение.

Сеть будет построена на модемном соединении, поэтому переходим к настройке Dial-up:

1) Панель управления = Установка и удаление = закладка Установка Windows = птичка напротив Сеть = 2й клик на этой самой Сеть = ещё птички на Hyper Terminal, Сервер удалённого доступа и Удалённый доступ к сети = ОК = ОК.
2) Удалённый доступ к сети = в верхней панели Соединения = Север удалённого доступа = ставим точку на против Разрешить удалённые подключения = жмем на кнопку Тип сервера = выбираем PPP:Интернет... = снять все галочки (две) = ОК =ОК.

После этого в системном трее (возле часиков) появится пиктограмма компьютера на ладони (модем должен быть включен иначе пиктограмма исчезнет). Учитывая, что на панели задач у Вас уже есть компьютер на ладони, звонящий Вам друг должен создать Удалённое соединение, указав в соответствующем поле номер Вашего телефона (обязательно уберите птичку возле Использовать код города ...) . Убедитесь, что Тип сервера удалённого доступа определён, как PPP: Интернет, Windows 2000/NT, Windows Me. Также надо выбрать все возможные сетевые протоколы и поставить птичку Войти в сеть и ОК. Теперь оба компьютера готовы стать сетью и осталось позвонить Вашему другу по модему используя только что созданное соединение. После дозвона у Вас, на панели задач, появится значок модема и если по нему кликнуть то Вы узнаете с какой скоростью произошло соединение и конечно поиграть!!! Также можно побродить по удалённому компьютеру Вашего друга: Нажимаете правой кнопкой на Сетевом окружении = выбираете Найти компьютер = пишете Имя компьютера = Найти.


Как организовать доступ между двумя удаленными компьютерами используя модемное соединение

FAQ по Microsoft Windows XP | Сеть

Q: Как организовать доступ между двумя удаленными компьютерами используя модемное соединение

Настройка ведущего компьютера (назовем его сервер):
Панель управления -> Сетевые подключения -> Создание нового подключения -> Установить прямое подключение к другому компьютеру -> Принимать входящие подключения -> Выбираем модем -> Разрешить виртуальные частные подключения -> Выбор пользователя ->.....
Лучше всего создать нового пользователя для подключения: "Добавить…"
..... ->
в свойствах TCP/IP назначаем IP адреса -> "С:" например 100.100.100.100, "По:" 100.100.100.101.
Таким образом получаем два IP адреса: IP сервера 100.100.100.100, IP клиента 100.100.100.101.

Настройка компьютера подключаемого (назовем его клиент) Панель управления -> Сетевые подключения -> Создание нового подключения -> Подключить к сети на рабочем месте -> Подключение удаленного доступа -> Организация -> Номер телефона (тот к которому подключен модем компьютера-сервера)


Как перезагрузить компьютер по сети

FAQ по Microsoft Windows XP | Сеть

Q: Как перезагрузить компьютер по сети

Для этого на удаленном компьютере должен быть доступен Удаленный доступ и добавлен пользователь, который может это делать.
Команда:
shutdown \имя_компьютера /t:0 /r


Как правильно настроить службу факсов в Windows XP для работы с факсами

FAQ по Microsoft Windows XP | Сеть

Q: Как правильно настроить службу факсов в Windows XP для работы с факсами

Что бы установить службу факсов, выполните следующие действия:

1. Нажмите кнопку Пуск, выберите пункт Панель управления и дважды щелкните значок Установка и удаление программ на панели Выберите категорию.
2. Нажмите кнопку Установка компонентов Windows, чтобы запустить мастер компонентов Windows.
3. В списке Компоненты установите флажок Служба факсов и нажмите кнопку Далее. Программа установки установит службу факсов. Если отображается запрос компакт-диска Microsoft Windows XP, вставьте его и нажмите кнопку OK.
4. Нажмите кнопку Готово, а затем Закрыть.

Настройка службы факсов 1. В меню Пуск последовательно выберите пункты Все программы, Стандартные, Связь и Факс, а затем выберите команду Fax Console.
Будет запущен мастер настройки факсов. 2. Нажмите кнопку Далее, введите информацию, которая будет отображаться на титульной странице факса, нажмите кнопку Далее.
3. Выберите нужный модем в списке Выберите устройство для работы с факсами.
4. Чтобы запретить отправку факсов с данного компьютера, снимите флажок Включить отправку.
Примечание. По умолчанию флажок Включить отправку установлен. 5. Чтобы включить прием факсов на данном компьютере, установите флажок Включить прием.
Примечание. Если данный флажок установлен, то для отключения автоматического приема факсов установите флажок Ответ вручную. По умолчанию включен режим автоматических ответов.
6. Нажмите кнопку Далее.
7. Введите необходимый идентификатор TSID в поле TSID.
Примечание. В некоторых случаях идентификатор TSID обязателен. Данная информация отображается в заголовке получаемого факса. С ее помощью можно определить отправителя факса. Как правило, она содержит название организации и номер телефона отправителя.
8. Нажмите кнопку Далее.
9. Введите необходимый идентификатор CSID в поле CSID.
Примечание. Указанный CSID отображается на факсимильном аппарате отправителя. С помощью этого номера можно проверить, правильному ли получателю отправляется факс.
10. Нажмите кнопку Далее.
11. Для автоматической печати всех получаемых факсов установите флажок Выводить на печать. После установки этого флажка можно выбрать принтер, на котором будут распечатываться получаемые факсы.
12. Для создания архивной копии всех факсов установите флажок Сохранять копию в папке. После установки данного флажка необходимо указать папку, в которой будут сохраняться копии факсов.
13. Нажмите кнопку Далее.
14. Проверьте установки в списке Параметры настройки и нажмите кнопку Готово.
Работа мастера настройки факсов будет завершена, и на экране появится окно консоли факсов. Теперь компьютер готов к отправке и приему факсов.

Изменение настроек службы факсов
1. В меню Пуск последовательно выберите пункты Все программы, Стандартные, Связь и Факс, а затем выберите команду Fax Console.
2. Чтобы запустить мастер настройки факсов, в окне консоли факсов в меню Сервис выберите команду Настройка факса.


Как сохранить настройки модемного соединения или перенести их на другой компьютер

FAQ по Microsoft Windows XP | Сеть

Q: Как сохранить настройки модемного соединения или перенести их на другой компьютер

Соединения удаленного доступа хранятся в файле "Remote Access Phonebook" (Rasphone.pbk)

Для сохранения и последующего восстановления соединений удаленного доступа, а также копирования их на другой компьютер выполните следующие действия:

1. Файл Rasphone.pbk располагается в папке "%SystemRoot%\Documents and Settings\All Users\Application Data\Microsoft\Network\Connections\Pbk".
Примечание: Папка "Application Data" является скрытой папкой. Для отображения данной папки выполните следующие действия:
a. Откройте папку "All Users" и выберите пункт "Свойства папки" из меню "Сервис".
b. Перейдите на вкладку "Вид" и установите флажок "Показывать скрытые файлы и папки", затем нажмите кнопку "OK".

2. После создания всех соединений скопируйте файл Rasphone.pbk в безопасное место, и затем скопируйте этот же файл в папку "%SystemRoot%\Documents and Settings\All Users\Application Data\Microsoft\Network\Connections\Pbk" на другом компьютере.
Примечание: При замене файла Rasphone.pbk, появится запрос на подтверждение замены файла. Нажмите кнопку "Да", чтобы подтвердить замену файла.

3. Перезагрузите компьютер, чтобы соединения стали доступны.

Более подробно c данным вопросом вы можете ознакомиться в этой статье MSKB:
Как сохранить и восстановить удаленные соединения в Microsoft Windows XP


Как убрать сообщение об ошибке при неудачном дозвоне

FAQ по Microsoft Windows XP | Сеть

Q: Как убрать сообщение об ошибке при неудачном дозвоне

В реестре в ветке
HKEY_CURRENT_USER\Software\Microsoft\RAS Phonebook
параметр: PopupOnTopWhenRedialing
тип: DWORD
значение: 0


Как увеличить количество одновременных закачек в Internet Explorer

FAQ по Microsoft Windows XP | Сеть

Q: Как увеличить количество одновременных закачек в Internet Explorer

Для увеличения количества одновременных закачек в Internet Explorer до десяти (вместо 2-х) скачайте и запустите этот скрипт: iedownloads10.vbs
Для восстановления значений по умолчанию скачайте и запустите этот скрипт: iedownloads2.vbs


Как увеличить пропускную способность для сетевых подключений. Или как отключить QoS

FAQ по Microsoft Windows XP | Сеть

Q: Как увеличить пропускную способность для сетевых подключений. Или как отключить QoS

В некоторых публикациях и группах новостей заявлялось, что Windows XP всегда резервирует под нужды механизма QoS 20% доступной полосы пропускания.

Данное утверждение неверно.

В Windows XP, как и в Windows 2000, программы используют механизмы QoS посредством интерфейсов API QoS. Если отсутствуют программы, требующие приоритетного доступа к сети, то программы сообща используют всю пропускную способность сети.
Если программа, «зарезервировала» пропускную способность, но не передает данные, то эта пропускная способность также может использоваться остальными программами.
По умолчанию на конечном компьютере программа может резервировать до 20% суммарной пропускной способности каждого интерфейса. Если программа, зарезервировавшая пропускную способность, использует ее не полностью, то неиспользуемая часть доступна для других программ.

За подробностями по данному вопросу вы можете обратиться к этой статье MSKB: Механизм качества обслуживания (QoS) в Windows XP


Можно ли использовать несколько модемов для одного соединения для увеличения общей скорости передачи данных

FAQ по Microsoft Windows XP | Сеть

Q: Можно ли использовать несколько модемов для одного соединения для увеличения общей скорости передачи данных

Многоканальные подключения (также известные как Multilink PPP или Multilink) соединяют несколько физических каналов в одну логическую связку.
Такой комбинированный канал увеличивает полосу пропускания подключения.
Многоканальное подключение может быть использовано в качестве альтернативы DSL или кабельным модемам.

Для использования многоканальных подключений необходимо:
• Ваш провайдер должен поддерживать синхронизацию при работе с несколькими модемами.
• Необходимо наличие отдельной телефонной линии для каждого используемого модема.
Обратите внимание, что каждый ISDN-адаптер может функционировать как несколько отдельных устройств, так как ISDN позволяет организовать два B-канала по 56-Kbps, которые могут использоваться вместе или независимо.

Настройка многоканального подключения

Сетевые подключения позволяют организовать работу по протоколу Point-to-Point (PPP) Multilink с помощью нескольких ISDN, X.25 или модемных линий. Данная возможность позволяет объединить несколько физических каналов в одну логическую связку для увеличения полосы пропускания. Для использования многоканальных подключений необходимо чтобы и ваше сетевое подключение и сервер удаленного доступа поддерживали такие подключения
Сетевые Подключения могут динамически управлять использованием каналов, задействованных в многоканальном подключении.
Это позволяет избежать чрезмерного расширения полосы пропускания, обеспечивая гораздо более эффективную работу пользователей.
Условия, при которых подключаются дополнительные линии и отключаются простаивающие, задаются параметрами компонента "Сетевые подключения".
Обратите внимание, что, если Вы используете многоканальные подключения при наборе номера сервера удаленного доступа, который требует ответного вызова, только одно из устройств многоканального подключения ответит на вызов.
Это происходит, потому что Вы можете указать только один номер в учетной записи пользователя.
По данной причине устанавливается соединение только с одним устройством и подключение теряет функциональные возможности многоканального подключения.
Вы можете избежать данной проблемы в следующих случаях:
• Если запись телефонной книги для многоканального подключения использует стандартную модемную конфигурацию, и сервер удаленного доступа использует больше чем одну линию для того же самого номера.
• Если запись телефонной книги для многоканального подключения использует ISDN-линию с двумя каналами, которые имеют тот же самый номер телефона.

Для создания многоканального подключения выполните следующие действия:

1. В меню "Пуск" выберите команду "Панель управления". Выберите категорию "Сеть и подключения к Интернету", затем выберите элемент Панели управления "Сетевые подключения".
2. Выберите сетевое подключение, настройку которого необходимо произвести (например, подключение удаленного доступа). В списке "Сетевые задачи" выберите "Изменение настроек подключения".
3. Перейдите на вкладку "Общие" и выберите все устройства, которые Вы хотите использовать для организации многоканального подключения.
4. Используйте один или несколько следующих шагов:
• Для настройки параметров набора номера, номера телефона, адреса, страны, кода области или правил набора номера, перейдите на вкладку "Общие".
• Для настройки набора номера, параметров ответного вызова или параметров X.25 перейдите на вкладку "Параметры".
• Для настройки параметров безопасности, шифрования или вывода окна терминала и использования сценариев перейдите на вкладку "Безопасность".
• Для настройки типа сервера удаленного доступа и протоколов, используемых для данного подключения, перейдите на вкладку "Сеть". Нажмите кнопку "Параметры" и установите флажок "Согласовать многоканальное подключение для одноканальных подключений".
• Для настройки параметров общего доступа к подключению к Интернету и Брандмауэра подключения к Интернету, а также вызова по требованию, перейдите на вкладку "Дополнительно".

Примечание: В зависимости от типа подключения, параметры которого Вы изменяете, свойства подключения могут различаться.


После установки SP2 перестала работать команда net send

FAQ по Microsoft Windows XP | Сеть

Q: После установки SP2 перестала работать команда net send

Для отправки сообщений по сети команда NET SEND использует службу сообщений. Описанная проблема возникает, потому что служба сообщений на компьютерах под управлением Windows ХР с пакетом обновления 2 (SP2) по умолчанию отключена.

Чтобы решить проблему, измените Тип запуска для службы сообщений на Авто и запустите службу. Для этого выполните следующие действия.

1. Запустите проводник Windows.
2. На левой панели щелкните правой кнопкой мыши узел Мой компьютер и выберите команду Управление.
3. В окне Управление компьютером разверните узел Службы и приложения на левой панели и выберите элемент Службы.
4. Дважды щелкните на правой панели службу сообщений.
5. В диалоговом окне Служба сообщений (локальный компьютер) откройте вкладку Общие.
6. На вкладке Общие в списке Тип запуска выберите вариант Авто и нажмите кнопку Применить.
7. В разделе Состояние нажмите кнопку Пуск, а затем — кнопку ОК.

За дополнительной информацией вы можете обратиться к этой статье MSKB:
Команда NET SEND неправильно работает на компьютере под управлением Windows XP с пакетом обновления 2 (SP2)


При входе в сеть Windows долго опрашивает ее на предмет наличия назначенных заданий на других компьютерах

FAQ по Microsoft Windows XP | Сеть

Q: При входе в сеть Windows долго опрашивает ее на предмет наличия назначенных заданий на других компьютерах

Windows ХР каждый раз сканирует сеть на наличие сетевых принтеров и отложенных заданий. Для отключения достаточно удалить две папки из реестра.

Находятся они в ветке HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Remote Computer\NameSpace
{2227A280-3AEA-1069-A2DE-08002B30309D} для принтеров
{D6277990-4C6A-11CF-8D87-00AA0060F5BF} для отложенных заданий


Создание и удаление скрытых и административных общих ресурсов (C$, D$, Admin$)

FAQ по Microsoft Windows XP | Сеть

Q: Создание и удаление скрытых и административных общих ресурсов (C$, D$, Admin$)

Скрытыми являются общие ресурсы, имя которых заканчивается знаком доллара («$»). Скрытые общие ресурсы не отображаются при просмотре списка общих ресурсов или при использовании команды net view. Windows XP создает скрытые административные общие ресурсы, используемые приложениями, службами и администраторами для управления компьютерами в сети. По умолчанию в Windows могут быть созданы следующие скрытые административные общие ресурсы:
• корневые разделы или тома
• корневой каталог операционной системы
• общий ресурс FAX$
• общий ресурс IPC$
• общий ресурс PRINT$

Для корневых разделов и томов в качестве имени общего ресурса используется имя диска, к которому добавляется символ «$». Например, для доступа к дискам C и D будут созданы общие ресурсы C$ и D$.
Корневой каталог операционной системы (%SYSTEMROOT%) – это папка, в которую установлена операционная система Windows. Общий ресурс ADMIN$ предоставляет администраторам доступ к этой папке по сети.

Общий ресурс FAX$ используется клиентами для отправки факсов. В этой папке кэшируются файлы и титульные страницы, находящиеся на файловом сервере.
Общий ресурс IPC$ используется при организации временных подключений, создаваемых приложениями для обмена данными с помощью именованных каналов. Как правило, он применяется для удаленного администрирования серверов в сети.
Общий ресурс PRINT$ используется для удаленного администрирования принтеров.

Если удалить скрытые административные ресурсы, созданные операционной системой (например, ADMIN$ или C$), то после перезагрузки компьютера или перезапуска службы «Сервер» они будут созданы повторно. Если удалить скрытые административные ресурсы, созданные пользователями, то после перезагрузки компьютера они повторно созданы не будут.
Microsoft Windows XP Home Edition не создает скрытые административные общие ресурсы.

Создание скрытого общего ресурса
Чтобы создать скрытый общий ресурс, выполните следующие действия:
1. На панели управления дважды щелкните значок Администрирование, а затем дважды щелкните значок Управление компьютером.
2. Разверните узел Общие папки, щелкните правой кнопкой мыши узел Ресурсы и выберите в появившемся меню пункт Новый общий файловый ресурс.
3. В поле Общая папка укажите путь к папке, к которой следует предоставить общий доступ, или нажмите кнопку Обзор, чтобы выбрать нужную папку.
4. Введите имя общего ресурса с символом доллара («$») в конце и нажмите кнопку Далее.
5. Чтобы предоставить доступ к созданному ресурсу только администраторам, установите флажок Администраторы имеют полный доступ, остальные не имеют доступа и нажмите кнопку Готово.
6. Нажмите кнопку Да, чтобы создать еще одну общую папку, или кнопку Нет, чтобы вернуться в консоль управления компьютером.

Удаление скрытого общего ресурса
Чтобы удалить скрытый общий ресурс, выполните следующие действия:
1. На панели управления дважды щелкните значок Администрирование, а затем дважды щелкните значок Управление компьютером.
2. Разверните узел Общие папки и выберите Ресурсы.
3. В столбце Общая папка щелкните правой кнопкой мыши имя удаляемого общего ресурса, выберите пункт Прекратить общий доступ и нажмите кнопку ОК.

Либо воспользуйтесь редактором реестра:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\AutoShareServer]
Параметр: AutoShareServer
Значение: 0

После отключения административных ресурсов, создаваемых по умолчанию, проверьте работоспособность используемых служб и приложений, поскольку ряду служб Windows и приложений независимых разработчиков для работы необходим доступ к некоторым административным общим ресурсам. Например, доступ к этим ресурсам требуется некоторым средствам резервного копирования.


Что такое удаленный рабочий стол. Как его настроить

FAQ по Microsoft Windows XP | Сеть

Q: Что такое удаленный рабочий стол. Как его настроить

Удаленный рабочий стол системы Windows® XP Professional позволяет управлять компьютером на расстоянии — из другой организации, из дома или находясь в пути.

С помощью указанной функции можно пользоваться данными, приложениями и сетевыми ресурсами, размещенными на рабочем компьютере, но при этом не присутствовать на рабочем месте.

О том как правильно настроить удаленный рабочий стол подробно описывает эта статья MS:
Настройка компьютера для работы с удаленным рабочим столом


FAQ по Microsoft Windows XP | Интерфейс

Перечень всех вопросов раздела Интерфейс

  1. Как настроить английскую версию Windows XP для нормального отображения кириллицы в программах

  2. Как настроить отображение вкладки Безопасность в свойствах файла/папки

  3. Как выборочно скрыть пользователей отображаемых в экране приветствия при загрузке

  4. Как настроить автоматический вход в систему без ввода пароля

  5. Как настроить в окне ввода пароля при загрузке системы английскую (русскую) раскладку по умолчанию

  6. При открытии диспетчера задач отсутствуют меню и вкладки

  7. При попытке открыть диспетчер задач появляется сообщение: "Диспетчер задач отключен администратором системы".

  8. Корзина не отображается на рабочем столе

  9. Как настроить систему для нормального отображения кириллицы в DOS-приложениях.

  10. Как изменить каталог открываемый по умолчанию при запуске Проводника

  11. Как изменить время задержки открытия меню Пуск и других

  12. Иконки файлов *.html и *.htm отображаются как неизвестный формат

  13. На рабочем столе надпись "Windows XP версия 0000. Только Для Тестов"

  14. После скринсейвера в экране приветствия (под картинкой пользователя) надпись "У вас N непрочитанных сообщений"

  15. Не отображаются эскизы графических файлов и эскизы web-файлов

  16. Не отображаются эскизы видео файлов, не показывается информация о файлах видео при наведении курсора

  17. Не запоминаются или искажаются параметры отображения или настройки внешнего вида папок

  18. Настройки рабочего для всех новых учетных записей компьютера

  19. Active Desktop - Включение, отключение, изменение настроек через реестр

  20. Добавление пункта Дефрагментация в контекстное меню дисков

  21. Отсутствует панель инструментов в Windows Explorer или Internet Explorer

  22. Восстановление всех вкладок в свойствах обозревателя Internet Explorer

  23. Отключение анимации в Windows XP

  24. Как отменить представление CAB-файлов в виде папок

  25. Как удалить некоторые пункты из контекстного меню в проводнике Windows

© Все права защищены OSzone.net 2001-2006


Active Desktop - Включение, отключение, изменение настроек через реестр

FAQ по Microsoft Windows XP | Интерфейс

Q: Active Desktop - Включение, отключение, изменение настроек через реестр

  • Включить Active Desktop
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    Параметр: ForceActiveDesktopOn
    Тип: REG_DWORD Значение: (0 = по умолчанию, 1 = включен)
  • Убрать опции Active Desktop из свойств экрана
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    Параметр: NoSetActiveDesktop
    Тип: REG_DWORD
    Значение: (0 = ограничение отключено, 1 = ограничение включено)
    Примечание: Это ограничение может быть применено как к конкретному пользователю так и ко всем пользователям компьютера, в первом случае изменения необходимо внести в куст реестра
    HKEY_CURRENT_USER во втором в HKEY_LOCAL_MACHINE

  • Включение Active Desktop, но запрет изменения его настроек
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    Параметр: NoActiveDesktopChanges
    Тип: REG_DWORD
    Значение: (0 = ограничение отключено, 1 = ограничение включено)
  • Включение ограничений на изменение некоторых настроек Active Desktop
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    Параметр: NoChangingWallpaper (Отключает возможность изменения фона рабочего стола)
    Тип: REG_DWORD
    Значение: (0 = ограничение отключено, 1 = ограничение включено)
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    Параметр: NoComponents (Отключает компоненты)
    Тип: REG_DWORD
    Значение: (0 = ограничение отключено, 1 = ограничение включено)
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    Параметр: NoAddingComponents (Отключает возможность добавления компонент)
    Тип: REG_DWORD
    Значение: (0 = ограничение отключено, 1 = ограничение включено)
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    Параметр: NoDeletingComponents (Отключает возможность удаления компонент)
    Тип: REG_DWORD
    Значение: (0 = ограничение отключено, 1 = ограничение включено)
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    Параметр: NoEditingComponents (Отключает возможность изменения компонент)
    Тип: REG_DWORD
    Значение: (0 = ограничение отключено, 1 = ограничение включено)
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    Параметр: NoCloseDragDropBands (Отключает возможность перетаскивания (Drag & Drop) компонент)
    Тип: REG_DWORD
    Значение: (0 = ограничение отключено, 1 = ограничение включено)
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    Параметр: NoMovingBands (Отключает установку на рабочий стол)
    Тип: REG_DWORD
    Значение: (0 = ограничение отключено, 1 = ограничение включено)
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    Параметр: NoHTMLWallPaper (Запрещает все форматы кроме *bmp для установки фона рабочего)
    Тип: REG_DWORD
    Значение: (0 = ограничение отключено, 1 = ограничение включено)


В экране приветствия (под картинкой пользователя) надпись "У вас N непрочитанных сообщений"

FAQ по Microsoft Windows XP | Интерфейс

Q: В экране приветствия (под картинкой пользователя) надпись "У вас N непрочитанных сообщений"

Сохраните приведенный ниже код в текстовый файл с именем tweak.reg и запустите его.

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\UnreadMail]
"MessageExpiryDays"=dword:00000000

C подробностями по данному вопросу вы можете ознакомиться в этой статье MSKB: Overview of the Mail Notification Display on the Windows XP Welcome Screen


Восстановление всех вкладок в свойствах обозревателя Internet Explorer

FAQ по Microsoft Windows XP | Интерфейс

Q: Восстановление всех вкладок в свойствах обозревателя Internet Explorer

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"GeneralTab"=dword:00000000
"ProgramsTab"=dword:00000000
"SecurityTab"=dword:00000000
"ContentTab"=dword:00000000
"PrivacyTab"=dword:00000000
"AdvancedTab"=dword:00000000
"ConnectionsTab"=dword:00000000
"HomePage"=dword:00000000
"Accessibility"=dword:00000000
"CertifPers"=dword:00000000
"CertifSite"=dword:00000000
"SecChangeSettings"=dword:00000000
"SecAddSites"=dword:00000000
"FormSuggest"=dword:00000000
"FormSuggest Passwords"=dword:00000000
"Connwiz Admin Lock"=dword:00000000
"Settings"=dword:00000000
"ResetWebSettings"=dword:00000000
"Connection Wizard"=dword:00000000

[HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"GeneralTab"=dword:00000000
"ProgramsTab"=dword:00000000
"SecurityTab"=dword:00000000
"ContentTab"=dword:00000000
"PrivacyTab"=dword:00000000
"AdvancedTab"=dword:00000000
"ConnectionsTab"=dword:00000000
"HomePage"=dword:00000000
"Accessibility"=dword:00000000
"CertifPers"=dword:00000000
"CertifSite"=dword:00000000
"SecChangeSettings"=dword:00000000
"SecAddSites"=dword:00000000
"FormSuggest"=dword:00000000
"FormSuggest Passwords"=dword:00000000
"Connwiz Admin Lock"=dword:00000000
"Settings"=dword:00000000
"ResetWebSettings"=dword:00000000
"Connection Wizard"=dword:00000000

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoFolderOptions"=dword:00000000

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
"NoBrowserOptions"=dword:00000000

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoSaveSettings"=dword:00000000


Добавление пункта Дефрагментация в контекстное меню дисков

FAQ по Microsoft Windows XP | Интерфейс

Q: Добавление пункта Дефрагментация в контекстное меню дисков

Для добавления пункта Дефрагментация в контекстное меню дисков скачайте и запустите этот скрипт: context_defrag.vbs
Для удаления пункта скачайте и запустите этот скрипт: context_defrag_remove.vbs


Иконки файлов *.html и *.htm отображаются как неизвестный формат

FAQ по Microsoft Windows XP | Интерфейс

Q: Иконки файлов *.html и *.htm отображаются как неизвестный формат

Способ 1
Панель управления -> Свойства папки -> Типы файлов -> Находим нужное расширение -> Дополнительно -> меняем иконку.

Способ 2
В реестре в ветке HKEY_CLASSES_ROOT\htmlfile\DefaultIcon


Как выборочно скрыть пользователей отображаемых в экране приветствия при загрузке

FAQ по Microsoft Windows XP | Интерфейс

Q: Как выборочно скрыть пользователей отображаемых в экране приветствия при загрузке

Сделать это можно в реестре в ветке

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList

Здесь необходимо создать параметр типа DWORD с именем равным имени пользователя которого необходимо скрыть и значением 1 (если значение изменить на 0, то этот пользователь вновь будет виден).
Данные изменения позволят скрыть пользователей в экране приветствия при загрузке и в Панели управления в оснастке Учетные записи пользователей.

Примечание: для того что бы войти в систему под скрытым пользователем нужно в экране приветствия дважды нажать Ctrl+Alt+Del - откроется классическое окно логона в котором можно будет ввести имя пользователя и пароль скрытой учетной записи.


Как изменить время задержки открытия меню Пуск и других

FAQ по Microsoft Windows XP | Интерфейс

Q: Как изменить время задержки открытия меню Пуск и других

В реестре в ветке

HKEY_CURRENT_USER\Control Panel\Desktop

Параметр MenuShowDelay.
значение по умолчанию 400, но можно выставить удобное для вас


Как изменить каталог открываемый по умолчанию при запуске Проводника

FAQ по Microsoft Windows XP | Интерфейс

Q: Как изменить каталог открываемый по умолчанию при запуске Проводника

В свойствах ярлыка проводника объект запуска напишите "%SystemRoot%\explorer.exe /e,c:" (без кавычек), тогда будет открываться диск С


Как настроить автоматический вход в систему без ввода пароля

FAQ по Microsoft Windows XP | Интерфейс

Q: Как настроить автоматический вход в систему без ввода пароля

Способ 1

1. Нажмите Пуск выберите команду Выполнить, введите в командную строку control userpasswords2 и нажмите OK
2. Снимите галочку с параметра "Требовать ввод имени пользователя и пароля" и нажмите кнопку Применить.
3. Выберите имя пользователя для автоматического входа в систему и введи пароль этой учетной записи

Способ 2

1. Нажмите кнопку Пуск, выберите команду Выполнить, введите в командную строку regedit и нажмите кнопку ОК.
2. Найдите следующий параметр реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon

3. Дважды щелкните параметр DefaultUserName, введите свое имя пользователя и нажмите кнопку OK.
4. Дважды щелкните параметр DefaultPassword, введите в поле [Значение] свой пароль и нажмите кнопку OK.

Если параметр DefaultPassword отсутствует, создайте его. Для этого выполните следующие действия.
a. В меню Правка редактора реестра выберите пункт Создать, а затем Строковый параметр.
b. Укажите в качестве названия параметра DefaultPassword и нажмите клавишу ВВОД.
c. Дважды щелкните созданный параметр и в поле Значение введите пароль.

Примечание: Если значение DefaultPassword не задано, система автоматически изменяет значение раздела реестра AutoAdminLogon с 1 (включен) на 0 (отключен), тем самым отключая автоматический вход.

5. Дважды щелкните параметр AutoAdminLogon, введите в поле Значение число 1 и нажмите кнопку OK.
Если параметр AutoAdminLogon отсутствует, создайте его.

Более подробно вы можете узнать из этой статьи MSKB: Автоматизация входа в систему на компьютере под управлением Windows XP


Как настроить английскую версию Windows XP для нормального отображения кириллицы в программах

FAQ по Microsoft Windows XP | Интерфейс

Q: Как настроить английскую версию Windows XP для нормального отображения кириллицы в программах

Панель Управления -> Языковые и Региональные Настройки (Settings -> Regional and Language Options)

Как правило, достаточно изменить настройки так, как показано на скриншоте 1

В некоторых программах (например, Small CD-Writer) меню не будут корректно отображаться до тех пор, пока в Стандартах и Форматах не выставлено Россия (позднее их можно модифицировать в соответствии со страной проживания - скриншот 2).

Если проблемы не исчезли, то есть еще одно средство - изменить параметры кодовых страниц в реестре. Скопируйте текст в Блокнот, сохраните как filename.reg и запустите. Перезагрузите компьютер

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]
"1252"="c_1251.nls"

Если все вышеперечисленные действия не привели к положительному результату, то рекомендую посетить сайт Павла Городянского, где проблемы поддержки кириллицы в Windows изложены весьма подробно.


Как настроить в окне ввода пароля при загрузке системы английскую (русскую) раскладку по умолчанию

FAQ по Microsoft Windows XP | Интерфейс

Q: Как настроить в окне ввода пароля при загрузке системы английскую (русскую) раскладку по умолчанию

Чтобы по умолчанию система выводила английскую раскладку в окне ввода пароля нужно в реестре в ветке

HKEY_USERS\.DEFAULT\Keyboard Layout\Preload

Поместить на первую позицию желаемую раскладку
00000409 - английская раскладка
00000419 - русская раскладка


Как настроить отображение вкладки Безопасность в свойствах файла/папки

FAQ по Microsoft Windows XP | Интерфейс

Q: Как настроить отображение вкладки Безопасность в свойствах файла/папки

1. Нажмите кнопку Пуск и выберите пункт Мой компьютер.
2. В меню Сервис выберите команду Свойства папки и перейдите на вкладку Вид.
3. В списке Дополнительные параметры снимите флажок Использовать простой общий доступ к файлам (рекомендуется).
4. Нажмите кнопку ОК.

Примечание: данное решение относится к Windows XP Professional и к папкам и файлам на дисках с файловой системой NTFS
К Windows XP Home и к файлам и папкам на дисках с файловой системой FAT32 данная опция неприменима.


Как настроить систему для нормального отображения кириллицы в DOS-приложениях

FAQ по Microsoft Windows XP | Интерфейс

Q: Как настроить систему для нормального отображения кириллицы в DOS-приложениях

Необходимо в реестре в ветке

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout\DosKeybIDs

Параметр 00000409
Значение изменить на "ru".
Кроме этого, в файле autoexec.nt, расположенном в Windows\system32, надо добавить строку "lh %SystemRoot%system32kb16.com ru" (без кавычек).
После перезагрузки переключение раскладки клавиатуры в DOS-приложениях будет производиться комбинациями Ctrl+Left Shift (английская) и Ctrl+Right Shift (русская).
Данный метод нормально работает в том случае, если в Региональных Параметрах в качестве параметра по умолчанию установлен русский язык.


Как отменить представление CAB-файлов в виде папок

FAQ по Microsoft Windows XP | Интерфейс

Q: Как отменить представление CAB-файлов в виде папок

Пуск - Выполнить - regsvr32 /u cabview.dll
Для включения отображения CAB-файлов в виде папок используйте команду regsvr32 cabview.dll


Как удалить некоторые пункты из контекстного меню в проводнике Windows

FAQ по Microsoft Windows XP | Интерфейс

Q: Как удалить некоторые пункты из контекстного меню в проводнике Windows

Значения отображаемые в контекстном меню логических дисков указаны в реестре
HKEY_CLASSES_ROOT\Drive\shell
HKEY_CLASSES_ROOT\Drive\shellex\ContextMenuHandlers

Контекстное меню каталогов:
HKEY_CLASSES_ROOT\Directory\shell
HKEY_CLASSES_ROOT\Directory\shellex\ContextMenuHandlers
HKEY_CLASSES_ROOT\Folder\shell
HKEY_CLASSES_ROOT\Folder\shellex\ContextMenuHandlers

Контекстное меню всех файлов:
HKEY_CLASSES_ROOT\*\OpenWithList
HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers

Контекстное меню отдельных форматов файлов в соответствующем расширению файла подразделе ветви реестра HKEY_CLASSES_ROOT
Например для файлов TXT это будет HKEY_CLASSES_ROOT\.txt\


Корзина не отображается на рабочем столе

FAQ по Microsoft Windows XP | Интерфейс

Q: Корзина не отображается на рабочем столе

Способ 1. В случае если для скрытия ярлыка корзины с рабочего стола была использована спец. утилита (твикер)
1. Откройте редактор реестра и перейдите в следующий раздел:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel
2. На правой панели щелкните мыши параметр {645FF040-5081-101B-9F08-00AA002F954E} и выберите команду Изменить.
3. В поле Значение введите 0 и нажмите кнопку ОК. (Для скрытия значка корзины программа TweakUI и ее аналоги присваивает этому параметру значение 1.)

Способ 2. Изменение реестра для восстановления корзины
Примечание. Данный способ не поможет, если для скрытия корзины (или всех значков) системный администратор использовал групповую политику.
Чтобы изменить реестр для появления значка Корзина на рабочем столе, выполните следующие действия.
1. Откройте редактор реестра и перейдите в следующий раздел:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace
2. Щелкните правой кнопкой мыши на разделе NameSpace, выберите пункт Создать, а затем — команду Раздел.
3. Введите {645FF040-5081-101B-9F08-00AA002F954E} и нажмите клавишу ВВОД.
4. В новом разделе {645FF040-5081-101B-9F08-00AA002F954E}, в правой области окна редактора реестра дважды щелкните запись (По умолчанию)
5. В диалоговом окне Изменение строкового параметра в поле Значение введите Recycle Bin и нажмите кнопку ОК.

Способ 3. Для восстановления корзины используйте редактор объектов групповой политики
Примечание. Данный способ возможен только в операционной системе Windows XP Professional.
Чтобы восстановить значок Корзина на рабочем столе, вы можете воспользоваться редактором объекта групповой политики (GPEDIT.msc) или вручную удалить сведения из реестра (которые были созданы с помощью редактора объекта групповой политики), связанные с корзиной.

• Чтобы использовать редактор объекта групповой политики для восстановления корзины, выполните следующие действия.
1. Выберите в меню Пуск пункт Выполнить, введите в поле Открыть команду GPEDIT.MSC и нажмите кнопку ОК.
2. В списке Конфигурация пользователя щелкните элемент Административные шаблоны, а затем дважды щелкните элемент Рабочий стол.
3. Дважды щелкните параметр Удалить значок "Корзины" с рабочего стола.
4. Перейдите на вкладку Состояние, выберите вариант Не задан и нажмите кнопку OK.

• Чтобы использовать реестр для восстановления корзины, выполните следующие действия.
1. Откройте редактор реестра и перейдите в следующий раздел:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum
2. В области справа щелкните значение {645FF040-5081-101B-9F08-00AA002F954E} и в меню Правка выберите команду Удалить и нажмите кнопку Да.

Способ 4.
Создайте папку с именем Корзина точка и {645FF040-5081-101B-9F08-00AA002F954E} то есть значение идентификатора как расширение после точки.

Временное решение Если не удалось восстановить корзину с помощью приведенных в этой статье решений, решите эту проблему, создав ярлык для корзины.
1. Зайдите в Панели управления в оснастку Свойства папки.
2. Перейдите на вкладку Вид и снимите флажок Скрывать защищенные системные файлы (рекомендуется).
3. На панели инструментов нажмите кнопку Папки.
4. В области слева в списке Папки найдите папку RECYCLER, а затем перетащите папку RECYCLER на рабочий стол.
5. В меню Сервис выберите команду Свойства папки.
6. Перейдите на вкладку Вид и установите флажок Скрывать защищенные системные файлы (рекомендуется). Нажмите кнопку ОК.
Примечание. С помощью этих действий не удастся восстановить исходный значок, однако можно восстановить большинство функций корзины, включая следующие:
• удаление файла перетаскиванием на значок Корзина на рабочем столе;
• восстановление удаленного файла. Два раза щелкните значок Корзина на рабочем столе, два раза щелкните файл, который требуется восстановить, а затем нажмите кнопку Восстановить;
• очистка корзины. Щелкните правой кнопкой значок Корзина на рабочем столе, а затем выберите команду Очистить корзину.
Если для восстановления корзины использовалось последнее решение, не удастся вызвать окно свойств, щелкнув правой кнопкой мыши значок Корзина.
Чтобы задать свойства корзины, выполните следующие действия.
1. Дважды щелкните ярлык Корзина на рабочем столе. Откроется папка корзины.
2. В верхнем левом углу папки «Корзина» щелкните правой кнопкой мыши значок Корзина, а затем выберите команду Свойства.


На рабочем столе надпись "Windows XP версия 0000. Только Для Тестов"

FAQ по Microsoft Windows XP | Интерфейс

Q: На рабочем столе надпись "Windows XP версия 0000. Только Для Тестов"

Такая надпись могла появиться после установки бета-версии какого-либо продукта Microsoft, например Windows Media Player.

Чтобы избавиться от нее вам необходимо проделать следующее:

Пуск -> Выполнить -> certmgr.msc -> Доверенные корневые центры сертификации -> Сертификаты -> Microsoft Test Root Authority -> удалить -> перезагрузка


Настройки рабочего для всех новых учетных записей компьютера

FAQ по Microsoft Windows XP | Интерфейс

Q: Настройки рабочего для всех новых учетных записей компьютера

Создайте пользователя, установите фон рабочего стола, настройте внешний вид рабочего стола
Войдите в систему с учетной записью администратора и скопируйте содержимое каталога новой учетной записи в каталог \Documents and Settings\Default User
После этого все новые учетные записи компьютера будут создаваться с определенными ранее настройками рабочего стола


Не запоминаются или искажаются параметры отображения или настройки внешнего вида папок

FAQ по Microsoft Windows XP | Интерфейс

Q: Не запоминаются или искажаются параметры отображения или настройки внешнего вида папок

Проблема
Не запоминаются или искажаются параметры отображения или настройки внешнего вида папок. Например, возможно возникновение в системе следующих проблем.
  • При повторном открытии папки параметры отображения не сохраняются.
    Примечание: к параметрам отображения относятся следующие режимы: «Эскизы страниц», «Крупные значки», «Мелкие значки», «Список» и «Таблица».
  • При повторном открытии окна папки Windows не запоминает его размер или положение на экране.
  • Эскизы страниц в папке отображаются неверно либо не отображаются вообще.

Примечание. Данная проблема возникает, даже если в области Дополнительные параметры на вкладке Вид компонента панели управления Свойства папки установлен флажок Помнить параметры отображения каждой папки. Перейти к началу страницы

Причина
Данная проблема возникает, так как параметры отображения и настройки внешнего вида каждой папки сохраняются в реестре. По умолчанию одновременно могут сохраняться параметры для 200 локальных папок и 200 сетевых папок, то есть всего для 400 папок максимум. Данные о параметрах отображения и настройках внешнего вида папок сохраняются в следующих разделах реестра:

HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags
HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\Bags

Решение

Для решения проблемы создайте параметр BagMRU Size типа DWORD в обоих приведенных ниже разделах реестра и установите для этих параметров значения, соответствующие числу папок, параметры отображения которых необходимо сохранять. Например, чтобы система сохраняла настройки для 5000 локальных папок и 5000 сетевых папок, укажите для обоих параметров значение 5000.

Новый параметр необходимо создать в следующих разделах реестра:
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell
HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam
Внимание! При указании значения параметра BagMRU Size следует учитывать конфигурацию системы. С увеличением значения параметра BagMRU Size увеличивается объем данных, сохраняемых в реестре. Если используются перемещаемые профили пользователей, то при завершении сеанса работы данные реестра копируются на сервер, а при входе пользователя в систему – обратно на компьютер. Таким образом, при увеличении значения параметра BagMRU Size для перемещаемых пользовательских профилей могут возникнуть проблемы с быстродействием.

Выполните следующие действия:
  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите в командную строку regedit и нажмите кнопку ОК.
  2. Найдите и выберите раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell
  3. В меню Правка выберите пункт Создать, а затем Параметр DWORD.
  4. Введите BagMRU Size и нажмите клавишу ВВОД.
  5. В меню Правка выберите команду Изменить.
  6. Введите значение 5000 и нажмите кнопку ОК.

Выполните следующие действия.

  1. Найдите и выберите раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam
  2. В меню Правка выберите пункт Создать, а затем Параметр DWORD.
  3. Введите BagMRU Size и нажмите клавишу ВВОД.
  4. В меню Правка выберите команду Изменить.
  5. Введите значение 5000 и нажмите кнопку ОК.

Дополнительная информация
Windows может запоминать для папки настройки режима просмотра, местоположение окна, порядок сортировки, данные столбцов, тип папки, параметры строки состояния, панели инструментов и результаты поиска.


Не отображаются эскизы видео файлов, не показывается информация о файлах видео при наведении курсора

FAQ по Microsoft Windows XP | Интерфейс

Q: Не отображаются эскизы видео файлов, не показывается информация о файлах видео при наведении курсора

Вероятнее всего в системе не зарегистрирована библиотека shmedia.dll.
Для устранения проблемы необходимо зарегистрировать в системе данную библиотеку. Для этого проделайте следующее:
1. Войдите в систему под учетной записью с правами администратора.
2. Нажмите Пуск, затем Выполнить, напишите следующую команду:

regsvr32 %systemroot%\system32\shmedia.dll
и нажмите ОК


Не отображаются эскизы графических файлов и эскизы web-файлов

FAQ по Microsoft Windows XP | Интерфейс

Q: Не отображаются эскизы графических файлов и эскизы web-файлов

Для обеспечения безопасности в Windows XP SP1 и Windows XP SP2 отключена возможность просмотра эскизов для следующих типов файлов:
• HTML (файлы .htm and .html)
• XML (.xml файлы)
• Internet e-mail messages (.eml файлы)
• Internet news messages (.nws файлы)

Если не отображаются эскизы графических файлов, то вероятнее всего в системе не зарегистрирована библиотека Shimgvw.dll.
Для устранения проблемы необходимо зарегистрировать в системе данную библиотеку. Для этого проделайте следующее:
1. Войдите в систему под учетной записью с правами администратора.
2. Нажмите Пуск, затем Выполнить, напишите следующую команду:

regsvr32 %systemroot%\system32\shimgvw.dll
и нажмите ОК


Отключение анимации в Windows XP

FAQ по Microsoft Windows XP | Интерфейс

Q: Отключение анимации в Windows XP

[HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics]
Параметр: MinAnimate
Значение: 0


Отсутствует панель инструментов в Windows Explorer или Internet Explorer

FAQ по Microsoft Windows XP | Интерфейс

Q: Отсутствует панель инструментов в Windows Explorer или Internet Explorer

Для восстановления панелей инструментов скачайте и запустите этот файл: ToolbarRepair.Exe


При открытии диспетчера задач отсутствуют меню и вкладки

FAQ по Microsoft Windows XP | Интерфейс

Q: При открытии диспетчера задач отсутствуют меню и вкладки

Что бы вернуть диспетчеру задач нормальное состояние достаточно дважды щелкнуть мышью (doubleclick) на серой рамке окна.


При попытке открыть диспетчер задач появляется сообщение: "Диспетчер задач отключен администратором системы"

FAQ по Microsoft Windows XP | Интерфейс

Q: При попытке открыть диспетчер задач появляется сообщение: "Диспетчер задач отключен администратором системы"

Временное решение:
Можно открыть диспетчер задач сочетанием клавиш CTRL+SHIFT+ESC

Решение постоянное:
Способ 1
Пуск -> Выполнить -> gpedit.msc -> Административные шаблоны -> Система -> Cntr+Alt+Del -> Удалить диспетчер задач -> отключено.

Способ 2
В реестре в ветке

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System

Параметр DisableTaskMgr
Тип DWORD
Значение 0 (или удалить параметр)


FAQ по Microsoft Windows XP | Разное

Перечень всех вопросов раздела Разное

  1. При запуске большинства игр в ХР частота монитора устанавливается 60 гц

  2. Как в Windows ХР запустить скандиск

  3. Какую версию Windows лучше установить на домашний компьютер Windows XP Professional или Home Edition.

  4. Где находится папка SendTo

  5. За что отвечает файл pagefile.sys

  6. Для чего необходима папка System Volume Information

  7. Какие существуют способы восстановления поврежденных системных файлов и системы в целом

  8. Где хранится код активации Windows XP

  9. Для чего нужна вкладка "Совместимость" в свойствах исполняемых файлов и ярлыков

  10. Как задать пpиоpитет процесса пpи его запуске

  11. Как переписать консоль восстановления (recovery console) на жесткий диск

  12. Процесс зависшего приложения был снят через диспетчер задач, после чего в панели задач и в трее увеличился размер ярлыков

  13. Как открыть папку System Volume Information

  14. Где система сохраняет закачанные обновления, получаемые автоматически с WindowsUpdate

  15. Появление сообщения об ошибке «Файл подкачки отсутствует или слишком мал»

  16. Как настроить файл подкачки для оптимизации и восстановления Windows XP

  17. Как правильно настроить механизм восстановления в Windows XP

  18. Как произвести печать на сетевой принтер из программы MS-DOS

  19. Как скопировать данные из поврежденного профиля пользователя в новый

  20. Доступ запрещен: Сообщение об ошибке Windows Update

  21. Специальные возможности: сброс всех настроек на стандартные

  22. При запуске мастера активации Windows (WPA) страница «Активация Windows» отображается пустой

  23. После восстановления из архива Windows XP требует выполнить повторную активацию


Где находится папка SendTo

FAQ по Microsoft Windows XP | Разное

Q: Где находится папка SendTo

C:\Documents and Settings\имя_пользователя\SendTo

имеет атрибут Скрытый


Где система сохраняет закачанные обновления, получаемые автоматически с WindowsUpdate

FAQ по Microsoft Windows XP | Разное

Q: Где система сохраняет закачанные обновления, получаемые автоматически с WindowsUpdate

Начиная с Windows XP SP2 скачанные с сайта WindowsUpdate обновления сохраняются в каталоге C:\Windows\SoftwareDistribution\Download в каталоги с именем типа ee071be92a4f386364897946da887aa70e78e17b, ee1d1ab09f7a702b9f6ca9528e159fa64d1f9e3c и т.д. В этих каталогах есть папка \update\ - это и есть загруженное обновление в распакованном виде. Номер обновления указан в файле с расширением CAT.

Но наиболее правильным решением, на мой взгляд будет интеграция обновлений в дистрибутив Windows. Как это сделать можете прочитать в этой статье: Интеграция обновлений и заплаток в дистрибутив
Дополнительную информациею можете получить прочитав эту тему форума: Сохранение обновлений Windows Update


Где хранится код активации Windows XP

FAQ по Microsoft Windows XP | Разное

Q: Где хранится код активации Windows XP

Как известно, лицензионная Windows XP при переустановке системы требует повторной активации. Чтобы этого избежать, достаточно перед переустановкой системы скопировать файл wpa.dbl, расположенный в папке \%WinDir%\System32 именно в этом файле хранится код активации. После переустановки системы, естественно, нужно будет заменить файл wpa.dbl на сохраненный


Для чего необходима папка "System Volume Information"

FAQ по Microsoft Windows XP | Разное

Q: Для чего необходима папка "System Volume Information"

Это папка в которой операционная система содержит данные для восстановления системы.

© Все права защищены OSzone.net 2001-2006


Для чего нужна вкладка "Совместимость" в свойствах исполняемых файлов и ярлыков

FAQ по Microsoft Windows XP | Разное

Q: Для чего нужна вкладка "Совместимость" в свойствах исполняемых файлов и ярлыков

Эта вкладка предназначена для "обмана" программ. Учитывая, что Windows XP является вроде как бы "гибридной" операционной системой, на которую будут переходить пользователи и Windows 98, и Windows NT, и Windows 2000, Microsoft приняла решение не ждать, пока разработчики программного обеспечения выпустят патчи и обновленные версии программ, совместимые с Windows XP, а сама добавила в операционную систему специальную функцию "режим совместимости", который как раз и настраивается на вкладке "Совместимость".
Поставив на этой вкладке галку напротив надписи "Запустить программу в режиме совместимости с" и выбрав одну из предложенных операционных систем:
Windows 95
Windows 98
Windows Me
Windows NT
Windows 2000
мы тем самым заставим программу поверить, что она работает не в Windows XP, а в выбранной операционной системе.

Стоит отметить, что Windows XP не просто сообщает программе, что она - не Windows XP, но и эмулирует структуру системного реестра соответствующей операционной системы, что позволяет заставить нормально работать в Windows XP большинство из программ, формально не предназначенных для работы в этой ОС, и только некоторые из них (те, что проверяют ядро ОС) не поддадутся на эту уловку и откажутся работать.


Доступ запрещен: Сообщение об ошибке Windows Update

FAQ по Microsoft Windows XP | Разное

Q: Доступ запрещен: Сообщение об ошибке Windows Update

Возможно запрещение политиками сети скачивания и установки обновлений с использованием узла Windows Update.

Для Windows XP Professional:
Пуск - Выполнить - gpedit.msc - Конфигурация пользователя - Административные шаблоны - Компоненты Windows Windows Update - Удалить доступ к возможностям Windows Update - установите значение параметра в положение Отключен.

Для Windows XP Home Edition:
Пуск - Выполнить - regedit - HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate

В правой панели найдите параметр с именем DisableWindowsUpdateAccess. Установите значение этого параметра равным 0 (ноль) или удалите его.

Дополнительно:

Для удаления всех ограничений использования Windows Update и установки значений по умолчанию можете загрузить и выполнить этот файл.

Просмотреть какие необходимы разрешения учетной записи для использования узла Windows Update вы можете в этой статье: При обращении на веб-узел Windows Update появляется сообщение об ошибке, разрешающее работу с узлом только администраторам.

Для того чтобы отобразить скрытые обновления выполните следующие действия:
Пуск - Выполнить - cmd - напишите и выполните команду

del /q "%SystemRoot%\System32\Catroot2\Edb.log

Если вы не можете скачать обновления попробуйте выполнить следующие действия:
Пуск - Выполнить - в поле Открыть напишите команду
regsvr32 wintrust.dll

Если это ничего не изменит, то выполните следующие действия:
Пуск - Выполнить - cmd
В командной строке напишите и выполните поочередно следующие команды:
net stop cryptsvc
ren %systemroot%\system32\catroot2 oldcatroot2
net start cryptsvc

Другие решения:
В случае если проверка доступности новых обновлений для вашего компьютера быстро проходит до 100% и сообщает, что для вашего компьютера нет новых обновлений:
1. Проверьте верно ли настроены дата и время на вашем компьютере, актуализируйте через интернет.
2. Проверьте языковые параметры в Internet Explorer - они не должны быть пустыми.
а. Для проверки языковых параметров IE сделайте следующее:
1. Сервис - Свойства обозревателя
2. Нажмите кнопку Языки...
3. Убедитесь, что в списке языков указан язык системы.

Если это не помогло проделайте следующее:
Сервис - Свойства обозревателя - Подключения - Настройка LAN - снимите отметку с параметра Автоматическое определение параметров.

Дополнительные материалы:
Microsoft Windows Update: Устранение неполадок


За что отвечает файл pagefile.sys

FAQ по Microsoft Windows XP | Разное

Q: За что отвечает файл pagefile.sys

Это файл подкачки. Скрытый файл на жестком диске, используемый Windows для хранения частей программ и файлов данных, не помещающихся в оперативной памяти. По мере необходимости Windows перемещает данные из файла подкачки в оперативную память (для их использования программой) и обратно (для освобождения места для новых данных)


Как в Windows ХР запустить скандиск

FAQ по Microsoft Windows XP | Разное

Q: Как в Windows ХР запустить скандиск

Мой компьютер -> нужный_диск -> Свойства -> Сервис -> Выполнить проверку. Если установить "Автоматически исправлять системные ошибки" и "Проверять и восстанавливать поврежденные сектора" то проверка будет произведена после перезагрузки.

Пуск -> Выполнить -> cmd -> chkdsk c: /f /r (список всех параметров запуска chkdsk /?)

Если у вас еще остались вопросы по работе chkdsk вы можете задать их в этой теме форума: chkdsk - утилита проверки дисков


Как задать пpиоpитет процесса при его запуске

FAQ по Microsoft Windows XP | Разное

Q: Как задать пpиоpитет процесса при его запуске

C помощью консольной команды start можно запускать приложение с нужным приоритетом, указывать время, через которое приложение должно быть закрыто, и некоторые другие параметры.
Для более подробной справки почитайте start /?
Все эти команды можно прописать в *.bat файле и пользоваться им для запуска приложений.
Чтобы не писать *.bat файлы для каждой программы отдельно, и не набирать команду целиком, можно сделать файл high.bat, с таким содержимым:

echo off
start /high %1

и поместить его в директорию SendTo профиля вашего пользователя. Тогда, чтобы запустить программу с более высоким приоритетом, достаточно просто переслать её на этот файл через правую кнопку мыши. Но пересылать надо именно исполняемый файл, а не ярлык к нему. Конечно же, этот фай можно и переделать и запускать программы с другим приоритетом.
Windows XP может работать в двух режимах. Первый отводит больший приоритет запущенным пользователем приложениям (эту настройку нужно выбрать для рабочей станции или домашнего компьютера), второй отводит больший приоритет на фоновые приложения и службы (эту настройку нужно выбрать для сервера).
Настройку можно посмотреть в Панель управления -> Система -> Дополнительно -> Параметры быстродействия.
Будьте осторожны в присвоении класса реального времени. Такая программа будет иметь очень высокий приоритет, что может сказаться на замедлении выполнения других программ. Более того, если у Вас не SMP система, то приложение может просто ничего не оставить системе, и вы столкнётесь с ситуацией, когда компьютер не будет реагировать на ваши действия, или будет реагировать с большим опозданием.


Как настроить файл подкачки для оптимизации и восстановления Windows XP

FAQ по Microsoft Windows XP | Разное

Q: Как настроить файл подкачки для оптимизации и восстановления Windows XP

Файл подкачки (Pagefile.sys) — это скрытый файл на жестком диске компьютера, который используется Windows XP по принципу оперативного запоминающего устройства (RAM).
Файл подкачки и физическая память вместе составляют виртуальную память.
По умолчанию Windows хранит файл подкачки в загрузочном разделе (раздел, в котором установлена операционная система и вспомогательные файлы).
Рекомендуемый размер файла подкачки должен быть в 1,5 раза больше общего объема RAM.

Для улучшения быстродействия системы файл подкачки следует переместить в другой раздел на другом жестком диске. В этом случае операционная система быстрее обрабатывает повторяющиеся запросы ввода-вывода.
Когда файл подкачки расположен в загрузочном разделе, Windows направляет запросы чтения с диска и записи на диск как к системной папке, так и к файлу подкачки. После перемещения файла подкачки в другой раздел конкуренция между запросами записи и чтения уменьшается.
С другой стороны, после удаления файла подкачки из загрузочного раздела, Windows не сможет создать файл аварийной копии памяти (Memory.dmp) для записи отладочной информации в случае возникновения неустранимой ошибки режима ядра. Отсутствие такого файла, когда необходима отладка произошедшей ошибки, может послужить причиной длительного простоя системы.
Оптимальным решением является создание одного файла подкачки в загрузочном разделе, а второго — в разделе, который используется менее часто (на другом жестком диске, если такой имеется).
Кроме того, для второго файла подкачки лучше всего отвести отдельный раздел, где нет других данных и системных файлов. По умолчанию Windows в первую очередь использует файл подкачки из менее загруженного раздела (а не файл подкачки из загрузочного раздела, количество обращений к которому намного больше). Для определения файла, который задействуется для управления виртуальной памятью, Windows применяет внутренний алгоритм.
Использование отдельного раздела для файла подкачки имеет еще одно преимущество — в этом случае файл не фрагментируется (не разбивается на куски). Файл подкачки, размещенный в разделе, где находятся другие данные, может быть фрагментирован в процессе его увеличения для наращивания размеров виртуальной памяти.
Дефрагментированный файл подкачки означает ускорение доступа к виртуальной памяти и увеличивает шансы записать файл аварийной копии памяти без существенных ошибок.

В результате соблюдения приведенных выше рекомендаций будут выполнены важные с точки зрения оптимизации и восстановления системы условия.

• Система соответствующим образом настроена для записи файла Memory.dmp в случае возникновения ошибки режима ядра.
• В основном используется файл подкачки из менее загруженного раздела.


Как открыть папку System Volume Information

FAQ по Microsoft Windows XP | Разное

Q: Как открыть папку System Volume Information

Папка System Volume Information - это скрытая системная папка, которая используется программой восстановления системы для хранения своих данных и точек восстановления. Папка создается в каждом разделе жесткого диска. Доступ к этой папке иногда необходим в процессе устранения возникших в системе неполадок.

Статья MSKB в которой описан процесс получения доступа к папке System Volume Information:
Получение доступа к папке System Volume Information


Как переписать консоль восстановления (recovery console) на жесткий диск

FAQ по Microsoft Windows XP | Разное

Q: Как переписать консоль восстановления (recovery console) на жесткий диск

Консоль восстановления (recovery console) - утилита для доступа к вашим данным без загрузки самой Windows XP. Она понадобится если из-за ошибки реестра или сбоя жесткого диска вы не можете загрузить XP даже в безопасном режиме. Вот статьи MSKB которые помогут Вам в установке и использовании консоли восстановления:

1. Описание консоли восстановления Windows XP
2. Установка и использование консоли восстановления в Windows XP
3. Включение автоматического входа администратора в систему при использовании консоли восстановления


Как правильно настроить механизм восстановления в Windows XP

FAQ по Microsoft Windows XP | Разное

Q: Как правильно настроить механизм восстановления в Windows XP

Операционная система Windows позволяет указывать, какие действия должны быть предприняты при возникновении системных ошибок (также называемых сбоями системы, неустранимыми ошибками или критическими ошибками). Ниже перечислены возможные действия.

• Запись данных о событии в системный журнал.
• Извещение администраторов (если настроена отправка административных оповещений).
• Сохранение дампа системной памяти в файле, который может быть использован при отладке.

Настройка механизма восстановления
Для настройки механизма восстановления необходимо использовать панель управления или изменять параметры механизма восстановления на локальных и удаленных компьютерах посредством изменения значений в следующем разделе системного реестра:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl
Далее для каждого параметра будут указываться соответствующее значение системного реестра, а также пример команды, изменяющей данное значение на локальном компьютере с помощью программы Wmic.exe, позволяющей получать доступ к инструментарию управления Windows (WMI). Дополнительные сведения см. в разделе Дополнительные сведения для специалистов данной статьи. Чтобы настроить механизм восстановления, выполните следующие действия.

1. Зайдите в свойства системы (правой кнопкой мыши значок Мой компьютер и выберите пункт Свойства)
2. Откройте вкладку Дополнительно и в области Загрузка и восстановление нажмите кнопку Параметры (или Загрузка и восстановление).
3. В области Отказ системы установите флажки, соответствующие действиям, которые должна выполнять операционная система при возникновении системной ошибки.
• Если флажок Записать событие в системный журнал установлен, сведения о событии будут записаны в системный журнал. По умолчанию данный параметр включен. Чтобы на компьютерах под управлением Windows XP и Windows 2000 Professional отключить данное действие путем изменения реестра, присвойте параметру LogEvent типа DWORD значение 0. Например, введите следующую команду и нажмите клавишу ВВОД.
wmic recoveros set WriteToSystemLog = False
• Параметр Отправить административное оповещение указывает, что администраторы должны оповещаться о системных ошибках. По умолчанию данный параметр включен. Чтобы отключить данное действие путем изменения реестра, присвойте параметру реестра SendAlert типа DWORD значение 0. Например, введите следующую команду и нажмите клавишу ВВОД.
wmic recoveros set SendAdminAlert = False
Дополнительные сведения о настройке оповещений см. в следующем вопросе.
• Если флажок Выполнить автоматическую перезагрузку установлен, то Windows автоматически перезапустит компьютер. Этот флажок установлен по умолчанию. Чтобы отключить данное действие путем изменения реестра, присвойте параметру реестра AutoReboot типа DWORD значение 0. Например, введите следующую команду и нажмите клавишу ВВОД.
wmic recoveros set AutoReboot = False

4. В области Запись отладочной информации выберите, какие данные операционная система должна сохранять в файле дампа памяти, если компьютер аварийно завершает работу. • Если выбрано значение (отсутствует), то в файле дампа не будут сохраняться никакие данные. Чтобы отключить сохранение данных в файле дампа памяти, присвойте параметру реестра CrashDumpEnabled типа DWORD значение 0. Например, введите следующую команду и нажмите клавишу ВВОД.
wmic recoveros set DebugInfoType = 0
• Если выбрано значение Малый дамп памяти, то будет произведена запись минимального набора сведений, необходимых для определения причины неполадок. Для создания малого дампа памяти необходимо, чтобы размер файла подкачки составлял как минимум 2 Мб на загрузочном томе. При этом каждый раз при возникновении неустранимой ошибки Windows будет автоматически создавать новый файл. Эти файлы будут храниться в папке, заданной в поле Папка малого дампа (%SystemRoot%\Minidump). На компьютерах под управлением Windows XP и Windows Server 2003 файл малого дампа памяти используется службой регистрации ошибок. Чтобы отключить сохранение данных в файле малого дампа памяти, присвойте параметру реестра CrashDumpEnabled типа DWORD значение 3. Например, введите следующую команду и нажмите клавишу ВВОД.
wmic recoveros set DebugInfoType = 3
Чтобы указать, что папка D:\Minidump должна использоваться в качестве папки для хранения малых дампов памяти, присвойте расширяемому строковому параметру реестра MinidumpDir значение D:\Minidump. Например, введите следующую команду и нажмите клавишу ВВОД.
wmic recoveros set MiniDumpDirectory = 3
• Если выбран параметр Дамп памяти ядра, то в файле дампа будет сохранена только память ядра.
При этом сохраняется больше информации, чем при использовании малого дампа памяти, но тратится меньше времени, чем при сохранении полного дампа памяти.
В этом случае имя файла дампа указывается в поле Файл дампа памяти (по умолчанию — %SystemRoot%\Memory.dmp).
Если установлен флажок Заменять существующий файл дампа, то находящиеся в указанной папке файлы дампа памяти ядра или полного дампа памяти будут перезаписаны.
Выбирая данный параметр, необходимо иметь на загрузочном томе достаточно большой файл подкачки. Требуемый размер зависит от объема памяти, установленной на компьютере (на 32-разрядных системах максимальный объем места, доступного для создания дампа памяти ядра, составляет 2 ГБ плюс 16 МБ; на 64-разрядных системах максимальный объем места, доступного для создания дампа памяти ядра, равен объему памяти, установленной на компьютере, плюс 128 МБ).
Следующая таблица поможет определить требуемый размер файла подкачки.
Размер ОЗУ Файл подкачки не должен быть меньше
256 – 1 373 МБ 1,5-кратного размера ОЗУ
1 374 МБ и больше 32-разрядные компьютеры: 2 ГБ плюс 16 МБ
64-разрядные компьютеры: размер ОЗУ плюс 128 МБ

Чтобы включить сохранение данных в файле дампа памяти ядра, присвойте параметру реестра CrashDumpEnabled типа DWORD значение 2. Например, введите следующую команду и нажмите клавишу ВВОД.
wmic recoveros set DebugInfoType = 2
Чтобы указать, что дамп памяти ядра должен сохраняться в файле D:\Dump\Mem.dmp, присвойте расширяемому строковому параметру реестра DumpFile значение D:\Dump\Mem.dmp. Например, введите следующую команду и нажмите клавишу ВВОД.
wmic recoveros set DebugFilePath = D:\Dump\Mem.dmp
Чтобы отключить перезапись созданных ранее файлов дампа памяти или полных дампов памяти, присвойте параметру реестра Overwrite типа DWORD значение 0. Например, введите следующую команду и нажмите клавишу ВВОД.
wmic recoveros set OverwriteExistingDebugFile = 0
• Если выбран Полный дамп памяти, то при возникновении неустранимой ошибки все содержимое системной памяти будет записано в файл дампа.
Этот параметр недоступен на компьютерах с объемом ОЗУ более 2 ГБ.
Для сохранения полного дампа памяти необходимо иметь на загрузочном томе файл подкачки, размер которого не меньше полного объема физической памяти плюс 1 МБ.
В этом случае имя файла дампа указывается в поле Файл дампа памяти (по умолчанию — %SystemRoot%\Memory.dmp).
Для создания файла полного дампа памяти необходим дополнительный мегабайт на диске, поскольку при создании такого дампа Windows не только сохраняет содержимое памяти, но и формирует заголовок, содержащий подпись аварийного дампа памяти и значения некоторых переменных ядра.
Чтобы включить сохранение данных в файле полного дампа памяти, присвойте параметру реестра CrashDumpEnabled типа DWORD значение 1. Например, введите следующую команду и нажмите клавишу ВВОД.
wmic recoveros set DebugInfoType = 1
Чтобы указать, что дамп памяти ядра должен сохраняться в файле D:\Dump\Mem.dmp, присвойте расширяемому строковому параметру реестра DumpFile значение D:\Dump\Mem.dmp. Например, введите следующую команду и нажмите клавишу ВВОД.
wmic recoveros set DebugFilePath = D:\Dump\Mem.dmp
Чтобы отключить перезапись созданных ранее файлов дампа памяти или полных дампов памяти, присвойте параметру реестра Overwrite типа DWORD значение 0. Например, введите следующую команду и нажмите клавишу ВВОД.
wmic recoveros set OverwriteExistingDebugFile = 0.

Дополнительные сведения
В приведенных выше примерах для изменения параметров системного реестра, отвечающих за работу механизма восстановления, использовалась программа Wmic.exe, поставляемая в составе Windows XP и Windows Server 2003.
Программа Wmic.exe не входит в состав Windows 2000, но ее можно использовать на компьютерах под управлением Windows XP и Windows Server 2003 для изменения некоторых параметров, отвечающих за работу механизма восстановления удаленных компьютеров под управлением Windows 2000.
На компьютерах под управлением Windows 2000 параметр DebugInfoType не поддерживается.
Дополнительные сведения о программе Wmic.exe см. в следующей статье базы знаний Майкрософт:
Описание средства Wmic.exe (Windows Management Instrumentation Command-Line Utility)
Чтобы просмотреть параметры механизма восстановления на локальном компьютере, введите в командной строке wmic recoveros и нажмите клавишу ВВОД. Чтобы просмотреть параметры механизма восстановления на удаленном компьютере, находящемся в текущей локальной сети, введите в командной строке wmic /node:"имя_компьютера" recoveros и нажмите клавишу ВВОД. Для успешного выполнения команд Wmic необходимо войти в систему с учетной записью, имеющей права администратора. Если вход в систему был выполнен с учетной записью пользователя, не имеющего прав администратора, используйте при запуске программы Wmic параметры /user:имя_пользователя и /password:пароль.

Информация
• Для записи отладочной информации необходимо, чтобы файл подкачки располагался на загрузочном томе. Если файл подкачки размещен на другом томе, перед включением записи отладочной информации необходимо переместить его на загрузочный том либо создать дополнительный файл подкачки на загрузочном томе.
• Если выбраны значения Дамп памяти ядра или Полный дамп памяти и установлен флажок Заменять существующий файл дампа, Windows всегда будет записывать данные в один и тот же файл. Чтобы дампы памяти сохранялись в разных файлах, снимите флажок Заменять существующий файл дампа и изменяйте имя файла после каждой неустранимой ошибки.
• Чтобы дополнительно освободить некоторый объем памяти, можно снять флажки Записать событие в системный журнал и Отправить административное оповещение. Объем сэкономленной при этом памяти зависит от типа компьютера. Как правило, он составляет 60–70 КБ.


Как произвести печать на сетевой принтер из программы MS-DOS

FAQ по Microsoft Windows XP | Разное

Q: Как произвести печать на сетевой принтер из программы MS-DOS

По умолчанию из большинства программ MS-DOS печать выполняется непосредственно через порт LPT1 или LPT2. Однако для автоматического вывода на общий принтер через перенаправитель необходимо использовать один из следующих способов.

Способ 1
Воспользуйтесь командой net.exe для установления постоянного соединения. Для этого используйте в командной строке следующий синтаксис

net use lptx \\сервер_печати\общий_принтер /persistent:yes
где x — номер сопоставляемого порта принтера,сервер_печати — сервер, обслуживающий общий принтер, и общий_принтер — имя общего принтера.
Например, для сопоставления порта LPT2 общему принтеру под названием Laser1 на сервере печати Pserver выполните следующие действия.
1. Нажмите кнопку Пуск и выберите команду Выполнить.
2. В поле Открыть введите команду cmd и нажмите кнопку ОК.
3. Введите команду
net use lpt2 \\pserver\laser1 /persistent:yes
и нажмите клавишу ВВОД.
4. В командной строке введите exit и нажмите клавишу «ENTER».
Примечание. В Windows XP пользователи, не обладающие правами администратора, не имеют возможности сопоставить порт LPT пути к сетевому принтеру, если у компьютера имеется реальный параллельный порт.

Способ 2 Можно печатать непосредственно на общем принтере с помощью следующей команды:
print /d:\\сервер_печати\общий_принтеримя_диска:\путь\имя_файла
где сервер_печати — сервер, обслуживающий общий принтер,общий_принтер — имя общего принтера, а имя_диска:, путь и имя_файла составляют полный путь к документу, который нужно напечатать.
Например, для печати документа с названием letter.doc из корневого каталога на диске C на общем принтере Laser1 на сервере печати Pserver, выполните следующие действия.
1. Нажмите кнопку Пуск и выберите команду Выполнить.
2. В поле Открыть введите команду cmd и нажмите кнопку ОК.
3. Введите команду
print /d:\\pserver\laser1 c:\letter.doc
и нажмите клавишу ВВОД.
Появится следующее сообщение:
Выполняется печать C:\letter.doc
4. В командной строке введите exit и нажмите клавишу ВВОД.
Поскольку команда Novell NetWare CAPTURE не поддерживается в Windows XP, используйте для сопоставления порта LPT очереди печати Novell NetWare следующую команду:
net use lpt1:x \\server\queue
Если порт LPT сопоставлен успешно, появится сообщение "Команда выполнена успешно"
Чтобы отключить постоянные соединения LPTx, введите команду:
net use lpt1:x /delete


Как скопировать данные из поврежденного профиля пользователя в новый

FAQ по Microsoft Windows XP | Разное

Q: Как скопировать данные из поврежденного профиля пользователя в новый

Копирование файлов в новый профиль пользователя
1. Войдите в систему с помощью учетной записи пользователя, отличного от пользователя, в профиль (из профиля) которого будут копироваться файлы.
2. В окне проводника Windows, откройте меню Сервис, выберите команду Свойства папки, перейдите на вкладку Вид, выберите вариант Показывать скрытые файлы и папки, снимите флажок Скрывать защищенные системные файлы и нажмите кнопку OК.
3. Найдите папку C:\Documents and Settings\старый_профиль, где C — диск, на котором установлена Windows XP, а старый_профиль — имя профиля, из которого необходимо скопировать данные пользователя.
4. Удерживая нажатой клавишу CTRL, выделите в этой папке все файлы и вложенные папки, кроме следующих:
• Ntuser.dat
• Ntuser.dat.log
• Ntuser.ini
5. В меню Правка выберите команду Копировать.
6. Найдите папку C:\Documents and Settings\новое_имя_пользователя, где C — диск, на котором установлена Windows XP, а новое_имя_пользователя — имя профиля нового пользователя
7. В меню Правка выберите команду Вставить.
8. Выйдите из системы и войдите в нее с помощью новой учетной записи.

После копирования данных пользователя в новый профиль, он практически становится дубликатом прежнего профиля, и содержит те же настройки, параметры отображения и документы. Если профиль пользователя по какой-либо причине поврежден, хранящиеся в нем файлы и настройки можно переместить в новый профиль.
Примечание. Перед удалением старого профиля необходимо импортировать в новый профиль почтовые сообщения и электронные адреса.
Для этого проделайте следующее:

1. Перейдите в папку C:\Documents and Settings\имя_пользователя\Local Settings\Application Data\Identities\{9EFEBDEA-CE00-4DD7-A4D6-CDB85C3EEDBF}(каждая папка удостоверения будет иметь уникальный алфавитно-цифровой номер)\Microsoft\Outlook Express».
2. Скопируйте почтовые папки в любую заранее созданную папку (например XPMail)
3. Импортируйте почту и папки
a. Откройте Outlook Express.
b. В меню Файл выберите команду Импорт.
c. Выберите команду Сообщения.
d. Щелкните параметр Microsoft Outlook Express 5 и нажмите кнопку Далее.
Примечание. В некоторых случаях предлагается только импорт Outlook Express 4 и Outlook Express 6. Если предыдущей версией Outlook Express была версия 4, используйте пункт меню Outlook Express 4. Если импорт осуществляется из Outlook Express 5 или 5.5, можно использовать пункт меню Outlook Express 6.
e. Выберите пункт Импортировать почту из банка сообщений программы Outlook Express версии 6 и нажмите кнопку OK.
f. Нажмите кнопку Обзор, выберите папку XPMail, созданную ранее, нажмите кнопку OK, а затем — кнопку Далее.
g. Выберите команду Все папки и нажмите кнопку Далее.
В результате этой процедуры в текущее удостоверение будет импортирована предыдущая почта. Для завершения нажмите кнопку Готово.

Адресная книга Windows
Найдите адресную книгу Windows
1. В поиске файлов укажите *.wab и нажмите кнопку Найти.
2. После окончания поиска дважды щелкните каждый файл, чтобы открыть его. Когда найден необходимый файл (он будет содержать контактные сведения), зафиксируйте его точное расположение и имя.

Импортируйте адресную книгу Windows
1. В Outlook Express выберите меню Файл.
2. Выберите команду Импорт, а затем команду Адресная книга.
3. В поле Поиск в укажите расположение, зафиксированное в пункте 2 раздела «Найдите адресную книгу Windows».
4. Щелкните файл WAB и нажмите кнопку Открыть.
5. Нажмите кнопку OK, чтобы импортировать адресную книгу.
Убедитесь, что импорт был выполнен успешно, после чего удалите все папки, созданные в процессе восстановления почты.


Какие существуют способы восстановления поврежденных системных файлов и системы в целом

FAQ по Microsoft Windows XP | Разное

Q: Какие существуют способы восстановления поврежденных системных файлов и системы в целом

Есть несколько способов восстановления системы:
1. Проверка целостности системных файлов. Осуществляется запуском из командной строки команды sfc /scannow
Подробнее можно прочитать в статье MSKB: Описание средства проверки системных файлов Windows XP и Windows
Примечание: если установлен Service Pack 1 или 2, то понадобится установочный диск Windows XP с интегрированным Service Pack 1 или 2 соответственно.
Тема по sfc на форуме

2. Восстановление при помощи механизма "Восстановление Системы" (System Restore).
Пуск -> Выполнить -> rstrui.exe
Подробнее можно прочитать в статье MSKB: Как вернуться к более раннему состоянию операционной системы в Windows XP

3. В случае проблем с загрузкой системы, нужно попробовать вернуться к последней удачной конфигурации.
Во время загрузки системы нужно нажать F8, выбрать систему для восстановления и затем выбрать пункт "Последняя удачная конфигурация".
Подробнее можно прочитать в статье MSKB: Как загрузить компьютер с Microsoft Windows XP, используя последнюю удачную конфигурацию

4. Если ни один из первых трех способов не помог, то попробуйте использовать Консоль Восстановления (Recovery Console).
Если она у вас установлена локально, то вы просто можете использовать соответствующую опцию при загрузке ОС. В противном случае, вам нужно будет загрузиться с установочного CD Windows XP.
Подробнее о том что такое Консоль Восстановления и как ей пользоваться вы можете узнать из статей MSKB:
"Описание консоли восстановления Windows XP"
"Как установить и использовать консоль восстановления в Windows XP"

5. Последним средством будет установка системы в режиме восстановления (поверх уже существующей).
Подробнее можно прочитать в статье MSKB: Как выполнить обновление (переустановку) Microsoft Windows XP

6. Если ни один из перечисленных способов не принес желаемого результата можете написать в тему на форуме по восстановлению системы


Какую версию Windows лучше установить на домашний компьютер Windows XP Professional или Home Edition

FAQ по Microsoft Windows XP | Разное

Q: Какую версию Windows лучше установить на домашний компьютер Windows XP Professional или Home Edition

Все зависит от того, что потребуется в будущем от вашей системы. Обе эти системы имеют очень много общего, и XP Pro и XP Home построены на одном и том же ядре. Разница между ними заключается только в том, что XP Home не поддерживает некоторые функции, работающие в XP Pro.

1. Remote Desktop - позволяет удалённую работу на компьютере.
2. Offline Files and Folders - позволяет иметь доступ к сетевым файлам когда отключены от сервера.
3. Scalable processor support - поддержка многопроцессорных систем.
4. Encrypting File System - шифрование файлов средствами файловой системы.
5. Access Control - ограничение доступа к файлам, программам и другим ресурсам.
6. Centralized administration - централизованное администрирование системы в рамках домена.
7. Group Policy - Групповые политики - администрирование групп пользователей на компьютере.
8. Software Installation and Maintenance - автоматически инсталлирует, конфигурирует, исправляет и удаляет программное обеспечение.
9. Roaming User Profiles - доступ к вашим документам и настройкам из любого места, где Вы подсоединились в домен.
10. Remote Installation Service (RIS) - поддержка удалённой инсталляции операционной системы по сети.
11. Multi-lingual User Interface (MUI) add-on - поддержка изменения языков интерфейса различных пользователей.

Кроме этого, есть незначительная разница в интерфейсах, например в XP Home нельзя выключить Simple File Sharing.


После восстановления из архива Windows XP требует выполнить повторную активацию

FAQ по Microsoft Windows XP | Разное

Q: После восстановления из архива Windows XP требует выполнить повторную активацию

Данная проблема может возникнуть в том случае, если с момента создания архива исходной установки произошли значительные изменения в оборудовании. В силу этих изменений требуется повторная активации продукта, поскольку теперь получается, что предыдущая установка выполнялась на другом (дополнительном) компьютере. Windows XP предлагает выполнить повторную активацию при наличии одного из следующих условий:
• Восстановление выполняется из архивного файла, хранящегося на компьютере с неактивированной системой.
• Было изменено или добавлено оборудование, что привело к отмене активации Windows XP.
• Восстановление осуществлялось из последнего архива, созданного до того, как были внесены изменения в оборудование, и перед выполнением активации.

Решение
Для устранения этой проблемы воспользуйтесь одним из следующих способов.
• Создайте еще один резервный файл после внесения изменений в оборудование или выполнения установки. Кроме того, необходимо создать резервный файл после повторной активации системы.
Примечание. Добавочной архивации будет достаточно для того, чтобы заархивировать файлы базы данных механизма архивации продуктов Windows (Wpa.dbl и Wpa.bak), поэтому полную архивацию можно не выполнять, а выполнить только добавочную.
• После восстановления архивного файла, созданного до внесения изменений в оборудование, будет предложено выполнить повторную активацию.


Появление сообщения об ошибке «Файл подкачки отсутствует или слишком мал»

FAQ по Microsoft Windows XP | Разное

Q: Появление сообщения об ошибке «Файл подкачки отсутствует или слишком мал»

При загрузке Windows личных параметров компьютер перестает отвечать на запросы (зависает) или после входа в Windows появляется следующее сообщение об ошибке.

Недостаточно виртуальной памяти
Файл подкачки отсутствует или слишком мал.
Для устранения этой проблемы дважды щелкните значок Система на панели управления, перейдите на вкладку Дополнительно и нажмите кнопку Параметры в разделе Быстродействие. На вкладке Дополнительно нажмите кнопку Изменить. Выберите 'Особый размер' и введите исходный или максимальный размер файла подкачки.

При попытке просмотреть параметры файла подкачки, следуя инструкциям, изложенным в данном сообщении, может появиться следующее сообщение об ошибке:
Создан временный файл подкачки, поскольку при запуске была обнаружена неполадка в конфигурации файла подкачки.
Общий объем файла подкачки для всех дисков может быть несколько больше указанного вами размера.

Причина
Данное сообщение об ошибке может возникать, если Windows пытается создать файл подкачки на томе NTFS, а учетные записи System и «Администраторы» не имеют соответствующих прав NTFS для доступа к этому тому.

Решение
Чтобы устранить проблему, предоставьте учетным записям System и «Администраторы» право полного доступа к тому NTFS, на котором должен находиться файл подкачки. Для этого выполните следующие действия.

1. Если компьютер работает под управлением Windows XP Home Edition или Windows XP Professional, но не является членом домена, загрузите компьютер в безопасном режиме.
Примечание. Если компьютер перестает отвечать в процессе загрузки операционной системой личных параметров, нажмите клавиши ALT+TAB, чтобы открыть окно "Недостаточно виртуальной памяти" и нажмите кнопку ОК.

2. Откройте в Проводнике диск, который должен содержать файл подкачки.
Чтобы определить, какой диск должен содержать файл подкачки, выполните следующие действия.
a. В меню Пуск выберите пункт Выполнить, введите команду control sysdm.cpl и нажмите кнопку ОК.
b. На вкладке Дополнительно в группе Быстродействие нажмите кнопку Параметры.
c. Откройте вкладку Дополнительно и нажмите кнопку Изменить в разделе Виртуальная память.
d. Если выделить в списке какой-либо диск, то в области Размер файла подкачки для выбранного диска будут отражены параметры файла подкачки для этого диска. Если для какого-либо диска отображается сообщение Без файла подкачки, значит, на выбранном диске файл подкачки отсутствует.
Если файл подкачки присутствует на нескольких дисках, то, выполняя данные шаги в первый раз, выберите первый диск в списке, выполняя второй раз — второй диск в списке и т. д.
e. Нажмите кнопку Отмена, а затем — снова Отмена, чтобы вернуться в окно Свойства системы.
f. На вкладке Имя компьютера найдите подстроку, находящуюся в поле Полное имя компьютера до первого символа точки. Данная подстрока представляет собой имя компьютера. Это имя понадобится при выполнении последующих шагов.

3. В меню Файл выберите команду Свойства. Выберите вкладку Безопасность для просмотра текущих разрешений.

4. Нажмите кнопку Добавить, введите имя_компьютера\system и нажмите кнопку ОК.

5. Нажмите кнопку Добавить, введите имя_компьютера\Администраторы, нажмите кнопку ОК, а затем — снова ОК.
Обратите внимание, что необходимо ввести Администраторы, а не Администратор.

6. Выберите пункт System и установите флажок Полный доступ. Это действие автоматически установит остальные флажки.

7. Выберите пункт Администраторы и установите флажок Полный доступ. Это действие автоматически установит остальные флажки.

8. Чтобы изменить параметры файла подкачки, выполните следующие действия. В меню Пуск выберите пункт Выполнить, введите команду control sysdm.cpl и нажмите кнопку ОК.

9. На вкладке Дополнительно в группе Быстродействие нажмите кнопку Параметры.

10. Откройте вкладку Дополнительно, нажмите кнопку Изменить, находящуюся в разделе Виртуальная память, и укажите требуемые значения.

11. Закройте окно Свойства системы, завершите работу всех запущенных приложений и перезагрузите компьютер.

Дополнительная информация
Файл подкачки (Pagefile.sys) — это скрытый файл операционной системы. Изменяя разрешения NTFS на доступ к тому, можно случайно отменить права доступа, предоставленные учетной записи System. В этом случае операционная система не сможет управлять некоторыми ресурсами (например файлом подкачки).
По умолчанию группа «Все» имеет разрешения полного доступа на том NTFS. В некоторых случаях для усиления безопасности разрешения для группы «Все» удаляются, а добавляются разрешения для отдельных учетных записей (например для учетной записи «Администратор»). Однако группа «Все» содержит учетную запись System. Удаление разрешений для группы «Все» без добавления разрешений для учетной записи System делает невозможным использование файла подкачки.


При запуске большинства игр в ХР частота монитора устанавливается 60 гц

FAQ по Microsoft Windows XP | Разное

Q: При запуске большинства игр в ХР частота монитора устанавливается 60 Гц

Должна помочь утилита RivaTuner. В ней есть функция жесткого выставления развертки в разных разрешениях монитора (разумеется только для Direct3D и OpenGL)


При запуске мастера активации Windows (WPA) страница «Активация Windows» отображается пустой

FAQ по Microsoft Windows XP | Разное

Q: При запуске мастера активации Windows (WPA) страница «Активация Windows» отображается пустой

Возможные причины:
• Поврежден или изменен реестр.
• Во время установки Windows XP были повреждены файлы, или ряд файлов отсутствует.
• Имеются проблемы с разрешением видеоизображения.
Решение
Примечание: Если 30-дневный период активации истек, эти действия можно выполнить, загрузив компьютер в безопасном режиме.
1. Перезапустите компьютер, нажмите при загрузке клавишу F8 и выберите параметр Активировать режим VGA в меню Дополнительные варианты загрузки Windows. Запустите мастер WPA и повторите попытку активации Windows XP. Если попытка активировать Windows XP завершится успешно, пропустите приведенные ниже действия. Если Windows XP не запускается, переходите к выполнению следующего действия.
2. Щелкните правой кнопкой мыши значок Мой компьютер, выберите пункт Свойства, перейдите на вкладку Оборудование и нажмите кнопку Диспетчер устройств. Щелкните правой клавишей видеоадаптер и выберите Отключить, чтобы компьютер запустился с использованием видеодрайвера Standard VGA. Перезапустите компьютер, запустите мастер WPA и повторите попытку активировать Windows XP. Если попытка активировать Windows XP завершится успешно, пропустите приведенные ниже действия. Если Windows XP не запускается, переходите к выполнению следующего действия.
3. Найдите следующий раздел реестра и связанные с ним параметры:
HKEY_CLASSES_ROOT\.htm
"PerceivedType"="text"
(Default) = "MozillaHTML"
"Content Type"="image/x-xbitmap"
Если такого раздела не существует, перейдите к следующему шагу. Если такого раздела не существует, отредактируйте параметры следующим образом:
"PerceivedType"="text"
(Default) = "htmlfile"
"Content Type"="text/html"
Перезапустите компьютер, запустите мастер WPA и повторите попытку активировать Windows XP. Если попытка активировать Windows XP завершится успешно, пропустите приведенные ниже действия. Если Windows XP не запускается, переходите к выполнению следующего действия.

4. Переустановите файл Oobe.inf. Для этого выполните следующие действия.
a. Нажмите кнопку Пуск и выберите пункт Выполнить.
b. В диалоговом окне Открыть введите команду inf и нажмите кнопку ОК.
c. В папке Inf щелкните правой кнопкой мыши oobe.inf и выберите команду Install.
d. Вставьте установочный компакт-диск Windows XP или Windows Server 2003, когда потребуется.

5. Зарегистрируйте вручную файлы Jscript.dll и Vbscript.dll. Для этого выполните следующие действия.
a. Выберите в меню Пуск пункт Выполнить, введите в поле Открыть команду cmd и нажмите кнопку ОК.
b. Введите следующие команды, нажимая после каждой из них клавишу ВВОД.
regsvr32 jscript.dll
regsvr32 vbscript.dll


Процесс зависшего приложения был снят через диспетчер задач, после чего в панели задач и в трее увеличился размер ярлыков

FAQ по Microsoft Windows XP | Разное

Q: Процесс зависшего приложения был снят через диспетчер задач, после чего в панели задач и в трее увеличился размер ярлыков

Способ 1
Свойства экрана -> Оформление -> Дополнительно -> Значок -> выставить размер.

Способ 2
в реестре в ветке

HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics

Для изменения размеров значков на [Рабочем столе] создайте (или измените существующий) в этом ключе параметр с именем Shell Icon Size (строковый) и значением равным размеру значков в пикселях.


Специальные возможности: сброс всех настроек на стандартные

FAQ по Microsoft Windows XP | Разное

Q: Специальные возможности: сброс всех настроек на стандартные

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Control Panel]

[HKEY_CURRENT_USER\Control Panel\Accessibility]
"Blind Access"="0"

[HKEY_CURRENT_USER\Control Panel\Accessibility\Blind Access]
"On"="0"

[HKEY_CURRENT_USER\Control Panel\Accessibility\HighContrast]
"Flags"="122"
"High Contrast Scheme"="High Contrast Black (large)"

[HKEY_CURRENT_USER\Control Panel\Accessibility\Keyboard Preference]
"On"="0"

[HKEY_CURRENT_USER\Control Panel\Accessibility\Keyboard Response]
"AutoRepeatDelay"="500"
"AutoRepeatRate"="1000"
"BounceTime"="0"
"DelayBeforeAcceptance"="1000"
"Flags"="122"

[HKEY_CURRENT_USER\Control Panel\Accessibility\MouseKeys]
"Flags"="122"
"MaximumSpeed"="40"
"TimeToMaximumSpeed"="300"
"Control Speed"="80"

[HKEY_CURRENT_USER\Control Panel\Accessibility\SerialKeys]
"Port"="COM2"
"ActivePort"="COM2"
"Baud"=dword:0000012c
"Flags"=dword:00000002
"PortState"="1"

[HKEY_CURRENT_USER\Control Panel\Accessibility\ShowSounds]
"On"="0"

[HKEY_CURRENT_USER\Control Panel\Accessibility\SoundSentry]
"Flags"="2"
"FSTextEffect"="0"
"WindowsEffect"="1"
"WindowsEffectDLL"=""
"WindowsEffectMSec"="500"
"WindowsEffectOrdinal"="0"
"TextEffect"="2"
"TextEffectColorBits"="0"
"TextEffectMSec"="500"
"GrafEffect"="3"
"GrafEffectColor"="0"
"GrafEffectMSec"="500"

[HKEY_CURRENT_USER\Control Panel\Accessibility\StickyKeys]
"Flags"="506"

[HKEY_CURRENT_USER\Control Panel\Accessibility\TimeOut]
"Flags"="3"
"TimeToWait"="300000"

[HKEY_CURRENT_USER\Control Panel\Accessibility\ToggleKeys]
"Flags"="26"