Стандартные программы Windows

Хорошо ли вы знаете Windows? Я думаю, что да. Знаете ли вы его на 100%? Вряд ли. Потому что программисты из Microsoft очень постарались, пряча некоторые функции и возможности от пользователей. Речь здесь пойдет о программах: самых обычных стандартных программах операционной системы, которые при установке ставятся по умолчанию и присутствие которых никак не афишируется. Более того, разработчики, как нарочно, пытаются отпугнуть пользователей от работы с этими утилитами. Посудите сами: программы нигде не упоминаются (ну, может быть в справке), на них нет ярлыков в меню "Пуск", а при попытке зайти в каталог Windows, где они, собственно, и находятся, появляется страшная надпись о том, что сюда заходить не надо, дабы не испортить системных файлов. Это может отпугнуть новичков. А ведь там немало полезных программ.


alg.exe

Местонахождение

WINDOWS\system32

Описание

Служба шлюза уровня приложения (Application Layer Gateway Service)

Оказывает поддержку протоколов третьей стороны протоколов PnP для общего доступа к подключению к Интернету и подключений к Интернету с использованием брандмауэра. Эта служба нужна при использовании Брандмауэра Интернета/Общего доступа к Интернету для подключения к интернету.

Значение по умолчанию | Рекомендуемое значение
Вручную | Вручную

Зависимости от данной службы

Брандмауэр Интернета (ICF) /Общий доступ к Интернету (ICS) (Internet Connection Firewall/Internet Connection Sharing)


arp.exe

Местонахождение

Windows\system32

Описание

TCP/IP Arp Command

Команда Arp используется для просмотра, добавления или удаления записей в таблицах трансляции адресов IP в физические адреса. Эти записи используются при работе протокола Address Resolution Protocol (ARP)

Синтаксис

arp -a [inet_addr] [-N [if_addr]]
arp -d inet_addr [if_addr]
arp -s inet_addr ether_addr [if_addr]

Параметры

-a
Displays current ARP entries by querying TCP/IP. If inet_addr is specified, only the IP and physical addresses for the specified host are displayed.
-d
Deletes the entry specified by inet_addr.
-g
Same as -a
-s
Adds an entry in the ARP cache to associate the IP address inet_addr with the physical address ether_addr. The physical address is given as 6 hexadecimal bytes separated by hyphens. The IP address is specified using dotted decimal notation. The entry is static. It will not be automatically removed from the cache after the timeout expires and will not exist after a reboot of your computer.
-N [if_addr]
Displays the ARP entries for the network interface specified by if_addr.
ether_addr
Specifies a physical address.
if_addr
Specifies, if present, the IP address of the interface whose address translation table should be modified. If not present, the first applicable interface will be used.
inet_addr
Specifies an IP address in dotted decimal notation.


at.exe

Местонахождение

Windows\system32

Описание

Интерфейс командной строки службы расписаний - Schedule service command line interface

Команда At предназначена для запуска команд и программ в указанное время по определенным дням. Для использования команды AT необходимо, чтобы была запущена служба расписаний. Возможна работа с удаленными компьютерами. Для запуска задач пользователь должен обладать необходимыми правами.

Синтаксис

AT [\\имя_компьютера] [ [код] [/DELETE] | /DELETE [/YES]]
AT [\\имя_компьютера] время [/INTERACTIVE] [ /EVERY:день[,...] | /NEXT:день[,...]] "команда"

Параметры

\\имя_компьютера
Имя удаленного компьютера. Если этот параметр опущен, используется локальный компьютер.
код
Порядковый номер запланированной задачи.
/delete
Отмена запланированной задачи. Если код задачи опущен, отменяются все задачи, запланированные для указанного компьютера.
/yes
Отмена запроса на подтверждение при отмене всех запланированных задач.
время
Время запуска команды.
/interactive
Разрешение взаимодействия задачи с пользователем, работающим на компьютере во время запуска задачи.
/every:день[,...]
Запуск задачи осуществляется по указанным дням недели или месяца. Если дата опущена, используется текущий день месяца.
/next:день[,...]
Задача будет запущена в следующий указанный день недели (например в следующий четверг). Если дата опущена, используется текущий день месяца.
"команда"
Команда Windows NT или имя пакетного файла.


atmadm.exe

Местонахождение

Windows\system32

Описание

Диспетчер вызовов ATM - ATM Call Manager Utility

Контроль подключений и адресов, зарегистрированных диспетчером вызовов ATM в сетях с асинхронным режимом передачи (ATM). Вызванная без параметров команда atmadm отображает статистику для контроля состояния активных ATM-подключений.

Синтаксис

atmadm [/c][/a] [/s]

Описание параметров есть в справке Windows


attrib.exe

Местонахождение

Windows\system32

Описание

Attribute Utility

Утилита командной строки позволяет просматривать, устанавливать или снимать атрибуты файла или каталога, такие как «Только чтение», «Архивный», «Системный» и «Скрытый». Выполненная без параметров команда attrib выводит атрибуты всех файлов в текущем каталоге.

Синтаксис

attrib [{+r|-r}] [{+a|-a}] [{+s|-s}] [{+h|-h}] [[диск:][путь] имя_файла] [/s[/d]]

Описание параметров есть в справке Windows


bootcfg.exe

Местонахождение

Windows\system32

Описание

Средство конфигурации загрузки - Boot Config Tool

Программа bootcfg позволяет из командной строки управлять загрузочным меню, редактируя, добавляя или удаляя записи в файле boot.ini. Функции программы аналогичны ручному редактированию файла, однако, позволяют автоматизировать процесс настройки меню загрузки, использовать команды в .bat файлах.

Описание параметров есть в справке Windows


cacls.exe

Местонахождение

Windows\system32

Описание

Изменение таблиц управления доступом - Control ACLs Program

Программа служит для просмотра или изменения файлов избирательных таблиц управления доступом (DACL).

Описание программы есть в справке Windows


calc.exe

Местонахождение

Windows\system32

Описание

Калькулятор для Windows - Windows Calculator

Калькулятор предназначен для выполнения тех же операций, что и обычный калькулятор: сложение, вычитание, а также функции инженерного калькулятора, например нахождение логарифмов и факториалов

Если в окно Калькулятора вставить из буфера обмена строку чисел, разделенных знаками простейших арифметических действий (+, -, *, /), оканчивающуюся знаком равенства, то калькулятор автоматически вычислит последовательно все действия, и на его "индикаторе" появится результат, который при необходимости можно легко перенести в любое работающее приложение Windows посредством того же буфера обмена. Это очень удобно, когда нужно быстро выполнить вычисления, особенно если их текст уже набран, например, в документе текстового редактора, в который нужно вставить результат вычислений. Пробелов в выражении можно не делать, хотя они обычно не мешают. В конце обязательно поставьте знак равенства, иначе последнее действие окажется не выполненным и в этом случае придется нажать [Enter] либо щелкнуть на клавише со знаком равенства.
Результат вычислений, выполняемых по такой методике, зависит от того режима, в котором находится Калькулятор. В Обычном режиме строка символов воспринимается как простая последовательность нажатий соответствующих клавиш, не отдавая приоритета операциям умножения и деления.
В Инженерном виде вычисления производятся по всем правилам, можно даже использовать скобки и некоторые специальные последовательности символов-кодов, выполняющих служебные функции:

Последовательности клавиш для вызова функций

Приведенные ниже последовательности нажатий клавиш воспринимаются как функции при вводе данных в калькулятор. Например, откройте блокнот и введите следующий текст:

123 :m

Скопируйте в блокноте 123 :m и вставьте в окно калькулятора. Число 123 будет отображено и записано в память калькулятора.

Специальные коды

:q Начало нового вычисления.
:c Очистка памяти.
:e Ввод десятичных чисел в экспоненциальной нотации.
:m Запоминание числа в памяти.
:p Добавление текущего числа к хранящемуся в памяти.
:r Вызов числа, хранящегося в памяти.


charmap.exe

Местонахождение

Windows\system32

Описание

Таблица символов - Character Map

Таблица символов служит для просмотра символов, включенных в выбранный шрифт. Она отображает следующие наборы символов: Windows, DOS и Юникод.

Отдельный символ или группу символов можно скопировать в буфер обмена, а затем вставить в любое приложение, в котором они будут отображаться. Многие программы, например WordPad, позволяют копировать символы путем их перетаскивания из таблицы символов непосредственно в открытый документ. Более подробное описание программы есть в справке


chcp.exe

Местонахождение

Windows\system32

Описание

Change CodePage Utility

Программа командной строки служит для просмотра номера текущей кодовой страницы или изменение текущей кодовой страницы консоли. Выполненная без параметров команда chcp выводит номер текущей кодовой страницы для окна командной строки.

Синтаксис

chcp [код]

Для русской кодовой страницы используется код 866

Описание программы есть в справке Windows


chkdsk.exe

Местонахождение

WINDOWS\system32

Описание

Check Disk Utility

Вывод на экран отчета о состоянии диска в форме, зависящей от используемой файловой системы. Команда chkdsk также составляет список ошибок на диске и исправляет их. Выполненная без параметров команда chkdsk выводит информацию о состоянии текущего диска. Описание программы есть в справке Windows


chkntfs.exe

Местонахождение

WINDOWS\system32

Описание

NTFS Volume Maitenance Utility

Просмотр или задание планирования автоматической проверки системы для томов файловых систем FAT, FAT32 или NTFS при запуске компьютера. Описание программы есть в справке Windows


cipher.exe

Местонахождение

WINDOWS\system32

Описание

Программа шифрования файлов - File Encryption Utility

Отображение или изменение шифрование папок и файлов на томах NTFS. Использованная без параметров команда cipher отображает состояние шифрования текущей папки и всех файлов, находящихся в ней. Описание программы есть в справке Windows


cleanmgr.exe

Местонахождение

WINDOWS\system32

Описание

Программа очистки дискового пространства для Windows - Disk Space Cleanup Manager for Windows

Программа очистки диска используется для освобождения пространства на жестком диске с помощью удаления временных файлов Интернета, установленных компонентов и программ, которые больше не используются, и очистки корзины. Программу можно запустить через Пуск-Все программы-Стандартные-Служебные-Очистка диска или через Пуск-Выполнить-cleanmgr


clipbrd.exe

Местонахождение

Windows\system32

Описание

Windows NT ClipBook Viewer

Программа папки обмена позволяет вырезать или копировать данные из других программ и хранить их на странице, которую можно сохранить под любым именем, использовать повторно и совместно с другими пользователями. Более подробное описание программы есть в справке


Cmd.EXE

Местонахождение

Windows\system32

Описание

Windows Command Processor

В Windows XP имеется так называемая консоль - программа Cmd.exe, которая является командным интерпретатором. При простом запуске, без указания параметров командной строки, консоль отображает версию операционной системы, информацию о защите авторских прав разработчиков ОС и саму командную строку, в которой можно ввести как параметр командной строки самой программы Cmd.exe, так и любую внешнюю команду, например, команду на запуск другого приложения или стандартную команду, типа mkdir, del и т. п.

Параметры командной строки

Синтаксис для командной строки:

CMD [/A | /U] [/Q] [/D] [/E:ON | /E:OFF] [/F:ON | /F:OFF] [/V:ON | /V:OFF]
[[/S] [/C | /K] команда]

Можно использовать одновременно несколько команд, используя между ними специальный разделитель - символы &&, при этом все сочетание нескольких команд должно быть заключено в кавычки, например, "команда&&команда&& команда".

/? - вызов справки
/A - вывод результатов выполнения заданной команды в формате ANSI
/C - выполнение заданной команды с последующим закрытием окна консоли
/D - отключение выполнения команд AutoRun (которые первыми автоматически выполняются при вызове cmd.exe), заданных в специальных разделах реестра HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\AutoRun и HKEY_CURRENT_USER\Software\Microsoft\Command Processor\AutoRun
/E:ON (/E:OFF) - разрешение (запрет) расширений команд. В Windows XP по умолчанию включена расширенная обработка всех команд cmd.exe, этот параметр служит для включения / выключения расширений конкретного процесса. Расширенная обработка включает следующие команды: assoc, call, chdir (cd), color, del (erase), endlocal, for, ftype, goto, if, mkdir (md), popd, prompt, pushd, set, setlocal, shift, start (изменен также вызов внешних команд)
/F:ON (/F:OFF) - разрешение (запрет) завершения имен файлов и папок (по умолчанию выключено) конкретного вызова cmd.exe. Довольно удобная функция, позволяющая не вводить полностью вручную в окне консоли пути к файлам или имена самих папок, а ввести только часть длинного пути и с помощью нажатия специальной комбинации клавиш дать операционной системе найти подходящие варианты и просто выбрать нужный. (Если необходимо включить или отключить завершение имен для всех вызовов cmd.exe, то смотри Автонабор команд). Параметры пользователя имеют приоритет над параметрами компьютера, значение параметра /F командного процессора имеет приоритет над параметрами реестра. Microsoft вносит некоторые разъяснения по поводу использования этой функции: "Если завершение включено с помощью ключа командной строки / F:ON, то используются два управляющих символа: Ctrl+D для имен папок и Ctrl+F для имен файлов. Чтобы отключить конкретный символ завершения в системном реестре, в качестве кода специального символа используется шестнадцатеричное значение символа пробела (0 x 20). Завершение вызывается при вводе одного из этих двух специальных символов. Функция завершения берет строку пути слева от точки ввода, дописывает к ней символ шаблона, если таковой отсутствует, а затем строит список путей, которые соответствуют полученному определению. После этого выводится первый элемент этого списка соответствующих путей. Если же список пуст, то подается звуковой сигнал, и ничего не выводится. После этого повторный ввод того же самого специального символа приводит к циклическому перебору всех соответствующих путей. Нажатие клавиши Shift при вводе управляющего символа позволяет просматривать список путей в обратном порядке. Если изменить выведенный путь, а затем снова ввести управляющий символ, сохраненный список очищается, и строится новый список путей. То же самое происходит, если переключиться с одного символа завершения на другой. Единственное отли чие при использовании символа завершения файла состоит в том, что при этом для построения списка соответствия берется и путь, и имя файла, а при использовании символа завершения папки - только путь. Если символ завершения используется в одной из встроенных команд манипулирования папками (CD, MD или RD), то всегда подразумевается символ завершения папок. Символ завершения правильно работает и с именами файлов, содержащими пробелы или иные специальные символы, если при этом строка соответствия заключена в кавычки. Кроме того, если сместить точку ввода влево, а затем использовать символ завершения внутри строки, оставшийся справа от точки ввода текст будет отброшен. Специальные символы, которые требуют обязательного заключения в кавычки: <пробел>&()[]{}^=;!'+,~". Все понятно?
/K - выполнение заданной команды без последующего завершения (окно консоли не закроется)
/Q - отключение вывода команд на экран (ECHO OFF). /R - аналогичен параметру /C
/S - изменение поведения команды после /C или /K
/T:цвет - задание цвета текста и фона окна консоли. Параметр цвет имеет значение в виде двух шестнадцатеричных чисел: первое определяет цвет фона окна, а второе - текста в окне. То есть результатом выполнения команды "CMD /T:7С" будут светло-красные буквы на белом фоне.
/U - вывод результатов выполнения команды в формате Unicode
/V:ON (/V:OFF) - разрешение (запрет) отложенного расширения переменных среды (для конкретного вызова cmd.exe) с применением восклицательного знака "!" в качестве разделителя. Например, /V:ON разрешает использовать !var! в качестве расширения переменной var во время выполнения. Синтаксис var служит для расширения переменных при вводе, что приводит совсем к другим результатам внутри цикла FOR. При включенном отложенном расширении переменных среды символ "!" (восклицательный знак) может использоваться для замены текущего значения переменной среды во время выполнения; /X - означает то же, что и ключ /E:ON, из соображений совместимости; /Y то же, что и /E:OFF. И еще несколько замечаний. Если указаны ключи /C или /K, то остальная часть командной строки после такого ключа обрабатывается как командная строка, а обработка символов кавычек (") ведется таким образом. Символы кавычек в командной строке сохраняются, если выполняются все перечисленные ниже условия: ключ /S отсутствует; есть ровно два символа кавычек; между ними нет других специальных символов, как то: &<>()@^|; между ними имеются один или несколько пробелов; строка, заключенная в кавычки, является именем исполняемого файла. В противном случае проверяется первый символ, и если он является символом кавычек, то он удаляется, также удаляется последний символ кавычек в командной строке, а весь текст после этого последнего символа кавычек сохраняется.

Таблица для задания цвета текста и фона окна консоли
0 - черный | 1 - синий | 2 - зеленый | 3 - голубой
4 - красный | 5 - лиловый | 6 - желтый | 7 - белый
8 - серый | 9 - светло-синий | A - светло-зеленый | B - светло-голубой
C - светло-красный | D - светло-лиловый | E - светло-желтый | F - ярко-белый
Кстати, цвет и другие настройки можно изменять и другим способом. Щелкните правой кнопкой мыши по строке заголовка окна и выберите пункт Свойства. Откроется окно с четырьмя вкладками, на которых будут доступны опции изменения настроек программы. Если вам не нравится стандартный черный экран командной строки, то на вкладке Color вам предлагается выбрать цвет экрана и текста либо из 16 стандартных цветов, для которых имеется соответствующие образцы, либо задав числовое значение цвета в формате RGB. На вкладке Layout настраивается размер окна и экранного буфера. Если в ранних ОС MS-DOS и Windows размер экрана оставался неизменным 25 строк в высоту и 80 символов в длину, и для вывода большего количества строк приходилось добавлять команду |more, то в системах NT и более поздних можно просто задать достаточно большой размер буфера экрана и пользоваться полосой прокрутки, что гораздо удобнее. Текст в окне командной строки Для копирования и вставки текста в окно командной строки обычные для Windows комбинации клавиш, такие как Ctrl+C, Ctrl+V, работать не будут. Для извлечения текста из буфера обмена вам придется вызвать меню, щелкнув правой кнопкой мыши по заголовку окна, и выбрать подменю Edit. Или же просто щелкните правой кнопкой по окну. Для копирования текста из окна выберите пункт Mark и мышью выделите нужный текст. Затем либо нажмите Enter, либо в том же меню выберите Copy. Если надо вставить какой-то текст в окно командной строки, обратитесь к команде Paste. Для повторного выполнения команды воспользуйтесь стрелками <<вверх>> и <<вниз >>, позволяющими перемещаться по списку выполненных команд. Для очистки экрана от текста служит директива cls.

Команды

TITLE - для изменения заголовка строки
TITLE [строка], где строка - это будущий заголовок окна командной строки (записывается без кавычек). После задания заголовка окна он может быть изменен только повторным вызовом команды TITLE. Использование данной команды может быть полезно в командных файлах. Так, выполнение примера, который приведен ниже, будет сопровождаться появлением соответствующей надписи в заголовке окна:

@ECHO OFF
TITLE Копируются файлы...
COPY \\Server\Share\*.doc C:\User\Common\*.doc
ECHO Копирование закончено.
TITLE Процесс завершен

Команда АТ - С помощью этой команды можно запускать команды и программы в определенное время.
AT [\\имя компьютера] [ [id] [/DELETE] | /DELETE [/YES]]
AT [\\имя компьютера] time [/INTERACTIVE] [ /EVERY:дата[,...] | /NEXT:дата [,...]] "команда"
\\имя компьютера указывает на удаленный компьютер, на котором могут быть запущены планируемые задачи. Если этот параметр не указан, то по умолчанию предполагается тот компьютер, на котором запускается команда АТ;
id идентификатор, назначенный указанной команде;
/delete отменяет намеченную команду. Если id опущен, все назначенные команды на компьютере отменены;
/yes этот параметр в случае использования с предыдущим параметром (/delete) автоматически включает подтверждение для всех запросов;
time время выполнения команды (в 24-часовом формате часы:минуты);
/interactive позволяет команде AT обмениваться с подключенными на данный момент в системе пользователями;
/every:дата[,...] выполняет команду в каждый указанный день (дни) недели или месяц. Если дата опущена, подразумевается текущий день месяца;
/next:дата[...] выполняет указанную команду при следующем наступлении указанной даты (например, в следующий четверг). Если дата не указанна, по умолчанию принимается текущий день месяца;
"команда" указывается команда Windows NT или пакетная программа, которая будет выполнена. Имя файла должно указываться полностью. При этом, если выполняется какая-либо из внутренних команд, например, COPY или DIR, а не исполняемый файл, то необходим запуск командного интерпретатора с ключом / С, например: AT 10:00 "CMD /C DIR > C:\test.out.
Команда For - Ее возможности обширны, но мы ограничимся демонстрацией лишь одной из них - Копирование по сети на все машины сразу. Допустим, что требуется скопировать файл на двадцать машин. Делается это очень быстро. Сначала в файл list.txt записываем список всех имеющихся в сети машин. В консоли пишем:

net view > c:\list.txt
Затем, чтобы выполнить, например, копирование файла patch.exe на каждую машину из списка, даем команду:
FOR /F "tokens=1" %i in (с:\list.txt) do copy d:\temp\patch.exe "%i\C$\program files\ICQ"
Переменная %i будет автоматически принимать значение NetBIOS-имени машины из новой строки файла list.txt и на эту машину будет производиться копирование.

Реестр

Изменение вида приглашения командной строки


cmstp.exe

Местонахождение

WINDOWS\system32

Описание

Microsoft Connection Manager Profile Installer

Установка или удаление профиля службы диспетчера подключений. Выполненная без параметров команда cmstp устанавливает профиль службы со стандартными параметрами, соответствующими данной операционной системе и разрешениям пользователя. Описание программы есть в Справке Windows


comp.exe

Местонахождение

WINDOWS\system32

Описание

File Compare Utility

Побайтное сравнение двух или нескольких файлов. Команда comp позволяет сравнивать файлы, находящиеся на разных дисках и в разных каталогах. При сравнении файлов с помощью команды comp выводятся их имена и расположения. Выполненная без параметров команда comp запрашивает файлы для сравнения.

Описание программы есть в Справке Windows

Синтаксис

comp [файл1] [файл2] [/d] [/a] [/l] [/n=кол_строк] [/c]

Примеры

Чтобы сравнить содержимое каталога C:\Reports с содержимым каталога резервных копий \\Sales\Backup\April, введите следующую команду:

comp c:\reports \\sales\backup\april

Чтобы сравнить первые десять строк файлов в каталоге \Invoice и вывести результат в десятичном формате, введите следующую команду:

comp \invoice\*.txt \invoice\backup\*.txt /n=10 /d


compact.exe

Местонахождение

WINDOWS\system32

Описание

Программа сжатия файлов - File Compress Utility

Вывод сведений или изменение уплотнения файлов и каталогов в разделах NTFS. Запущенная без параметров команда compact выводит сведения об уплотнении файлов в текущем каталоге. Описание программы есть в Справке Windows

Синтаксис

compact [{/c|/u}] [/s[:каталог]] [/a] [/i] [/f] [/q] [имя_файла[...]]


control.exe

Местонахождение

Windows\system32

Описание

Панель управления Windows - Windows Control Panel

Данная команда служит для запуска апплетов Панели управления

Советы

Как автоматизировать вход в систему

Реестр

Запрет за запуск Панели управления и ее апплетов


convert.exe

Местонахождение

Windows\system32

Описание

File System Conversion Utility

Утилита командной строки служит для преобразования томов с файловой системой FAT и FAT32 в тома с файловой системой NTFS.

Синтаксис

convert [том] /fs:ntfs [/v] [/cvtarea:имя_файла] [/nosecurity] [/x]

Описание параметров есть в справке Windows


cscript.exe

Местонахождение

Windows\system32

Описание

Microsoft (r) Console Based Script Host

Сервер сценариев cscript.exe является консольным вариантом, предназначенный для взаимодействия с пользователем через командную строку (в отличии от GUI-приложения wscript.exe).

Синтаксис

cscript [имя_сценария] [параметры_сервера] [аргументы_сценария]

Описание параметров есть в справке Windows


defrag.exe

Местонахождение

Windows\system32

Описание

Disk Defragmenter Module

Поиск и объединение фрагментированных файлов загрузки, файлов данных и папок на локальных томах.

Синтаксис

defrag том

defrag том [/a]

defrag том [/a] [/v]

defrag том [/v]

defrag том [/f]

Описание параметров есть в справке Windows


diskpart.exe

Местонахождение

Windows\system32

Описание

Diskpart Application

Программа DiskPart.exe — это работающий в текстовом режиме командный интерпретатор, который позволяет управлять объектами (дисками, разделами или томами) с помощью сценариев или команд, вводимых с командной строки.

Синтаксис

diskpart [/add | /delete] [имя_устройства | имя_диска | имя_раздела] [размер]

Описание программы есть в справке Windows


driverquery.exe

Местонахождение

Windows\system32

Описание

Опрос драйверов - Driver Query

Утилита командной строки для вывода списка всех установленных драйверов устройств и их свойств

Синтаксис

driverquery  [/s компьютер] [/u домен\пользователь /p пароль] [/fo {TABLE|LIST|CSV}] [/nh] [/v] [/si]

Описание параметров есть в справке Windows


drwtsn32.exe

drwtsn32.exe (Доктор Ватсон в Windows)

Местонахождение

Windows\system32

Описание

DrWatson Postmortem Debugger

Программа Доктор Ватсон (Drwtsn32.exe) устанавливается в системную папку при установке Windows. Параметры, используемые по умолчанию, задаются при первом запуске программы «Доктор Ватсон», который выполняется при возникновении программной ошибки или по команде пользователя.

При возникновении программной ошибки в Windows система выполняет поиск обработчика программных ошибок. Он обрабатывает ошибки по мере их возникновения во время выполнения программы. Если найти обработчик не удается, система проверяет, чтобы приложение не находилось в режиме отладки, после чего рассматривает ошибку как не подлежащую обработке. Далее система ищет отладчик программных ошибок в системном реестре и обрабатывает такие ошибки.

Более подробное описание программы ищите в справке Windows


explorer.exe

Местонахождение

Windows

Описание

Проводник - Windows Explorer

Одна из основных программ Windows для навигации по папкам и дискам

Ключи командной строки Проводника

  • /e - Вид Проводника по умолчанию (двухпанельное), иначе выводится как однопанельное (как Папка).
  • /e, object - Открывается Проводник с видом по умолчанию и с фокусом на заданной папке (Explorer /e,C:\Windows)
  • /n - Открытие однопанельного нового окна на диске, на котором установлена система (C:\). Иначе информация выводится в существующем окне Проводника, если оно открыто.
  • /root, object - Указывает на то, что корнем будет object - это дисковод (сетевой или локальный) или папка. Иначе корнем считается Рабочий стол. (Explorer /root, C:\Windows\Cursors)
  • /select, object - Указывает на необходимость открытия Родительской папки объекта object и выделит object (Explorer /select, C:\Windows\Cursors\banana.ani).

Советы

По умолчанию Проводник открывается на диске C:, но вы можете изменить это поведение...


fc.exe

Местонахождение

Windows\system32

Описание

DOS 5 File Compare Utility

Утилита командной строки для сравнения двух файлов и вывода различий между ними

Синтаксис

fc [/a] [/b] [/c] [/l] [/lbn] [/n] [/t] [/u] [/w] [/nnnn] [диск1:][путь1]имяфайла1 [диск2:][путь2]имяфайла2

Описание параметров есть в справке Windows

Советы

Есть простой способ отследить изменения, которые происходят в реестре Windows


find.exe

Местонахождение

Windows\system32

Описание

Find String (grep) Utility

Поиск заданной строки текста в файле или нескольких файлах. После поиска в заданных файлах команда find выведет на экран все строки из этих файлов, содержащие заданный образец.

Синтаксис

find [/v] [/c] [/n] [/i] "строка" [[диск:][путь]ИмяФайла[...]]

Описание параметров есть в справке Windows


fsutil.exe

Местонахождение

Windows\system32

Описание

fsutil.exe

Fsutil является служебной программой командной строки, которая используется для выполнения связанных задач файловых систем FAT и NTFS, таких как управление точками повторной обработки, управление разреженными файлами, отключение тома или расширение тома. Поскольку программа fsutil является весьма мощной, ее должны применять только опытные пользователи, имеющие опыт работы с Microsoft Windows XP. Для использования программы fsutil необходимо войти в систему с помощью учетной записи администратор или члена группы администраторов.

Описание программы и ее подкоманд есть в справке Windows.

Для отображения справки о подкомандах утилиты используйте команду

fsutil подкоманда help

Применение

С помощью утилиты командной строки fsutil можно создать файл с заданным размером. Например, вам надо создать файл sample.txt размером 1 кб, не заботясь о его содержании. Делаем так:

fsutil file createnew FileName Size
где FileName - имя файла (sample.txt, или c:\folder\sample.txt), а Size - размер файла в байтах.


ftp.exe

Местонахождение

Windows\system32

Описание

File Transfer Program

Позволяет передавать файлы с компьютера и на компьютер с помощью программ, поддерживающих протокол FTP (File Transfer Protocol)

Синтаксис

ftp [-v] [-d] [-i] [-n] [-g] [-s:имя_файла] [-a] [-w:размер] [-A] [Ведомый компьютер]

Описание параметров есть в справке Windows


hostname.exe

Местонахождение

Windows\system32

Описание

Hostname APP

Утилита командной строки hostname выводит имя системы, на котором была запущена эта команда

Синтаксис

hostname

У данной команды нет параметров


iexpress.exe

Местонахождение

Windows\system32

Описание

Wizzard

В Windows XP есть простейший инстяллятор файлов IExpress. Удобный диалог, упаковывает файлы в exe-файлы, один минус: не руссифицирован. Причем, например, 2 десятка картинок сжимаются даже лучше чем в WinRAR 3.0


ipconfig.exe

Местонахождение

Windows\system32

Описание

IP Configuration Utility

Утилита командной строки ipconfig служит для отображения всех текущих параметров сети TCP/IP и обновления параметров DHCP и DNS. При вызове команды ipconfig без параметров выводится только IP-адрес, маска подсети и основной шлюз для каждого сетевого адаптера

Синтаксис

ipconfig [/all] [/renew [адаптер]] [/release [адаптер]] [/flushdns] [/displaydns] [/registerdns] [/showclassid адаптер] [/setclassid адаптер [код_класса]]

Например, для очистки кэша разрешений DNS используется команда

ipconfig /flushdns

Описание параметров есть в справке Windows


logonui.exe

Местонахождение

Windows\system32

Описание

Интерфейс входа в Windows - Windows Logon UI

Программа, запускающая при входе в Windows. Именно в этом файле содержится внешний вид экрана приветствия. Существует ряд программ, позволяющих модифицировать внешний вид экрана приветствия путем изменения данного файла. Если вам хочется просто изменить внешний вид экрана приветствия без модификации файла, то можете воспользоваться более безопасным способом настройки экрана через реестр. (Смотри параметр UIHost в Справочнике по реестру).


lpq.exe

Местонахождение

Windows\system32

Описание

TCP/IP Lpq Command

Служит для отображения состояния очереди печати на компьютере, использующем программное обеспечение сервера печати Line Printer Daemon (LPD). При вызове команды lpq без параметров в командной строке отображается справка по этой команде

Синтаксис

lpq -S имя_сервера -P имя_принтера [-l]

Описание параметров есть в справке Windows


makecab.exe

Местонахождение

WINDOWS\system32

Описание

Microsoft® Cabinet Maker

Утилита командной строки makecab.exe служит для создания cab-файлов

Для получения списка параметров используйте ключ makecab /?


migwiz.exe

Местонахождение

WINDOWS\system32\usmt

Описание

Мастер переноса файлов и параметров - Files and Settings Transfer Wizard

Очень удобная утилита для переноса файлов и параметров различных программ с одного компьютера на другой. Например, вы легко перенесете все настройки и письма из Outlook Express. Программу можно запустить через Пуск-Все программы-Стандартные-Служебные-Мастер переноса файлов и параметров или через Пуск-Выполнить-migwiz


mmc.exe

Местонахождение

Windows\system32

Описание

Консоль управления (MMC) - Microsoft Management Console

Консоль MMC (Microsoft Management Console) группирует средства администрирования, которые используются для администрирования компьютеров, служб, других системных компонентов и сетей. Впервые она появилась в Windows 2000. Чтобы запустить ее, проделайте следующее:
Пуск->Выполнить->mmc. Перед вами откроется окно.

Дальше необходимо добавить групповую политику "Локальный компьютер", где и будут проводиться все настройки. Для этого выберите пункт меню Консоль->Добавить или удалить оснастку..., в появившемся окне нажмите кнопку "Добавить", и из появившегося диалога "Добавить изолированную оснастку" выберите "Групповая политика". Нажмите последовательно кнопки "Готово", "Закрыть", "ОК".

Давайте попробуем убрать пункт "Выполнить" из меню "Пуск" с помощью этого инструмента. В левой части окна консоли перед вами древовидная структура настраиваемых параметров операционной системы. Откройте пункт меню Конфигурация пользователя->Административные шаблоны->Панель задач и меню "Пуск". В расширенном варианте отображения данных вы сможете почитать описание настраиваемого пункта. Если вы знаете что именно вам надо настроить, то лучше переключиться в стандартный режим, чтобы не занимать лишнее место на экране монитора ненужной вам информацией. Итак, найдите строку Удалить команду "Выполнить" из меню "Пуск".

Дважды кликните по ней левой кнопкой мыши, отметьте пункт "Включен" и нажмите "ОК". Теперь если вы выберите Пуск->Выполнить, то увидите сообщение, что операция отменена вследствие действующих для компьютера ограничений. После перезагрузки этот пункт вообще пропадет из меню "Пуск". Аналогичным образом можно настроить и другие параметры меню "Пуск" и не только. Значения "Включен" и "Отключен" показывают действует или нет данная политика, а значение "Не задан" возвращает настройку политики в значение по умолчанию, заложенное в операционной системе. Вы наверняка уже обратили внимание на большое количество параметров, которые можно настроить с помощью оснастки MMC. Действительно, здесь можно настроить очень многие параметры операционной системы без использования дополнительных инструментальных средств. Описывать их все нет смысла, так что если вас заинтересовал этот способ твикинга, ознакомьтесь с ними самостоятельно, тем более описание настраиваемых параметров дает более чем исчерпывающую информацию. Ну, а для начального знакомства с оснасткой MMC приведенных сведений должно хватить.

Оснастки

  • Диспетчер устройств
  • Локальные пользователи и группы - Local Users and Groups
  • Общие папки
  • Производительность
  • Просмотр событий
  • Служба индексирования
  • Службы
  • Съемные ЗУ
  • Управление дисками - Disk Management
  • Управление компьютером

Реестр

Запрет на запуск консоли управления в авторском режиме


mplayer2.exe

Местонахождение

Program Files\Windows Media Player

Описание

Проигрыватель Windows Media - Windows Media Player

Оказывается вместе с навороченной версией Универсального проигрывателя Windows Media (wmplayer.exe) существует и более простая старая версия 6.4. Причем, данный проигрыватель менее требователен к ресурсам памяти и отлично справляется с проигрыванием звука и видео.


msconfig.exe

Местонахождение

WINDOWS\PCHealth\HelpCtr\Binaries

Описание

Настройка системы (System Configuration Utility)

После загрузки появляется окно с шестью вкладками:
- Общие
- System.ini
- Win.ini
- BOOT.INI
- Службы
- Автозагрузка - здесь перечислены все программы, которые запускаются при загрузке системы.
Очень удобно то, что все собрано в одном месте. Не надо лазить по реестру и файлам, чтобы посмотреть, что загружается на компьютере. Можно отключить загрузку любой программы или выполнение строки одного из перечисленных файлов, не правя ничего вручную. При этом комментарии будут расставлены автоматически, а программы, запускаемые из реестра, например, из раздела "Run", будут перенесены в раздел "Run-" (в конце соответствующего раздела добавляется символ "-").

Более подробное описание программы есть в справке самой программы

Изменения в программе

11 октября 2005 года вышло обновление 906569, которое добавляет новую вкладку Сервис (Tools) к этой программе. С помощью этой вкладки вы можете запускать различные утилиты. Вы можете самостоятельно настроить список программ на этой вкладке Tools, а также модифицировать имеющиеся записи. Для этого вам нужно отредактировать файл Mscfgtlc.xml. Данный файл должен находиться в той же папке, что и Msconfig.exe. Так как этот файл является системным, то вам необходимо иметь привилегии администратора для изменения файла.

Вот пример формата файла Mscfgtlc.xml:

<?xml version="1.0" ?>
    <MSCONFIGTOOLS>
<a NAME="Remote Assistance" PATH="%windir%\\system32\\rcimlby.exe" DEFAULT_OPT="-LaunchRA" ADV_OPT=""
HELP="Receive help from (or offer help to) a friend over the Internet"/>
<b NAME="Конфигурация IP-протокола" PATH="%windir%\system32\cmd.exe"
DEFAULT_OPT="/k %windir%\system32\ipconfig.exe" ADV_OPT="/k %windir%\system32\ipconfig.exe /all"
HELP="IPCONFIG - это команда, использующаяся для управления сетевыми подключения компьютеров, работающих под управлением Windows."/>
</MSCONFIGTOOLS>

In this example, entry "a" shows an entry that contains no advanced functionality. No advanced functionality is available because of the null argument for the ADV_OPT element. Entry "b" contains an entry that has advanced functionality. In entry "b," the whole command is repeated together with the addition of a switch. Additionally, the tool is started in a Command Prompt window.

You do not have to provide a tool description in the Mscfgtlc.xml file. However, if you use incorrect path, syntax or option information, you receive an error message. Additionally, if you use incorrect path, syntax or option information, the tools that you want to display are not visible on the Tools tab in this situation.

Обновленная версия программы доступна на Microsoft Download Center: http://www.microsoft.com/downloads/details.aspx?FamilyId=9689F6E9-ADED-44B8-BBBB-BEAE1B4A4BC9)

Обновление доступно только для Windows XP SP2

.

Данное обновление планируется включить в Windows XP Service Pack 3 (SP3).

Реестр

Удаление ненужных записей


msinfo32.exe

msinfo32.exe (Сведения о системе)

Местонахождение

C:\Program Files\Common Files\Microsoft Shared\MSInfo

Описание

System Information

Программа Сведения о системе собирает и отображает данные о конфигурации системы как для локальных, так и для удаленных компьютеров. Сюда входит информация о конфигурации оборудования, компонентах компьютера, а также программном обеспечении, в том числе о подписанных и неподписанных драйверах. При устранении неполадок, связанных с конфигурацией системы, сотрудникам службы технической поддержки необходимы определенные данные о компьютере. Программа «Сведения о системе» позволяет быстро собрать необходимые данные.

Для хранения данных о системе предназначены файлы с расширением .nfo. Кроме того, программа «Сведения о системе» работает с файлами форматов .cab и .xml. Содержимое открытого файла .cab можно просматривать средствами меню Сервис.

Синтаксис

msinfo32 [/?] [/pch] [/nfo имя_файла] [/report имя_файла] [/computer имя_компьютера] [/showcategories] [/category код_категории] [/categories код_категории]

Описание программы есть в справке Windows


msoobe.exe

Местонахождение

WINDOWS\system32\oobe

Описание

Microsoft Out of Box Experience

Программа активации Windows. Если ваша Windows еще не активирована, то запустите ее через Пуск-Выполнить
oobe/msoobe /a
Далее следуйте дальнейшим указаниям


mspaint.exe

Местонахождение

Windows\system32

Описание

Paint

Оказывается, в Microsoft Paint можно быстро увеличить картинку аж в 10 раз. Для этого активизируйте инструмент Лупа. В нижней части поля, где фиксируется степень увеличения, находится тонкая белая линия. Аккуратно щелкните по ней. Как себя чувствует ваша картинка?

Если при работе в Paint, во время рисования линии удерживать нажатой клавишу Shift, то будет рисоваться прямая линия. Если проводить линию под углом, то при этом угол будет составлять 45 градусов.

А если удерживать нажатой клавишу Shift при рисовании фигур, то будет рисоваться квадраты и круги, вместо прямоугольников и эллипсов.


net.exe

Местонахождение

Windows\system32

Описание

Net Command

В утилите net.exe реализовано множество команд для управления различными сетевыми компонентами, такими, как разделы, сессии, службы и учетные записи пользователей. Например, с помощью команды net User можно получить информацию о группах, к которым принадлежит пользователь. Пожалуй, это наиболее часто используемая утилита из арсенала любого системного администратора. Описание синтаксиса команды может занять больше десятка страниц.

Например, для отключения учетной записи можно использовать команду

net user имя_пользователя /active :no

Для более подробной информации наберите в командной строке:

net /?


netsh.exe

Местонахождение

Windows\system32

Описание

Оболочка сетевых команд - Network Command Shell

Netsh представляет собой поддерживающую сценарий программу с командной строкой, позволяющую локально или удаленно отображать и изменять параметры сети текущего компьютера. Netsh также обеспечивает средства написания сценариев, которые позволяют запускать группу команд в пакетном режиме на определенном компьютере. Программа Netsh может также сохранять сценарии конфигурации в текстовом файле для помещения в архив или для настройки других серверов.

Описание параметров есть в справке Windows. После выхода Пакета обновлений 2 (SP2) в программу были добавлены новые параметры для брандмауэра Windows

  • netsh firewall
  • netsh firewall show allowedprogram
  • netsh firewall show config
  • netsh firewall show currentprofile
  • netsh firewall show icmpsetting
  • netsh firewall show logging
  • netsh firewall show multicastbroadcastresponse
  • netsh firewall show notifications
  • netsh firewall show opmode
  • netsh firewall show portopening
  • netsh firewall show service
  • netsh firewall show state

Чтобы узнать конкретно о параметре команд, введите этот параметр, затем пробел и знак вопроса. Например, netsh firewall show ?


netstat.exe

Местонахождение

Windows\system32

Описание

TCP/IP Netstat Command

Отображение активных подключений TCP, портов, прослушиваемых компьютером, статистики Ethernet, таблицы маршрутизации IP, статистики IPv4 (для протоколов IP, ICMP, TCP и UDP) и IPv6 (для протоколов IPv6, ICMPv6, TCP через IPv6 и UDP через IPv6). Запущенная без параметров, команда nbtstat отображает подключения TCP.

Синтаксис

netstat [-a] [-e] [-n] [-o] [-p протокол] [-r] [-s] [интервал]

Описание программы есть в справке Windows

Чтобы вывести все активные подключения, отсортированные по возрастанию номера порта, необходимо набрать:

netstat -n

Чтобы получить список ожидающих портов, введите следующую команду и нажмите клавишу ВВОД:

netstat –ano > netstat.txt


notepad.exe

Местонахождение

Windows\system32

Описание

Блокнот - Notepad

Простейший текстовый редактор, известный как Блокнот. Используется для создания и просмотра простых текстовых документов. Многие веб-дизайнеры используют Блокнот в качестве инструмента для создания интернет-страничек, не доверяя более навороченным программам! В каждой новой версии Windows приобретал новые возможности. В Windows XP текстовый редактор уже научился понимать некоторые кодировки. В Windows традиционно используется в качестве просмотра HTML-кода, log-файлов и т.п.

Советы

Блокнот для ежедневных заметок

Реестр

Настройка шрифтов


nslookup.exe

Местонахождение

Windows\system32

Описание

nslookup APP

Предоставляет сведения, предназначенные для диагностики инфраструктуры DNS. Для использования этого средства необходимо быть знакомым с принципами работы системы DNS. Средство командной строки Nslookup доступно, только если установлен протокол TCP/IP

Синтаксис

nslookup [-подкоманда ...] [{искомый_компьютер| [-сервер]}]

Описание параметров есть в справке Windows


ntbackup.exe

Местонахождение

Windows\system32

Описание

Архивация данных Windows - Windows Backup Utility

Программа архивации позволяет защитить данные от случайной утери в случае, если в системе возникнет сбой оборудования или носителя. Например, с помощью программы архивации можно создать резервную копию данных на жестком диске, а затем создать архив на другом устройстве хранения данных. При случайном удалении или замене исходных данных на жестком диске из-за его сбоя данные могут быть легко восстановлены из архивной копии. Программа архивации создает снимок состояния тома, представляющий собой точную копию содержимого жесткого диска на определенный момент времени. В справке Windows есть подробное описание работы программы


ntoskrnl.exe

Местонахождение

Windows\system32

Описание

Системный модуль ядра NT - NT Kernel & System

Данный файл интересен прежде всего тем, что содержит в себе загрузочную картинку (boot screen). Существуют программы, которые изменяют содержимое данного файла. Используется любителями украшений Windows под свой вкус.


openfiles.exe

Местонахождение

Windows\system32

Описание

Открыто файлов - Open Files

Утилита командной строки, которая запрашивает или отображает открытые файлы. Также запрашивает, отображает или разъединяет файлы, открытые сетевыми пользователями.

Синтаксис

openfiles.exe /query [/s компьютер [/u домен\пользователь [/p пароль]]] [/fo {TABLE|LIST|CSV}] [/nh] [/v]

Описание параметров есть в справке Windows


pathping.exe

Местонахождение

Windows\system32

Описание

TCP/IP PathPing Command

Утилита командной строки pathping.exe в течение некоторого периода времени отправляет многочисленные сообщения с эхо-запросом каждому маршрутизатору, находящемуся между исходным пунктом и пунктом назначения, а затем на основании пакетов, полученных от каждого из них, вычисляет результаты. Поскольку pathping показывает коэффициент потери пакетов для каждого маршрутизатора или связи, можно определить маршрутизаторы или субсети, имеющие проблемы с сетью. Команда Pathping выполняет эквивалентное команде tracert действие, идентифицируя маршрутизаторы, находящиеся на пути. Затем она периодически в течение заданного времени обменивается пакетами со всеми маршрутизаторами и на основании числа пакетов, полученных от каждого из них, обрабатывает статистику. Запущенная без параметров, команда pathping выводит справку.

Описание программы и ее подкоманд есть в справке Windows.

Для отображения справки о подкомандах утилиты используйте команду pathping без параметров в командной строке

pathping

Синтаксис

pathping [-n] [-h максимальное_число_переходов] [-g список_узлов] [-p период] [-q число_запросов [-w интервал] [-T] [-R] [имя_конечного_компьютера]

Параметры

-n
Предотвращает попытки команды pathping сопоставить IP-адреса промежуточных маршутизаторов с их именами. Это позволяет ускорить вывод результатов команды pathping.
-h максимальное_число_переходов
Задает максимальное количество переходов на пути при поиске конечного пункта назначения. Значение по умолчанию равно 30.
-g список_узлов
Указывает для сообщений с эхо-запросом использование параметра свободной маршрутизации в IP-заголовке с набором промежуточных мест назначения, указанным в списке_компьютеров. При свободной маршрутизации последовательные промежуточные места назначения могут быть разделены одним или несколькими маршрутизаторами. Максимальное число адресов или имен в списке равно 9. Список_адресов представляет собой набор IP-адресов (в точечно-десятичной нотации), разделенных пробелами.
-p период
Задает время ожидания между последовательными проверками связи (в миллисекундах). Значение по умолчанию равно 250 миллисекунд.
-q число_запросов
Задает количество сообщений с эхо-запросом, отправленных каждому маршрутизатору пути. По умолчанию - 100.
-w интервал
Задает время ожидания каждого отклика (в миллисекундах). Значение по умолчанию равно 3000 миллисекунд.
-T
Присоединяет тег приоритета уровня 2 (например 802.1p) к сообщениям с эхо-запросом, отправляемым каждому сетевому устройству на маршруте. Это помогает обнаружить сетевые устройства, для которых не настроен приоритет уровня 2. Он предназначен для проверки соединений, использующих спецификации QoS.
-R
Проверяет, все ли сетевые устройства вдоль маршрута поддерживают протокол RSVP (Resource Reservation Setup Protocol, протокол настройки резервирования ресурсов), который позволяет главному компьютеру резервировать определенную часть пропускной способности для потока данных. Этот параметр предназначен для проверки соединений, использующих спецификации QoS.
имя_конечного_компьютера
Задает пунтк назначения, идентифицированный IP-адресом или именем узла.
/?
Отображает справку в командной строке.

Примечания

Параметры команды Pathping вводятся с учетом регистра.

Во избежание перегрузки сети пакеты должны передаваться через довольно большие интервалы времени.

Чтобы минимизировать эффект потери пакетов, не нужно слишком часто выполнять проверку связи.

После запуска pathping сначала выводится путь. Это тот же путь, который выводится командой tracert. Далее в течение 90 секунд команда выдает сообщение о том, что она занята (это время варьируется в зависимости от числа переходов).В течение этого времени происходит сбор сведений со всех маршрутизаторов, перечисленных выше, и со всех соединений между ними. По завершении этого периода выводятся результаты проверки.


ping.exe

Местонахождение

Windows\system32

Описание

TCP/IP Ping Command

Утилита командной строки Ping проверяет соединение на уровне протокола IP с другим компьютером, поддерживающим TCP/IP, с помощью отправки сообщений с эхо-запросом по протоколу ICMP . После каждой передачи выводится соответствующее сообщение с эхо-ответом. Ping - это основная TCP/IP-команда, используемая для устранения неполадки в соединении, проверки возможности доступа и разрешения имен. Команда ping, запущенная без параметров, выводит справку.

Синтаксис

ping [-t] [-a] [-n счетчик] [-l размер] [-f] [-i TTL] [-v тип] [-r счетчик] [-s счетчик] [{-j список_узлов | -k список_узлов}] [-w интервал] [имя_конечного_компьютера]

Описание параметров есть в справке Windows

Команда Ping лежит в основе диагностики сетей TCP/IP. Например, чтобы быстро получить значения параметров конфигурации TCP/IP на своем компьютере, следует набрать:

C:\>ping 127.0.0.1


powercfg.exe

Местонахождение

Windows\system32

Описание

Power Settings Command-Line Tool

Эта команда позволяет администратору управлять параметрами электропитания системы.

Получить более подробную информацию о программе и ее параметрах можно через команду

powercfg /?

Пример

Например, чтобы отобразить текущую конфигурацию схемы электропитания, нужно ввести команду

powercfg /Q


progman.exe

Местонахождение

Windows\system32

Описание

Program Manager (Диспетчер программ)

Из Windows 3.1 нам достался такой замечательный продукт, как PROGMAN.EXE. Он представляет из себя панель, которая с успехом может заменить Рабочий Стол, поскольку позволяет завести внутри себя неограниченное количество Групп, каждая из которых может содержать произвольное количество ярлыков (команды "Создать группу" и "Создать элемент" соответственно). Ярлык PROGMAN.EXE имеет смысл или помещать в стартовую папку с параметром "Свёрнутое в значок" (Windows 95, NT), или выводить на панель Quick Launch.
В результате можно существенно разгрузить Рабочий Стол, оставив на нём только необходимое. Остальные рабочие ярлыки можно разместить по группам Прогмана. В результате получится что-то вроде свёртываемого Рабочего Стола с рядом Рабочих Подстолов внутри!
P.S. К сожалению, PROGMAN.EXE обладает одним "родимым пятном" Windows 3.1: он не понимает длинных имён файлов, которые надо преобразовывать в короткие. Однако это неудобство не сильно умаляет его достоинства.


reg.exe

Местонахождение

Windows\system32

Описание

Утилита редактирования системного реестра из командной строки

Данная утилита позволяет просматривать, добавлять, удалять различные данные из реестра. Дополнительную информацию можно получить, запустив в командной строке

reg /?

Примеры

Для получения номера версии Internet Explorer из реестра введите в командной строке:

reg query "HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer" /v Version


regedit.exe

Местонахождение

Windows

Описание

Редактор реестра - Registry Editor

Редактор реестра позволяет модифицировать данные в реестре. Реестру посвящен отдельный Справочник по реестру Windows


regsvr32.exe

Местонахождение

Windows\system32

Описание

Сервер регистрации, (C) Microsoft - Microsoft(C) Register Server

Данная команда регистрирует в реестре файлы .dll как компоненты команды. Данная утилита весьма активно используется программистами для регистрации различных собственных компонентов

Синтаксис

regsvr32 [/u] [/s] [/n] [/i[:cmdline]] имя_dll

Параметры

/u
Отменяет регистрацию сервера
/s
Задает запуск regsvr32 без вывода сообщений на экран.
/n
Указывает не вызывать DllRegisterServer. Этот параметр можно использовать с параметром /i.
/i:cmdline
Вызывает DllInstall с помощью дополнительной передачи [cmdline]. При использовании с параметром /u вызывает удаление dll.
dllname
Задает имя файла dll для последующей регистрации.
/?
Вывод справки в командной строке.

Примеры

Для регистрации файла .dll для схемы Active Directory введите:

regsvr32 schmmgmt.dll

Советы

Удаление папок Мои рисунки и других подпапок в папке Мои документы

Отключить работу с zip-файлами как с папками


route.exe

Местонахождение

Windows\system32

Описание

TCP/IP Route Command

Эта команда нужна для редактирования или просмотра таблицы маршрутов IP из командной строки. Ключ /? выводит все доступные ключи при работе с Route.

Синтаксис


rstrui.exe

Местонахождение

Windows\system32\Restore

Описание

Приложение восстановления системы - System Restore Application

Программа Восстановление системы служит, как видно из названия, для восстановления системы. Программа позволяет вернуть настройки компьютера в более раннее состояние (контрольная точка). Обратите внимание, что восстановление конфигурации системы происходит без потерь текущих данных (документы, почтовые сообщения, ссылки). Об этой программе достаточно много говорится в справке Windows.

Управление восстановлением системы через скрипты

Для программы восстановления системы можно создавать различные скрипты, позволяющие создавать контрольные точки восстановления, перечислять имеющиеся точки, включать или выключать возможность восстановления системы для заданных дисков. При использовании данных скриптов задействованы WMI и файл srclient.dll, которая является клиентской DLL для программы восстановления системы и пользователь должен иметь права администратора системы

Создание контрольной точки

'Используем WMI и класс SystemRestore
set SRP = getobject("winmgmts:\\.\root\default:Systemrestore")
CSRP = SRP.createrestorepoint ("Создание тестовой контрольной точки", 0, 100)

Отключение или включение Восстановления системы для заданного диска

onoff = InputBox ("Вы хотите включить (вкл) или отключить (выкл) Восстановление системы? Введите слова вкл или выкл", "Восстановление системы")
Drive = InputBox ("Выберите нужный диск. Вы должны использовать формат 'c:\'", "Работа с диском")

set SRP = GetObject("winmgmts:\\.\root\default:SystemRestore")

If onoff = "вкл"  then
eSRP = SRP.enable(drive)
end if

If onoff = "выкл" then
eSRP = SRP.disable(drive)
end if

Перечисление контрольных точек восстановления системы

' Перечисление контрольных точек
set SRP = getobject("winmgmts:\\.\root\default").InstancesOf ("systemrestore")
for each Point in SRP
msgbox point.creationtime & vbcrlf & point.description & vbcrlf & "Порядковый номер= " & point.sequencenumber
next

Реестр

Восстановление системы


rundll32.exe

Местонахождение

Windows\system32

Описание

Запуск библиотеки DLL как приложения - Run a DLL as an App

Windows имеет в своем составе утилиту командной строки rundll32.exe, которая позволяет запускать некоторые команды-функции, заложенные в DLL-файлах.

Вообще-то данная утилита была разработана для внутреннего пользования программистами Microsoft. Но богатые возможности этой программы дало повод на всеобщее использование пользователями.

Область применения данной утилиты довольно широк. Вы можете вводить приведенные ниже команды в окне Запуск программы (Пуск-Выполнить), также создать ярлыки с заданнами параметрами запуска, использовать в коде на программируемом вами языке (C++, Delphi, Visual Basic и т.д.)

Список команд слишком обширен. Приведем список наиболее значимых команд.

SHELL32.DLL

  • rundll32 shell32.dll,Control_RunDLL hotplug.dll - диалоговое окно Отключение или извлечение аппаратного устройства
  • rundll32 shell32, Control_FillCache_RunDLL - запустить начальную инициализацию Панели управления.
  • rundll32 shell32,Control_RunDLL - открыть в Проводнике папку "Панель управления"
  • rundll32.exe shell32.dll,Control_RunDLL access.cpl,,1 - апплет Специальные возможности (вкладка Клавиатура)
  • rundll32.exe shell32.dll,Control_RunDLL access.cpl,,2 - апплет Специальные возможности (вкладка Звук)
  • rundll32.exe shell32.dll,Control_RunDLL access.cpl,,3 - апплет Специальные возможности (вкладка Экран)
  • rundll32.exe shell32.dll,Control_RunDLL access.cpl,,4 - апплет Специальные возможности (вкладка Мышь)
  • rundll32.exe shell32.dll,Control_RunDLL access.cpl,,5 - апплет Специальные возможности (вкладка Общие)
  • rundll32 shell32,Control_RunDLL appwiz.cpl,,1 - вызов диалогового окна "Установка и удаление программ"(вкладка Установка программ).
  • rundll32 shell32,Control_RunDLL appwiz.cpl,,2 - вызов диалогового окна "Установка и удаление программ"(вкладка Установка компонентов Windows).
  • rundll32 shell32,Control_RunDLL appwiz.cpl,,3 - вызов диалогового окна "Установка и удаление программ"(вкладка Выбор программ по умолчанию).
  • rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,0 - апплет Экран (вкладка Рабочий стол).
  • rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,1 - апплет Экран (вкладка Заставка).
  • rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,3 - апплет Экран (вкладка Параметры).
  • rundll32.exe shell32.dll,Control_RunDLL inetcpl.cpl,,0 - апплет Свойства обозревателя (вкладка Общие).
  • rundll32.exe shell32.dll,Control_RunDLL inetcpl.cpl,,1 - апплет Свойства обозревателя (вкладка Безопасность).
  • rundll32.exe shell32.dll,Control_RunDLL inetcpl.cpl,,2 - апплет Свойства обозревателя (вкладка Конфиденциальность).
  • rundll32.exe shell32.dll,Control_RunDLL inetcpl.cpl,,3 - апплет Свойства обозревателя (вкладка Содержание).
  • rundll32.exe shell32.dll,Control_RunDLL inetcpl.cpl,,4 - апплет Свойства обозревателя (вкладка Подключения).
  • rundll32.exe shell32.dll,Control_RunDLL inetcpl.cpl,,5 - апплет Свойства обозревателя (вкладка Программы).
  • rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,0 - апплет Язык и региональные стандарты (вкладка Региональные параметры)
  • rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,1 - апплет Язык и региональные стандарты (вкладка Языки)
  • rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,2 - апплет Язык и региональные стандарты (вкладка Дополнительно)
  • rundll32.exe shell32.dll,Control_RunDLL joy.cpl - апплет Игровые устройства
  • rundll32 shell32,Control_RunDLL main.cpl @0 - открыть диалог "Свойства мыши".
  • rundll32 shell32,Control_RunDLL main.cpl @1 - открыть диалог "Свойства клавиатуры".
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL PrintersFolder - открыть папку "Принтеры" (другой способ).
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL FontsFolder - открыть папку "Шрифты" (другой способ).
  • rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,0 - апплет Звуки и аудиоустройства (вкладка Громкость)
  • rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,1 - апплет Звуки и аудиоустройства (вкладка Звуки)
  • rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,2 - апплет Звуки и аудиоустройства (вкладка Аудио)
  • rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,3 - апплет Звуки и аудиоустройства (вкладка Речь)
  • rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,4 - апплет Звуки и аудиоустройства (вкладка Оборудование)
  • rundll32.exe shell32.dll,Control_RunDLL modem.cpl - апплет Телефон и модем
  • rundll32.exe shell32.dll,Control_RunDLL ncpa.cpl - открытие окна Сетевые подключения
  • rundll32.exe shell32.dll,Control_RunDLL odbccp32.cpl - апплет ODBC Data Source Administrator
  • rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,0 - апплет Система (вкладка Общие). Параметры от 1 до 6 - остальные вкладки
  • rundll32.exe shell32.dll,Control_RunDLL telephon.cpl - апплет Телефон и модем
  • rundll32 shell32,Control_RunDLL timedate.cpl - открыть диалог "Дата и время".
  • rundll32 shell32,Control_RunDLL timedate.cpl,,/f - открыть вкладку Часовой пояс диалогового окна свойств времени Панели управления
  • rundll32 shell32,OpenAs_RunDLL - вызвать диалог "Открыть с помощью...".
  • rundll32 shell32,ShellAboutA WHATIS.RU - информация о версии Windows.
  • rundll32 shell32,SHExitWindowsEx 0 - закрыть все программы, перегрузить оболочку.
  • rundll32 shell32, SHExitWindowsEx 1 - выключить ПК.
  • rundll32 SHELL32, SHExitWindowsEx -1 - перегрузить оболочку Windows.
  • rundll32 shell32, SHExitWindowsEx 2 - перегрузить ПК.
  • rundll32 shell32,SHExitWindowsEx 4 - принудительно закрыть все программы.
  • rundll32 shell32,SHExitWindowsEx 8 - выход из Windows и выключение ATX-совместимого ПК.
  • rundll32 shell32,SHFormatDrive - вызов диалога форматирования диска А:.
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL AddPrinter - запуск "Мастера установки принтера".
  • rundll32 shell32,SHHelpShortcuts_RunDLL Connect - запуск мастера подключения сетевого диска.
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL PrintTestPage - распечатать тестовую страницу.

URL.DLL

  • rundll32 url.dll,FileProtocolHandler %1 - открыть веб-страницу, где %1 - URL сайта (включая http://).
  • rundll32 url.dll,MailToProtocolHandler %1 - создать новое письмо, где %1 - e-mail адресата.
  • rundll32 url.dll, NewsProtocolHandler %1 - произвести подключение к новостному серверу, где %1 - URL сервера.
  • rundll32 url.dll, TelnetProtocolHandler %1 - осуществить подключение telnet, где %1 - адрес сервера.

USER.EXE

  • rundll32 user,CASCADECHILDWINDOWS - расположить все окна каскадом.
  • rundll32 user,TILECHILDWINDOWS - расположить все окна по экрану.
  • rundll32 user,disableoemlayer - сбой системы (!) - выключить все функции ввода-вывода (клавиатура, дисплей, мышь). В результате будет черный экран с курсором и ни на что не реагирующая система, однако Windows продолжает работать.
  • rundll32 user,enableoemlayer - включить и загрузить OEM Layer, если есть возможность выполнить эту команду дистанционно.
  • rundll32 user,ExitWindowsExec - быстрая перезагрузка Windows.
  • rundll32 user,RepaintScreen - выполнить команду "Обновить".
  • rundll32 user,SetCaretBlinkTime n - задать частоту мигания курсора, соответствующую значению параметра n.
  • rundll32 user,SetCursorPos - переместить курсор мыши в верхний левый угол экрана.
  • rundll32 user,SetDoubleClickTime n - задать скорость двойного нажатия левой кнопки мыши (Double Click), соответствующую параметру n.
  • rundll32 user,SwapMouseButton - поменять местами клавиши мыши (обратная смена невозможна).
  • rundll32 user,WNetConnectDialog - вызов диалога "Подключение сетевого диска".
  • rundll32 user,WNetDisconnectDialog - вызов диалога "Отключение сетевого диска".

Разное

  • rundll32 diskcopy,DiskCopyRunDll - вызов диалога "Копирование диска".
  • rundll32 keyboard,disable - отключение клавиатуры, действует до следующей перезагрузки.
  • rundll32 mouse,disable - отключение мыши вплоть до перезагрузки.
  • rundll32 krnl386.exe,exitkernel - выгрузить ядро системы, выход из Windows.
  • rundll32 mshtml.dll,PrintHTML "HtmlFileNameAndPath" - распечатать документ HTML, где "HtmlFileNameAndPath" - путь к файлу и его имя.
  • rundll32 мсprint2.dll,RUNDLL_PrintTestPage - распечатать тестовую страницу на принтере.
  • rundll32 netplwiz.dll,AddNetPlaceRunDll - вызов мастера подключения нового сетевого ресурса "Добавление в сетевое окружение".
  • rundll32.exe ntlanui.dll,ShareCreate - вызов окна Новый общий ресурс
  • rundll32.exe ntlanui.dll,ShareManage - вызов окна Общие папки
  • rundll32 shell,ShellExecute - открыть Проводник (папка "Рабочий стол").
  • rundll32 sysdm.cpl,InstallDevice_Rundll - вызов мастера установки оборудования.
  • rundll32 AppWiz.Cpl,NewLinkHere %1 - запуск мастера создания нового ярлыка, где %1 - путь к исходному файлу.
  • rundll32 syncui.dll, Briefcase_Intro - вызов мастера по работе с "Портфелем"
  • rundll32 SYNCUI.DLL, Briefcase_Create - создать новую папку "Портфель", если эта функция установлена в системе.
  • rundll32 msgina,ShellShutdownDialog - вызов диалога "Завершение работы Windows".
  • rundll32 tcpmonui.dll, LocalAddPortUI - запуск мастера установки TCP-порта принтера.
  • rundll32 shdocvw.dll,DoOrganizeFavDlg - вызов окна "Упорядочить избранное"
  • rundll32 shdocvw.dll,OpenURL filename - запуск .url файла с именем filename
  • rundll32 user32.dll LockWorkStation - блокировка компьютера
  • rundll32 desk.cpl, InstallScreenSaver [filename.scr] - задать файл скринсейвера в диалоговом окне свойств дисплея.
  • rundll32 IEdkcs32.dll, Clear - сброс некоторых настроек Internet Explorer, полезно использовать при некоторых сбоях в работе обозревателя.
  • rundll32.exe powrprof.dll,SetSuspendState - ввести компьютер в спящий режим


SFC.EXE

Местонахождение

Windows\system32

Описание

Windows 2000 System File Checker

Утилита SFC.EXE предназначена для проверки всех версий защищенных системных файлов и восстановления их из специального кэша в случае подмены или повреждения.

В Windows XP она запускается только из командной строки - в отличие от Windows 9х, где подобная утилита имеет графический интерфейс. Запуск утилиты возможен только с правами администратора, синтаксис такой:
sfc [/scannow] [/scanonce] [/scanboot] [/revert] [/cancel] [/enable] [/purgecache] [/cache size=x] [/quiet]

Параметры командной строки, которые можно задавать для программы SFC, следующие:

  • /scannow - немедленная проверка всех защищенных системных файлов
  • /scanonce - проверка защищенных системный файлов при следующей загрузке системы
  • /scanboot - проверка всех защищенных системных файлов при каждой загрузке системы
  • /revert - восстанавливает все настройки по умолчанию (Windows XP)
  • /cancel - отменяет все проверки защищенных системных файлов (Windows Me/2000)
  • /purgecache - очистка кэша защищенных файлов программы и немедленная проверка всех защищенных системных файлов
  • /cachesize=x - установка размера кэша защищенных файлов в мегабайтах (по умолчанию 50 мГб)
  • /enable - включение защиты системных файлов Windows (Windows Me/2000)
  • /quiet - замена поврежденных файлов без предупреждения (Windows Me/2000)
  • /? - вызов справки

Давайте рассмотрим практическое применение утилиты.

Папка dllcache

Если вас не устраивает, что Windows XP занимает слишком много места и восстанавливает удалённые из его директории файлы, то может удалить папку dllcache, но после следующей проверки системных файлов Windows снова заполнит эту папку. Для устранения этого "греха", после удаления или до удаления файлов (но не папки), нужно запустить команду sfc /cachesize=число. Числом будет количество мегабайт которое должно резервироваться для папки windows\system32\dllcache. Можно поставить = 0.

Поврежденные файлы

Предположим, вы обнаружили, что на вашем компьютере отсутствуют некоторые файлы, например, шрифты (шрифты - тоже системные файлы). Проверяем наличие системных файлов с помощью команды
sfc.exe /scannow
Windows проверит файлы и при необходимости переустановит недостающие или поврежденные.


Shutdown

SHUTDOWN.EXE

Местонахождение

Windows\system32

Описание

Windows Remote Shutdown Tool

Утилита Shutdown позволяет выключать или перегружать локальный или удаленный ПК, используя командную строку или специально созданный ярлык. Простой ее вызов без каких-либо параметров обеспечивает завершение сеанса текущего пользователя. Для использования всех возможностей этой утилиты необходимо задействовать параметры командной строки, синтаксис которых таков:
shutdown [{-l|-s|-r|-a}] [-f] [-m [\\Computer Name]] [-t xx] [-c "message"] [-d[u] [p]:xx:yy]

Подробнее о параметрах.
-l - завершение сеанса текущего пользователя. При наличии параметра -m последний имеет приоритет, то есть завершение сеанса производится для удаленного ПК
-s - выключить локальный ПК
-r - перезагрузка
-a - отмена выключения ПК, игнорируются все параметры, кроме -l и ComputerName. Данный параметр может использоваться только в тот момент, когда длится так называемый период тайм-аута, то есть когда программа Shutdown выделяет пользователю время на отмену своих действий
-f - разрешить принудительное закрытие всех работающих приложений
-m [\\ComputerName]- задать удаленный компьютер, который необходимо выключить
-t xx - задает временную задержку до вызова процедуры выключения компьютера в секундах - xx. По умолчанию используются 20 секунд
-c "message" - эта команда позволяет задать любое сообщение, которое будет отображаться в окне программы Shutdown. Максимальная длина сообщения - 127 символов. Текст сообщения необходимо заключать в кавычки
-d [u][p]:xx:yy - активирует некий специальный код выключения:
u - отображение пользовательского кода, p - отображение запланированного кода, xx - задает основной код (0-255), yy - задает дополнительный код (0-65536)
/? - отображает справочную информацию по программе


sndvol32.exe

Местонахождение

Windows\system32

Описание

Громкость - Volume Control

Данная программа позволяет управлять регулятором громкости звука

Советы

Чтобы одним щелчком открыть эту программу (а не десятью, как это предусмотрено разработчиками), достаточно создать ярлык с командой "c:\windows\system32\sndvol32.exe -rec". Эту же команду можно использовать в окне Выполнить из меню Пуск


sol.exe

Местонахождение

Windows\system32

Описание

Пасьянс "Косынка" - Solitaire Game Applet

Одна из встроенных игр Windows, представляющих собой карточную игру


systeminfo.exe

Местонахождение

Windows\system32

Описание

System Information

Выводит на экран подробные сведения о конфигурации компьютера и операционной системы, сведения о безопасности, код продукта и параметры оборудования, такие как ОЗУ, дисковое пространство и сетевые карты

Синтаксис

systeminfo[.exe] [/s компьютер [/u домен\пользователь [/p пароль]]] [/fo {TABLE|LIST|CSV}] [/nh]

Описание параметров есть в справке Windows


taskkill.exe

Местонахождение

Windows\system32

Описание

Принудительное завершение процесса - Kill Process

Завершает одно или несколько заданий или процессов. Процессы могут быть уничтожены кодом процесса или именем образа.

Синтаксис

taskkill [/s компьютер] [/u домен\пользователь [/p пароль]]] [/fi имя_фильтра] [/pid код_процесса]|[/im имя_образа] [/f][/t]

Описание параметров есть в справке Windows


tasklist.exe

Местонахождение

Windows\system32

Описание

Задачи - Task List

Отображает список приложений и служб с кодом процесса (PID) для всех задач, выполняющихся на локальном или удаленном компьютере.

Синтаксис

tasklist[.exe] [/s компьютер] [/u домен\пользователь [/p пароль]] [/fo {TABLE|LIST|CSV}] [/nh] [/fi фильтр [/fi фильтр2 [ ... ]]] [/m [модуль] | /svc | /v]

Описание параметров есть в справке Windows

Чтобы получить список идентификаторов запущенных процессов, введите следующую команду и нажмите клавишу ВВОД:

tasklist > tasklist.txt
Примечание. Если программа выполняется в виде службы, добавьте в команду параметр /svc, чтобы составить перечень служб, которые загружаются каждым процессом:
tasklist /svc > tasklist.txt


taskmgr.exe

Местонахождение

Windows\system32

Описание

Диспетчер задач Windows - Windows TaskManager

Описание программы есть в справке Windows.

Советы

Запустить программу можно как по имени файла taskmgr.exe, так и одновременным нажатием трех клавиш (Ctrl+Alt+Del).

Откройте Диспетчер задач, дважды шелкните левой кнопкой мыши по серой области окна чуть ниже меню и она развернется на все окно. Чтобы вернуть все назад, кликните еще два раза по бортику окна.

Реестр

Запрет на запуск Диспетчера задач


tracert.exe

Местонахождение

Windows\system32

Описание

TCP/IP Traceroute Command

Определяет путь до точки назначения с помощью посылки в точку назначения эхо-сообщений протокола Control Message Protocol (ICMP) с постоянным увеличением значений срока жизни (Time to Live, TTL). Выведенный путь — это список ближайших интерфейсов маршрутизаторов, находящихся на пути между узлом источника и точкой назначения. Ближний интерфейс представляют собой интерфейс маршрутизатора, который является ближайшим к узлу отправителя на пути. Например, чтобы вывести трассу маршрута к http://www.microsoft.com, нужно набрать:

C:\>tracert www.microsoft.com
Запущенная без параметров, команда tracert выводит справку

Синтаксис

tracert [-d] [-h максимальное_число_переходов] [-j список_узлов] [-w интервал] [имя_конечного_компьютера]

Описание параметров есть в справке Windows


winmsd.exe

Местонахождение

WINDOWS\system32

Описание

Сведения о системе - System Information

Программа Сведения о системе собирает и отображает данные о конфигурации системы как для локальных, так и для удаленных компьютеров. Сюда входит информация о конфигурации оборудования, компонентах компьютера, а также программном обеспечении, в том числе о подписанных и неподписанных драйверах. При устранении неполадок, связанных с конфигурацией системы, сотрудникам службы технической поддержки необходимы определенные данные о компьютере. Данная программа позволяет быстро собрать необходимые данные.

К программе прилагается справка, в которой вы найдете дополнительную информацию.


wmic.exe

Местонахождение

WINDOWS\system32\wbem

Описание

командная строка wmi - wmi command line

Утилита командной строки wmic.exe собирает информацию из Инструментария управления Windows WMI (Windows Management Instrumentation) для локального администратора

Описание параметров есть в справке Windows. Вот небольшой скрипт для определения имени компьютера, версии операционной системы и номера сервис-пака:

@echo off
setlocal
for /f %%v in ('wmic os get version /value^|find "Version"') do set %%v
if "%Version:~0,4%" NEQ "5.1." goto finish
for /f %%v in ('wmic os get servicepackmajorversion /value^|find "ServicePackMajorVersion"') do set %%v
if "%ServicePackMajorVersion%" LSS "2" goto finish
@echo %computername% %Version% %ServicePackMajorVersion%
:finish
endlocal

В справке Windows есть несколько статей о данной программе.


wscript.exe

Местонахождение

Windows\system32

Описание

Microsoft (r) Windows Based Script Host

Сервер сценариев wscript.exe является GUI-вариантом, предназначенный для взаимодействия с пользователем через диалоговые окна Windows (в отличии от консольного приложения cscript.exe). С помощью сервера сценариев можно изменять реестр без вывода диалоговых окон, удалять и создавать файлы, многое другое.

Уникальная возможность - можно удалить файл скрипта до завершения его работы. То есть, скрипт сидит в памяти, а самого файла уже давно нет. Используя эту возможность можно создать так называемый скрипт-призрак.

Чтобы запустить написанный скрипт, можно просто дважды щелкнуть левой кнопкой мыши по нему в окне проводника. При этом сценарий запустится с настройками по умолчанию. Чтобы сценарий работал с другими параметрами, нужно в командной строке указать имя сервера сценариев, имя самого сценария и параметры запуска.

Синтаксис

wscript имя_сценария.расширение [параметры...] [аргументы...]
Чтобы получить полный список параметров, используйте wscript /?

Однако, такой вариант запуска изменит параметры по умолчанию для всех запускаемых впоследствии сценариев. Если в этом нет необходимости, есть возможность задать свои параметры для каждого отдельного файла сценария, более того, можно задать несколько вариантов запуска одного и того же сценария. Для этих целей служит файл с расширением wsh. Он представляет собой обычный текстовый файл и по своей структуре очень похож на inf или ini файл. Чтобы создать простейший *.wsh файл откройте свойства любого скрипта и на вкладке "Сценарий" измените любой параметр. После нажатия на "OK" в том же каталоге появится файл с аналогичным именем и расширением wsh. Вот пример одного из таких файлов:

[ScriptFile]
Path=G:\files\p010.js
[Options]
Timeout=0
DisplayLogo=1

В секции [ScriptFile] есть только один параметр - Path, который указывает на запускаемый скрипт, в секции [Options] перечисляются параметры для запуска этого скрипта.

Если теперь запустить созданный нами файл, он будет выполняться с настроенными параметрами.

Возможность указания параметров при старте сценариев является, безусловно, очень полезной и позволяет более тонко контролировать процесс работы скрипта


whoami.exe

Местонахождение

Support\Tools

Описание

Whoami - queries user information

Утилита командной строки позволяет получать информацию о пользователе (учетная запись, SID, привилегии)

Синтаксис

whoami [/option] [/option]

Используйте параметр /help для получения информации о параметрах программы. Например, для получения идентификаторов безопасности используйте строку

whoami /all /sid


AppEvent.Evt

Местонахождение

WINDOWS\system32\config

Файл AppEvent.Evt является журналом событий приложений, используемого реестром Windows


boot.ini

Местонахождение

C:\ (в корневой папке системного диска)

Описание

Файл boot.ini имеет очень много настроек. Microsoft посвятила описанию настроек в данном файле целую страницу на своем сайте. Оставляю описание почти без изменений. Если есть желание, то можете присылать переводы

Доступные ключи для файла boot.ini (Windows XP и Windows Server 2003)

Вы можете добавлять в файл boot.ini различные ключи, которые используются при загрузке системы Windows XP или Windows Server 2003.

/3GB

This switch forces x86-based systems to allocate 3 GB of virtual address space to programs and 1 GB to the kernel and to executive components. A program must be designed to take advantage of the additional memory address space. With this switch, user mode programs can access 3 GB of memory instead of the usual 2 GB that Windows allocates to user mode programs. The switch moves the starting point of kernel memory to 3 GB. Some configurations of Microsoft Exchange Server 2003 and Microsoft Windows Server 2003 may require this switch.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

823440 You must use the /3GB switch when you install Exchange Server 2003 on a Windows Server 2003-based system

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

171793 Information on application use of 4GT RAM tuning

/basevideo

Ключ /basevideo позволяет загружаться с использованием основного стандартного драйвера VGA (640x480, 16 цветов). Этот режим полезен, если причиной неправильной загрузки Windows является новый драйвер для видеоадаптера. Основной драйвер видеоадаптера всегда используется при загрузке в безопасном режиме («Безопасный режим», «Безопасный режим с загрузкой сетевых драйверов» или «Безопасный режим с поддержкой командной строки»). Причиной сбое может быть неправильное разрешение экрана и частота развертки. Можно для удобства также использовать в связке ключ /sos.

/baudrate=number

This switch sets the baud rate of the debug port that is used for kernel debugging. For example, type /baudrate=9600. The default baud rate is 9600 kilobits per second (Kbps) if a modem is attached. The default baud rate is 115,200 Kbps for a null-modem cable. 9,600 is the normal rate for remote debugging over a modem. If this switch is in the Boot.ini file, the /debug switch is automatically enabled.

For additional information about modem configuration, click the following article number to view the article in the Microsoft Knowledge Base:

148954 How to set up a remote debug session using a modem

For additional information about null modem configuration, click the following article number to view the article in the Microsoft Knowledge Base:

151981 How to set up a remote debug session using a null modem cable

/bootlog

При использовании данного параметра система записывает в файл Windows\Ntbtlog.txt перечень всех драйверов и служб, которые были загружены (или не загружены). При загрузке компьютера в безопасном режиме, в безопасном режиме с загрузкой сетевых драйверов и в безопасном режиме с поддержкой командной строки в журнал загрузки добавляется список всех загружаемых драйверов и служб. Журнал загрузки полезен для определения точной причины неполадок при загрузке системы.

/bootlogo

Используется собственный экран загрузки в Windows XP или Windows Server 2003, вместо стандартного экрана с бегающей полоской индикатора. Предварительно следует создать 16-цветную растровую картинку размером 640x480 пикселов и сохранить ее в папке Windows под именем Boot.bmp. Затем добавить в boot.ini ключи "/bootlogo /noguiboot".

/break

Causes the hardware abstraction layer (HAL) to stop at a breakpoint at HAL initialization. The first thing the Windows kernel does when it initializes is to initialize the HAL, so this breakpoint is the earliest one possible. The HAL will wait indefinitely at the breakpoint until a kernel-debugger connection is made. If the switch is used without the /DEBUG switch, the system will Blue Screen with a STOP code of 0x00000078 (PHASE0_ EXCEPTION).

/burnmemory=number

This switch specifies the amount of memory, in megabytes, that Windows cannot use. Use this parameter to confirm a performance problem or other problems that are related to RAM depletion. For example, type /burnmemory=128 to reduce the physical memory that is available to Windows by 128 MB.

/CHANNEL=

Used on conjunction with /DEBUGPORT=1394 to specify the IEEE 1394 channel through which kernel debugging communications will flow. This can be any number between 0 and 62 and defaults to 0 if not set. Use this switch together with the /debug switch and the /debugport switch to configure Windows to send debug information over an Institute of Electrical and Electronics Engineers, Inc. (IEEE) 1394 port. To support debugging over a 1394 port, both computers must be running Microsoft Windows XP or later. The 1394 port has a maximum number of 63 independent communications channels that are numbered 0 through 62. Different hardware implementations support a different number of channels across one bus. Windows XP has a limit of four destination computers. However, this limitation is removed in Windows Server 2003. To perform debugging, select a common channel number to use on both the computer that the debugger runs on, which is also known as the host computer, and the computer that you want to debug, which is also known as the destination computer. You can use any number from 1 to 62.

To configure the destination computer

  1. Edit the Boot.ini file to add the /CHANNEL=x option to the operating system entry that you have configured for debugging. Replace x with the channel number that you want to use. For example, configure the [operating systems] area of the Boot.ini file to look similar to the following:
    [boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003, Enterprise" /fastdetect /debug /debugport=1394 /CHANNEL=3
  2. Plug the 1394 cable in one of the 1394 ports.
  3. Disable the 1394 host controller on the destination computer. To do this, start Device Manager, right-click the device, and then click Disable.
  4. Restart the computer.

To configure the host computer

  1. Plug the 1394 cable in one of the 1394 ports.
  2. Install the kernel debugger binary files.
  3. Start a command prompt. Press enter after you type each of the following commands:

    set_NT_DEBUG_BUS=1394
    set_NT_DEBUG_1394_CHANNEL=x
    kd -k

  4. Move to the folder where you installed the kernel debugger, and then type the following command:

    kd.exe

When you first start the debugger, a 1394 virtual driver is installed. This driver permits the debugger to communicate with the destination computer. You must be logged on with administrator rights for this driver installation to complete successfully.

/CLKLVL

Causes the standard x86 multiprocessor HAL (Halmps.dll) to configure itself for a level-sensitive system clock rather then an edge-triggered clock. Level-sensitive and edge-triggered are terms used to describe hardware interrupt types.

/CMDCONS

Passed when booting with into the Recovery Console (described later in this chapter).

/crashdebug

This switch loads the kernel debugger when you start the operating system. The switch remains inactive until a Stop message error occurs. /crashdebug is useful if you experience random kernel errors. With this switch, you can use the COM port for normal operations while Windows is running. If Windows crashes, the switch converts the port to a debug port. (This action turns on remote debugging.)

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

151981 How to set up a remote debug session using a null modem cable

/debug

This switch turns on the kernel debugger when you start Windows. The switch can be activated at any time by a host debugger that is connected to the computer, if you want to turn on live remote debugging of a Windows system through the COM ports. Unlike the /crashdebug switch, /debug uses the COM port whether you are debugging or not. Use this switch when you are debugging problems that are regularly reproducible.

For additional information about remote debugging, click the following article number to view the article in the Microsoft Knowledge Base:

121543 Setting up for remote debugging

/debugport=comnumber

This switch specifies the communications port to use for the debug port, where number is the communications port, such as COM1, that you want to use. By default, /debugport uses COM2 if it exists. Otherwise, the switch uses COM1. If you include this switch in the Boot.ini file, the /debug switch becomes active.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

151981 How to set up a remote debug session using a null modem cable

/EXECUTE

This option disables no-execute protection. See the /NOEXECUTE switch for more information.

/fastdetect:comnumber

This switch turns off serial and bus mouse detection in the Ntdetect.com file for the specified port. Use this switch if you have a component other than a mouse that is attached to a serial port during the startup process. For example, type /fastdetect:comnumber, where number is the number of the serial port. Ports may be separated with commas to turn off more than one port. If you use /fastdetect, and you do not specify a communications port, serial mouse detection is turned off on all communications ports.

Note In earlier versions of Windows, including Windows NT 4.0, this switch was named /noserialmice.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

131976 How to disable detection of devices on serial ports

The reason the qualifier exists (vs. just having NTDETECT perform this operation by default) is so that NTDETECT can support booting Windows NT 4. Windows Plug and Play device drivers perform detection of parallel and serial devices, but Windows NT 4 expects NTDETECT to perform the detection. Thus, specifying /FASTDETECT causes NTDETECT to skip parallel and serial device enumeration (actions that are not required when booting Windows), whereas omitting the switch causes NTDETECT to perform this enumeration (which is required for booting Windows NT 4).

/HAL=filename

With this switch, you can define the actual hardware abstraction layer (HAL) that is loaded at startup. For example, type /HAL=halmps.dll to load the Halmps.dll in the System32 folder. This switch is useful to try out a different HAL before you rename the file to Hal.dll. This switch is also useful when you want to try to switch between starting in multiprocessor mode and starting in single processor mode. To do this, use this switch with the /kernel switch.

/INTAFFINITY

Directs the standard x86 multiprocessor HAL (Halmps.dll) to set interrupt affinities such that only the highest numbered processor will receive interrupts. Without the switch, the HAL defaults to its normal behavior of letting all processors receive interrupts.

/kernel=filename

With this switch, you can define the actual kernel that is loaded at startup. For example, type /kernel=ntkrnlmp.exe to load the Ntkrnlmp.exe file in the System32 folder. With this switch, you can switch between a debug-enabled kernel that is full of debugging code and a regular kernel. Enable you to override Ntldr's default filename for the kernel image (Ntoskrnl.exe) and/or the HAL (Hal.dll). These options are useful for alternating between a checked kernel environment and a free (retail) kernel environment or even to manually select a different HAL. If you want to boot a checked environment that consists solely of the checked kernel and HAL, which is typically all that is needed to test drivers, follow these steps on a system installed with the free build: • Copy the checked versions of the kernel images from the checked build CD to your \Windows\System32 directory, giving the images different names than the default. For example, if you're on a uniprocessor, copy Ntoskrnl.exe to Ntoschk.exe and Ntkrnlpa.exe to Ntoschkpa.exe. If you're on a multiprocessor, copy Ntkrnlmp.exe to Ntoschk.exe and Ntkrpamp.exe to Ntoschkpa.exe. The kernel filename must be an 8.3-style short name. • Copy the checked version of the appropriate HAL needed for your system from \I386\Driver.cab on the checked build CD to your \Windows\System32 directory, naming it Halchk.dll. To determine which HAL to copy, open \Windows\Repair\Setup.log and search for Hal.dll; you'll find a line like \WINDOWS\system32\ hal.dll="halacpi.dll","1d8a1". The name immediately to the right of the equals sign is the name of the HAL you should copy. The HAL filename must be an 8.3-style short name. • Make a copy of the default line in the system's Boot.ini file. • In the string description of the boot selection, add something that indicates that the new selection will be for a checked build environment (for example, “Windows XP Professional Checked”). • Add the following to the end of the new selection's line: /KERNEL=NTOSCHK.EXE /HAL= HALCHK.DLL Now when the selection menu appears during the boot process you can select the new entry to boot a checked environment or select the entry you were using to boot the free build.

/LASTKNOWNGOOD

Causes the system to boot as if the LastKnownGood boot option was selected.

/maxmem=number

This switch specifies the maximum amount of RAM that Windows can use. Do not make this setting less than 12. Use this parameter to confirm whether a memory chip is faulty. For example, if you have a 128-megabyte (MB) system that is equipped with two 64-MB RAM modules, and you are experiencing memory-related Stop messages, you can type /maxmem=64. If the computer starts Windows and operates without problems, replace the first module to see if this action resolves the problem.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

108393 MAXMEM option in Windows NT Boot.ini file

/MAXPROCSPERCLUSTER=

For the standard x86 multiprocessor HAL (Halmps.dll), forces cluster-mode Advanced Programmable Interrupt Controller (APIC) addressing (not supported on systems with an 82489DX external APIC interrupt controller).

/MININT

This option is used by Windows PE (Preinstallation Environment) and causes the Configuration Manager to load the Registry SYSTEM hive as a volatile hive such that changes made to it in memory are not saved back to the hive image.

/NODEBUG

Prevents kernel-mode debugging from being initialized. Overrides the specification of any of the three debug-related switches, /DEBUG, /DEBUGPORT, and /BAUDRATE.

/NOEXECUTE

This option is only available on 32-bit versions of Windows when running on processors supporting no-execute protection. It enables no-execute protection (also known as Data Execution Protection - DEP), which results in the Memory Manager marking pages containing data as no-execute so that they cannot be executed as code. This can be useful for preventing malicious code from exploiting buffer overflow bugs with unexpected program input in order to execute arbitrary code. No-execute protection is always enabled on 64-bit versions of Windows on processors that support no-execute protection. There are several options you can specify with this switch: /NOEXECUTE=OPTIN Enables DEP for core system images and those specified in the DEP configuration dialog. /NOEXECUTE=OPTOUT Enables DEP for all images except those specified in the DEP configuration dialog. /NOEXECUTE=ALWAYSON Enables DEP on all images. /NOEXECUTE=ALWAYSOFF Disables DEP.

/noguiboot

Данный ключ позволяет отключить загрузочный экран, в котором вы обычно видите логотип Windows XP и индикатор прогресса.

/nodebug

This switch turns off debugging. This scenario can cause a Stop error if a program has a debug hardcoded breakpoint in its software.

/NOLOWMEM

Requires that the /PAE switch be present and that the system have more than 4 GB of physical memory. If these conditions are met, the PAE-enabled version of the Windows kernel, Ntkrnlpa.exe, won't use the first 4 GB of physical memory. Instead, it will load all applications and device drivers, and allocate all memory pools, from above that boundary. This switch is useful only to test device driver compatibility with large memory systems.

/NOPAE

Forces Ntldr to load the non-Physical Address Extension (PAE) version of the Windows kernel, even if the system is detected as supporting x86 PAEs and has more than 4 GB of physical memory.

/NOSERIALMICE=[COMx | COMx,y,z...]

Obsolete Windows NT 4 qualifier—replaced by the absence of the /FASTDETECT switch. Disables serial mouse detection of the specified COM ports. This switch was used if you had a device other than a mouse attached to a serial port during the startup sequence. Using /NOSERIALMICE without specifying a COM port disables serial mouse detection on all COM ports. See Microsoft Knowledge Base article Q131976 for more information.

/numproc=number

This switch sets the number of processors that Windows will run at startup. With this switch, you can force a multiprocessor system to use only the quantity of processors (number) that you specify. This switch can help you troubleshoot performance problems and defective CPUs.

/ONECPU

Causes Windows to use only one CPU on a multiprocessor system.

/PAE

Causes Ntldr to load Ntkrnlpa.exe, which is the version of the x86 kernel that is able to take advantage of x86 PAEs. The PAE version of the kernel presents 64-bit physical addresses to device drivers, so this switch is helpful for testing device driver support for large memory systems. Use the /PAE switch with the corresponding entry in Boot.ini to permit a computer that supports physical address extension (PAE) mode to start normally. In Safe Mode, the computer starts by using normal kernels, even if the /PAE switch is specified.

/pcilock

For x86-based systems, this switch stops the operating system from dynamically assigning hardware input, hardware output, and interrupt request resources to Peripheral Connect Interface (PCI) devices. With this switch, the BIOS configures the devices.

/RDPATH=

Specifies the path to a System Disk Image (SDI) file, which can be on the network, that the system will use to boot from. Often used in conjunction with the /RDIMAGEOFFSET= flag to indicate to NTLDR where in the file the system image starts.

/REDIRECT

Introduced with Windows XP. Used to cause Windows to enable Emergency Management Services (EMS) that reports boot information and accepts system management commands through a serial port. Specify serial port and baudrate used in conjunction with EMS with redirect= and redirectbaudrate= lines in the [boot loader] section of the Boot.ini file. Use this switch to turn on Emergency Management Services (EMS) on a Windows Server 2003, Enterprise Edition-based computer. For additional information about EMS, search on "Emergency Management Services" in Windows Help and Support.

To turn on EMS by editing the Boot.ini on an x86-based computer, edit both the [boot loader] section and the [operating systems] section of the Boot.ini file. To do this, configure the following entries:
  • Under [boot loader], add one of the following required statements:
    redirect=COMx
    In this statement, replace x with one of the following COM port numbers:

    1
    2
    3
    4

    redirect=USEBIOSSETTINGS
    This statement permits the computer BIOS to determine the COM port to use for EMS.
  • Under [boot loader], add the following option statement:
    redirectbaudrate=baudrate
    Replace baudrate with one of the following values:

    9600
    19200
    57600
    115200

    By default, EMS uses the 9600 Kbps baud rate setting.
  • Under [operating systems], add the /redirect option to the operating system entry that you want to configure to use EMS. The following example illustrates the use of these switches:
    [boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
redirect=COM1
redirectbaudrate=19200
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003, Enterprise" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003, EMS" /fastdetect /redirect

/safeboot:parameter

This switch causes Windows to start in Safe Mode. This switch uses the following parameters:
  • minimal
  • network
  • safeboot:minimal(alternateshell)
You can combine other Boot.ini parameters with /safeboot:parameter. The following examples illustrate the parameters that are in effect when you select a Safe Mode option from the startup recovery menu.
  • Safe Mode with Networking
    /safeboot:minimal /sos /bootlog /noguiboot
  • Safe Mode with Networking
    /safeboot:network /sos /bootlog /noguiboot
  • Safe Mode with Command Prompt
    /safeboot:minimal(alternateshell) /sos /bootlog /noguiboot
Note The /sos, /bootlog, and /noguiboot switches are not required with any one of these settings, but the switches can help with troubleshooting. These switches are included if you press F8 and then select one of the modes. Specifies options for a safe boot. You should never have to specify this option manually, since Ntldr specifies it for you when you use the F8 menu to perform a safe boot. (A safe boot is a boot in which Windows only loads drivers and services that are specified by name or group under the Minimal or Network registry keys under HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot.) Following the colon in the option you must specify one of three additional switches: MINIMAL, NETWORK, or DSREPAIR. The MINIMAL and NETWORK flags correspond to safe boot with no network and safe boot with network support, respectively. The DSREPAIR (Directory Services Repair) switch causes Windows to boot into a mode in which it restores the Active Directory directory service from a backup medium you present. An additional option you can append is (ALTERNATESHELL), which tells Windows to use the program specified by the HKLM\SYSTEM\CurrentControlSet\ SafeBoot\AlternateShell value as the graphical shell rather than to use the default, which is Windows Explorer.

/SCSIORDINAL:

Directs Windows to the SCSI ID of the controller. (Adding a new SCSI device to a system with an on-board SCSI controller can cause the controller's SCSI ID to change.) See Microsoft Knowledge Base article Q103625 for more information.

/SDIBOOT=

Used in Windows XP Embedded systems to have Windows boot from a RAM disk image stored in the specified System Disk Image (SDI) file.

/sos

The /sos switch displays the device driver names while they are being loaded. By default, the Windows Loader screen only echoes progress dots. Use this switch with the /basevideo switch to determine the driver that is triggering a failure.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

99743 Purpose of the Boot.ini file in Windows 2000 or Windows NT

/userva

Use this switch to customize the amount of memory that is allocated to processes when you use the /3GB switch. This switch permits more page table entry (PTE) kernel memory but still maintains almost 3 GB of process memory space.

For additional information about how to use the /USERVA switch, click the following article number to view the article in the Microsoft Knowledge Base:

316739 How to use the /USERVA switch in the Boot.ini file to tune /3GB configurations

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

810371 XADM: Using the /userva switch on Windows Server 2003-based Exchange Servers

323427 HOW TO: Manually edit the Boot.ini file in a Windows Server 2003 environment

317526 HOW TO: Edit the Boot.ini file in Windows Server 2003

317521 Description of the Bootcfg command and its uses

289022 HOW TO: Edit the Boot.ini file in Windows XP

291980 A discussion about the Bootcfg command and its uses

/WIN95

Directs Ntldr to boot the Consumer Windows boot sector stored in Bootsect.w40. This switch is pertinent only on a triple-boot system that has MS-DOS, Consumer Windows, and Windows installed. See Microsoft Knowledge Base article Q157992 for more information.

/WIN95DOS

Directs Ntldr to boot the MS-DOS boot sector stored in Bootsect.dos. This switch is pertinent only on a triple-boot system that has MS-DOS, Consumer Windows, and Windows installed. See Microsoft Knowledge Base article Q157992 for more information.

/YEAR=

Instructs the Windows core time function to ignore the year that the computer's real-time clock reports and instead use the one indicated. Thus, the year used in the switch affects every piece of software on the system, including the Windows kernel. Example: /YEAR=2001. (This switch was created to assist in Y2K testing.)


filelist.xml

Местонахождение

WINDOWS\system32\Restore

Скрытый файл filelist.xml содержит список файлов и настроек, за которыми следит программа восстановления системы rstrui.exe. Вы можете просмотреть данный файл в Internet Explorer. Изучив внимательно XML-файл, можно заметить, что он дает указание программе восстановления системы следить за файлами определенных расширений, заданными папками и ветвями реестра


hosts

Местонахождение

WINDOWS\system32\drivers\etc

Специальный файл hosts (обратите внимание, что файл без расширения) предназначен для сопоставления IP-адресов и имен серверов. Наиболее распространенное использование - Блокировка рекламных сайтов (подробнее в справочнике Народные советы)


lusrmgr.msc

Местонахождение

Windows\system32

Локальные пользователи и группы - Local Users and Groups

Оснастка Локальные пользователи и группы — это инструмент, предназначенный для управления локальными пользователями и группами. В Windows XP Home Edition данная оснастка отсутствует.

Будьте осторожны с неиспользуемыми пользовательскими учетными записями. Например, на вашем компьютере была учетная запись сотрудника фирмы. После увольнения сотрудника неиспользуемую учетную запись лучше сразу же отключить. Запустите остнастку и в появившемся окне из соответствующей папки выберите «отслужившего» пользователя. Щелкнув правой кнопкой мыши в свойствах учетной записи активируйте пункт Отключить учетную запись. Читатели могут удивиться: а зачем отключать, если можно удалить? Можно и удалить, но при удалении учетной записи безвозвратно теряется ее идентификатор безопасности SID (даже если вы потом снова создадите новую запись с тем же именем и паролем, идентификатор все равно будет уже другим). А с потерей SID вы потеряете доступ ко всем закодированным файлам и паролям, которые использовал прежний пользователь.

Обладатели XP Home Edition оснастка могут воспользоваться утилитой net для отключения пользователя.

net user имя_пользователя /active :no


mydocs.dll

Местонахождение

Windows\system32

Описание

Пользовательский интерфейс папки "Мои документы"

Windows XP сама создает свои подпапки в папке Мои документы (My Pictures, My Video и др.). При удалении этих папок они создаются заново! Если вам не нравится подобное поведение, то надо лишь выполнить команду regsvr32 /u mydocs.dll и подпапки создаваться не будут. А если захотите вернуть все обратно, то введите в командной строке следующее: regsvr32 mydocs.dll


ntshrui.dll

Местонахождение

Windows\system32

Описание

Расширения оболочки, обеспечивающие доступ к ресурсам - Shell extensions for sharing

Файл, в котором содержатся различные данные, необходимые для работы с ресурсами. В частности в этом файле содержится изображение ладошки, используемое в значках расшаренных ресурсов. Чтобы удалить эту ладошку, можно воспользоваться правкой реестра (смотри Справочник по реестру Windows)


ntuser.dat

Местонахождение

C:\Documents and Settings\ИмяПользователя

Файл ntuser.dat является кустом реестра Windows HKEY_USERS/SID


oeminfo.ini

Местонахождение

Windows\system32

Описание

Если создать текстовый файл oeminfo.ini и поместить его в системную папку Windows (как правило Windows\system32), то в апплете Система Панели управления, появится кнопка Сведения о поддержке

Файл oeminfo.ini имеет следующую структуру:

[General]
Manufacturer=Название компании
Model=Название модели

[Support Information]
Line1=За поддержкой обращайтесь по телефону 03
Line2=Бла-бла-бла
Line3=Часы работы:
Line4=Понедельник-Пятница 08.00-16.00
Line5=Суббота-Воскресенье 11.00-12.00!
Line6=Всего шесть строчек

Строго говоря, данный файл не присутствует на чистом инсталяционном диске Windows, но может входить в Windows, который предустановлен на компьютерах различных производителей, имеющих соответствующую лицензию.

Смотри также файл oemlogo.bmp


oemlogo.bmp

Местонахождение

Windows\system32

Описание

Чтобы добавить собственную картинку в апплет Система Панели управления, надо создать или модифицировать картинку, которая находится в файле oemlogo.bmp и поместить файл в системную папку Windows (как правило Windows\system32)

Файл oemlogo.bmp создается в любом графическом редакторе (напр. Paint) с размером 172 на 100 пикселов (русская версия Windows XP). Надо сказать, что размеры картинки в разных версиях Windows постоянно менялись. Как правило, слишком большая картинка просто обрезается. Также необходимо иметь в этой же папке файл oeminfo.ini, иначе картинка не будет выводиться вообще

Строго говоря, данный файл не присутствует на чистом инсталяционном диске Windows, но может входить в Windows, который предустановлен на компьютерах различных производителей, имеющих соответствующую лицензию.


pfirewall.log

Местонахождение

WINDOWS

В файл pfirewall.log записывается информация, которую впоследствии можно использовать для устранения неполадок. По умолчанию, данный файл находится в папке Windows. Вы можете изменить местонахождение данного файла. Для этого выбираем Пуск Панель управления Брандмауэр Windows Допольнительно Ведение журнала безопасности кнопка Параметры. В диалоговом окне вы можете изменить имя файла и его местоположение. А также управлять размером данного файла. Если вы уберете галочки с двух верхних кнопок, то данного файла на компьютере не будет.


SAM

Местонахождение

WINDOWS\system32\config

Файл SAM (обратите внимание, что файл без расширения) содержит раздел реестра HKLM\SAM


SecEvent.Evt

Местонахождение

WINDOWS\system32\config

Файл SecEvent.Evt является журналом событий безопасности, используемого реестром Windows


SECURITY

Местонахождение

WINDOWS\system32\config

Файл SECURITY (обратите внимание, что файл без расширения) содержит раздел реестра HKLM\SECURITY


shmedia.dll

Местонахождение

Windows\system32

Описание

Извлечение свойств медиа-файлов - Media File Property Extractor Shell Extension

Эта библиотаек отвечает за сбор информации об AVI-файлах. На некоторых компьютерах при щелчке правой кнопкой по файлу с расширением AVI выскакивает окно с ошибкой "Explorer.exe Обнаружена ошибка...". В этом случае попробуйте отключить библиотеку

Пуск | Выполнить | regsvr32 /u %SystemRoot%\system32\shmedia.dll


software

Местонахождение

WINDOWS\system32\config

Файл software (обратите внимание, что файл без расширения) содержит раздел реестра HKLM\Software


srclient.dll

Местонахождение

WINDOWS\system32

Описание

SR CLIENT DLL

Файл srclient.dll является клиентской DLL для программы восстановления системы rstrui.exe и используется при написании скриптов


Svcpack.log

Местонахождение

Windows

Описание

Файл Svcpack.log является протоколом хода установки сервис-пака. Исследуя лог установки, вы можете найти причины неудачной установки. Например, если вы увидите такие записи: "There is not enough space on the disk. Service Pack 2 installation did not complete", то станет ясно, что программе установки не хватает места на жестком диске. Попробуйте освободить диск от лишних файлов и повторите попытку.


SysEvent.Evt

Местонахождение

WINDOWS\system32\config

Файл SysEvent.Evt является журналом событий системы, используемого реестром Windows


system

Местонахождение

WINDOWS\system32\config

Файл system (обратите внимание, что файл без расширения) содержит раздел реестра HKLM\System


UsrClass.dat

Местонахождение

C:\Documents and Settings\ИмяПользователя\Local Settings\Application Data\Microsoft\Windows

Файл UsrClass.dat является кустом реестра Windows HKEY_USERS/SID_Classes


WindowsUpdate.log

Местонахождение

Windows

Файл, содержащий историю автоматического обновления.


wpa.dbl

Местонахождение

Windows\system32

Описание

Как известно, лицензионная Windows XP при переустановке системы требует повторной активации. Чтобы этого избежать, достаточно перед переустановкой системы скопировать файл wpa.dbl, расположенный в папке windows\System32, например, на дискету - именно в этом файле хранится код активации. После переустановки системы, естественно, нужно будет заменить файл wpa.dbl на тот, что записали на дискету.


DBX-файлы

В файлах с расширением DBX хранятся записи программы Outlook Express. В этих файлах, называемых Банком сообщений, находятся письма, сообщения новостных групп и т.п. При желании, можно скопировать эти файлы на носитель информации для переноса данных в другой компьютер.


INF-файлы

В данной статье мы рассмотрим, что представляет собой INF-файл, как с его помощью работать с другими файлами и реестром, создавать ярлыки, запускать программы и т.д.

Как известно, для более-менее серьезного программного продукта обычно требуется специальная программа инсталляции, с помощью которой пользователь сможет легко установить и так же легко удалить сам продукт. Существует много инструментальных средств, позволяющих быстро создавать инсталляционные пакеты. Однако, большинство из них добавляют к исходному размеру программы 200–500 Кб. А ведь это далеко не всегда радует. Серьезный продукт не обязательно должен быть внушительных размеров. И если вы хотите сделать инсталляцию доступной в Сети, то эти 200–500 Кб могут сильно сказаться на популярности продукта.

Как выйти из подобной ситуации? Здесь на помощь придут inf-файлы. Именно с помощью inf-файлов можно удалять, копировать другие файлы, добавлять информацию в реестр, в ini-файлы, создавать ярлыки, в общем, все то же, что обеспечивают громоздкие программы установки.

Перейдем к изучению спецификации inf-файлов.

inf-файл представляет собой текстовый файл, который, содержит условия установки программного обеспечения.

Чтобы запустить inf-файл, нужно щелкнуть по нему правой кнопкой мыши и выбрать в открывшемся контекстном меню параметр Установить (Install). Но для подготовки дистрибутива можно воспользоваться IExpress, который поддерживает запуск .inf-файлов. Вооружившись этой программой, а также знанием спецификации .inf-файлов, можно создавать профессиональные инсталляционные пакеты.

Основную информацию в .inf-файле содержат секции, представленные в Таблице 1 (более сложные .inf-файлы могут иметь дополнительные секции).

Секция [Version] обязательно должна включать строку

Эта секция определяет стандартный заголовок для всех inf-файлов Microsoft Windows. Если сигнатура будет не $Chicago$, операционная система Windows не примет inf-файл как принадлежащий любому из классов устройств, признанных Windows.

При написании сигнатуры вы можете использовать как верхний, так и нижний регистры букв — $Chicago$ или $CHICAGO$.

Секция установки [DefaultInstall] может содержать следующие параметры:

CopyFiles — копирование файлов;

RenFiles — переименование файлов;

DelFiles — удаление файлов;

UpdateInis — изменение данных в ini-файлах;

UpdateIniFields — изменение областей в .ini-файлах;

AddReg — добавление информации в реестр;

DelReg — удаление информации из реестра;

Ini2Reg — перемещение строки или секции в ini-файлах;

UpdateCfgSys — изменение файла Config.sys;

UpdateAutoBat — изменение файла Autoexec.bat.

Этим параметрам в качестве значения присваивается имя секции с файлами. Например:

Чуть ниже представлены цифровые обозначения специальных папок, применяемые в .inf-файлах:

10 — C:\WINDOWS;

11 — C:\WINDOWS\System;

12 — C:\WINDOWS\SYSTEM\IOSUBSYS;

13 — C:\WINDOWS\COMMAND;

17 — C:\WINDOWS\Inf;

18 — C:\WINDOWS\Hlp;

20 — C:\WINDOWS\FONTS;

21 — C:\WINDOWS\SYSTEM\VIEWERS;

22 — C:\WINDOWS\SYSTEM\VMM32;

23 — C:\WINDOWS\SYSTEM\COLOR;

30 — Корневой загрузочный диск (обычно C:\).

Например, если нужно скопировать файл в папку Web, которая находится в каталоге Windows, сделайте это так:

Так же можно поступить и с другими папками, находящимися в определенных каталогах.

Параметр CopyFiles содержит имя секции, где находятся имена файлов для копирования с исходного диска в папку назначения. Папка назначения определяется в секции [DestinationDirs] inf-файла. В следующем примере копируются два файла:

Цифры через три запятые обозначают дополнительные флаги при копировании файлов и могут принимать значения, представленные в

Параметр CopyFiles может копировать файл непосредственно из строки. Для этого перед именем файла нужно поставить символ @. В следующем примере копируются два текстовых файла:

Параметр RenFiles содержит секции, которые в свою очередь содержат имена файлов для переименования. Папка, где будет происходить переименование, должна быть определена в секции [DestinationDirs] inf-файла. В следующий примере происходит переименование двух файлов из .bmp в .txt:

Все старые имена файлов (Example1.bmp, Example2.bmp) должны быть определены в секции [SourceDisksFiles].

Параметр DelFiles содержит секции, которые содержат имена файлов для удаления. Папка, где будет происходить удаление, как всегда, должна быть определена в секции [DestinationDirs] .inf-файла. Следующий пример удаляет два файла:

В параметре AddReg указываются секции, которые содержат информацию о добавлении или изменении ключей, значений в реестре. Следующий пример регистрирует вашу копию операционной системы Windows.

С помощью этого файла в реестр добавляется следующая информация:

Обратите внимание на запятые в inf-файле. Если нужно добавить в реестр параметр по умолчанию, запятые должны быть проставлены иначе. Например, в рассмотренном нами ключе реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion сделаем параметр по умолчанию равным единице (1):

Ниже представлены корневые имена реестра, применяемые в inf-файлах.

HKCR — HKEY_CLASSES_ROOT;

HKCU — HKEY_CURRENT_USER;

HKLM — HKEY_LOCAL_MACHINE;

HKU — HKEY_USERS;

HKR — относительный ключ, используется классом installer; обычно применяется для дисков устройства.

В параметре DelReg указываются секции, которые содержат информацию об удалении подключей с параметрами и значениями из реестра. Следующий пример демонстрирует удаление подключа Graphviz со всеми параметрами и значениями этого раздела реестра — HKEY_CURRENT_USER\Software\AT&T\Graphviz:

Корневые имена реестра, естественно, обозначаются так же, как и при добавлении информации в реестр.

В процессе установки можно прервать выполнение .inf-файла для показа пользователю какого-нибудь документа (после закрытия которого установка продолжится) или запустить определенный процесс. Следующий пример отображает файл справки About.hlp и текстовый файл About.txt, после чего запускает другой inf-файл — Example.inf:

После того как определенные в секции [ExampleView] команды выполнятся, записи, добавленные в реестр, будут автоматически удалены из него. Таким образом можно запускать и другие процессы, например апплеты Панели управления:

В следующем примере показано, как с помощью inf-файла изменить содержимое ini-файла:

С помощью inf-файлов можно также создавать/удалять ярлыки в меню Пуск. Ярлык можно создать в уже созданной группе программ. Если таковой не существует, она будет создана автоматически.

Следующий пример создает группу программ Windows + + в меню Пуск > Программы и ярлыки к утилитам winipcfg.exe (Конфигурация IP), Regedit.exe (Редактор реестра) и Winfile.exe (Диспетчер файлов — только в Win98). Все они есть у вас на компьютере и лежат в папке Windows.

Ярлык прописывается в таком порядке:

1. Название группы программ. В нашем случае — Windows + +.

2. Имя ярлыка.

3. Путь к программе, к которой создается ярлык.

4. Рабочий каталог, обычно тот же, что и путь. Некоторые программы не работают, если это условие не выполняется.

5. Имя программы с расширением.

Параметр %30%\ определяет корневой диск. Если вы хотите создать ярлык к файлу, который находиться в каталоге Program Files, смело прописывайте полный путь (не используйте короткие имена), например %30%\Program Files\Setup Generator Pro\Sgpro.exe.

Для удаления ярлыка нужно убрать все записи, указанные после имени ярлыка. В следующем примере удаляется ярлык Конфигурация IP из программной группы Windows + +.

Если вы удаляете один из ярлыков программной группы, то удаление не затронет другие ярлыки. Для полного удаления программной группы нужно прописать данное действие для каждого ярлыка.

К сожалению, вы не сможете с помощью inf-файла обычным способом скопировать файлы с длинными именами. Поддержка длинных файловых имен в .inf-файлах немного усложнена, но главное, что она существует. Для этого нужно проделать следующее: исходный файл должен быть с коротким именем, после установки его имя нужно сделать подлиннее. Для удаления процесс повторяется в обратном порядке: длинное файловое имя делается коротким и удаляется уже файл с 8.3-именем. Происходит все это с помощью реестра. Для этих действий в реестре предусмотрены специальные ключи:

Для действий переименования или удаления нужно добавить подключ с любым именем в соответствующую ветвь реестра. Минимум два ключа должны быть определены. Первый ключ содержит имя каталога, где будет происходить переименование или удаление файлов. Следующий ключ содержит имена файлов: первое — короткое, второе — длинное и его атрибуты, если нужно:

1 — Только для чтения;

2 — Скрытый;

3 — Системный.

Следующий пример демонстрирует переименование в каталоге C:\Files файла About.txt в About View files.txt и установление ему атрибута «Скрытый», а также переименование того же файла в подкаталоге Xmp папки C:\Files с установлением ему атрибута «Только для чтения»:

Ключи для удаления файлов имеют такую же структуру. Рассмотрим пример, который в каталоге C:\Files удаляет файл About View files.txt и такой же файл удаляет в подкаталоге Xmp папки C:\Files:

Параметры Example и SubDir могут быть любыми, например названием вашей программы, подкаталога и т.д. Важно, чтобы они были разными, т.к. переименование/удаление происходит в разных каталогах.

Данная статья не претендует на полноту, но надеюсь, поможет читателю освоить inf-файлы хотя бы поверхностно. Не бойтесь экспериментировать, но будьте предельно осторожны, особенно с процессами удаления.


HTA-файлы

HTML-приложения

Начиная с Internet Explorer 5.0 появилась возможность создавать HTML-приложения с любым пользовательским интерфейсом при помощи JavaScript или VBScript. Причем, созданное html-приложение будет запускаться вне браузера и ничем не будет отличаться от стандартных Windows-приложений.

Созданное приложение будет присутствовать на панели задач, иметь свое собственное окно, меню и значок. Плюс ко всему отпадает необходимость подтверждать использование ActiveX-компонентов (система защиты Internet Explorer предусматривает появление предупреждающих сообщений при попытке использования ActiveX в HTML-документах). Вы имеете полный контроль над системой, включая чтение/запись файлов, данных в реестре, управление процессами. Для создания такого приложения достаточно обычного Блокнота (или другой текстовый редактор).

Данные html-приложения должны иметь расширение *.hta. Простейший случай будет выглядеть так:

Создайте подобный файл и запустите его. Как видите, появившееся окно ничем не напоминает браузер, однако вы можете использовать такую возможность, например, как Refresh документа (в нашем случае это главное окно будущего приложения) или изменение кодировки на лету. Для удаления полосы прокрутки мы воспользовались параметром SCROLL=no в тэге BODY, можно также воспользоваться специальными свойствами тэга HTA.

HTA-файлы обрабатывается программой mshta.exe, задача которой - обеспечить связь вашей программы с браузером.

Для того чтобы полностью использовать новые возможности, необходимо включить тэг HTA:APPLICATION между тэгами HEAD.

Как видно из приведенного примера, в тэге HTA:APPLICATION мы определяем специфические для HTA параметры. Рассмотрим их подробнее.

  • ID - идентификатор, который позволяет обращаться к нему как к объекту в скриптах

    Например:

  • APPLICATIONNAME - возвращает имя вашего приложения. Должно быть уникальным.

  • BORDER - позволяет задать тип окантовки окна. Доступны следующие значения:

    thick — толстая рамка, позволяющая изменять размер окна;

    dialog — обычная рамка без возможности изменять размер;

    none — рамка отсутствует;

    thin — тонкая без возможности изменять размер;

    Дополнительно указывается стиль рамки при помощи атрибута BORDERSTYLE, который может иметь следующие значения:

    normal — обычная;

    raised — приподнятая (3D);

    complex — комбинация стилей raised и sunken;

    static — может использоваться для окон, в которых не предусмотрен пользовательский ввод, - к примеру, для создания «флэш»-окон;

    sunken — вдавленная (3D).

  • CAPTION - определяет, будет ли окно отображаться с заголовком. Может принимать значения yes или no.
  • ICON - путь к файлу, содержащему значок (*.ico), содержащий картинку 32х32 пикселя. Можно использовать в качестве иконки и обычный bmp-файл - главное, чтобы соблюдались размеры картинки.
  • SHOWINTASKBAR - если это свойство имеет значение yes, окно будет сворачиваться в панель задач, а также отображаться на Панели задач
  • SINGLEINSTANCE - позволяет разрешить запуск только одной копии вашего приложения; для того чтобы определить, запущенно ваше приложение во второй раз или нет, это свойство использует APPLICATIONNAME. Может принимать значения yes/no.
  • SYSMENU - будет ли отображаться системное меню.
  • WINDOWSTATE - определяет, в каком виде приложение будет стартовать.

    Принимает следующие значения:

    normal — обычное окно.

    minimize — свернуто.

    maximize — на весь экран.

  • MAXIMIZEBUTTON и MINIMIZEBUTTON принимают значения yes/no и отвечают за отображение кнопок Maximize и Minimize соответственно в заголовке окна.

Помимо атрибутов, характеризующих внешний вид программы, может быть задана версия продукта — например, так:

Для управления полосой прокрутки в окне HTA есть целых два параметра: SCROLL со значениями yes/no/auto и SCROLLFLAT — yes/no.

Если у вас установлен IE5.5, то вы можете воспользоваться дополнительным атрибутом NAVIGABLE, который позволяет переход по ссылке в окне HTA.

Для управления текстом предусмотрен параметр SELECTION (yes/no).

В дополнение ко всему перечисленному, вы можете иметь доступ к параметрам командной строки посредством свойства commandLine. Внимание, это свойство не имеет HTML-синтаксиса и может быть доступно только из скриптов! Немаловажно заметить, что все перечисленные параметры во время выполнения доступны только для чтения.

Давайте приступим к написанию своего первого скриптового приложения - создадим простейший текстовый редактор.

Константы для работы с диалогами открытия и сохранения файлов:

CdlOFNFileMustExist — пользователь может вводить только имя существующего файла, в противном случае возникнет предупреждение.

CdlOFNHideReadOnly — прячет опцию Hide Only (открыть только для чтения).

Константы для работы с файлами:

ForReading — файл открывается для чтения;

ForWriting — для записи в файл.

Создаем объект для доступа к файловой системе:

И настраиваем общие свойства для диалога открытия и сохранения:

Заголовок диалога:

Фильтр, для отображения групп файлов.

Вызываем диалог открытия и в случае если пользователь осуществил выбор пытаемся прочитать файл и отобразить его.

Естественно, дополнительными тэгами все вкусности скриптовых приложений не исчерпываются. Особую ценность представляет возможность повторного использования однажды написанного кода, создание универсальных компонентов, с которыми можно работать аналогично COM-компонентам. Дополнительную информацию, а также примеры и некоторую документацию вы можете найти по следующим адресам:

http://www.wshscripting.com/ — открытый исходный код и множество примеров скриптов для WSH (Windows Scripting Host).

Также стоит посетить http://www.serialscripter.com/, где помимо бесплатных HTA-приложений, сопровождающихся подробными описаниями, находится неплохая подборка ссылок на ресурсы, тем или иным образом связанные со скриптовым программированием.

Источник: http://www.mycomp.com.ua/


wscui.cpl

Местонахождение

Windows\system32

Описание

Центр обеспечения безопасности Windows - Security Center

Новый апплет панели управления, появившийся после выхода Пакета обновления 2 (Service Pack 2)

Центр обеспечения безопасности помогает управлять параметрами безопасности Windows.

Пример разрешения выполнения программы с помощью брандмауэра Windows

  1. Откройте апплет Центр обеспечения безопасности Windows - Пуск | Выполнить | wscui.cpl
  2. Нажмите на ссылку Брандмауэр Windows.
  3. В диалоговом окне Брандмауэр Windows откройте вкладку Исключения и нажмите кнопку Добавить программу.
  4. В диалоговом окне Добавление программы выберите программу в предложенном списке или нажмите кнопку Обзор и найдите ее самостоятельно.
  5. Выбрав программу, нажмите кнопку ОК.
  6. Убедитесь, что на вкладке Исключения флажок напротив названия нужной программы установлен, и нажмите кнопку ОК.

Примечание. Если в будущем возникнет необходимость удалить программу из списка исключений, снимите этот флажок.

Добавление программы в список исключений имеет следующие преимущества:

  • не нужно знать номер сопоставленного программе порта
  • порт, который используется программой из списка исключений, открывается только в том случае, когда программа ожидает получения данных извне.

Открытие портов вручную с помощью брандмауэра Windows

  1. Откройте апплет Центр обеспечения безопасности Windows - Пуск | Выполнить | wscui.cpl
  2. Нажмите на ссылку Брандмауэр Windows.
  3. На вкладке Исключения нажмите кнопку Добавить порт.
  4. В диалоговом окне Добавление порта введите в поле Номер порта номер открываемого порта и выберите вариант TCP или UDP.
  5. Введите название порта и нажмите кнопку ОК (например, Игровой порт).
  6. Чтобы просмотреть или изменить область исключения для порта, нажмите кнопку Изменить область, а затем — OК.
  7. Убедитесь, что на вкладке Исключения указана новая служба. Чтобы открыть порт, установите флажок рядом с новой службой и нажмите кнопку OК


ciadv.msc

Местонахождение

Windows\system32

Служба индексирования

Служба индексирования извлекает сведения из набора документов и собирает их в структуру, обеспечивающую быстрый и удобный доступ к этим сведениям с помощью команды Найти Windows XP, формы запроса службы индексирования или обозревателя. Эти сведения могут включать текст (содержимое) документа, характеристики и параметры (свойства) документа, такие как имя автора. После создания индекса можно запросить в нем документы, содержащие ключевые слова, фразы или свойства. Например, можно запросить все документы, содержащие слово «продукт», либо все документы Microsoft Office, созданные определенным автором. Служба индексирования возвращает список всех документов, соответствующих указанным условиям поиска.


compmgmt.msc

Местонахождение

Windows\system32

Управление компьютером (Computer Management)

Оснастка Управление компьютером — это инструмент, предназначенный для управления локальным и удаленным компьютерами. Эту оснастку можно вызвать из контекстного меню значка Мой компьютер командой Управление


devmgmt.msc

Местонахождение

Windows\system32

Диспетчер устройств (Device Management)

Диспетчер устройств используют для обновления драйверов (или программного обеспечения) оборудования, изменения настроек оборудования, а также для устранения неполадок.


diskmgmt.msc

Местонахождение

Windows\system32

Управление дисками - Disk Management

Оснастка Управление дисками предназначена для таких задач, как создание и форматирование разделов и томов и назначение букв дисков

Смотри также

Переназначить буквы дисков


gpedit.msc

Местонахождение

Windows\system32

Групповая политика

Оснастка Групповая политика используется для определения параметров политики, которые будут применяться к компьютерам или пользователям. С помощью данной оснастки можно запретить доступ пользователя к отдельно взятым оснасткам консоли. Очень подробную информацию можно почерпуть из справки.


eventvwr.msc

Местонахождение

Windows\system32

Просмотр событий (Event Viewer)

В окне просмотра событий ведутся журналы программных, системных событий, а также событий безопасности на компьютере. Окно просмотра событий используется для просмотра журналов событий и управления ими, получения сведений о неполадках аппаратного и программного обеспечения, а также для наблюдения за событиями безопасности Windows.


fsmgmt.msc

Местонахождение

Windows\system32

Общие папки (Shared Folders)

Компонент «Общие папки» может быть использован для управления общими ресурсами по сети. При помощи компонента «Общие папки» можно осуществлять контроль над разрешениями учетных записей пользователей, сеансами и свойствами общих ресурсов.


ntmsmgr.msc

Местонахождение

Windows\system32

Съемные ЗУ

Служба «Съемные ЗУ» упрощает отслеживание съемных носителей и управление библиотеками, например устройствами смены дисков.


perfmon.msc

Местонахождение

Windows\system32

Производительность (Performance Monitor)

Огромное количество счетчиков производительности компьютера (в т.ч. компьютера в сети) Загруженность процессора, памяти, кэша, логических дисков. Большое количество настроек и возможностей. Можно, например, узнать активность жесткого диска, его загруженность или отследить сколько байт занимает отдельно взятая программа в файле подкачки и т.д.


services.msc

Местонахождение

Windows\system32

Службы (Services)

Оснастка «Службы» используется для управления службами на локальном или удаленном компьютерах.


Службы в Windows

Ускорить работу системы, попутно освободив немного памяти, можно запретив загрузку ненужных системных служб. Отключить ненужные службы можно через оснастку Службы (Services). Здесь надо быть предельно осторожным, потому как последствия необдуманных действий могут быть непредсказуемы. Многие службы для своей работы требуют работы других служб, поэтому если Вы отключите слишком много лишнего, то можете столкнуться с такой ситуацией, что не сможете включить всё обратно. Какая служба от какой зависит можно посмотреть через закладку Dependencies из свойства службы. Но чтобы полностью избежать проблем при экспериментах со службами, мы бы советовали вам перед тем как производить эксперименты с службами сохранить ветку реестра отвечающую за запуск системных служб. Для этого в реестре найдите раздел HKLM\SYSTEM\CurrentControlSet\Serviсes. Не рекомендуется отключать службы через утилиту msconfig.exe.

Список служб в Windows

  • Служба шлюза уровня приложения (Application Layer Gateway Service)
Ниже мы приведём несколько служб, которые могут быть отключены. Используйте эти советы на свой страх и риск, авторы не несут никакой ответственности за возможные последствия (список служб дан для XP Pro).
  • Print Spooler: Спулер печати, ускоряет печать; если принтера нет, то его можно отключить.
  • Automatic Updates: Автоматичесткое обновление. Если у вас нет постоянного соединения с Интернетом, или если вы просто хотите контролировать всё что делает компьютер, то обновлять программное обеспечение входящее в состав XP можно и вручную. Выключая эту службу не забудьте выключить Automatic Updates в одноименной закладке System Properties.
  • Cryptographic Service: Отвечает за безопасный обмен ключами и шифрование. Используется для установки защищённых соединений, как в локальной сети, так и в интернет, играет важную роль в поддержке шифрования файловой системой. Если вам не надо шифровать файлы находящиеся на NTFS разделах, и вы не планируете использовать защищённые соединения в интернет (что использует, например, Windows Update), можете эту службу отключить. Используется она и во время проверки системных файлов (команда sfc), поэтому перед такой проверкой не забудьте включть её обратно.
  • Portable media serial number: Обеспечивает получение серийного номера переносного музыкального устройства подключаемого к компьютеру. Очередное нововведение Microsoft в рамках борьбы с музыкальным пиратством. На сегодняшний день для большинства из нас эта служба не актуальна.
  • SSDP Discovery service: обеспечивает автоматических устройств подключаемых к сети устройств, поддерживающих UPnP. Пока что это редкость.
  • Terminal Service: Раньше эта служба была доступна только в серверных вариантах ОС. Она позволяет подключаться к Вашей машине про сети, и удалёно работать на ней. В XP Pro эта служба предназначена для удаленного администрирования Вашей машины, чтобы IT специалисту не приходилось бегать самому чинить всё что Вы там натворили, а можно было сделать это удалённо. Кроме этого, через эту службу работает переключение пользователей на одной машине (Switch User). Если Вам эти возможности не нужны, можете отключить эту службу.
  • Windows time: синхронизирует время на локальной машине и сервере. Нет time-сервера - служба не нужна.
  • Messenger: Принимает и отправляет сообщения, посланные администратором. Если нет сети и администратора, то можно отключить.
  • Protected Storage: Служит для защиты важных данных, ключей пользователей. Запрещает неавторизированный доступ. Если нет сети (в том числе Интернет), или безопасность не волнует, то данный сервис можно отключить.
  • Computer Browser: Обновляет список компьютеров в сети. Если у вас нет локальной сети, то можно отключить.
  • Server: Обеспечивает общий доступ к принтерам, папкам и файлам, а также обеспечивает поддержку Remote Procedure Call. В случае, если у вас нет ни сетевой карты, ни модема, он вам не нужен.
  • Network Connections: Занимается управлением объектами в директории Network and Dial-Up Connections, то есть всеми сетевыми соединениями. Если нет сети, то он становится не нужным.
  • DHCP client: Отвечает за автоматическое распределение IP-адресов. Если нет сети (ни локальной, ни модема), то он не нужен.
  • Telephony: Работает с модемом. Если модема нет, то он не нужен.
  • Telnet: Обеспечивает возможность соединения и удалённой работы с хостами по протоколу telnet. Если уверены, что это не пригодится, то данный сервис можно отключить.

Этот список можно ещё продолжить, необходимость того или иного сервиса определяется задачами, которые выполняются на конкретной машине, и установленным аппаратным обеспечением. Поэтому каждый должен сам решать, что можно отключить.


Alerter

Оповещатель (Alerter)

Посылает выбранным пользователям и компьютерам административные оповещения. Если служба остановлена, программа, использующая административные оповещения их не получит. Если данная служба неразрешена, не удастся запустить любые явно зависимые службы, например, не будет работать команда net send

Установки по умолчанию

Вручную

Рекомендации

Данная служба нужна для посылки сообщений по локальной сети. В большинстве случаев можете ее отключить.


COMSysApp

Системное приложение COM+ (COM+ System Application)

Управление настройкой и отслеживанием компонентов COM+. Если данная служба остановлена, большинство компонентов COM+ не будет работать правильно.

Установки по умолчанию

Вручную

Рекомендации

Нет необходимости менять настройки по умолчанию


CryptSvc

Службы криптографии (Cryptographic Services)

Предоставляет три службы управления: службу баз данных каталога, которая проверяет цифровые подписи файлов Windows; службу защищенного корня, которая добавляет и удаляет сертификаты доверенного корня центра сертификации с этого компьютера; и службу ключей, которая позволяет подавать заявки на сертификаты с этого компьютера. Если эта служба остановлена, все эти службы управления не будут работать. Если эта служба отключена, любые службы, которые явно зависят от нее, не могут быть запущены."

Установки по умолчанию

Авто

Рекомендации

Нет необходимости менять настройки по умолчанию. Иначе будут проблемы при установке драйверов, автоматического обновления, сервис-паков, DirectX и т.д.


clipsrv.exe

Местонахождение

WINDOWS\system32

Описание

Windows NT DDE Server

Сервер папки обмена (ClipBook) позволяет хранить информацию и делить ее с удаленными компьютерами. Если данная служба остановлена, то такой возможности не будет.

Значение по умолчанию | Рекомендуемое значение
Автоматически | Вручную

Зависимости данной службы

Network DDE Network DDE DSDM


System Volume Information

В папке C:\System Volume Information находится кэш службы восстановления системы. Для его удаления сначала отключить восстановление системы (Панель управления | Система | Восстановление системы | Отключить восстановление системы на всех дисках). Но лучше воспользоваться кнопкой Параметры и ограничить объем дискового пространства, резервируемого системой.

По умолчанию, данная папка является скрытой. Программа восстановления системы создает копии реестра в данной папке. Данная папка содержит один или несколько подпапок вида _restore{GUID}RPx\Snapshot. По своей сути, они являютя каталогами точек восстановления системы. Обычным способом Windows не позволяет просматривать содержимое этой папки. Существуют способы обойти эти ограничения, но данная операция небезопасна и не рекомендуется для использования на собственном рабочем компьютере.


C:\Documents and Settings

В папке C:\Documents and Settings находятся профили пользователей, работающих с системой Windows XP. Например, если вы входите в систему под учетной записью Alexandr, то в папке C:\Documents and Settings будет создана папка Alexandr, в котором будет содержаться различные ваши данные. Например, в этой папке Alexandr будет содержаться файл ntuser.dat

Смотри также

Default Pictures
CD Burning


C:\Documents And Settings\All Users\Application Data\Microsoft\User Account Pictures\Default Pictures

В папке C:\Documents And Settings\All Users\Application Data\Microsoft\User Account Pictures\Default Pictures содержатся картинки-пиктограммы, используемые на странице приветствия для идентификации пользователей. Вы можете модифицировать имеющиеся картинки, либо добавить свои. Когда вы воспользуетесь апплетом Учетные записи пользователей, то войдите в любую имеющую запись и выберите команду Изменение изображения, и вы увидите ваши собственные картинки в этом окне


C:\Documents and Settings\(имя пользователя)\Local Settings\Application Data\ Microsoft\CD Burning

В папке C:\Documents and Settings\(имя пользователя)\Local Settings\Application Data\ Microsoft\CD Burning Windows создает файл образа будущего компакта-диска.


SendTo

Папка SendTo является папкой, в которой находятся ярлыки программ для команды Отправить контекстного меню Проводника. Когда вы щелкаете правой кнопкой на файле или папке выбираете пункт Отправить и там выбираете, куда хотите отправить, то выбранный вами файл копируется (перемещается) в ту папку, которую вы выбрали. В отличие от старых версий Windows, в Windows XP папка находится в C:\Documents and Settings\имя пользователя. По умолчанию в этой папке уже есть несколько ярлыков. Можно добавить самому свои ярлыки, которые будут отображаться в контекстном меню. Порядок работы с папкой следующий:

  • Создаёте ярлык программы для папки SendTo
  • Копируете этот ярлык в папку SendTo
  • Выбираете из контекстного меню выбранного файла пункт Отправить и ищете нужный вам подпункт

Например, я использую эту возможность для отправки обновлений в папку программы Ad-Aware SE Personal


Driver Cache\i386

Windows\Driver Cache\i386

В папке Driver Cache\i386 находится кэш драйверов. Некоторые пользователи рекомендуют удалять эту папку после установки всего оборудования. Имейте в виду, что при добавлении любого нового оборудования Windows будет запрашивать установочный диск.


Media

Windows\Media

В папке Windows\Media хранятся звуковые файлы WAV для озвучивания системных событий. Если у вас осталось слишком мало места на жестком диске, а звуковыми колонками не пользуетесь, то можете удалить эти файлы (почти 2 мегабайта). Также отключите звуковые схемы в апплете Звуки и аудиоустройства Панели управления, что разгрузить немного оперативную память.


Minidump

Windows\Minidump

Малый дамп памяти — это специальная запись минимального набора сведений, необходимых для определения причины неполадок. Windows каждый раз при возникновении неустранимой ошибки будет автоматически создавать новый файл в данной папке. Данная папка задается в диалоговом окне Загрузка и восстановление (апплет Система | вкладка Дополнительно | кнопка Параметры рамки Загрузка и восстановление | Папка малого дампа).


msagent

Windows\msagent

Папка msagent содержит подпапки и файлы, необходимые для работы с технологией MS Agent 2.0. В частности, подпапка Chars служит для хранения анимированных персонажей. По умолчанию, Windows XP уже имеет одного такого персонажа. Более подробно о технологии MS Agent 2.0 вы сможете прочитать в книге А.Климова MS Agent. Графические персонажи для интерфейсов, выпущенной издательством BHV

С использованием технологии Microsoft Agent


ShellNew

Windows\ShellNew

В папке Windows\ShellNew хранятся файлы-шаблоны, которые используются при выборе пункта меню Создать контекстного меню Проводника. О том как создавать новые команды в данном пункте меню можно прочитать в справочнике по реестру


SoftwareDistribution

WINDOWS\SoftwareDistribution

В папке WINDOWS\SoftwareDistribution хранятся папки и файлы, закачанные с помощью автоматического обновления. В принципе, эту папку можно удалить. В этом случае Windows заново создаст эту папку. На различных форумах некоторые пользователи утверждали, что удаление этой папки иногда помогало решить проблему сбоев при автоматическом обновлении.


Temp

Windows\Temp

Папка Temp предназначена для хранения временных файлов. Очень многие программы при своей установке временно копируют в эту папку свои файлы для дальнейшей инсталляции. К сожалению, порой эти программы забывают самостоятельно удалить свои временные файлы. Рекомендуется регулярно заглядывать в папку для очистки мусора


WinSxS

WinSxS, или Windows Side by Side (бок о бок), является еще одним новшеством Windows XP. Microsoft создала систему, позволяющую сохранять несколько версий одинаковых библиотек (DLL) и использовать при необходимости именно ту, что требует конкретная программа. Дело в том, что некоторые программы перезаписывают при инсталляции даже более новую версию библиотеки, что может привести ко всякого рода неприятностям, поэтому, если какая-нибудь программа вздумает беспричинно заменить уже имеющуюся в системном каталоге DLL, операционная система поместит сомнительную библиотеку в специальную папку (WinSxS), а программа так и останется уверенной, что сделала свое дело...


dllcache

Windows\system32\dllcache

В папке Windows\system32\dllcache находится кэш защищенных системных файлов, которые используются для автоматического восстановления в случае повреждения системы. По умолчанию размер этой папки - 50 мб (он задается в реестре параметром SFCQuota, находящемся в ключе HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon). Изменить размер папки до нуля можно командой sfc:

sfc /cachesize=0

Если поставить, например, 10, то размер папки уменьшится до 10 мб


config

Windows\system32\config

В папке Windows\system32\config содержатся файлы, которые работают с реестром

Возможный список файлов

  • AppEvent.Evt
  • default
  • default.LOG
  • default.sav
  • SAM
  • SAM.LOG
  • SecEvent.Evt
  • SECURITY
  • SECURITY.LOG
  • software
  • software.LOG
  • software.sav
  • SysEvent.Evt
  • system
  • system.LOG
  • system.sav
  • TempKey.LOG
  • userdiff
  • userdiff.LOG

Обратите внимание, что некоторые файлы не имеют расширения


Restore

Windows\system32\Restore

В папке Windows\system32\Restore содержатся программа восстановления системы rstrui.exe и сопутствующие файлы. В частности здесь находится интересный файл filelist.xml