Индекс

Пожалуйста, обратите внимание, что любая переведённая версия документации может, во-первых, не совсем точно отражать оригинальный английский текст, а, во-вторых, может не содержать последних изменений и исправлений.

Введение
Миссия kX Project
Краткий обзор kX драйвера
kX меню

kX Микшер
Краткий обзор kX Микшера
Основные функции
Основные регулировки
Входы и выходы
Запись
Кодек AC97
Уровни эффектов
SoundFont
Анализатор

Скины

kX DSP
Руководство по kX DSP
Руководство для начинающих

kX Router
Руководство по kX Router
Руководство по маршрутизации

kX Редактор
Руководство по kX Dane ассемблеру

kX Automation
Руководство по kX автоматизации

kX Пульт
kX пульт

kX Установка
Инструкции по установке kX драйвера

kX ASIO
Управление ASIO
Запись ASIO
Руководство для начинающих

kX Проверка Колонок и настройка эффекта Surrounder
Проверка колонок
Surrounder

Решение проблем
Известные проблемы и их решение

FAQ
Часто задаваемые вопросы

Приложение A: Технический справочник
Сигнальная блок-схема
Обзор аппаратных средств
Назначения входов и выходов
Перемена местами Фронта и Тыла
MIDI Implementation

Приложение B: Глоссарий
Глоссарий

Приложение C: Справочник параметров командной строки
Справочник параметров командной строки

Авторские права и благодарности
Авторские права и торговые марки
Благодарности
Лицензионное соглашение
SDK Лицензионное соглашение


Миссия

Наша миссия состоит в том, чтобы предоставить конечным пользователям свободный доступ ко всем аппаратным возможностям kX-совместимых* звуковых плат, пропагандировать развитие дополнительных прикладных программ и поощрять свободный обмен информацией, необходимой для развития программного обеспечения для всех kX-совместимых звуковых плат. Наш девиз: "Расширять Потенциал Экспоненциально" (Expanding the Potential Exponentially).

Историческое отступление

KX Project был рожден из объективной потребности расширить возможности использования музыкантами kX-совместимых звуковых плат под новыми операционными системами, не поддерживающими старую модель драйверов VxD.

До сих пор музыканты, заинтересованные исследованием возможностей их Emu10k1 и 10k2-совместимых звуковых плат, были ограничены либо работой с драйверами, идущими в комплекте с их звуковыми картами, либо установкой превосходящих по возможностям VxD драйверов, изначально предназначенных для плат E-MU Sуstems APS (Audio Production Studio), которые были не приспособлены для установки под современные операционные системы. В итоге, наиболее требовательные пользователи нередко решали установить себе другую операционную систему (например, Linux), либо ограничить использование своих звуковых карт играми и воспроизведением простейших SoundFont.

Независимый разработчик весной 2001 года задумал разработать WDM драйверы, которые бы вернули власть над аппаратурой в руки конечного пользователя, что открыло бы двери к фактически неограниченному программному развитию 10kХ плат. Этот бесстрашный и неустанный разработчик - Евгений Гаврилов, который продолжает возглавлять дальнейшую разработку kX Драйвера.

Небольшая группа независимых бета-тестеров и разработчиков теперь объединилась с Евгением, чтобы продолжить развитие kX Project. Работая вместе, мы сможем расширить потенциал и дать беспрецедентный контроль конечным пользователям над их звуковыми платами, а также разработать инструментальные средства для музыкантов.

- Hanz Petrov, Евгений Гаврилов
Декабрь, 2001


Краткий обзор kX Аудио Драйвера

kX аудио драйвер - WDM (Windows Driver Model) драйвер, разработанный для использования с любой kX-совместимой PCI звуковой платой (особенно Creative Labs SoundBlaster Live! и серией плат Audigy, а также звуковыми платами E-mu Systems' Audio Production Studio).

Следующие возможности полностью или частично поддерживаются kX аудио драйвером:

  • Воспроизведение и запись WAVE
  • MIDI синтезатор
  • MIDI UART вход/выход
  • DirectSound 2D
  • DirectSound 3D / EAX
  • SoundFonts
  • Воспроизведение и запись ASIO
  • Загрузка/выгрузка/редактирование микрокода DSP
  • Полное управление AC97 кодеком
  • Программное декодирование AC-3 потоков
  • Поддержка GSIF

Обратите внимание, что kX аудио драйвер соответствует WDM спецификации и совместим со следующими операционными системами Microsoft Windows: Windows 98 (Second Edition), Windows Me, Windows 2000 and Windows XP.

Окна управления kX драйвером

К следующим окнам управления kх можно обращаться через kX меню (клик правой кнопкой мыши на значке в системном трее или в любом свободном месте окна kX Микшера):

kX Микшер | Главное приложение, используемое для управления kX аудио драйвером. Содержит главные фэйдеры и переключатели, входы и выходы, уровни записи, кодек AC97, уровни эффектов, загрузку/выгрузку SoundFonts и анализатор, а также доступ к другим окнам управления kX.
kX DSP | Окно управления DSP для загрузки, выгрузки и редактирования микрокода. Этот апплет также обеспечивает доступ к kX редактору и другим интерфейсным плагинам DSP (для настройки параметров эффектов).
kX Router | Окно управления, обеспечивающее доступ к маршрутизации программных входных каналов, включая PCM Wave, AC3, MIDI Синтерзатор (16 каналов) и 16 kX ASIO каналов.
kX Редактор | Редактор DSP микрокоманд. Доступен из окна управления kX DSP, или непосредственно из kX Меню.
kX автоматизация | Окно управления в котором MIDI каналам могут быть назначены параметры регулировок микшера и других обьектов управления kX драйвером.
kX Пульт | Удаленный контроллер для kX. На данный момент не имеет каких либо кнопок, но планируется в будущем.
kX SoundFont | Загрузчик SF2 банков. Обеспечивает загрузку SoundFonts в оперативную память для воспроизведения MIDI Синтезатором.
kX проверка колонок | Утилита для тестирования и решения проблем установки колонок.


kX меню в Системном Трее

kX меню

kX меню обеспечивает доступ к функциям kX драйвера так же, как и окна управления.

kX Меню вызывается кликом правой кнопкой мыши на значке , который находится в системном лотке (system tray) Windows (обычно располагается в правом нижнем углу рабочего стола), или, щелкая правой кнопкой мыши в пределах области kX микшера или любого другого окна управления kX (кроме kX DSP).

kX меню появится в следующем виде:

Параметры меню:

Окна управления kX драйвером:
kX микшер | Открывает главное окно kX микшера.
kX DSP | Открывает окно управления kX DSP.
kX Router | Открывает окно kX Router.
kX редактор | Открывает окно kX редактора.
kX автоматизация | Открывает окно управления kX автоматизации.
kX пульт | Открывает kX пульт.
kX SoundFont | Открывает окно управления kX SoundFont.

Устройства Открывает подменю выбора устройства:

Для систем с несколькими kX-совместимыми платами это меню позволяет пользователю изменить выбранную в настоящее время плату.
Изменения, сделанные в любом окне управления kX, затронут только выбранную в настоящее время плату.

Настройки Открывает подменю настроек:

Сохранить настройки
Позволяет сохранить настройки для всех окон kX как файл с расширением .kx. Заданное по умолчанию имя файла - kxdefault.kx, однако, можно использовать любое имя файла.

Загрузить настройки
Позволяет загрузить предварительно сохраненные настройки для всех окон kX. Расширение файла для kX настроек - .kx

Сбросить настройки
Сбрасывает все настройки kX аудио драйвера и kX Микшера в значение "по умолчанию". Убедитесь, что сохранили текущие параметры настройки перед сбросом..

Настройка буферов

Установка буферов. В нормальном состоянии не требует дополнительных корректировок заданных по умолчанию величин, однако, обеспечивается корректировка следующих величин:

  • Размер основной памяти (TRAM). Диапазон от 0 до 2048Кб. Задает количество основной памяти, доступной для использования некоторыми DSP эффектами (TRAM обычно используется для линий задержки). Параметр по умолчанию - 256Кб. Обратите внимание, что установка этого параметра не затрагивает общее количество памяти, доступной для микрокоманд DSP (значение, установленное аппаратными средствами).
  • Размер буфера воспроизведения. Диапазон от 16384 байт (с задержкой 17.07ms) до 256 байт (с задержкой 0.26 ms). Чем меньше величина, тем быстрее, но в этом случае она может быть не пригодна для использования, в зависимости от вашей аппаратной и программной конфигурации.
  • Размер буфера записи. Диапазон от 384 до 65536. По умолчанию величина равна 16384 байтам. Обычно не требуется никакой корректировки этого параметра.
  • Количество AC3 буферов. Диапазон от 2 до 8.

Сгенерировать GUID
GUID (Глобальный Уникальный Идентификатор) утилита генерирования. Генерирует и копирует GUID в буфер обмена, готовый для вставки. GUID используется при редактировании скинов и идентификации DSP плагинов. Рядовые пользователи не нуждаются в услугах этой функции.

Эффекты Открывает подменю эффектов и плагинов:

Это меню позволяет подключить новые DSP объекты и плагины, и зарегистрировать их для использования в окне kX DSP.
Также, к текущим зарегистрированным объектам DSP, имеющим пользовательский интерфейс, можно обращаться непосредственно из этого меню (для редактирования параметров эффектов).

Скин Открывает подменю скинов:

Это меню позволяет зарегистрировать новые скины для использования их в kX микшере и других окнах управления kX. Расширения файлов по умолчанию для kX скинов - kxs (заметьте, что файлы kxs - это фактически zip / rar архивы, которые вы можете открыть для просмотра, модификации или переименования).
Также, в этом меню вы можете выбрать уже зарегистрированные скины, которые вступят в силу при следующем открытии kX Микшера (или другого kX окна).

Интернет Открывает подменю Интернет-ссылок:

Это меню обеспечивает связь с сайтом kxproject, позволяет автоматически проверять обновления драйвера и облегчить загрузку DSP эффектов и скинов через прямое соединение (обратите внимание, что эта возможность находится еще в разработке).

Язык В настоящее время поддерживаются следующие языки: английский, русский, немецкий, польский, испанский, румынский, французский, итальянский, шведский, норвежский, голландский, бразильский, болгарский, хорватский и венгерский. Обратите внимание, что для дополнительной поддержки нового языка нужно просто отредактировать файл kxskin.ini. Этот файл вы можете найти в архиве kxskin.kxs, который фактически является zip архивом (щелкните правой кнопкой мыши и выберите "открыть с помощью", затем выберите winzip (или альтернативный архиватор) чтобы распаковать его, или просто переименуйте файл с расширением .zip - и не забудьте переименовать потом назад, в расширение .kxs когда закончите).

О программе... Открывает информационное окно:

Прокрутите вниз для получения детальной информации, включающей номер версии kX драйвера, информацию о скинах, авторские права, информацию о PCI плате и благодарности.
Любые сообщения об ошибках должны включать содержимое этого окна. Для копирования в буфер обмена - щелкните правой кнопкой мыши в пределах этого окна, выберите "Выбрать все" и затем "Копировать". Вставьте в сообщение об ошибках.

Помощь Открывает это окно помощи.

Проверка колонок Открывает окно проверки колонок

Выход Закрывает и выгружает kX микшер.

После выбора Выход из kX Меню, все kX драйвера и Микшер Windows будут оставаться активными, хотя kX Микшер и все остальные окна kX будут закрыты. Чтобы открыть Микшер снова, сделайте двойной щелчок на файле [image] kxmixer.exe, находящийся в директории windows/system32, или из меню Windows Пуск - Программы - kx Audio Driver - kx Mixer, или выберите меню Пуск - Выполнить, напечатайте kxmixer.exe и нажмите ОК.


Краткий обзор kX микшера

kX микшер - приложение для управления kX аудио драйвером. Доступ к управлению входами/выходами и к окнам управления kX обеспечивается через пользовательский интерфейс kX микшера. Основные функции управления микшером (применимые для большинства приложений) приводятся здесь.

Значки, находящиеся слева обеспечивают доступ к различным инструментам управления микшера .
(Обратите внимание, что вид этих значков соответствует использованию kX скина по умолчанию. kX скин по умолчанию - "Aqua"). Подробнее о скинах.

Управление главными уровнями и кнопками

Уровни входов и выходов

Уровни записи

Управление AC97 кодеком

Управление эффектами

Управление SoundFont

Анализатор

Кнопки внизу kX микшера открывают следующие новые окна:

Открывает окно kX DSP

Открывает окно kX Router

Открывает окно kX автоматизация

Открывает этот файл помощи

Открывает оено проверки колонок

Опускающееся меню выбор устойства

Значки с правой стороны Микшера выполняют следующие функции:

Закрывает окно kX микшера (микшер остается активным в системном трее Windows).

Сворачивает окно kX микшера

Открывает информационное окно kX


Basic

Основные Функции Управления

В kX Микшере используются одиночные или двойные фэйдеры (ползунки) для регулировки уровней, в зависимости от характера назначения (моно или стерео).

Одиночный (моно) фэйдер

Двойной (стерео) фэйдер

Уровни фэйдеров могут быть установлены щелчком и перемещением мыши (удерживая кнопку), использованием клавиш "PageUp" и "PageDown" (для больших величин) или используя стрелки вверх и вниз (для маленьких величин). Колесо мыши также может использоваться для подстройки уровней фэйдеров.

Двойные фэйдеры могут быть связаны друг с другом, чтобы двигаться вместе. Связанные фэйдеры отображаются значком

Чтобы разъединить фэйдеры, щелкните по значку; разъединенные фэйдеры отображаются значком

Большинство средств управления может быть приглушено, щелкая по значку

Приглушенный фэйдер отображается значком [image] "Приглушить"; щелкните, чтобы отменить приглушение

Цифры над фэйдером показывают текущий уровень.


Главное Средство Управления

Управление главными уровнями и кнопками

Главное окно управления kX микшера обеспечивает доступ к следующим фэйдерам и кнопкам:

Общий уровень громкости
Этот стерео фэйдер управляет общим уровнем воспроизведения.

Громкость PCM Wave
Этот стерео фэйдер управляет уровнем воспроизведения PCM Wave.

Громкость MIDI синтезатора
Этот стерео фэйдер управляет уровнем воспроизведения MIDI синтезатора.

Настройка колонок
Эта кнопка открывает окно настройки эффекта 'Surrounder' (Surrounder загружен по умолчанию). Для больших подробностей обратитесь к руководству по Surrounder .

Только цифровой выход
Эта кнопка переключает звуковую плату в режим "только цифровой выход" (DOO) для EMU10k1-совместимых плат и позволяет одновременную запись с нескольких аналоговых источников, таких как линейный вход, CD аудио, вспомогательный вход и TAD вход. В активном режиме "только цифровой выход", для контроля требуется устройство цифрового выхода (кроме плат Audigy, которые рассматриваются как всегда находящиеся в режиме DOO, таким образом позволяя одновременную запись нескольких аналоговых источников).

Поменять фронт и тыл
Кнопка переключения выхода фронтальных и тыловых колонок используется для улучшения качества мониторинга аналогового сигнала, что обосновано превосходящим качеством ЦАП, используемого для тыловых колонок (обратите внимание, что колонки заменены по умолчанию). Опция недоступна для плат APS, потому что они не имеют AC97 Кодека.

SPDIF Bypass
Кнопка SPDIF Bypass выключает цифровой выход SPDIF (для плат 10k1 и 10k2 - не тестировалось, но должно работать).

Вывод наушников через центр/сабвуфер
Кнопка вывода наушников через центр/сабвуфер может быть использована для перенаправления выхода наушников на канал центр/субвуфер.

Частота дискретизации SPDIF
Это опускающееся меню позволяет выбирать частоту дискретизации цифрового выхода SPDIF (только для плат 10k2). Выбирается 44100, 48000 (по умолчанию) и 96000, измеряется в количестве звуковых отсчётов в секунду. Эта установка не будет затрагивать внутреннюю частоту дискретизации, которая всегда блокируется аппаратными средствами в 48000.


Входа и Выхода

Входы и выходы

Вкладка kX микшера входы и выходы позволяет управлять следующими входами и выходами (обратите внимание, что в зависимости от модели вашей звуковой платы, некоторые входы могут быть не отображены).

Выходы:

Аналоговой фронт
Этот фэйдер управляет уровнем передних аналоговых выходов (стерео).

Аналоговый тыл
Этот фэйдер управляет уровнем тыловых аналоговых выходов (стерео).

Аналоговый центр
Этот фэйдер управляет уровнем центрального аналогового выхода (только платы 5.1 и Audigy).

Аналоговый сабвуфер
Этот фэйдер управляет уровнем выхода сабвуфера (только платы 5.1 и Audigy).

SPDIF
Этот фэйдер управляет уровнем SPDIF выхода (цифровой стерео)

Наушники
Этот фэйдер управляет уровнем выхода наушников (аналоговый стерео - только LiveDrive).

A1/A2 выход
Этот фэйдер управляет уровнем Analog-1 и Analog-2 выходов (аналоговый стерео - только APS)

A3/A4 выход
Этот фэйдер управляет уровнем Analog-3 и Analog-4 выходов (аналоговая стерео пара - только для плат APS с MOC)

A5/A6 выход
Этот фэйдер управляет уровнем Analog-5 и Analog-6 выходов (аналоговая стерео пара - только для плат APS с MOC)

A7/A8 выход
Этот фэйдер управляет уровнем Analog-7 и Analog-8 выходов (аналоговая стерео пара - только для плат APS с MOC)

Входы:

AC97 вход
Этот фэйдер управляет уровнем сигнала, поступающего из AC97 кодека (аналоговые моно и стерео входы).

Цифровой CD вход
Этот фэйдер управляет уровнем цифрового CD входа (цифровой стерео SPDIF).

I2S вход
Этот фэйдер управляет уровнем I2S входа (цифровой стерео I2S - только LiveDrive).

Оптический вход
Этот фэйдер управляет уровнем оптического входа (цифровой стерео SPDIF - только LiveDrive).

Mic2 вход
Этот фэйдер управляет уровнем Mic2 входа (аналоговый моно - только LiveDrive).

Coaxial вход
Этот фэйдер управляет уровнем коаксиального входа (цифровой стерео - только LiveDrive).

Aux2 вход
Этот фэйдер управляет уровнем Auxiliary-2 входа (аналоговый стерео - только LiveDrive).

A1/A2 вход
Этот фэйдер управляет уровнем Analog-1 и Analog-2 входов (аналоговая стерео пара - только APS).

A3/A4 вход
Этот фэйдер управляет уровнем Analog-3 и Analog-4 входов (аналоговая стерео пара - только APS с Edrive).

D1 вход
Этот фэйдер управляет уровнем Digital-1 входа (цифровой стерео - только APS)

D2 вход
Этот фэйдер управляет уровнем Digital-2 входа (цифровой стерео - только APS с Edrive)

Дополнительную информацию можно найти в нашем руководстве по назначению входов и выходов (I/O Assignment Guide).


Запись

Контроль уровня записи

Вкладка записи окна kX Микшера обеспечивает доступ к следующим регулировкам уровня записи:

Программные источники:

Общий уровень записи
Эта стерео пара управляет общим уровнем записи для всех источников.

Уровень записи Wave
Этот моно фэйдер управляет уровнем записи PCM Wave источников.

Уровень записи синтезатора
Этот моно фэйдер управляет уровнем записи MIDI Синтезатора.

Уровень записи FX1 (Ревер)
Этот моно фэйдер управляет количеством FX1 (Ревера по умолчанию) добавляемого при записи к воспроизводимым источникам.

Уровень записи FX2 (Хорус)
Этот моно фэйдер управляет количеством FX2 (Хоруса по умолчанию) добавляемого при записи к воспроизводимым источникам.

Аппаратные источники:

Уровень записи AC97
Эта стерео пара управляет уровнем записи AC97 источника(ов)

Уровень записи CD Digital
Эта стерео пара управляет уровнем записи цифрового входа CD Digital (CD_SPDIF).

Уровень записи I2S
Эта стерео пара управляет уровнем записи цифрового входа I2S (только для систем с LiveDrive).

Уровень записи Optical
Эта стерео пара управляет уровнем записи оптического цыфрового входа (только для систем с LiveDrive).

Уровень записи Mic-2 / Line-2
Эта стерео пара управляет уровнем записи источников Mic-2 / Line-2 (только для систем с LiveDrive).

Уровень записи Coaxial
Эта стерео пара управляет уровнем записи коаксиального цифрового входоа (только для систем с LiveDrive).

Уровень записи Aux2
Эта стерео пара управляет уровнем записи второго дополнительного входа Aux2 (только для систем с LiveDrive).

Уровень pаписи Analog-1/Analog-2 (только для плат APS)
Эта стерео пара управляет уровнем записи аналоговых источников A1/A2.

Уровень записи Analog-3/Analog-4 (только для плат APS с Edrive)
Эта стерео пара управляет уровнем записи аналоговых источников A3/A4.

Уровень записи цифрового входа D1 (только для плат APS)
Эта стерео пара управляет уровнем записи цифрового входа D1.

Уровень записи цифрового входа D2 (только для плат APS с Edrive)
Эта стерео пара управляет уровнем записи цифрового входа D2.


AC97 Кодек

Кодек AC97

Окно AC97 kX микшера позволяет управлять входами и выходами кодека AC97 (обратите внимание, что все kX-совместимые платы имеют AC97 кодек, за исключением E-mu APS и Audigy2 Platinum eX).

Выходы:

TAD Выход
Выходной уровень разъёма, подключаемого к голосовому модему (моно). Обычно вход и выход подключаются через внутренний 4-штырьковый разъём, маркируемый "TAD".

PC Динамик
Выходной уровень PC Динамика (моно). Обычно подключается через внутренний 2-штырьковый разъём, маркируемый "PC_SPK".

Входы:

TAD Вход
Входной уровень разъёма, подключаемого к голосовому модему (моно). Обычно вход и выход подключаются через внутренний 4-штырьковый разъём, маркируемый "TAD".

Микрофон
Входной уровень иикрофонного входа (моно). Обычно исполнен в виде 1/8" стерео джека в задней части платы. Обратите внимание, что предпочтительней использовать линейный вход с внешними предусилителями, так как Микрофонный Вход имеет тенденцию к сильным шумам из-за дешевых встроенных компонентов усилителя.

Линейный вход
Входной уровень линейного входа (стерео). Обычно исполнен в виде 1/8" стерео джека в задней части платы.

CD
Уровень Аналогового входа CD (стерео). Обычно подключается через внутренний 4-штырьковый разъём, маркируемый "CD_IN" (не путать с цифровым входом CD_SPDIF).

Видео
Уровень видео входа (стерео). Обратите внимание, что на большинстве kX-совместимых плат этот вход не предусмотрен изготовителем (никакое аппаратное подключение не доступно).

Дополнительный
Уровень дополнительного входа (стерео). Обычно подключается через внутренний 4-штырьковый разъём, маркируемый "AUX_IN"

Другие функции:

Источник записи AC97
Источник записи AC97 выбирается через опускающееся меню, можно выбрать микрофон, CD, видео, дополнительный, линейный, стерео микс, моно микс или TAD. Обратите внимание, что одновременно можно записывать только с одного аналогового источника AC97, если только не выбрано СтереоМикс (или МоноМикс), позволяющее записывать вместе несколько AC97 источников с PCM (системный звук) выходом. Для дальнейших подробностей обратитесь к сигнальной блок-схеме.

Настройки AC97 кодека можно сбросить к настройкам по умолчанию нажатием кнопки AC97 Reset.

Опция увеличения чувствительности микрофона на 20dB включается щелчком по кнопке x2 Boost.


Уровни эффектов (FX)

Вкладка FX (DSP эффекты) окна kX Микшера позволяет управлять уровнями двух основных эффектов.

Ревер
Этот фэйдер управляет уровнем ревера.

Хорус
Этот фэйдер управляет уровнем хоруса.

Обратитесь к руководству по kX DSP или к руководству по kX Router для получения большей информации об использовании FXBus и заданных по умолчанию схем.


SoundFonts

SoundFont

kX микшер обеспечивает возможность загружать банки звуков в формате SoundFont (*.sf2) для воспроизведения их MIDI синтезатором.

Загрузите SoundFont кликая по значку "загрузить" [image] на вкладке SoundFont. Откроется диалоговое окно выбора файла. Выберите файл SoundFont для загрузки (расширение .SF2).

Загруженные в настоящее время банки перечислены в верхней области окна. Выбирая какой либо SoundFont из этого списка вы получите более детальную информацию о нем в нижней области окна, включая название, устройство воспроизведения и номер банка, назначенный синтезатор, авторские права, разработчика и статистику.

Текущее использование памяти отображается в статусной панели в нижней части окна SoundFont.

Для выгрузки банка, выберите его в верхней панели и кликните по значку "выгрузить".

kX драйвер поддерживает загрузку только SoundFont 2.0 и 2.1 файлов (а также файлов sfArk 2.0 и выше); формат SoundFont 1.0 (.SBK) не поддерживается. Обратите внимание, что в настоящее время не поддерживаются свойства SF2.1 модулятора.

Внизу вы также можете увидеть опции сохранения [image] и загрузки [image] коллекции SoundFont.

kX WDM драйвер назначает SoundFont кэш-память по необходимости; нет никакого корректируемого пользователем управления кэшем. Теоретически, максимальный размер загружаемых СаундФонтов ограничен только системными ресурсами, однако этот максимум может колебаться в пределах от 30% до 70% физической оперативной памяти (RAM), ограничений памяти ядра и многих других факторов. В любом случае, из-за аппаратных ограничений может быть загруженно одновременно только 32MB банков.


Анализатор

kX микшер включает в себя анализатор - графическое представление Wave и Synth голосов, отображаемых согласно их громкости.

Synth голоса отображаются синим цветом, Wave голоса - красным и ASIO голоса - зеленым цветом.

Громкость отображается светлым цветом (голубой - светло голубой, зеленый - светло зеленый, красный - оранжевый).

Доступ к анализатору вы можете получить из окна kX DSP или подменю эффектов.


Руководство по kX DSP

Краткий обзор
Окно kX DSP представляет в графическом виде внутренние соединения kX драйвера, и это одна из самых мощных особенностей kX драйвера. Маршрутизация сигнала происходит соединением виртуальных входов и выходов виртуальными кабелями, в которых цифровые звуковые потоки передаются тем же способом, как если бы вы использовали настоящие соединительные кабели для подключения различных модулей в вашей звуковой студии или в вашей домашней стерео системе.

Окно DSP состоит из четырех основных объектов:

FXBus
Prolog
Routing
Epilog

Другие объекты (DSP эффекты, такие как эквалайзер и т.п.) могут быть добавлены или удалены по необходимости.

Соединения
Назначение текущих разъемов входов и выходов можно узнать перемещая мышь по полю разъемов (входы обозначены красным цветом, а выходы - синим). Это активизирует маленькое всплывающее окно, показывающее название разъема. Многие из заданных по умолчанию соединений не являются необходимыми для ваших личных настроек, но дают возможность гарантировать активацию множества функций вашей звуковой платы. Это касается как аналоговых и цифровых входов, так и аналоговых и цифровых выходов.

Соединение и отсоединение
Соединения производятся щелчком/удерживанием левой кнопки мыши и перемещением мыши к месту назначения. Входы всегда располагаются с левой стороны объекта, в то время как выходы - с правой стороны. Выходы могут соединяться с несколькими входами, однако вход может быть соединен только с одним выходом, также вы не можете соединять входы с входами, а выходы с выходами. Чтобы отсоединить любой вход или выход, щелкните правой кнопкой мыши на точке подключения и выберите "отсоединить вход/выход".

Сброс DSP
Окно DSP может быть очищено и переинициализировано щелчком правой кнопкой мыши на фоне окна и выбором соответствующей функции всплывающего меню. Очистить DSP - удаляет все эффекты и объекты (кроме FXBus). Переинициализировать DSP - восстанавливает настройки по умолчанию. Выровнять плагины - восстанавливает заданные по умолчанию позиции DSP объектов.

Добавление объектов и эффектов
Новый DSP объект или эффект может быть добавлен в окно DSP щелчком правой кнопкой мыши на фоне окна и выбором 'Добавить Эффект/ Плагин' из всплывающего меню. Вы можете выбрать любой из перечисленных объектов или эффектов, скачать дополнительный эффект с сайта kX Project, или создать свой собственный. Обратите внимание, что перед использованием эффектов в окне DSP, они должны быть зарегистрированы. Для этого выберите 'Зарегистрировать плагин (Dane/RIFX/DLL...)' в всплывающем меню и выберите желаемый файл эффекта или плагина. После успешной регистрации, все новые эффекты будут отображены в списке доступных объектов.

Когда новый объект добавляется в окно DSP ему автоматически назначаются все необходимые аппаратные ресурсы. При выборе режима "Дополнительные параметры" (Advanced options), объект появляется в красной рамке: после этого он должны быть транслированы, прежде чем его можно будет редактировать и использовать (трансляция требуется для распределения физических ресурсов; памяти микрокода, TRAM и регистров). Щелкните правой кнопкой мыши по объекту, выберите 'Транслировать...' и нажмите на значок 'ok'. Обратите внимание, что обычно используется позиция микрокода по умолчанию - "Положение не важно", однако, в будущем, можно самому выбрать физическое местоположение эффекта/плагина в памяти микрокода - при некоторых обстоятельствах, это может быть важно для правильной маршрутизации. Если свободные ресурсы доступны, объект будет транслирован - цвет рамки изменится на синий (обратите внимание, что доступность ресурсов, таких как TRAM, память микрокода, регистры и т.п., зависит от модели вашей звуковой платы, размера и количества загруженных объектов и эффектов). Подключите источник и адресат к объекту. Активизируйте объект, щелкнув правой кнопкой мыши и выбрав 'Разрешить'.

Настройка параметров DSP объектов
Если объект DSP имеет изменяемые параметры, вы можете менять их, выбрав 'Настроить...' из всплывающего меню объекта (правый щелчок мыши) или двойным щелчком по объекту. К параметрам настройки можно также обратиться из kX меню (щелкая правой кнопкой мыши по главному окну kX Микшера или по значку в системном трее). Эти настройки находятся в подменю 'Эффекты'. Чтобы сбросить параметры настройки объекта, выберите 'Сбросить настройки' из всплывающего меню объекта в окне DSP.

Пример: Настройка параметров эффекта стерео хорус в версии 3531

Выгрузка и удаление объектов DSP
Объекты DSP могут быть отключены или выгружены, выбором соответствующих команд из всплывающего меню объекта в DSP окне (правый щелчок мыши). Отключение объекта просто отключает его выходы; чтобы удалить объекты из памяти DSP, они должны быть нетранслированы или выгружены. Команда Untranslate освобождает аппаратные ресурсы, связанные с объектом, не выгружая объект из системной памяти. Чтобы полностью выгрузить объект, освобождая все распределенные ресурсы драйвера, выберите команду Выгрузить.

Дополнительные опции
DSP объекты могут быть приглушены или отключены, щелчком по значку "приглушить" или "обойти" в настройках эффекта.
Настройки эффекта могут быть сброшены кнопкой сброса.

Выбор устройства в окне DSP
Параметры настройки DSP уникальны для каждой установленной kX-совместимой звуковой платы. Текущая звуковая плата отображается (и выбирается) в правом нижнем углу окна DSP.

Основные объекты

Когда окно kX DSP открывается в первый раз, вы увидите загружаемые по умолчанию объекты DSP. Они включают в себя объекты FxBus, Prolog, Routing, и Epilog . Эти основные объекты используются для представления и соединения аппаратных и программных входов и выходов.

FXBus

FXBus - виртуальные 'потоки', идущие от звуковой платы к окну DSP. Весь звук, который генерируется на компьютере музыкантами и программами-секвенсорами, проходит через один или несколько из них (обычно в стерео парах).

Настройки по умолчанию:

Волновой (Wave) выход левый и правый - в FXBus 0 и FXBus 1.
Выход MIDI синтезатора левый и правый - в FXBus 02 и FXBus 03.
Surround (AC3) и DirectSound 3-D - расположены от FXBus 04 до 09.

Эффекты ревер и хорус связаны с Wave и MIDI через FXBus13/14. Прямые стерео соединения с Wave/MIDI позволяют корректировать стерео ревер и хорус непосредственно из вкладки FX окна kX микшера.
Разъемы FXBus 13 и 14 - это моно соединения, использующие посыл сигнала и возврат его с эффектом. Имейте в виду, что сигнал возможно применять дважды к эффектам, таким образом эффект сигнала удвоится.

Заданные по умолчанию маршруты могут быть изменены для каждого источника. Это описано в секциях kX Routing и kX ASIO .

Prolog

Входы звуковой платы располагаются в объекте пролог. Другими словами, выходы на прологе представляют собой физические входы на вашей звуковой плате (на фронтальной части платы, дочерних платах или внешних устройствах, связанных с платой). Эти разъемы - стерео пары и соответствуют нижней строке фэйдеров, расположенных на вкладке входы и выходы окна kX микшера.

Обратите внимание, что эти фэйдеры не затрагивают параметров записи, но в действительности затрагивают уровни ASIO.

На платах 10k1 пролог представляет следующие входные сигналы (7 стерео пар):

In0/1: AC97 - левый/правый
In2/3: CD Цифровой - левый/правый
In4/5: I2S - левый/правый
In6/7: Coaxial / Optical - левый/правый (LiveDrive)
In8/9: Line 2/mic 2 - левый/правый (LiveDrive)
In10/11: Coaxial / Optical - левый/правый (LiveDrive/дочерние платы)
In12/13: AUX 2 - левый/правый (LiveDrive)

Routing

Объект маршрутизации (routing) производит микширование всех поступающих сигналов и распределение посылов на правильные выходы (эффекты, запись и т.д). Routing микширует входы пролога с сигналами FXBus и направляет их на различные выходы, в зависимости от ваших параметров настройки микшера, включая фронт, тыл, центр, субвуфер, наушники и, не в последнюю очередь, настроек записи (но не ASIO записи).

Дополнительную информацию вы можете найти здесь.

Epilog

Эпилог представляет собой физические выходы вашей звуковой платы, включая входы на запись и 16 входов на ASIO запись .

Обычно, соединены все выходы, но в некоторых случаях (например, установка двух колонок) вам необходима только одна пара кабелей, которая соединяется с выходами на колонки.

Соединения на запись сделаны согласно параметрам настроек вкладки запись окна kX микшера. Обратите внимание, что эти параметры настройки затрагивают только фактическую запись, а не то, что вы слышите. Также, это не затрагивает ASIO запись.

Последние 16 каналов - входы на ASIO запись. Они связаны в стерео пары (четный/нечетный равные левый/правый), когда ASIO запись установлена в режим стерео записи.

Вы можете подключить к этим входам любой выход любого объекта.

Подсказки и советы

Вы должны хорошо изучить окно DSP, перемещая (и удаляя) некоторые кабели и объекты, и наблюдая, что при этом происходит с kX Микшером. Удаление любого из основных объектов DSP приведет к уменьшению функциональных возможностей микшера и удалит связанные с этим объектом фэйдеры в kX Микшере.

Можно обойтись и без объекта routing , подключая FXBus непосредственно к выходу (epilog). Это может быть полезно для программ, использующих настройки ASIO драйверов, таких как, например, Emagic Logic Platinum или Steinberg Nuendo.

Если ваша DSP маршрутизация вышла из-под контроля или перестала функционировать, вы можете или очистить и повторно инициализировать DSP или загрузить предварительно сохраненные установки (из основного меню микшера или из Меню в системном трее).

Пример конфигурации kX DSP


kX Router

Краткий обзор

Окно kX Router вызывается из kX микшера или из kX меню. Этоо окно отображает и позволяет вам изменять - где и как будут проходить аудио потоки из системы к 16 FXBus каналам в апплете kX DSP.

Аудио потоки kX Router включают программные выходы:

  • Wave Левый и Правый (Подсистема Windows MultiMedia (WinMM))
  • DirectSound2D голоса (аппаратное ускорение)
  • DirectSound3D голоса (аппаратное ускорение)
  • AC3 голоса (5+1)
  • 16 MIDI каналов
  • 16 ASIO выходных каналов

Эти программные выходы сгруппированы следующим образом:

  • Группа 1. Wave Левый/Правый и DirectSound 2D голоса (стерео или моно)
  • Группа 2. DirectSound3D и AC3 голоса (они используют только один моно выход, который разбит драйвером на 2,4 или 6 каналов);
  • Группа 3. 2х16 MIDI каналов
  • Группа 4. 16 ASIO каналов

Эти группы могут иметь различные маршруты, включая 32 разных маршрута для MIDI-каналов и 16 для ASIO каналов (все управляется отдельно).

Каждый программный голос направляется аппаратными средствами к 4 различным FXBus каналам. Эти маршруты называются 'A', 'B', 'C', 'D', и уровень каждого посыла может быть индивидуально откорректирован. Уровни посылов обозначается как 'send_a', 'send_b', 'send_c' и 'send_d'. Четыре дополнительных FXBus добавляется в платах 10k2 ('E', 'F', 'G' и 'H'), общее количество равно 8. Эти параметры могут управляться фэйдерами на вкладке уровни эффектов окна kX микшер.

Обратите внимание, что Wave, DirectSound и MIDI маршруты требуют посылы send_a и send_b, которые зарезервированы kX драйвером для установки стереопозиции. Поэтому, пользователь может управлять только количеством send_c и send_d (хотя все 'маршруты' управляемы). Для ASIO голосов, все 4 посыла управляемы (8 для 10k2 плат) фэйдерами в kX Router. Подробная информация здесь.

Заданная по умолчанию конфигурация позволяет устанавливать стереопозицию, используя стандартные Windows / DirectX / Midi методы (внутренне обработанные send_a и send_b), и использовать send_c и send_d как 'уровни эффектов'. Посылы c и d по умолчанию идут к Реверу и Хорусу и управляются через MIDI-контроллеры, так же как и фэйдерами kX микшера.

Как только сигнал будет изменён фэйдерами посыла и скоммутирован в FX Bus, он может управляться через kX DSP апплет.

Использование kX Router

Функции kX Router очень похожи на функции описанной ранее ASIO маршрутизации , поэтому они совмещены.

Потоки здесь могут быть моно или стерео.

Wave и SoundFont синтезатор направляются к парам FXbus 0/1 и 2/3, в то время как ac3 потоки используют отдельные шины 4-8.

По умолчанию, все потоки направляются к шине 13/14, которая действует как посыл/возврат для эффектов ревера и хоруса в настройках по умолчанию.

Подсказки и советы.

Параметры настройки маршрутизатора уникальны для каждой установленной звуковой платы. Текущая выбранная звуковая плата отображается в нижнем правом углу окна. Текущая плата может быть изменена, щелчком по наименованию устройства.


Routings

Руководство по маршрутизации

Вступление

kX драйвер представляет 4 разлчных Wave устройства: Wave 0/1, Wave 4/5, Wave 6/7 и Wave 8/9. Каждое устройство имеет собственные возможности и заданные по умолчанию направления.

Wave 0/1

Это устройство может использоваться для многоканального воспроизведения (типа Sonar, DirectSound 3-D или DVD приложения). Однако, из-за многоканальной поддержки, требуется немного большей мощности процессора и, таким образом, это устройство не рекомендуется для приложений критических к времени задержки, таких как Sonar (в котором, однако, время ожидания в 10ms может быть легко достигнуто). Обратите внимание, что большинство приложений, которые открывают устройство 'Wave 0/1' в режиме 'моно' или 'стерео', не затрагивают программные процессы, потому что они автоматически выключаются.
Выход этого устройства направляется по пути 'Generic Stereo' сигнала и микшируется с выходом синтезатора так же как и с 'передними' выходами surround эффектов (ревер и хорус). Это происходит до эффекта 'Surrounder', куда направляется сигнал 'Generic Stereo'. То есть он может быть раскинут по панораме* между 'передними' и 'тыловыми' колонками (* эта особенность в настоящее время не поддерживается).

Wave 4/5, Wave 6/7, Wave 8/9

Эти устройства направляют сигнал непосредственно к вашим аппаратным выходам. Wave 4/5 направляет к 'передним колонкам', Wave 6/7 - к 'тыловым', Wave 8/9 - к 'центр+Сабвуфер'.
Wave 6/7 выход дополнительно микшируется с 'тыловыми' выходами surround эффектов (ревер и хорус). Если Вы хотите использовать kX драйвер для воспроизведения '5.1' (DVD, Игры), то используйте заданные по умолчанию соединения (не забудьте поменять 'передние' и 'тыловые' колонки). Иначе вы получите 3 независимых стерео выхода, которые могут использоваться отдельно. Также учтите, что 'Wave 4/5', ' Wave 6/7' и 'Wave 8/9' не требует дополнительной программной обработки (по сравнению с 'Wave 0/1') и вы можете получить лучшее время ожидания, работая с Sonar'ом и другими подобными приложениями, которые используют 'потоки на уровне ядра'.

Пользователям E-mu APS

E-mu APS имеет такую же схему маршрутизации. Устройство Wave 0/1 имеет те же самые функциональные возможности, что и у других kX аудио плат, и направляется по умолчанию к A1/A2 (это можно изменить через эффект 'Surrounder' и kX DSP апплет). Wave 4/5 также направлено к 'A1/A2'. Wave 6/7 направлено к 'D1', и Wave 8/9 направлено к 'D2' (A3/A4) физическим выходам. Так что, если вы хотите получить '5.1' звук, просто соедините ваш D2 с 'центром/субвуфером' и D1 с 'тыловыми' колонками. Иначе, вы получите 3 независимых стерео выхода.

ASIO

ASIO каналы непосредственно соответствуют выходам устройства 'Wave X/Y'. То есть, ASIO 4/5 направляются к FXBUS 4,5 и на 'передние' колонки, ASIO 6/7 - к 'Тыловым' колонкам и так далее. ASIO 2/3 направляются к выходам 'Synth'.

Наушники

Наушники, по умолчанию, подключаются к 'передним' колонкам. Вы можете изменить это в настройках эффекта 'Surrounder' или, пересоединяя входы Эпилога ('Headphones') к нужным выходам 'Surrounder'. E-mu APS Наушники не могут управляться через kX DSP.


kX DSP Editor

kX DSP редактор

kX Dane (дизассемблер, ассемблер и редактор) - редактор kX DSP эффектов. Когда объекты загружены в окне kX DSP, вы можете вызвать редактор объектов - kX Editor щелчком правой кнопки мыши и выбором команды 'Редактировать' из всплывающего меню.

; Эта документация, возможно, немного устарела
; написана Максом Михайловым

Перед чтением этого раздела рекомендуется просмотреть документацию/патенты
E-mu/Creative, в которых рассматривается Emu10kx DSP, И настоятельно
рекомендуется прочитать "руководство по 10k1" написанное Дэниелом Бертраном
для его 10k1 ассемблера.
(все выше перечисленные документы вы  можете найти на сайте <kxproject.com>)

Синтаксис языка Dane.
-----------------

Dane Language is use a mix of classic asm and classic C-like syntax
(maybe too mad mix).

Dane DSP Program is a set of instructions and registers to be used in
that instructions. (doh..)

You may treat DSP Program like function which dsp calls every sample
cycle feeding it with samples of sound data.

More comments later, let's jump into syntax right now...
-----------------

;registers declaration

Each program must have atleast one input and one output register to
be able to process sound data.

Input is a register where you read sound sample from and output is a
register you should write processed sample to.

Dane register declaration is C-like:

; declare input register:
input a;
; will allocate one register from dsp memory and says to
; the driver that it is input of the program

; output
output b;

You just must to keep in mind the important difference from C,
semicolon ';' -
is not the end of expression like in C, but the start of ;comments.
Anything after ';' until next line will be ignored by dane:
output x; output y
; this will produce only one output register

However you can declare more then one register of the same type in one line
using comma ',':
input k, l, m, n; declares four inputs.

Also you may not use ';' at all, dividing declarations just with newline
; followed lines produce one input and one output
input i1
output o1

Of coarse you will need some other register where you can store
intermediate values and some constants needed for effect's algorithm
calculation.
The main basic types of such registers are static and temp:

; example
static s;
temp t

Use static when you want register to store its value for next sample cycle
(in other words value of static register is preserved for next sample cycle).

Use temp when you need value only for current sample cycle, the value of this
type of registers is preserved only during one sample cycle and it is
unpredictable for the next sample cycle.

Another important type of the register you may need is constant.
Constant registers are defined with const keyword:
;defines constant with 0.5 value
const c = 0.5

Also you may avoid declaration of constant and use numeric values right in code
(see later). Using numeric value in code causes Dane to automatically allocate
constant register in DSP memory.

As well as you can assign numeric value to constant, you can initialize
static register with value (as always).
; static intitialized to 0.25
static quarter = 0.25;

Next type: Control.
This type implemented mostly for future compability, when it will
say to Dane export some header file for kX DSP Plugin.
For now it is the same as static except two things:
It is read-only for dsp code (like const) and its value can be changed
from the host only.
And control register must be initialized with some value
; control register
control level = 1
control nolevel; error!

-----------------

Tip: If you are not sure which register type from above ones to use,
use static and you'll naver make a mistake.

-----------------

As you can see Dane is not case sensitive language, so foolowed
declarations do the same job:
static s;
STATIC s;
static S;
sTaTic S;

-----------------

Using Delays.

I will not get into details of using fx8010's 'tank memory',
you can get much deeper guide from 'As10k1 Manual' (thanks to
Daniel for the great work) and Patents.

Just some details on declaring and using delays/tankmemory access registers
in Dane.

It's not so user friendly to use delays in Dane, but i tryed to keep
Dane syntax simple, and we have what we got.

At first you should declare/request the whole amount of Tank memory (aka TRAM)
you want to use in program:

; allocate 834 samples in internal tank memory:
itramsize 834;

; allocate the number of samples in external tram:
xtramsize 834;
; or
xtramsize 0x342;

Then you don't need to declare delayline, it's automatically allocated
when you are creating tram write access register.
; declare external tram write access register
xdelay write delayinput at 0x888;
; above statement allocates tram write registers pair
; with address of tram to write with offset 0x888 (2184 samples)
; + offset of tram allocated for program (doh..)

Did you remember that tram access requires two registers actually?
Since TRAM Access Data Register and TRAM Access Data Register always
go together let's use the term "TRAM Access Pair".

;In code you access Data register using symbol you declared access with,
;and access Address register with same symbol after '&' operator:
idelay write idw at 0x00; in most cases first tram of the programm write will have offset 0
; and later in code
"idw" will represent DATA register and
"&idw" will represnt ADDRESS register.

(compare with as10k1 syntax where "idw" will be DATA too, but ADDRESS will be
represented with "idw.a" symbol)

Also don't mess Dane '&' operator with  C/C++ '&' operator:
In C - "&symbol" means address of memory where value of "symbol" located,
but in Dane "&symbol" means address of tram memory where "symbol" points
to!

;Let's declare Tank Memory Read Access Pair:
xdelay read delayout at 0x1000;

So to get an 0x2000 samples delay line we should:
;declare write register
idelay write d at 0x0000;
;declare read register
idelay read dr at 0x2000;
; Later in code writing to d and reading from dr
; we will get desired 0x2000 samples delay line

You can convert samples into seconds using equation
'seconds = samples / 48000' - since emu10kx DSP has 48kHz fixed sample rate.
(Dane does not support values in seconds yet, -> todo)

Two important difficulties of using Delays/TankMemory with Dane.

1. Tram access pairs are declared with address offset within whole TRAM
requested for program.
So to get two delay lines with size of (for example) 2 seconds
we should do something like:

xtramsize 0x2EE01; 0x2EE01 = 2 * 2 * 48000 + 1
xdelay write delayline1write at 0x00000;
xdelay read delayline1write at 0x17700; 0x17700 = 2 * 48000
xdelay write delayline2write at 0x17701; 0x17701 = 2 * 48000 + 1
xdelay read delayline1write at 0x2EE01; 0x2EDF7 = 0x17701 + 2 * 48000

Looks very weird, but see echo1 and chorus, it's a bit simplier that it seems.

2. Tram access pairs are declared with address offset within whole TRAM
requested for program, but when we'll try to access ADDRESS register
from fx8010 code (at runtime) it will have other value:

addressvalue = offset_of_reg_within_pgm + offset_of_tram_allocated_for_pgm

This cannot be simply avoided (at least with asm - compiler maybe),
but good example trick is shown in chorus program source (pgms\chorus1\chor14ti.da).

Tip: Don't forget to declare delays with 'at' instead of '='!

Future: Of coarse i think of making usage of delay lines with Dane simplier.

-----------------

Other register declaration keywords.

wscl, iscl, oscl, intr, coarse.
They are implemented for RIFX compability and will be removed (or changed)
in future, don't use them!

-----------------

Reserved keywords and operators:

"rsaw".

-----------------

DSP and Numeric Values.

As you know fx8010 is a 32 bit fixed-point DSP,
so we need some tips on using numeric values.

At first read fixed-point math relaited stuff in 'As10k1 Manual',
then read followed stuff considering Dane:

1. Dane is kind of typeless language, since in most cases values
are stored in 32 bit register.

2. Default number format is fractional (fixed-point),
i.e. 1, 1.0, 1., 0.5, 0.2 etc. stored as 32 bit fractionals.

3. Fractional numbers have range from -1.0 to 1.0

4. Numbers having value more then 1 or less then -1 are truncated
to and stored as 32 bit integers.

5. To assign an integer to a register used C-like hex digit format
starting with '0x' (e.g. 0x3fff5555)

6. Fractional 0 and integer 0 are the same values.

Some examples:

static fone = 1; stored as 0x7fffffff
static ione = 0x1; stored as 0x00000001
control half = 0.5; stored as 0x3fffffff
control minfract = -1; stored as 0x80000000
const int = 1024; stored as 0x00000400
const notfract = 5.2; truncated and stored as 0x00000005

Also see some numbers tips in next section.

-----------------

Code Syntax.

Code represented with set of instructions in followed format

OPCODE R, A, X, Y

where OPCODE is DSP instruction mnemonic (e.g MACS ;),
and R, A, X, Y operands representing registers.

What can be used as operand:

1. Symbol representing register you declared before.
2. Any numeric value (with convenions described in 'DSP and Numeric Values' above).

Examples:

;----------
input in;
output out;

;code
macs out, in, 0, 0
; writes value of 'in' register to 'out' register
; i.e. out = in + 0 * 0 or just out = in

;----------
static S
const half = 0.5

MACW	s, 0xcccccccc, s, HALF;
; in fractional tirms: s = -0.40 + s * 0.5
; in integer: s = 0xcccccccc + s * 0x3fffffff

-----------

Note: '1' (as well as '1.' and '1.0') are not always undestantood by Dane as
fractional 1 in code, for example using 1 as Y operand in MACINTS instruction
cause Dane to use value 0x1 instead of 0x7fffffff.
Example:

static a;
const c = 1.0;

MACS	a, 0, c, 1.0;		a = c * 0x7fffffff
MACINTS a, 0, c, 1.0;		a = c * 0x00000001

(Guide to follow / Subject to change)

-----------

END Keyword.

Dane DSP Programm must be ended with end keyword,
and all after end will be ignored.

-----------

Critical notes on Beta verion of Dane.

1. (absolute) Use all of input/output registers you've declared in code,
living unused may cause unexpected execution of program.
Comment out or remove unused register of such type.

2. Do not use input registers in code more then once,
this limitation relaited to current format of binary dsp program
(atleast rfx one) and may cause unexpected execution.

3. Do not use input/output registers in single instruction
more then once, in future it may cause unpredictable DSP behaviour
due to nature of Emu10kx architecture.
(For now it's ok to do this).

4. Dane does not check if your program resources will fit
into available target dsp resources. So check it yourself
if program is built successful but cannot be loaded.

-----------

OK, more information to follow, and now
Dane / As10k1 / FxAsm conventions.

+----------------------------------------------------------+
|                       Instructions                       |
|----------------------------------------------------------|
|       Dane          |    As10k1         |    FxAsm       |
+----------------------------------------------------------+
        macs                macs              n/a
        macsn               macs1             n/a
        macw                macw              n/a
        macwn               macw1             n/a
        macints 	    macints           n/a
        macintw             macintw           n/a
        acc3                acc3              n/a
        macmv               macmv             n/a
        andxor         	    andxor            n/a
        tstneg         	    tstneg            n/a
        limit         	    limit             n/a
        limitl        	    limit1            n/a
        log            	    log               n/a
        exp                 exp               n/a
        interp              interp            n/a
        skip                skip              n/a
+----------------------------------------------------------+

+----------------------------------------------------------+
|                       Register Types                     |
|----------------------------------------------------------|
|       Dane          |    As10k1         |    FxAsm       |
+----------------------------------------------------------+
    input                                      ??
    output                                     ??
    static                static               GPR
    control               control              ??
    static coarse         n/a                BUF GPR
    const                 constant             ??
    n/a	       	      n/a		 DELAY
    idelay read           tread                n/a
    idelay write          twrite               n/a
    temp                  dynamic            TEMP GPR
+----------------------------------------------------------+

------------
Stuff.

Yep, Dane is pretty simple (so i prefer to call it Translator instead
of Assembler).

------------
Anyway.

Don't fear to expirement with it because:
1. You don't burn you card (well, speakers maybe ;)
2. Dane can determine and notify you of about 300 errors
you could make in *.da program


The kX Automation

kX автоматизация

Краткий обзор

Когда загружается плагин в окне kX DSP ему присваивается номер и он появляется в разделе Plugin окна kX автоматизация. При выборе плагина в правом верхнем окне появятся доступные параметры настройки.

Здесь вы можете задать различные параметры MIDI контроллера. Доступные управления по MIDI каналам - контроллеры, модуляция звука и нот, вкл./выкл. сообщений на 16 MIDI каналах.

Диапазон сообщений нот и сообщений контроллера от 0 до 127. Диапазон модуляции звука - 16384 шага, что хорошо подходит для изменения больших величин как частотных значений.

Параметры управляются из любой MIDI совместимой программы через MIDI порт kX Control или через kXi VST инструмент.


Remote Controller

kX пульт

Окно kX пульта на данный момент не имеет никаких кнопок, так что руководство будет готово только после реализации.


Setup & Installation

Руководство по инсталляции kX драйвера

Примечение: данное руководство по установке несколько устарело. Наша новая инсталляционная программа позволяет произвести практически автоматическую установку без вмешательства пользователя. Однако, ручная установка по-прежнему возможна. Файлы драйвера распаковываются программой установки в папку: "C:\Program Files\kX Project\35xx", откуда Вы можете осуществить ручную установку с использованием программы setup.exe или запустив Мастер установки аппаратуры Windows.

Перед началом инсталляции вы должны извлечь библиотеки (MFC42D.DLL и MSVCRTD.DLL) в системную директорию (Windows\System - Win98SE/WinMe; WINNT\System32 - Win2000; Windows\System32 - WinXP). Иначе, установка не запустится.

Инсталяция kX микшера начинается с запуска файла setup.exe:

1. Когда вы кликните 'Install', появится Лицензионное соглашение и чтобы продолжить установку вы должны ознакомиться с условиями и принять их.
2. Инсталлятор удалит текущие драйвера (если обнаружена ранняя версия, попробует ее модифицировать).
3. kX драйвер не сертифицирован WHQL, так что вы должны нажать 'всё равно продолжить' если спросит.
4. Если нет никаких gameport драйверов, kX установит их также (если есть, то инсталлятор их не тронет).
5. После инсталяции вы должны указать путь к папке с VST плагинами (или нажмите 'Cancel' если не используете что либо подобное Cubase VST).
6. Перезагрузите компьютер и начинайте работу.

Минимальные инсталляционные требования - Microsoft Windows 98 Second Edition, Windows Millenium Edition, Windows 2000 или Windows XP. Не менее одной Creative Labs Audigy или EMU10k1-совместимой звуковой платы, или E-mu Systems APS. DirectX 8 или выше должен быть установлен до инсталяции kX Драйвера. Минимум 32 MB оперативной памяти и видео, способное отображать HiColor (16 bit) или TrueColor (24bit) строго рекомендуется (фактически - требуется).

Примечание к установке с несколькими платами:

Для систем с более чем одной kX-совместимой платой; Все платы будут автоматически установлены и вы будете видеть всплывающее окно с предупреждением о WHQL сертификации. Если вы хотите использовать одну плату с kX драйверами а другую с оригинальными драйверами - вы должны провести инсталяцию вручную (это редкий и исключительный случай).

Метод ручной инсталяции:

Попробуйте сначала запустить setup.exe, если вы потерпите неудачу, переходите к ручному способу.

1. Извлеките все файлы из RAR или ZIP во временную папку.
2. Щелкните на диспетчере устройств в панели управления/система.
3. Выберите драйвер, нажмите 'Обновить' и укажите путь к файлу kx.inf во временной папке.
4. Произойдет автоматический выбор нужных драйверов для вашей звуковой платы (обнаруживая PCI ID) и их инсталяция.
5. После завершения инсталяции перезагрузитесь.

Далее, в Панели управления щелкните на звук и мультимедиа, или что-то подобное и в раскрывающемся списке Основных устройств выберите kX Wave 0/1 как устройство по умолчанию, щелкните на кнопке 'Дополнительно' и установите режим работы колонок kX Драйвера:

Динамики:
'Установка Динамиков' --> '5.1 Surround Sound Speakers' или 'Surround Sound Speakers'

Быстродействие:
'Аппаратное ускорение' --> 'ПОЛНОЕ'
'Частота дискретизации' --> 'МАКСИМУМ'

Удаление kX аудио драйвера:

1. Закрыть kX Микшер.
2. 'Пуск/Программы/kX Audio Driver' выбрать 'Uninstall kX Software'.
3. Дождаться окончания деинсталяции и если устройства удалились не полностю, удалите их вручную в диспетчере устройств.

Примечание:

Вторая перезагрузка может потребоваться при работе под Windows 98SE во время изменения названия мультимедия устройства.

Под kX драйвером, микшер Windows отображает только основные функции (Master, Wave, CD, LineIn, Synth). Используйте kX микшер для дополнительных функциональных возможностей.

Обратите внимание, что под Windows 98SE может появляться "фантом" фэйдеры (фантом не управляет никакими аудио источниками и ничего не затрагивает - это баг Windows).


kX ASIO Routing and Playback

kX ASIO маршрутизация и воспроизведение

Краткий обзор

Секция ASIO воспроизведения состоит из 16 моно шин, идущих на выходы FXBus 0-15 в kX DSP апплете. По умолчанию, шины разделены с другими звуковыми потоками, такими как wave, синтезатор, и посылы на эффекты. Вы всегда можете изменить установки ASIO маршрутизации и настроить их для личного использования. Это включает в себя использование внутренних DSP эффектов и/или параметров микширования.

kX ASIO Router

Функции kX ASIO маршрутизатора ограничиваются окном kX Router. Ранее известный как kX ASIO Router был "перемещен" в kX Router (из-за их похожести). Маршрутизация абсолютно идентична маршрутизации в kX Router.

Окно ASIO маршрутизатора открывается нажатием кнопки kX Router в kX микшере. Каждый моно выход имеет свои собственные параметры настройки маршрутизации и может быть быть направлен одновременно к 4 шинам. (стерео выход в ASIO состоит из двух FXBus, имеющих четные/нечетные последовательные номера.)

Одна шина не может быть направлена к той же шине более чем один раз.

Например, левый выход kX Out 0 направлен к шинам 0, 15, 13 и 14, и, допустим выдвинуты ползунки фэйдеров 0 и 14. В этом случае, на шине 0 будет чистый сигнал, в то время как шина 14, соединенная с эффектом стерео хорус, будет действовать подобно эффекту посыла/возврата.

Примечание: Это будет зависеть от ваших текущих настроек окна DSP.

Чтобы использовать различные шины с применением ASIO драйвера, вы должны:

  • Удостовериться, что выходы разрешены в прорамме(ах), использующих ASIO.
  • Выбрать режим выхода (моно или стерео) в вашей программе.

Панель управления kX ASIO

Установки ASIO открываются из программы, использующей ASIO драйвер. Используйте это окно для установки latency (времени задержки) ASIO.

Кнопка kX Automation открывает окно kX автоматизации.

Использование увеличения времени ожидания может быть полезно, если вы слышите щелчки или сбои при записи wave или при использовании программных синтезаторов. Самое маленькое пригодное для использования время ожидания зависит от вашего аппарвтного обеспечения, системных ресурсов и текущей загруженности системы.

ASIO драйвер поддерживает задержки от 'почти реального масштаба времени' 2.66ms до 341.33ms.

Обратите внимание, что из-за аппаратных ограничений kX ASIO драйвер блокирует частоты дискретизации отличные от 48kHz (оба чипа 10k1 и 10k2 имеют фиксированную частоту дискретизации).

Подсказки и Советы

Cubase VST разрешает по умолчанию только один стерео выход ('Master'). Новые выходы можно разрешить в Cubase Master mixer. Разверните окно, чтобы открыть все 8 стерео выходов. Их разрешают, нажимая 'Active' для каждой шины, которую вы хотите активизировать. Фактически, пара kX FXBus выбирается ниже кажого фэйдера. После этого, новые выходы станут доступны из VST микшера для кажого канала. Cubase SX также по умолчанию активирует только одну стереопару. Включаются они в окне VST Outputs. Входные ASIO каналы включаются соответственно в окне VST Inputs

Logic Audio автоматически разрешает все ASIO входы и выходы, когда выбран тип этого драйвера. Входы и выходы выбираются из Аудио микшера. Вы можете уменьшить число ASIO I/O (входов-выходов) в настройках Logic 'Audio Hardware and Drivers'.

Logic Audio Platinum автоматически устанавливает четыре колонки объемного звучания на выходы 1-4 (FXBus 0-3) - фактически, может быть установлено до 9 колонок (8 каналов + LFE).

Для получения более подробной информации об использовании и настройке ASIO драйвера, пожалуйста обратитесь к документации, поставляемой с программным обеспечением.

Cubase и VST - зарегистрированные торговые марки и ASIO - торговая марка Steinberg Media Technologies AG.


Getting started with ASIO recording

Руководство по записи ASIO

Включение ASIO записи требует некоторого внесения исправлений в kX DSP апплет. kX DSP апплет открывается нажатием кнопки kX DSP в окне микшера или щелчком правой кнопкой мыши по значку в сиситемном трее и выбором 'kX DSP' из kX Меню.

Входы на ASIO запись располагаются в объекте epilog (обратитесь к Руководству по kX DSP за более подробной информации по этому и другим основным объектам). Последние 16 входов этого объекта соответствуют ASIO входам. Эти входы позволяют одновременно записывать 8 стерео входов или 16 моно входов (или любую комбинацию из них).

По умолчанию, никакие источники не связаны с этими входами, поэтому вам надо будет самим добавить источник записи на вход ASIO. (в последних версиях добавлена ASIO маршрутизация по умолчанию. прим. редактора)

Входы звуковой платы располагаются в объекта prolog. Другими словами, выходы на прологе представляют собой физические входы на вашей звуковой плате (на фронтальной части платы, дочерних платах или внешних устройствах, связанных с платой). Эти разъемы - стерео пары и соответствуют нижней строке фэйдеров, расположенных на вкладке Входы и Выходы окна kX Микшера.

На платах 10k1 пролог представляет следующие входные сигналы (7 стерео пар):

In0/1: AC97 Вход
In2/3: CD Цифровой вход
In4/5: I2S вход
In6/7: Optical / Coaxial вход (LiveDrive)
In8/9: Line 2/mic 2 вход (LiveDrive)
In10/11: Coaxial / Optical вход (LiveDrive/дочерние платы)
In12/13: AUX 2 вход (LiveDrive)

Пример - запись с линейного входа

Аналоговые входы располагаются непосредственно на звуковой плате (Line/Mic/Aux/CD/TAD/Video) и выбираются на вкладке AC97 окна kX микшера, и запись может производиться отдельно с каждого из них в режиме стерео или моно (но не комбинировано - смотрите сигнальную блок-схему для получения большей информации). Чтобы произвести запись с линейного входа, на вкладке AC97 окна kX Микшера, выберите источник записи - линейный вход и включите фэйдер LineIn. Все остальные фэйдеры должны быть приглушены; перейдите на вкладку входы и выходы микшера. Здесь вы можете использовать фэйдер AC97 (должен быть включен) для регулировки уровня. Далее, в окне kX DSP вы должны соединить контакты in0 и in1 объекта prolog с контактами asio0 и asio1 объекта epilog, как это показано ниже (о том, как производить соединения, вы можете узнать из руководства по kX DSP):

Теперь ASIO драйвер установлен в режим записи со входа AC97 (который выбран в kX микшере). Обратите внимание, что не обязательно удалять все установленные по умолчанию соединения пролога.

Теперь вы должны разрешить ASIO вход в вашей программе, использующей ASIO запись (такой как Cubase, Logic, и т.п.). Может быть, было бы мудро отключить программный мониторинг в вашей программе, чтобы избежать появления двух сигналов. Если вы хотите одновременно записываться с другого входа, просто соедините выходы сигнала из пролога с другой ASIO парой и разрешите запись с этого входа в использующейся для записи программе.

Другие подсказки

Фактически, вы можете соединить любой выход в kX DSP апплете с ASIO входами и записать все, что идет с этого выхода. Это означает, что вы можете записать любой сигнал, будь то ревер, конечный смикшированный сигнал или сигнал с одного канала миди синтезатора.

ASIO Подсказки

В программе Cubase, вы можете разрешить функцию 'Play In Background' , чтобы позволить Кубэйсу воспроизводить в то время, когда вы будете находиться в других программах (или корректировать DSP настройки).

Cubase и VST - зарегистрированные торговые марки и ASIO - торговая марка Steinberg Media Technologies AG.


Проверка колонок

kX Проверка колонок

kX микшер предоставляет утилиту "проверка колонок" для тестирования конфигурации динамиков.

Для 2-х колонок или наушников будет доступна только передняя пара динамиков.

Для 4-х колонок также доступна еще и задняя пара динамиков.

Для настроек с объемным звучанием 5.1 помимо центральных и тыловых колонок доступны также динамики центрального канала и сабвуфера.

Для проверки колонок кликните на иконку Test . Контрольный звук будет воспроизводиться в каждой колонке поочередно для проверки их функциональности.

Примечание
Независимо от того, какую конфигурацию динамиков Вы используете, мы рекомендуем режим 5.1 объемного звука или режим Динамики объемного звука (в зависимости от доступного выбора) в панели управления Windows. Установка режима динамиков не важна - кроверка колонок всегда будет показывать все доступные динамики [в зависимости от ваших аппаратных средств: 4 или 5.1], но Вы можете использовать 'downmix', 'Surrounder', 'surround' или 'cnv51to20' эффекты в kX DSP, чтобы произвести микширование в соответствии с установкой ваших колонок.


Surrounder

kX Surrounder

Surrounder используется для установки конфигурации динамиков.

Возможно создать вручную любую конфигурацию динамиков, либо выбрать из готовых установок подходящую к различным целям. Также возможно выгрузить этот эффект и протянуть виртуальные кабеля в kX DSP непосредственно от нужных выходов routing или FX Bus к нужным контактам эпилога.


Known Issues

Общие

  • Передние и тыловые колонки заменены по умолчанию (это сделано специально) - объяснения здесь.
  • EAX/EAX2.0/EAX3.0 поддерживаются не полностью.
  • Нет поддержки DirectSound3D (только 2D эмуляция).
  • Громкость MIDI синтезатора не меняется в масштабе реального времени.
  • Если у вас ACPI система, то возможно вам придется отключить ее. Обратитесь к ACPI руководству для более подробной информации.

DSP

  • Установка TRAM в размер 0 (хотя это не рекомендуется) может вызвать BSOD.

SoundFonts

  • Максимальный размер одного сэмпла для SoundFonts может быть ограничен параметрами системной памяти.

Аппаратная зависимость

  • Настройки уровней, фаз и т.д. не могут быть оптимизированы для редких версий AC97 кодека.
  • SB006x / SB010x платы имеют проблему с отображением ASIO входов и выходов, которую нельзя устранить (аппаратная проблема).
  • SB020x платы (Dell OEM SB Live!) базируются на других EMU10k1 чипах, которые в настоящее время не поддерживаются.

Системная зависимость

  • Может потребоваться специальная настройка параметров панели управления для систем Win2k (обратитесь к руководству по инсталяции).
  • Могут быть фантомные фэйдеры управления CD-Audio и Wave в микшере Windows.

Другие программы

  • Использование сторонних "Lilac" скинов может привести к утечке ресурсов.
  • Некоторые TV-тюнер программы (например от ATI) могут быть несовместимы с kX драйвером. Смотри ATI сайт поддержки для большей информации.
  • Могут быть проблемы при завершении работы. Смотрите сайт техподдержки Microsoft для большей информации.


FAQ

[Некоторые части данного документа могли устареть. Пожалуйста, дополнительно прочтите более новую английскую версию]

Общие вопросы

  • Что такое kX Project?
  • Действительно, что kX Драйвер БЕСПЛАТНЫЙ?
  • Какие звуковые платы я могу использовать с kX драйвером?
  • Почему я должен использовать kX драйвер, а не драйвера, которые шли с моей звуковой платой? В чем преимущества kX Аудио Драйвера?
  • kX драйвера нацелены на музыкантов или геймеров, или и тех и других?
  • Под какой операционной оистемой я могу использовать kX драйвер?
  • kX драйвер включает поддержку DirectX?
  • kX драйвер имеет поддержку ASIO? ASIOv2?
  • Какое наименьшее время задержки я могу получить в Cakewalk Sonar?
  • kX драйвер поддерживает несколько звуковых плат? Как много?
  • Могу я использовать стандартный микшер Windows с kX драйвером?
  • Имеется ли специализированный микшер в поставке с kX драйвером?
  • Каковы характеристики микшера? Могу я сохранять и восстанавливать настойки микшера?
  • Будет поддержка GSIF?
  • Будет поддержка для Creative Labs Extigy?
  • Почему происходит серьезная загрузка процессора при использовании kX ASIO драйверов под Logic?
  • Почему передние и тыловые колонки заменены по умолчанию?
  • Где я могу получить техническую поддержку для kX драйвера?
  • Почему нет устройства 'Wave 2/3'?
  • Почему моя CT4830/SB0090/SB0220 распознается как CT4832/SB0092/SB0222? Влияет это на качество звука?

Инсталяция / деинсталяция

  • Почему Windows говорит мне, что отсутствует требуемый DLL, когда я пытаюсь установить kX драйвер?
  • Как установить kX драйвер под Windows 2000 или Windows XP?
  • Как я могу деинсталировать kX драйвера?
  • Какие минимальные системные требования рекомендуются для работы kX драйвера?
  • Почему я получаю следующее сообщение: 'The ordinal 11 could not be located in the dynamic link library DSOUND.DLL'?
  • Почему я получаю сообщение, что kxsetup.exe обращается к отсутствующему SHELL32.DLL:SHGetSpecialFolderPathA?

ASIO

  • kX драйвер имеет поддержку ASIO? ASIOv2?
  • Почему я получаю следующее сообщение: "Error creating input buffer: -2147467263 (#0) [size=4096] ret=-2147467263"?
  • Какую величину latency (время задержки) я могу установить?
  • kX поддерживает ASIO 2 Direct Monitoring?

DSP

  • DSP эффекты поддерживаются kX драйвером?
  • В набор kX драйвера включена панель управления эффектами?
  • В набор kX драйвера включены новые эффекты?
  • Могу я написать свои собственные DSP эффекты для использования с kX драйвером?

SoundFonts

  • Могу я использовать SoundFont с kX драйвером?
  • В набор kX драйвера включена панель управления SoundFont?
  • Могу я использовать редактор SoundFont Vienna с kX драйверами?
  • Могу я использовать редактор SoundFont Alive с kX драйверами?
  • 32MB - это предел воспроизведения сэмпла? Относится это также и к Audigy?
  • Почему я не могу загрузить большие SoundFont'ы?

Неисправности и их устранение

  • Почему kX Микшер не находит файл kxskin.kxs, хотя он находится в той же самой папке?
  • Почему у меня появляются щелчки и повреждения данных при копировании / прожиге CD? У меня чип VIA 686B Southbridge.
  • Почему Windows говорит мне, что отсутствует требуемый DLL, когда я пытаюсь установить kX драйвер?
  • Почему я получаю следующее сообщение: 'The ordinal 11 could not be located in the dynamic link library DSOUND.DLL'?
  • Почему я получаю следующее сообщение: "Error creating input buffer: -2147467263 (#0) [size=4096] ret=-2147467263"?
  • Почему Cubase вызывает неисправимую прикладную ошибку (Синий экран) в файле emuaps.vxd?
  • Почему я получаю сообщение, что kxsetup.exe обращается к отсутствующему SHELL32.DLL:SHGetSpecialFolderPathA?
  • Почему я испытываю проблемы с завершением работы с kX микшером?
  • Почему я получаю сообщение 'Debug assertion failed'?
  • Как настроить мой компьютер для оптимальной работы?
  • При воспроизведении MIDI слышатся потрескивания независимо от того, какой SoundFont я использую - что я должен сделать? У меня VIA чипсет и AMD процессор.

В. Что такое kX Project?

О. kX Project является полностью независимым проектом разработки, цель которого состоит в том, чтобы обеспечить совместимость WDM Аудио Драйверов с более новыми операционными системи для всех kX-совместимых аудио плат. kX Проект возглавляют Евгений Гаврилов, Макс Михэйлов и Hanz Petrov (полный список смотрите здесь).

Top

В. Действительно, что kX Драйвер БЕСПЛАТНЫЙ?

О. Да, kX Драйвер БЕСПЛАТНЫЙ и будет БЕСПЛАТНЫМ. Однако, Вы можете поддержать дальнешую разработку проекта, осуществив Ваши инвестиции и пожертвования в kX Фонд.

Top

В. Как установить kX драйвер под Windows 2000 или Windows XP?

О. Windows 2000 и Windows XP обеспечивают некоторые EMU10KX-подобные аудио платы своими собственными заверенными драйверами. Наш kX Аудио Драйвер не был заверен Microsoft (WHQL), и таким образом требуется специальная процедура нсталляции . Рекомендуем сначала пробовать запустить kXSetup, и если это не сработало, следуйте нашему руководству по установке в Windows XP.

Top

В. Будет поддержка GSIF?

О. GSIF не является открытым стандартом, но после проведения переговоров с Nemesys/Tascam, мы наконец то получили технические требования GSIF (под NDA) и мы в настоящее время исследуем способы поддержки GigaSampler. В настоящее время мы не можем назвать никаких конкретных дат выхода. (поддержка GSIF добавлена начиная с версии 3532. Прим. редактора)

 Top

В. Почему происходит серьезная загрузка процессора при использовании kX ASIO драйверов под Logic?

О. Вы должны попробовать отключить неиспользуемые kX ASIO входы и выходы. Logic открывает все 16 входов и 16 выходов по умолчанию.

 Top

В. Почему передние и тыловые колонки заменены по умолчанию?

О. Прочитайте пояснение к передним и тыловым выходам для больших подробностей.

Top

В. Почему у меня появляются щелчки и повреждения данных при копировании / прожиге CD? У меня чип VIA 686B Southbridge.

О. Пожалуйста прочитайте нашу статью Проблемы Via 686B Southbridge и SBLive / Audigy.

Top

В. Почему Windows говорит мне, что отсутствует требуемый DLL, когда я пытаюсь установить kX драйвер?

О. kX Микшер и kX Setup статически соединены с некоторыми Windows DLL, которые отсутствуют в вашей системе. Вы можете загрузить требуемые библиотеки с нашей страницы kX Скачивание если они отсутствуют в вашей системе. (в последних версиях инсталлятор делает это автоматически. прим. редактора)

Top

В. Как я могу деинсталировать kX драйвера?

О. Запустите 'kxsetup --clean' из командной строки или выполните Пуск - Программы - kX Audio Driver - Uninstall kX Software.

 Top

В. Какие минимальные системные требования рекомендуются для работы kX драйвера?

О. kX драйвер устанавливается и работает только на системах Microsoft Windows 98 Second Edition, Windows Millenium Edition, Windows 2000 или Windows XP. Не менее, чем одна Creative Labs Audigy или EMU10k1-подобная звуковая плата, или звуковая плата E-mu Systems APS. DirectX 8 или выше должен быть инсталирован до установки kX драйвера. Минимум 32 MB оперативной памяти и видеокарта, способная отображать режим HiColor (16 bit) или TrueColor (24bit), что настоятельно рекомендуется (фактически требуется).

 Top

В. Почему я получаю следующее сообщение: 'The ordinal 11 could not be located in the dynamic link library DSOUND.DLL'?

О. У Вас не установлен DirectX 8 или выше.

 Top

В. Почему я получаю следующее сообщение: "Error creating input buffer: -2147467263 (#0) [size=4096] ret=-2147467263"?

О. Вы не установили 'Аппаратное ускорение' в 'Полное' в Панели Управления.

 Top

В. Почему я получаю сообщение, что kxsetup.exe обращается к отсутствующему SHELL32.DLL:SHGetSpecialFolderPathA?

О. Ваша Операционная Система - Windows 98 Lite - эта ОС частично поддерживается последними версиями kX Драйверов.

 Top

В. Почему Cubase вызывает неисправимую прикладную ошибку (Синий экран) в файле emuaps.vxd?

О. Вы не полностью деинсталировали E-mu APS драйвера и удалили APS-связанные файлы из вашей Windows\System директории.

 Top

В. Какие звуковые платы я могу использовать с kX драйвером?

О. В настоящее время, kX-совместимые звуковые платы включают все EMU10k1 и EMU10k2 PC платы, изготовленные Creative Technology Ltd. и/или E-mu Systems Inc., включая:

  • E-mu Audio Production Studio (APS) платы
  • Материнские модели 10k1 плат (M002, M003 и другие)
  • PCI256 (CT4890, CT4891 и CT4893) и PCI512 (CT4820 и SB0150) включая OEM модель (CT4790)
  • Оригинальный Live! (CT4620) и Live! Value платы (CT4670)
  • Live! X-Gamer, Live! MP3+, Live! Player 1024, Live! Platinum платы (CT4760) и value платы (CT4780)
  • Live! X-Gamer 5.1, Live! MP3+ 5.1, Live! Player 5.1, Live! Platinum 5.1, Live! Digital Entertainment 5.1 платы (SB0060, SB0100, SB0102, SB0220, SB0222, SB0103 and SB0105) и Value 5.1 (SB0101)
  • Универсальные и заказные OEM Live платы (CT4830, CT4831, CT4832, CT4850, CT4870, CT4871 и CT4872)
  • Серии Audigy и Audigy2, включая Audigy MP3+, X-Gamer, Platinum и OEM платы (CT0070, CT0072, SB0090 и SB0092), платы Audigy2, Audigy2 Platinum, Platinim Ex (SB0240,SB0280,SB0320).

    • Поддержка серий Audigy2 ZS в данный момент экспериментальна, т.к. у нас нет Audigy2 ZS платы для испытаний. Однако, как только у нас будет достаточно денег, чтобы купить ее, поддержка будет осуществлена. Если Вы хотите нам помочь, пожалуйста пожертвуйте в kX Фонд.

    Dell OEM SB Live! (SB020x) не поддерживается, т.к. использует заказную версию EMU10k1, технические параметры которой неизвестны. Экспериментальная поддержка может быть обеспечена после того, когда подробная информация об этом станет доступной.

    Top

    В. Будет поддержка для Creative Labs Extigy?

    О. Не в настоящее время. Extigy - это НЕ 10k1/10k2 совместимые платы (большинство из них функционируют на основе программного обеспечения), и т.к. это USB аудио устройство, то в настоящее время не является kX-совместимым.

     Top

    В. Под какой операционной системой я могу использовать kX драйвер?

    О. kX драйвер приспособлен к техническим требованиям WDM (Windows Driver Model) драйвера и поэтому совместим со следующими операционными системами Microsoft Windows: Windows XP, Windows 2000, Windows 98 (только SE) и Windows Me. Windows .NET Server 2003 также может использоваться, однако, это не было проверено. Windows 98 (Первая редакция) не будет поддерживаться, т.к. не имеет встроенной поддержки WDM драйверов (v1.1 или позже).

    Top

    В. Почему я должен использовать kX драйвер, а не драйвера, которые шли с моей звуковой платой? В чем преимущества kX Аудио Драйвера?

    О. kX драйвер может или не может удовлетворять вашим специфическим потребностям, теряете от этого вы немного, так почему бы вам не попробовать? kX драйвер - часть независимого проекта разработки и уже включает большинство, если не все характеристики оригинальных драйверов. Фактически, kX драйвер постоянно модифицируется, обновляется и улучшается.

    основные преимущества

    • быстрая скачка / программа занимает немного места на диске
    • поддержка скинов микшером
    • API является открытым -- SDK, документация и исходные коды доступны для скачивания
    • квалифицированные пользователи могут писать свои собственные эффекты и плагины
    • открытый API позволяет разрабатывать нестандартные микшеры и другие приложения
    лучшие функциональные возможности
    • лучшая поддержка DSP [аппаратное ускорение звуковых эффектов]
    • возможность маршрутизации практически неограниченного количества виртуальных сигналов
    • завершенное и гибкое управление аппаратными средствами (без искуственно наложенных ограничений)
    • прямая неинтерполированная SPDIF запись из Оптических, Коаксиальных и CDSPDIF источников
    лучшая поддержка ASIO
    • ASIO поддерживается для всех 10k1 и 10k2 плат
    • Полная поддержка ASIO v2
    лучшая поддержка MIDI
    • kX VST и kX автоматизация обеспечивают MIDI управление DSP эффектами
    • поддержка расширеной MIDI CC
    • поддержка SoundFont 2.01 и AWE NRPN

     Top

    В. kX драйвера нацелены на музыкантов или геймеров, или и тех и других?

    О. В настоящее время kX драйвер нацелен прежде всего на музыкантов, особенно на тех, кто желает выжать все из своей звуковой платы (и кто был традиционно забыт большими производителями звуковых плат, которые предпочитают концентрировать усилия на прибыльном игровом рынке). Однако, характеристики, специфичные для геймеров будут несомненно добавляться, поскольку развитие драйвера продолжается.

     Top

    В. kX драйвер имеет поддержку ASIO? ASIOv2?

    О. ASIO v2.0 - полностью поддерживается, однако, некоторые особенности ASIO2 не осуществлены из-за аппаратного ограничения. Запланированная поддержка 24-bit ASIO для 10k1 и 10k2 будет осуществлена как можно быстрее (сначала для 10k2, потом для 10k1).

     Top

    В. Какую величину latency (время задержки) я могу установить?

    О. Минимальное время задержки ASIO может быть 5.33 ms (и возможно даже до 2.66 ms, в зависимости от ваших настроек железа/программ).

     Top

    В. Какое наименьшее время задержки я могу получить в Cakewalk Sonar?

    О. kX драйвер - потоковый WDM драйвер, и вы можете установить время задержки до 10 ms, работая с Сонаром (в зависимости от настроек железа/программ) (Sonar 2.2 поддерживает ASIO, соответственно может работать и с меньшими задержками. прим. редактора).

     Top

    В. kX драйвер включает поддержку DirectX?

    О. В настоящее время полностью поддерживается DirectSound2D, а DirectSound3D поддерживается только программно. Обратите внимание, что любые предложения о помощи в осуществлении поддержки DirectSound3D будут с удовольствием приняты (только, пожалуйста, от квалифицированных программистов!).

     Top

    В. kX драйвер поддерживает несколько звуковых плат? Как много?

    О. Несколько звуковых плат действительно поддерживаются kX драйвером. Теоретически, может быть использовано одновременно неограниченное количество звуковых плат, но реально вы будете ограничены количеством PCI слотов на вашей материнке. Любая комбинация EMU10k1 и/или EMU10k2-подобных плат может быть использована с kX драйвером (вместе с звуковыми платами других производителей, использующих собственные драйвера).

     Top

    В. Могу я использовать SoundFont с kX драйвером?

    О. Да, ваша звуковая плата будет функционировать как SoundFont-совместимое устройство под kX драйвером. SoundFonts может быть загружен или выгружен из SoundFont-использующих приложений, или из страницы управления SoundFont kX Микшера. В настоящее время поддерживаются только SF2 файлы, однако SF1 (SBK) файлы можно конвертировать в SF2 файлы используя свободно распространяемую утилиту.

     Top

    В. В набор kX драйвера включена панель управления SoundFont?

    О. Да, в kX Микшер включена панель управления SoundFont, которая позволяет загружать и выгружать SoundFont на совместимых звуковых платах, работающих под kX драйверами.

     Top

    В. Могу я использовать редактор SoundFont Vienna с kX драйверами?

    О. Текущая версия kX драйвера включает поддержку редактора Vienna (за исключением параметра 'wave воспроизведение').

     Top

    В. Могу я использовать редактор SoundFont Alive с kX драйверами?

    О. Редактор Alive еще не полностью совместим с kX драйвером (улучшение поддержки продолжается).

     Top

    В. 32MB - это предел воспроизведения сэмпла? Относится это также и к Audigy?

    О. Воспроизведение сэмпла SoundFont ограничено 32MB данных за раз, хотя можно загружать SoundFont больше 32MB.

     Top

    В. Могу я использовать стандартный микшер Windows с kX драйвером?

    О. Основные функциональные возможности Windows Микшера продолжают работать, хотя аудио микшер (kX Микшер) включенный в пакет драйверов предоставляет доступ к еще многии параметрам. Windows микшер позволяет контролировать уровень воспроизведения Master, Wave, Synth и записи Record. Фэйдер Line-in также может быть добавлен для совместимости с программным обеспечением TV-платы.

     Top

    В. Имеется ли специализированный микшер в поставке с kX драйвером?

    О. Да, пакет kX драйвера включает аудио микшер с богатым набором средств - kX Микшер.

     Top

    В. Каковы характеристики микшера? Могу я сохранять и восстанавливать настойки микшера?

    О. kX Микшер включает регулировку уровней всех входов и выходов, полное управление AC97 Кодеком, отдельный контроль уровня записи, выбираемый режим цифрового выхода, и т.д., и т.д. kX Микшер поддерживает сохранение, загрузку и восстановление всех параметров настройки микшера а так же автоматизацию всех фэйдеров по MIDI.

     Top

    В. DSP эффекты поддерживаются kX драйвером?

    О. Да, kX драйвер поддерживает DSP эффекты, Ревер и Хорус загружены по умолчанию для совместимости с MIDI Синтезатором.

     Top

    В. В набор kX драйвера включена панель управления эффектами?

    О. kX Микшер включает панель управления DSP, позволяя редактирование, загрузку, внесение исправлений и выгрузку выбранных DSP эффектов. Утилита командной строки также включена в пакет kX драйвера, предоставляя прямой доступ ко многим функциям.

     Top

    В. В набор kX драйвера включены новые эффекты?

    О. Да, фактически все включенные в пакет kX драйвера DSP эффекты новые. В настоящее время это: Reverb Lite, Stereo Chorus, Delay, Overdrive, M4Tube (TubeSound), Chorus, AutoWah, CL Reverb, ProLogica, RingMod, Eq10a, APS Flanger, APS AutoWah, Stereo/Mono Vocoders, Overdrive2, Encode4, APS Fuzz, Stereo Mix, Mono Mix, Pan, Pan x2, EQ Bandpass, EQ Highpass, EQ Highshelf, EQ Lowpass, EQ Lowshelf, EQ Notch, EQ Peaking, Frequency Splitter и Timbre эффекты, которые включены в пакет kX драйвера; остальные эффекты будут доступны в ближайшем будущем.

     Top

    В. Могу я написать свои собственные DSP эффекты для использования с kX драйвером?

    О. Да, пакет kX драйвера включает DSP компилятор и загрузчик, позволяя квалифицированным пользователям писать свои собственные DSP эффекты.

     Top

    В. Где я могу получить техническую поддержку для kX драйвера?

    О. kX Форум был создан для того, чтобы позволить пользователям задавать вопросы и обмениваться полезными советами и информацией друг с другом. Разработчики и сторудники будут иногда заглядывать туда, чтобы ответить на вопросы, но не часто (главным образом из-за нехватки времени :-P). Обратите внимание, что адрес электронной почты kX проекта должен использоваться только для сообщений об Ошибках и предложений - вопросы, касающиеся поддержки будут переданы в kX Форум.

    Top

    В. Почему я испытываю проблемы с завершением работы с kX микшером?

    О. Это известная проблема под Windows 2000 / Windows XP. Смотри сайт поддержки Microsoft для большей информации. Пользователям Windows 2000 рекомендуется последний Service Pack - как правило это решает данную проблему с завершением работы у kX пользователей.

    Top

    В. Почему я получаю сообщение 'Debug assertion failed' (Выражение 'SUCCEEDED(hr)&&gpPicture')?

    О. Эта ошибка указывает на то, что повреждена установка Internet Explorer. Чтобы разрешить проблему, переинсталируйте Internet Explorer 5.0 или выше.

     Top

    В. Почему я не могу загрузить большие SoundFont'ы?

    О. Это вызвано ограничениями в управлении памятью Windows. Попробуйте подредактировать следующие ключи в реестре (только для Windows 2000 и Windows XP):

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\
PagedPoolSize
NonPagedPoolSize
NonPagedPoolQuota
PagedPoolQuota
    Для получения большей информации посетите наш форум и Microsoft Knowledge Base.

     Top

    В. Как настроить мой компьютер для оптимальной работы?

    О. Начните с чтения следующих документов: pdf and pdf.

    Top

    В: При воспроизведении MIDI слышатся потрескивания независимо от того, какой SoundFont я использую - что я должен сделать? У меня VIA чипсет и AMD процессор.

    О: Если Вы используете любое программное охлаждение подобно VCool, CPUCool, CPUIdle, и т.д Вы должны отключить их (в VCool Вы должны отключить NB Cool Bit, в CPUIdle отключить 'AMD аппаратно-зависимые' опции).

     Top

    В: Почему нет устройства 'Wave 2/3'?

    О: 'Wave 0/1', 'Wave 4/5', 'Wave 6/7', 'Wave 8/9' являются единственными wave устройствами доступными для WinMM / DirectSound приложений. Они направлены к соответствующему FxBusses, то есть, 'Wave 0/1' по умолчанию направлено к 'стерео' соединению, которое идет на 'передний' выход, 'Wave 4/5' направлено только на перед, 'Wave 6/7' направлено только на тыл, 'Wave 8/9' направлено на центр и сабвуфер.
    Читайте наше "; klink("routings"); print "Руководство по маршрутизации     для большей информации.

    Top

    В: Почему моя CT4830/SB0090/SB0220 распознается как CT4832/SB0092/SB0222? Влияет это на качество звука?

    О: CT4830 и CT4832 - почти идентичные платы с различными PCI идентификаторами (которые запрограммированы во встроенное СППЗУ). CT4832 плата - это вообще OEM версия CT4830, хотя обе платы могли бы маркироваться как 'CT4830'. Работа kX Аудио драйвера не затрагивает качество звука, потому что эти платы распознаются kX (то же самое относится к SB0090/SB0092 и SB0220/SB0222 платам).

     Top

    В: kX поддерживает ASIO 2 Direct Monitoring?

    О: Когда активизирована эта опция в диалоге "установки аудио системы", контроль осуществляется аппаратными средствами звуковой платы, то есть контролируемый сигнал не проходит через Cubase VST. Вместо этого, ASIO драйвер для звуковых аппаратных средств проинструктирован послать аудио из контролируемого входа непосредственно назад к указанному выходу, таким образом обеспечивая контроль практически без временем ожидания, то есть ASIO2 Direct Monitoring просто обеспечивает нулевое время ожидания, контролируя входы. Однако, контроль с нулевым временем ожидания уже обеспечивает kX драйвер ("прямой контроль" включается, когда Вы незаглушаете вход на вкладке "Входы и Выходы" kX Микшера), так что нет никакой причины загружать ваш процессор прямым понтролем ASIO2. Вопреки тому, что много людей верят, что прямой контроль ASIO не позволяет контролировать входящий сигнал с VST эффектами, он обеспечивает только контроль входного сигнала. Другими словами, это означает, что единственная вещь, отсутствующая в kX без "прямого контроля" ASIO2 - отсутствие прямого управления из Cubase (или другой ASIO-использующей программы) для аппаратных средств управления pan/level/peakmeter необработанного сигнала, хотя даже их можно контролировать через kX микшер. И, конечно, Вы можете всегда применять VST/DirectX плагины к стольким входным каналам, к скольким Вы хотите, используя kX ASIO драйвер.

    Top

    В: Почему kX Микшер не находит файл kxskin.kxs, хотя он находится в той же самой папке?

    О: Вы не должны пробовать запускать kX Микшер из папки, в которую Вы вручную скопировали его. kX Микшер должен быть установлен в вашу системную директорию Windows/System32 приложением установки. Не пробуйте установить его вручную - просто повторно запустите инсталляционную программу.

     Top


kX I/O. Сигнальная блок-схема

kX Входы/Выходы. Сигнальная блок-схема

В аналоговом режимe (по умолчанию для не-10k2 плат):

PCM Volume - константа (=0 – нет коэффициента ослабления); Master Volume - константа (=0); Surround Volume - константа (=0); возможность записи/мониторинга одного аналогового источника только через 'Rec Source'; уровень всех ac97 входов установлен в 'mute'; если не приглушенны, то они идут непосредственно на Передние Колонки. Использование режима 'StereoMix' или не глушение ac97 выходов не рекомендуется. Уровень контролируется через DSP ac97in (in0/in1).

В режиме “Только Цифровой Выход”

AC97 PCM, Surround и Master Volumes приглушены; “Rec Source' - 'StereoMix'; это позволяет записывать/контролировать несколько аналоговых источников (с или без PCM – в зависимости от настроек kX DSP); уровни входа могут управляться отдельно. Нужно не заглушать требуемые аналоговые AC97 входы. Уровень управляется исходным ac97 уровнем и DSP ac97in (in0/in1).

Чип 10k2 способен записывать несколько аналоговых источников, когда его PCM уровень установлен в 'muted' и передний выход идет непосредственно в I2S кодек; AC97 выход приглушен по умаолчанию; уровни входа могут управляться раздельно; Толко Цифровой Выход не влияет на AC97 кодек; нет AC97 'surround' выходов – вместо него используется I2S.

The Audigy2-based boards use AC97 codec for recording only. That's why the default signal routing is different compared to 10k1 and 10k2 (Audigy) boards. The AC97 codec outputs are always muted, thus, not affecting front/rear/center+lfe outputs. The 'i2s codec' shown on the diagram above (marked '10k2 only') is used for all the analog outputs.

Audigy2-based boards also have a special 24/96 unit called 'P16V'. More details can be found in here.


Audigy2 routings

Audigy2-based cards have slightly more complicated signal flow compared to 10k1 and Audigy 1 boards (shown on the following diagram).

That is, there's a special unit dealing with 24/96 audio streams called 'p16v'. This unit is capable of recording incoming SPDIF and I2S streams in 24/96 mode. The kX Audio driver enables both p16v and 10k2 to access inputs and outputs by default (as shown above). However, the actual hardware routing is even more complex. In the default mode the Audigy2 chip acts as Audigy1 with p16v unit operating in parallel mode.

By default, p16v->10k2 path is disabled. It is necessary to load the ‘p16v’ effect into the kX DSP window in order to enable it. For example, if you wish to process p16v output and add some 10k2-based reverb, use the following routing:

(Note: ‘swap front & rear’ option might affect the actual p16v outputs you will be using. For instance, in this case ‘swap’ is active, that’s why p16v.‘in7/in8’ are used instead of p16v. ‘in0/in1’. The input numbers correspond to particular i2s/spdif outputs listed in our ‘I/O Assignment guide’).

Recording

P16v 24/96 audio recording uses the same considerations mentioned in our ‘Direct SPDIF Recording guide’. That is, the sampling rate is not auto-detected and it is up to the user to choose the appropriate sampling rate in the audio recording application. Note: you may need to re-assign the sampling rate after recording (not 'resample' the audio, but just re-assign the sampling rate :)).


Руководство по аппаратным средствам

Руководство по аппаратным средствам содержит информацию для Live!, Live! Value, Live! 1024, Live! 5.1, E-mu APS, Audigy и Audigy2 плат.

EMU10k1 выводы: [1]

Вывод | Название | AUD_EXT | SPDIF_EXT
127 | spdifo0 | 17 | 1
126 | spdifo1 | 19 | 9
124 | spdifo2 | 22 | 11
109 | spdifo3 | 9 | 12
122 | cdromi / gpspdifin2 [2] | 6 | 6
123 | gpspdifin1 | 15 |
106 | in0 | 35 |
107 | in1 | 33 |
108 | in2 | 31 |
8,9,10,11,12 | AC97 a1,a2 in; a1,a2 out |  |
112 | gpinput0 | 23 |
110 | gpinput1 | 24 |
 | gpoutput0 | 13 |
 | gpoutput1 | 10 |
 | gpoutput2 | 11 |
128 | outmidi | 25 |
130 | inmidi | 27 |
134,132,131 | ZVideo / i2s |  |

Live!, Live! 1024, Live! 5.1, Audigy встроенные соединения:

 | TAD | CD | AUX In | PC Speaker | I2S [3] | CD SPDIF [4]
Yellow/Orange[5] |  |  |  |  |  |
LineIn | modem connector [6] |  |  |  |  |
MicIn | condenser microphone [7] |  |  |  |  |
LineOut |  |  |  |  | AUD_EXT | SPDIF_EXT [8]
RearOut |  |  |  |  |  |
Joystick/MIDI [9] |  |  |  |  |  |
SB1394 [10] |  |  |  |  |  |

Оранжевый разъём:

  • аналоговый режим: (5.1, Audigy) Центр (левый), Субвуфер (правый)

  • цифровой режим:
    A) левый сигнал: (1024, 5.1, Audigy): spdifo0 (цифровой фронт)
    B) правый сигнал:
    I. (1024): spdifo3 (цифровой тыл) или spdifo1 [11] (микширование фронта и тыла) [12]
    II. (5.1, Audigy); spdifo3 (цифровой тыл)

  • третий сигнал: (5.1, Audigy): цифровой центр/субвуфер (spdifo2 [13])

Обратите внимание: SPDIF#1 - это SPDIFO0; SPDIF#2 - это SPDIFO3; третий сигнал не показан (должен быть перед 'GND' для 5.1 и Audigy плат)

Неофициальная информация по входам/выходам:

Вход/Выход | Live! | APS [14]
ac97out (front) | ac97 front out | (i2s) a1, a2
spdifo0 | digital front; generic SPDIF output | e-card (d1) or a5, a6
spdifo1 | front&rear mix (headphones?) or digital center/sub(?) | a3, a4 (d2) or a7, a8
spdifo2 | digital center/subwoofer or front\rear mix/phones (?) | a5, a6 or (d1)
spdifo3 | digital rear | a7, a8 or a3, a4 (d2)
ac97out (rear) | ac97 analog center/subwoofer (5.1, audigy) |
ac97in | ac97 in (l,r) | a1, a2
cdromi | CDSPDIF | e-card, CDSPDIF
zvideo/i2s | on-board i2s(?) / ZVideo? |
gpspdif | Optical In (?),generic SPDIF In | e-drive
in0 | Line2In / Mic2In (?) and on-board i2s (?) | a3, a4
in1 | Coaxial In (?) |
in2 | AUX2 In (?) |
gpinput0 |  | e-drive present(?)
gpinput1 |  | moc present(?)
Пожалуйста обратите внимание, что обновленную информацию вы можете найти в нашем руководстве 'Значения IO (входов/выходов)'

Ограничения входов/выходов (согласно официальным PDF):

  • Line2/Mic2 не может использоваться одновременно со встроенным i2s.
  • AUX2 не может использоваться одновременно с Optical/Coaxial SPDIF in (кроме режима Обхода).

Дочерние платы:

Цифровой I/O интерфейс (оригинал. модель CT4660):

  • midi in
  • midi out
  • coaxial RCA in
  • coaxial RCA out
  • digital DIN

Оптический цифровой I/O интерфейс (модель CT4770):

  • LineIn2 (*)
  • Digital I/O (for Digital I/O module)
  • digital DIN
  • midi in
  • midi out

(*) – доступен, если только соединен через AUD_EXT

Цифровой Модуль I/O (модель CT4800): -- соединен с “Цифровой Вход/Выход”

  • optical in
  • optical out
  • coaxial in
  • coaxial out

Модуль цифрового выхода (модель CT4801): -- соединяется с 'оранжевым джеком'

  • coaxial output (spdifo 0) -- front
  • optical output (spdifo 0) -- front
  • coaxial output (spdifo 2(?)) – rear
  • optical output (spdifo 2(?)) – rear

LiveDrive (CT4860), LiveDrive II (CT4861), LiveDrive IR (SB0010), AudigyDrive (?):

  • coaxial input
  • coaxial output
  • optical input (*)
  • optical output (*)
  • AUX2 input (*)
  • headphones
  • mic2/line2
  • midi in
  • midi out
  • sb1394 (Audigy only)
  • IR (LiveDrive IR, Audigy Drive)

(*) – доступен на LiveDrive II и более поздних моделях

Описание цифрового DIN:

Вывод | Сигнал
1 | GND
2 | GND
3 | MIDI_IN
4 | S/PDIFO#2
5 | S/PDIFO#1
6 | S/PDIF_IN
7 | MIDI_OUT
8 | S/PDIFO#0
9 | S/PDIFO#3

[1] Официальная информация: базируется на патентах и hwinfo.hlp.
[2] Не ясно, является ли gpspdif1/2 - gpspdif0/1 или 1/0 (hwinfo.hlp): т.е. pin123=gpspdif0=audext#15 и pin122=cdromi=audext#6 или еще как.
[3] Только на оригинальных Live!.
[4] Отсутствует на некоторых 1024 платах.
[5] Только Live! 1024, 5.1 и Audigy.
[6] Только на оригинальном Live! (не-OEM) – MB_PRO соединитель.
[7] Только на оригинальном Live! (не-OEM).
[8] Оригинальные OEM платы.
[9] Не только на Audigy кроме 'большей части OEM плат'.
[10] Только Audigy.
[11] Не проверено; неофициально.
[12] Зависит от перемычки JP1.
[13] Не проверено; неофициально.
[14] APS соединения базируются на неофициальном EMU10k1 выводе ('Рисунок 4').


Назначения входов и выходов kX

Назначения входов и выходов (I/O and DSP assignments)

Выходы

kX Номер | Epilog название | Значение | 10k1 DSP # | 10k1 mne | 10k2 DSP # | 10k2 mne
KX_OUT(0) | out0 | Аналоговый Фронт Левый / A1 | 0x20 | ac97 L | 0x68 | i2s 0 L
KX_OUT(1) | out1 | Аналоговый Фронт Правый / A2 | 0x21 | ac97 R | 0x69 | i2s 0 R
KX_OUT(2) | out2 | Универсальный SPDIF Левый / Цифровой Фронт L / D1 L | 0x22 | spdif 0 L | 0x60 | spdif 0 L
KX_OUT(3) | out3 | Универсальный SPDIF Правый / Цифровой Фронт R / D1 R | 0x23 | spdif 0 R | 0x61 | spdif 0 R
KX_OUT(4) | out4 | Цифровой Центр / A3 / D2 L | 0x24 | spdif 1 L | 0x62 | spdif 1 L
KX_OUT(5) | out5 | Цифровой LFE / A4 / D2 R | 0x25 | spdif 1 R | 0x63 | spdif 1 R
KX_OUT(6) | out6 | Наушники L / A5 | 0x26 | spdif 2 L | 0x64 | spdif 2 L
KX_OUT(7) | out7 | Наушники R / A6 | 0x27 | spdif 2 R | 0x65 | spdif 2 R
KX_OUT(8) | out8 | Тыл L / A7 | 0x28 | spdif 3 L аналоговый и цифровой тыл | 0x6e | i2s 3 L только аналоговый тыл
KX_OUT(9) | out9 | Тыл R / A8 | 0x29 | spdif 3 R аналоговый и цифровой тыл | 0x6f | i2s 3 R только аналоговый тыл
KX_OUT(0x11) | out17 | аналоговый Центр | 0x31 | ac97 S L | 0x6a | i2s 1 L
KX_OUT(0x12) | out18 | Аналоговый LFE | 0x32 | ac97 S R | 0x6b | i2s 1 R
KX_OUT(0x20) | (не существует) не управляемый | AC97 псевдо L | - | - | 0x70 | ac97 L
KX_OUT(0x21) | (не существует) не управляемый | AC97 псевдо R | - | - | 0x71 | ac97 R
KX_OUT(0x28) | (не существует) управляется out8 | Цифровой Тыл | - | - | 0x66 | spdif 3 L только цифровой
KX_OUT(0x29) | (не существует) управляется out9 | Цифровой Тыл | - | - | 0x67 | spdif 3 R только цифровой
KX_OUT(0x30) | out30 | Неизвестный L | - | - | 0x6c | i2s 2 L
KX_OUT(0x31) | out31 | Неизвестный R | - | - | 0x6d | i2s 2 R
KX_OUT(0xa) | RecL | ADC Rec L | 0x2a | ADC Rec L | 0x76 | ADC Rec L
KX_OUT(0xb) | RecR | ADC Rec R | 0x2b | ADC Rec R | 0x77 | ADC Rec R
KX_OUT(0xc) | (не существует) | Mic Rec | 0x2c | Mic Rec | 0x78 | Mic Rec

Выходы

kX Номер | Prolog название | 10k2 mne | 10k2 DSP # | 10k1 mne | 10k1 DSP # | Значение
KX_IN(0x0) | in0 | AC97 ADC Left | 0x40 | -""- | 0x10 | AC97 line-in/mic-in L / A1
KX_IN(0x1) | in1 | AC97 ADC Right | 0x41 | -""- | 0x11 | AC97 line-in/mic/in R / A2
KX_IN(0x2) | in2 | SPDIF A Left | 0x42 | -""- | 0x12 | CD SPDIF L / D1 L
KX_IN(0x3) | in3 | SPDIF A Right | 0x43 | -""- | 0x13 | CD SPDIF R / D1 R
KX_IN(0x4) | in4 | SPDIF C Left | 0x46 | (?) | 0x14 | Unknown 1 In L (ZVideo I2S)
KX_IN(0x5) | in5 | SPDIF C Right | 0x47 | (?) | 0x15 | Unknown 1 In R (ZVideo I2S)
KX_IN(0x6) | in6 | SPDIF B Left | 0x44 | -""- | 0x16 | Coaxial+Optical In L / D2 L
KX_IN(0x7) | in7 | SPDIF B Right | 0x45 | -""- | 0x17 | Coaxial+Optical In R / D2 R
KX_IN(0x8) | in8 | I2S 0 Left | 0x48 | -""- | 0x18 | Line2/Mic2 / Line1(A2Ex) L / A3
KX_IN(0x9) | in9 | I2S 0 Right | 0x49 | -""- | 0x19 | Line2/Mic2 / Line1(A2Ex) R / A4
KX_IN(0xa) | in10 | I2S 1 Left | 0x4a | -""- | 0x1a | Unknown 2 L / Line2(A2Ex) L
KX_IN(0xb) | in11 | I2S 1 Right | 0x4b | -""- | 0x1b | Unknown 2 R / Line2(A2Ex) R
KX_IN(0xc) | in12 | I2S 2 Left | 0x4c | -""- | 0x1c | Aux2 L / Line3(A2Ex) L
KX_IN(0xd) | in13 | I2S 2 Right | 0x4d | -""- | 0x1d | Aux2 R / Line3(A2Ex) R
KX_IN(0xe) | in14 | AC97 Mic ADC | 0x4e | -""- | 0x1e | неиспользуемый
KX_IN(0xf) | (не существует) | Неиспользуемый | 0x4f | -""- | 0x1f | неиспользуемый


Front & Rear Issues

Примечание по передним/тыловым ЦАП

Это примечание относится ко всем E-MU10kX картам, кроме E-mu APS. Зуковые карты Creative audio, основанные на чипах EMU10kX требуют ЦАП (Цифро-Аналоговые Преобразователи) для реалзации аналоговых выходов. В основном эти задачи совместно выполняются кодеками AC97 и I2S.

Как правило, звуковые карты Creative используют AC97 для передних колонок и каналов центр/сабвуфер, и I2S кодек для тыловых выходов. AC97 кодек также используется в качестве АЦП (Аналого-Цифровой преобразователь) и относится ко всем встроенным аналоговым входам. (обратите внимание, что LiveDrive и другие дочерние платы используют другие схемы).

AC97 кодеки, используемые в картах SBLive! - достаточно шумные устройства (в сравнении с кодеками I2S), это объясняет некоторые проблемы в качестве воспроизведения. Как правило, тыловые выходы SBLive имеют лучшее соотношение сигнал/шум и меньший уровень гармонических искажений поскольку они используют кодек I2S. Так, если Вы хотите получить лучшее качество воспроизведения, рекомендуется подключить Ваши акустические системы к тыловому выходу и включит опцию 'поменять местами тыл и фронт' в кХ микшере (включено по умолчанию). Обратите внимание, что i2S кодеки не имеют встроенных буферных усилителей, по этой причине КРАЙНЕ не рекомендуется подключать к тыловым выходам низкоомную нагрузку, как то - колонки без усилителя или наушники.

Карты Audigy используют оба AC97 и I2S кодека для переднего выхода и это теоретически даёт Вам лучшее качество передних выходов. Но всё равно, AC97 кодек является причиной некоторых искажений, так что мы также рекомендуем использовать данную процедуру и с картами Audigy.

Конечно, всё написанное выше является только рекомендацией.


kX Внедрение MIDI

Present kX Audio Driver MIDI implementation:

 0x80 note off
 0x90 note on / off
       Velocity affects Filter Cutoff according to SoundFont 2.01 specification:
       (8.4.2 MIDI Note-On Velocity to Filter Cutoff (-2400 cents))
       for velocities less than 64: Filter Cutoff -= (64-velocity)*2400/64 (0..2400 cents)
 0xa0 key pressure (realtime velocity change)
 0xb0 controller
 0xc0 program change
 0xd0 channel pressure (realtime modulation change)
       MIDI Channel Pressure affects Vibrato LFO Pitch Depth [50 cents / max excursion]
       (according to SoundFont 2.01 specification, 8.4.3)
 0xe0 pitchbend
 0xf0, 0xf7 sysex

 MIDI Controllers:

  0 - bank LSB
       see #32
  1 - modulation
       MIDI Continuous Controller 1 affects Vibrato LFO Pitch Depth [50 cents / max excursion]
       (according to SoundFont 2.01 specification, 8.4.4)
       in 'Legacy mode' affects Modulation LFO Pitch Depth (18 * Modulation CC) / 1200
  2 - breath [under development]
  4 - foot [under development]
  5 - portamento time [under development]
  6 - data entry
  7 - volume
  8 - balance
       stereo balance
       doesn't change instrument positions
  10 - pan
        affects stereo samples in generic way
  11 - expression
  16 - General Purpose 1 [10k2 SendE Amount]
  17 - General Purpose 2 [10k2 SendF Amount]
  18 - General Purpose 3 [10k2 SendG Amount]
  19 - General Purpose 4 [10k2 SendH Amount]
  32 - bank MSB
        supports 'mixed' programming model
        resulting bank number is: LSB+MSB,
        thus, 254 banks are accessible and both 'LSB only' & 'MSB only' modes are supported
        kX Mixer supports 251 (0..250) banks
        this behaviour might change in the future...
  38 - data entry
  64 - sustain
  65 - portamento on/off [under development]
  66 - sostenuto
  67 - soft pedal
       implemented via Filter Cutoff:
       if active, Filter Cutoff is increased by 0x9e (158) - that is, gives 9000 cents
       (that is, Filter Cutoff frequency is decreased)
  68 - legato
       if active, sets Attack time to 0
  69 - hold2
        implemented via Modulation / Volume Envelope Release Time
        if active, Modulation / Volume Envelope Release Time is increased by 1900 timecents
  71 - sound resonance
        implemented via Filter Q (0..15 units)
        0 - resonance is decreased by 15 units
        64 - default
        127 - resonance is increased by 15 units
  72 - sound release
        implemented via Volume Envelope Release Time
        0 - release time is decreased by 2400 timecents
        64 - default
        127 - release time is increased by 2400 timecents
  73 - sound attack
        implemented via Volume Envelope Attack time (0..127 units)
        0 - attack time is decreased by 64 units
        64 - default
        127 - attack time is increased by 64 units
        (log-encoded)
  74 - sound brightness
        implemented via Filter Cutoff
        0 - Filter Cutoff frequency increases (minimum effect depth)
        64 - default;
        127 - Filter Cutoff frequency decreases (maximum effect depth)
  84 - portamento control [under development]
  91 - reverb level
        implemented according to SoundFont 2.01 specification:
        8.4.8 MIDI Continuous Controller 91 to Reverb Effects Send
        Amount equals to 200 tenths of a percent
        that is, 127 gives 20% reverb increase
  92 - tremulo level [under development]
  93 - chorus level
        implemented according to SoundFont 2.01 specification:
        8.4.9 MIDI Continuous Controller 93 to Chorus Effects Send
        Amount equals to 200 tenths of a percent
        that is, 127 gives 20% chorus increase
  94 - celeste level [under development]
  95 - phaser level [under development]
  96 - data increment
  97 - data decrement
  98 - NRPN lsb fine
  99 - NRPN msb coarse
  100 - RPN lsb fine
  101 - RPN msb coarse
  120 - all sounds off [terminate all notes]
  121 - reset all controllers
         the following controlles aren't reset (according to MIDI specification):
         7 (Volume),
         10 (Pan),
         8 (Balance),
         91 (Reverb),
         93 (Chorus),
         92, 94, 95 (Tremulo, Celeste, Phaser)
         0, 32 (Bank selection)
  123 - all notes off [release all notes]

 supported RPNs:
  00 - pitchbend sensivity
  01 - master fine tuning
  02 - master coarse tuning
  7f - RPN reset

 supported NRPNs:
  SoundFont 2.01 NRPNs
  AWE NRPNs

 SysEx:
  f0 7f 7f 04 01 LL MM f7 - synth volume


Глоссарий

AC97 | Звуковой кодек 97 (кодек - от кодер-декодер). Обычно используется в качестве Аналого-Цифровых и Цифро-Аналоговых Преобразователей на SoundBlaster Live! и Audigy платах.
ADC | Аналогово-Цифровой Преобразователь (АЦП). Устройство, которое преобразовывает аналоговые сигналы в цифровую форму.
APS | Audio Production Studio . EMU10k1-подобная карта от E-mu Systems Inc.
ASIO | Audio Stream Input Output . Многоканальный звуковой протокол передачи аудио данных, разработанный фирмой Steinberg.
DAC | Цифро-Аналоговый Преобразователь (ЦАП). Устройство, которое преобразовывает цифровые сигналы в аналоговую форму.
DOO | Только цифровой выход. Настройка AC97 кодека, разрешающая запись нескольких аналоговых источников.
DSP | Цифровой сигнальный процессор.
E-Drive | Внешний модуль E-mu APS входов/выходов, разработанный с поддержкой стандарта 5-1/4" накопителей.
FXBus | Шина Эффектов. Виртуальное устройство, которое направляет сигналы цифровых эффектов с одного или более источников к одному или более адресатам.
GPR | Регистр общего назначения.
I2S | Inter-IC Sound - цифровой звуковой формат.
LiveDrive | Внешний модуль входов/выходов, разработанный с поддержкой стандарта 5-1/4" накопителей, для использования с Live! и Audigy платами.
MIDI | Цифровой интерфейс музыкальных инструментов. Протокол для объединения и управления музыкальными инструментами.
PCM | Импульсно-кодовая модуляция. Распаковываемая схема кодирования для сохранения цифровых данных, обычно связанные с волновыми данными.
SoundFont | Формат данных, содержащий сэмплы и команды для таблично-волнового синтеза.
SPDIF | Sony-Philips Digital Interface Format - стандарт объединения цифровой звукозаписи.
TAD | Автоответчик (или голосовой модем).
kX-совместимость Звуковые платы совместимые с kX Аудио Драйвером. В настоящее время подерживаются модели включаяя все EMU10k1 и EMU10k2-подобные PCI звуковые платы, производимые Creative Technology Ltd. и/или E-mu Systems Inc., включая:
  • E-mu Audio Production Studio (APS) платы
  • Модели материнских плат с 10k1 чипами (M002, M003 и другие)
  • PCI256 (CT4890, CT4891 и CT4893) и PCI512 (CT4820 и SB0150) включая OEM модели (CT4790)
  • Оригинальные Live! (CT4620) и Live! Value платы (CT4670)
  • Live! X-Gamer, Live! MP3+, Live! Player 1024, Live! Platinum платы (CT4760) и value платы (CT4780)
  • Live! X-Gamer 5.1, Live! MP3+ 5.1, Live! Player 5.1, Live! Platinum 5.1, Live! Digital Entertainment 5.1 платы (SB0060, SB0100, SB0102, SB0220, SB0222, SB0103 и SB0105) и Value 5.1 (SB0101)
  • Универсальные и заказные OEM Live платы (CT4830, CT4831, CT4832, CT4850, CT4870, CT4871 и CT4872)
  • Серия Audigy, включая Audigy MP3+, X-Gamer, Platinum и OEM платы (CT0070, CT0072, SB0090 и SB0092).
  • Платы Audigy2, Audigy2 Platinum, Platinim Ex (SB0240,SB0280,SB0320).

Поддержка серии Audigy2 ZS завершена еще не полностью, потому что мы не имеем образцов для теста. Но, как только у нас появится достаточно денег купить одну, будет осуществлена полная поддержка. Если Вы хотите помочь нам, поддержите наш проект, осуществив пожертвования или инвестиции в kX Фонд.


Справочник Консольных Команд

kX Справочник консольных команд

kxsetup.exe опции Запускает стандартный kX драйвер и настройки kX микшера
--clean
 Выполняет процедуру очистки перед инсталяцией, которая выполнится автоматически при установленных kX драйверах. Отключает некоторые программные компоненты Creative и любые предыдущие установленные компоненты kX микшера и kX драйвера.
--noreboot
 Отменяет перезагрузку после инсталяции драйвера.
kxmixer.exe опции:
--quit
 Закрывает все активные компоненты kX микшера
--once
 Автоматически выгрузить микшер после восстановления настроек (необходимо использовать совместно с '--startup')
--startup
Исполняет последовательность ввода в действие: восстановливает kX параметры настройки из файла kxdefault.kx
--shell
Опция интеграции оболочки: только для внутреннего использования
--no10k2
Отключает поддержку 10k2
--10k2
Принудительная поддержка 10k2
--no51
Отключает поддержку 5.1
--51
Принудительная поддержка 5.1
--aps
Принудительная поддержка E-mu APS
--noaps
Отключает поддержку E-mu APS
--noa2
Отключает поддержку Audigy2
--a2
Принудительная поддержка Audigy2
--nok2ex
Отключает поддержку Audigy2 Platinum Ex
--k2ex
Принудительная поддержка Audigy2 Platinum Ex
--no2k
Отключает поддержку Windows 2000/XP Extended GUI


Copyright

Legal Trademarks and Copyright

  • kX Audio Driver, kX Mixer (including kX DSP, kX DSP Editor, kX ASIO, kX Router, kX Remote, kX Automation), and Aqua Skin are Copyright © Eugene Gavrilov, 2001-2003. All rights reserved.
  • kX DSP effects library Copyright © Eugene Gavrilov, Hanz Petrov and Max Mikhailov, 2001-2003. All rights reserved.
  • Portions of code Copyright © Sergey Komarinsky, 2002.
  • DAnE Assembler Copyright © Max Mikhailov and Eugene Gavrilov, 2001-2003. All rights reserved.
  • kX Help file Copyright © Hanz Petrov, Eugene Gavrilov, Soeren Bovbjerg and Vedran Miletic, 2002-2003. All rights reserved.
  • CodeMax2.0 Copyright 1997-2000 Barry Allyn.
  • inflate 1.1.3 Copyright 1995-1998 Mark Adler
  • sfArk SoundFont Compression is Copyright © melodymachine.com. All Rights Reserved
  • Sound Blaster and EAX are registered trademarks and EMU10k1, Audigy, Environmental Audio, Environmental Audio eXtensions, and Live! are trademarks of Creative Technology Ltd.
  • E-MU, E-MU SYSTEMS, APS, Audio Production Studio, ENSONIQ and SoundFont are registered trademarks owned or licensed by E-MU / ENSONIQ.
  • Cubase and VST are registered trademarks and ASIO is a trademark of Steinberg Media Technologies AG.
  • Microsoft, Windows and DirectX are registered trademarks of Microsoft Corporation.

    All other brand and product names are trademarks or registered trademarks of their respective holders and are hereby recognized as such.

kX Project is in no way affiliated, associated or connected with E-mu Systems Ltd. or Creative Technology Inc.


Благодарности

kX драйвер и kX микшер были написаны мной, Евгением Гавриловым.
kX драйвер - бесплатная программа, однако я провёл над этой работой много времени и буду благодарен за любые пожертвования и инвестиции, которые Вы можете предоставить.

Мне хочется выразить благодарности Hanz Petrov с Independent EMU10K1 Programmers Site за его поддержку; Soeren Bovbjerg за тестирование и отзывы; Friedemann Wolpert за хостинг, Dennis Samuelsson и Luki Goldschmidt за зеркала kX сайта.

Я также благодарен всем за отзывы, сообщения и письма, которые люди присылали.

Я благоларю людей с opensource.creative.com, в особенности Daniel Bertrand и Rui Sousa. Спасибо Fabio Bizzetti за его работу над исправлением межканальных межконвертерных задержек на AC97 / I2S кодеках. Также благодарю Sergey Komarinsky за оптимизации C++ кода.

Хочу поблагодарить Vedran "RIV@NVX" Miletic за BETA тестирование, сообщения об ошибках, хорватский перевод, обновления хэлпа и скриншотов и некоторые идеи.

Огромная признательность также всем инженерам Creative/EMU за замечательное оборудование.

Благодарности:

Следующим людям, предоставившим DSP эффекты для kX проекта: Cybercurve, eYagos, Robert Mazur, Martijn van Eeten, Remy TROTIN, WORM, Soeren Bovbjerg, Hanz, Mathias Wagner moudi, LeMury, Max M.

Людям, работавшим над переводами kX драйвера на различные языки: alino [Italian] _a_l_e_@mail.com, Guayabo [Spanish], Valentin RUSU [Romanian] kx@valentinrusu.net, Treasure [Deutsch], stachooo@poczta.fm, Yves Prigent / Kapifree [French versions] yves.prigent@numericable.fr / kapi@free.fr, Petri Jokinen petri.jokinen@telia.com, Bedeox [Second Polish version] bedeox@emil.teleton.pl, poprawki polskiego tiumaczenia Siawomir Siodelski s.siodelski@kujawy.ruch.com.pl, Marko P. / Michael Lilja [Swedish] axiomis@hotmail.com / michael.lilja@telia.com, Vedran "RIV@NVX" Miletic [Croatian] riva_station@yahoo.com, Pal A. Lind [Norwegian] palind@online.no, Tim Mertens [Dutch] tim@dimed.be, Svetlin Staikov [Bulgarian] sjs@abv.bg, Daniel Marinho Drummond [Brasilian] daniel@ufla.br, Sьmegi Tamбs [Hungarian] sumegit@enternet.hu, Shyguy [Korean] freebits@hanafos.com, Vasilis Platanias [Greek] azathoth@otenet.gr, Benny Wen [Chinese] itwinner@cmmail.com.

Также хочу поблагодарить Matt Young, DK, DM и Tom Weber за их замечательные инвестиции в kX проект.

И напоследок, но конечно не последняя - благодарность Максу Михайлову за RIFX информацию, DSP эффекты, Dane ассемблер, сообщения об ошибках, BETA тестирование и его исходный код.

- Евгений Гаврилов


PLEASE READ THIS DOCUMENT
CAREFULLY BEFORE INSTALLING
THE SOFTWARE.

EUGENE GAVRILOV
SOFTWARE LICENSE AGREEMENT:

This is a legal agreement  between you (individual
or entity) and Eugene Gavrilov  ('the Author').
This Agreement states  the terms and conditions upon
which Eugene Gavrilov offers to license the software,
including, but not limited to, the executable programs,
drivers, libraries, DSP microcode both in source and
in binary form and data files associated with such
programs (collectively, the 'Software').
The Software is licensed, not sold, ownership remains
with the Author. By installing, copying, or making any
use of this Software you agree to be bound by the terms
of this agreement. If you do not agree, do not use or
install the Software -- immediately remove any and all
downloaded or installed versions from your computer
system and/or storage archives.

LICENSE:
The Author grants you a conditional license to use the
Software, subject to the terms included herein.

ASSIGN OR TRANSFER OF LICENSE:
License may not be assigned or transferred to another
person or entity, without prior written permission from
the Author.

COPYRIGHT:
This Software is the proprietary property of the Author
and is protected by Copyright Law. You do not acquire
any rights of ownership whatsoever.

DESCRIPTION OF RIGHTS AND LIMITATIONS:
You agree to not permit or cause any removal or
modification of copyright or proprietary notices,
file name changes, or any modification or additions
to the Software files of any kind. You agree the
Software may not be sold or included in any product
or package without specific written permission of
the Author -- and that only sites designated by the
Author are allowed to distribute this Software,

NO OTHER DISTRIBUTION IS ALLOWED.

DECOMPILING, DISASSEMBLING,
OR REVERSE ENGINEERING:
Except to the extent expressly permitted by this
Agreement or by the laws of the jurisdiction where
you are located, you may not decompile, disassemble
or otherwise reverse engineer the Software, or
engage in any other activities to obtain underlying
information that is not visible to the user in
connection with normal use of the Software.

TERMINATION:
The Author may terminate this agreement should you
fail to comply with any of these terms and/or
conditions. In such event, you agree to immediately
remove this Software from your computer system and
destroy any copies on hand.

DISCLAIMER OF WARRANTY -- NO WARRANTY:
The Author expressly disclaims any warranty for this
product, including all descriptions, documentation,
and on-line documentation. This Software is provided
'AS IS' without warranty of any kind, including
without limitation, any implied warranties of fitness
for a particular purpose or result.
Eugene Gavrilov does not warrant that the functions
contained in the Software will meet your requirements
or that the operation of the Software will be
uninterrupted or error-free or free from malicious code.
For purposes of this paragraph, 'malicious code'
means any program code designed to contaminate
other computer programs or computer data, consume
computer resources, modify, destroy, record, or
transmit data,or in some other fashion usurp the
normal operation of the computer, computer system,
or computer network.

LIMITATION OF LIABILITY -- NO LIABILITY:
The Software is provided 'AS IS'. You agree to assume
the entire risk for any damage or result arising from
its download, installation and use, including the license
process. In no event will the Author (or his agents
and/or associates) be liable to you for any incidental
or consequential damages or losses whatsoever,
including without limitation, damage to data,
property or profits, arising from any use, or
from any inability to use said Software.

FINAL PROVISIONS:
This agreement and the interpretation thereof shall be
exclusively subject to the laws of Russian Federation.
If any one stipulation of this License contract should
be or become invalid, completely or in part, this shall
not affect the validity of the remaining stipulations.
The parties undertake instead to replace the invalid
stipulations with a valid regulation which comes as
closely as possible to the purpose originally intended.
Amendments, supplements and notices of termination
of this agreement must be made in writing. The
rescission of this agreement or an alteration to the
requirement of the written form must also be made
in writing.
Subsidiary agreements have not been concluded.
Place of jurisdiction for all disputes is Moscow.

(c) 2001,2002,2003 Eugene Gavrilov.  All rights reserved.
Contact information: www.kxproject.com


EUGENE GAVRILOV KX AUDIO DRIVER SOFTWARE DEVELOPMENT KIT LICENSE AGREEMENT:
(REVISION #2; September, 27, 2003)

This is a legal agreement between you (individual or entity) and
Eugene Gavrilov ("the Author"). This Agreement states the terms and
conditions upon which Eugene Gavrilov offers to license the software,
including, but not limited to, the executable programs, binary files,
custom microcode for digital signal processors (DSPs) both in source
and in binary form as well as host-based control code, header files,
source code, libraries and data files associated with kX Audio Driver
Software Development Kit (kX SDK), kX Audio Driver Effects Library
(kX FXLIB), kX Graphics User Interface (kX GUI), kX Audio Driver,
kX Audio Driver Plugin Interface and
kX Audio Driver Application Programming Interface (kX API)
(collectively, the "Software").

§ 1	OBJECT OF THE AGREEMENT

1.	The object of this agreement consists of the kX Audio Driver
    Software Development Kit (kX SDK), comprising of (but not limited to)
    documentation, header and library files, executable programs, binary files,
    kX Application Programming Interface (kX API),
    kX Graphics User Interface (kX GUI), kX Audio Driver Effects Library (kX FXLIB),
    kX Audio Driver Plugin Interface,
    custom microcode for digital signal processors (DSPs) both in source and binary
    form, host-based control code and several examples.
    These are described hereinafter as the "Software".

    The header and library files describing kX Application Programming Interface (kX API),
    kX Graphics User Interface (kX GUI) and kX Audio Driver Plugin Interface
    are described hereinafter as the "kX Application Programming Interface (kX API)".

    The source code and the executable programs of the DSP effects, custom microcode for
    digital signal processors (DSPs), both in source and binary form, host-based control
    code are described hereinafter as the "kX Audio Driver Effects Library (kX FXLIB)".

    The distribution package containing the "Software" is described hereinafter as
    "kX Audio Driver Software Development Kit (kX SDK)".

    The term "Software" includes both the "Application Programming Interface (kX API)" and
    "kX Audio Driver Effects Library (kX FXLIB)".

2.	Eugene Gavrilov is the holder of all copyrights, rights of ownership, and other
    rights concerning the "Software", including "kX Application Programming Interface (kX API)".
    Eugene Gavrilov is also the holder of all copyrights, rights of ownership, and other
    rights concerning the "kX Audio Driver Effects Library (kX FXLIB)", unless it is
    clearly mentioned that the particular part was written by third-parties.

3.	The "Software" contains information about
    - how to extend an application so that it can use kX Driver extensions,
    - how to program custom digital signal processors for audio processing,
    - how to provide host-based control code,
    - how to organize user interaction and custom microcode control,
    and also contains custom microcode for digital signal processors and
    host-based control code (both in source and binary form).

§ 2	GRANTING OF RIGHTS

1.	Eugene Gavrilov grants to the Licensee a non-exclusive, worldwide, nontransferable
    license during the term of this agreement to use the "Software" solely:

    (i) for the development of an application that uses kX Audio Driver Interface (kX API);
    (ii) to publish a product under his own name that is using parts of the "Software".

    For the purpose of this article, 'parts of the Software' are: kX Application Programming
    Interface (kX API), kX Graphics User Interface (kX GUI) and kX Audio Driver
    Plugin Interface. Any custom microcode for digital signal processors both in
    source and / or binary form and host-based control code copyrighted by Eugene
    Gavrilov and/or third-parties and covered by this license agreement cannot be
    published by the licensee without prior written permission from Eugene Gavrilov or
    the copyright holders.

2.	The Licensee has no permission to sell, licence, give-away and/or distribute
    the "Software" or parts of it in anyway, on any medium, including the Internet,
    to any other person, including sub-licensors of the Licensee or companies
    where the Licensee has any involvement. This includes re-working this
    specification, or reverse-engineering any products based upon this specification.
        THE LICENSEE HAS NO PERMISSION TO USE CUSTOM MICROCODE FOR DIGITAL SIGNAL PROCESSORS
        BUNDLED WITH THE "Software" NEITHER IN SOURCE, NOR IN BINARY FORM FOR ANY COMMERCIAL USE
        WITHOUT PRIOR WRITTEN PERMISSION OF THE COPYRIGHT OWNER.

3.	If the Licensee is developing a product, that is using parts or all of the
    Software, and this product is not published under his own name but will be
    published by another company, the Licensee is under the obligation to inform
    the publisher of the resulting product, that he too must be a party to this
    Licensing Agreement. The publisher has to completely agree with the Software License
    Agreement. If the publisher is not in agreement with these conditions,
    the publisher is not allowed to distribute this product which is using
    parts or all of the Software.

4.	If the Licensee is planning to publish a product, that is using parts or all
    of the Software, the Licensee is under the obligation to inform Eugene Gavrilov
    about it by sending a e-mail request to Eugene Gavrilov. (See contact address below).

§ 3	USE OF TRADEMARKS

    If the Licensee is publishing a product under his own name that is using
    parts or all of the "Software", the Licensee  shall be under an obligation
    to refer to Eugene Gavrilov's copyrights and trademarks in the following way:

    a) Eugene Gavrilov's copyright notice should be included in the documentation,
    regardless of the media used to supply the documentation.
    Copyright notice: "kX Audio Driver Interface Copyright (c) by Eugene Gavrilov, www.kxproject.com"

    b) In the 'about box' of the product in the following format:
    "kX Audio Driver Interface Copyright (c) by Eugene Gavrilov, www.kxproject.com".

    c) The source code should contain the following notice:
     "This program is free software; you can redistribute it and/or"
     "modify it under the terms of the "
     "EUGENE GAVRILOV KX DRIVER SOFTWARE DEVELOPMENT KIT LICENSE AGREEMENT"

    d) The Licensee can optionally release the product under GNU L-GPL license agreement.

§ 4	FEES AND ROYALTIES

    The Licensee shall not obligated to pay to Eugene Gavrilov any fees or
    royalties with respect to the Software.

§ 5	LIABILITY FOR CONSEQUENTIAL DAMAGES

    Eugene Gavrilov will not be liable for any consequential, special,
    incidental, direct or indirect damages of any kind, including the
    loss of data, damage of data-storage-devices, or any loss or damage
    to other programs being used, arising out of the use of the Software
    or any software developed by the Licensee, including any future up-dates.

§ 6	PRODUCT WARRANTY

    1. Eugene Gavrilov licences the Software on an "AS IS" basis.
    Eugene Gavrilov makes no warranties, express or implied, including
    without limitation the implied warranties of merchantability and
    fitness for a particular purpose, regarding the Software or operation
    and use in combination with the Licensee's program. Neither the
    Licensee, its employees, agents, or Distributors have any right
    to make any other representation, warranty or promise with respect
    to the Software.

    2. In no event shall Eugene Gavrilov be liable for incidental or
    consequential damages arising from the use, or distribution of
    the Software by the Licensee, whether theory of contract, product
    liability or otherwise. All  claims for indemnification for losses
    by the Licensee itself or by third parties shall be excluded.

    3. Eugene Gavrilov may release improved versions of the Software
    but offers no commitment whatsoever that such releases will occur
    at anytime or for anybody.

§ 7	INFRINGEMENT

    Eugene Gavrilov represents and warrants that, as of the date of
    this Agreement, it is not aware of any claim or action alleging that
    the content of the Software infringes any third party intellectual
    property right. Eugene Gavrilov, however, disclaims any obligation
    of defense or indemnify of the Licensee or its customer  with respect
    to any such claim or action, or otherwise arising out of this agreement.
    Eugene Gavrilov shall have no liability arising out of any such actual
    or alleged intellectual property infringement. The Licensee, however,
    shall promptly notify Eugene Gavrilov, in writing, of each such
    infringement claim of which the Licensee becomes aware.

§ 8	RELATIONSHIP BETWEEN THE TWO PARTIES

    Nothing stated in this Agreement will be construed as creating the
    relationships of joint ventures, partners, principal, agent or whatsoever.
    The Licensee shall not be entitled to represent Eugene Gavrilov or to make
    statements on its behalf.

§ 9	TERM OF THE AGREEMENT

    1. The Agreement shall run for a unlimited period.

    2. If the Licensee is in breach of any of its obligations set out in
    this agreement, Eugene Gavrilov shall be entitled to terminate this
    agreement immediately in writing and inform the Licensee verbally or by
    e-mail about it. In such a case, this license and all the rights granted
    to the Licensee herein shall immediately cease.

    3. Eugene Gavrilov reserves the rights to release an updated revisions of
    this license agreement which immediately cease any rights granted to the
    Licensee by any previous revisions of this license.

§ 10	FINAL PROVISIONS

    1. This agreement and the interpretation thereof shall be exclusively
    subject to the laws of Russian Federation.

    2. If any one stipulation of this License contract should be or become
    invalid, completely or in part, this shall not affect the validity of
    the remaining stipulations. The parties undertake instead to replace
    the invalid stipulations with a valid regulation which comes as closely
    as possible to the purpose originally intended.

    3. Amendments, supplements and notices of termination of this agreement
    must be made in writing. The rescission of this agreement or an alteration
    to the requirement of the written form must also be made in writing.
    Subsidiary agreements have not been concluded.

    5. Place of jurisdiction for all disputes is Moscow.

    6. This agreement does not require a specific form (e.g. recording by a notary).

Copyright (c) 2001,2002,2003 Eugene Gavrilov.  All rights reserved.
Contact information: www.kxproject.com

You may need to accept Steinberg ASIO SDK Licensing Agreement in order to use
kX Driver ASIO extensions

ASIO Technology by Steinberg


Direct Recording Guide

Introduction

The 10k1 and 10k2-based audio cards support SPDIF digital inputs and outputs. It is widely known that the 10k1 and 10k2 chips operate at a fixed sampling rate, 48000 Hz. So, in order to synchronize internal clocks with SPDIF In signals, the input stream is resampled to 48000 frequency (regardless of its original frequency). Moreover, if the input stream frequency is already 48000, it is still resampled in order to avoid possible synchronization issues. That is why it is theoretically impossible to record SPDIF input bit-to-bit (make an 'exact' copy of the digital signal). The problem cannot be fixed for 10k1-based boards, however, the 10k2 chip (used in Audigy and Audigy2 series of cards) has a special feature - Direct SPDIF recording.

Detailed description

The 'Direct SPDIF Recording' is activated via kX Mixer (on the main page). Due to the nature of this recording method, the signal completely bypasses the DSP, which is why it is not affected by any uploaded effects or by the kX Mixer sliders and recording levels. After enabling 'Direct SPDIF Recording' no other recording sources are unavailable.
It is possible to choose which SPDIF input to record: Coaxial/Optical SPDIF, CD SPDIF etc. In the present implementation it is possible to record analog I2S sources (Line2/Mic2, AUX2) in 'direct' mode, too. This feature is currently being tested since this aspect of hardware functionality has not been clearly defined.
Note that SPDIF inputs can transmit the signal at any sampling rate (44100, 48000, 96000 etc...), so, it is up to user to choose the correct sampling rate in his/her audio application. The kX driver won't try to autodetect the sampling rate. The sampling rate is, however, limited by the actual hardware capabilities. It should be possible to record at 96000 frequency on practically every 10k2-based board (such as Audigy1 and Audigy2). Also note that it might require up to 10 seconds for the SPDIF Input to synchronize to the incoming signal, if its sampling rate is more than 48000. If the signal is distorted or audio is muted, try unplugging and re-plugging the SPDIF cable.

Conclusion

Direct SPDIF recording drammatically improves the recording quality of digital sources when the main goal is to make an 'exact' copy of the digital signal. The improvements include better frequency response and intermodulation. In the present implementation Direct SPDIF Recording is not supported for ASIO.


Руководство для начинающих

kX драйвер был разработан для звуковых плат, основанных на чипах Emu10k1 и Emu10k2, например, таких как SBLive, Audigy и других плат. Эти Emu10kx чипы фактически являются цифровыми сигнальными процессорами (DSP). Если Вы откроете окно DSP kX Драйвера, Вы увидите, что фактически можете редактировать свойства и поведение чипа вашей звуковой платы, изменяя маршрутизации, загружая и редактируя эффекты и так далее.

Чтобы объяснять это более подробно, давайте сначала посмотрим на основные объекты kX окна DSP. Лучший способ описать это состоит в том, чтобы представить окно DSP с объектами как своего рода стойку, с различными устройствами ввода и вывода и устройствами эффектов, соединенными между собой (очень высокого качества) аудио кабелями (представьте себе стойку эффектов профессионального гитариста, включающей в себя ламповый усилитель, микшер, ревер, хорус, дисторшн, квакушку и т.д.). "устройства", которые Вы видите в окне kX DSP, имеют входы (слева) или выходы (справа) или и то и другое, и связаны друг с другом виртуальными аудио кабелями (синие линии).

Кроме различных эффектов, мы видим 4 устройства "ввода - вывода" в окне DSP. Это - FXbus (два, если у вас 10k2 плата), Prolog, Epilog и (x)Routing . Давайте исследуем эти четыре объекта более подробно, затем взглянем на ASIO маршрутизацию с кратким обзором окна kX Routing.

1. FXBus

FXbus имеет 16 выходов (или 32 для 10k2 плат, и 64, если загружен дополнительный 'FXBus2' эффект) для аудио потоков, сгенерированных программным обеспечением, запущенным на вашем PC (типа mp3 плейера, звук из WaveTable MIDI синтезатора, или из одного из выходов ASIO). Все аудио данные, которые сгенерируются, будут находиться в этом устройстве.

2. Prolog

Пролог выводит любые аудио данные, поступающие в ваш PC СНАРУЖИ, такие как линейный вход (сигнал с подключенной гитары), цифровой оптическй вход на LiveDrive, или цифровой вход CD (CDSPDIF) , разъем которого находится непосредственно на плате. Существует один специальный выход Пролога, который является причиной большого замешательства среди новых пользователей kX драйвера, - это выход AC97.

10k1 и 10k2 - это цифровые микросхемы, поэтому они не могут непосредственно принять аналоговый входной сигнал. На Live! (Audigy) платах есть другой чип, отвечающий за это - AC97 кодер-декодер (кодек). Этот чип подключен ко всем аналоговым входам на Live! платах (за исключением входов LiveDrive), микширует их, и посылает в Emu10kX. Этот кодек отвечает за линейный и микрофонный входы на плате и, среди прочего, за аналоговый вход CD (не путать с цифровым CD). Вы можете управлять этим кодеком на вкладке AC97 окна kX микшера, помня, что линия AC97 на Прологе - это то, где появляются аудио данные с аналоговых входов (в прологе вы также можете найти все остальные входы, расположенные на звуковой плате и на LiveDrive). Обратите внимание, что LiveDrive использует высококачественный аналого-цифровой преобразователь (ADC), который во многом превосходит AC97 кодек (E-mu APS и Audigy2 Platinum Ex вообще не имеют AC97 кодеков).

3. Epilog

Эпилог - это устройство, куда в конечном счете выводятся все данные. Он состоит из 2 частей; "реальные" ('физические') выходы и "запись" (например, ASIO) выходы. Реальные выходы просто отражают все физические выходы (и аналоговые и цифровые) на чипе Emu10kX. Обратите внимание, что чип Emu10kX реально поддерживает 4 цифровых стерео выхода (да, оригинальный Live!, и даже 512 PCI и все 7.1 платы). Чтобы использовать в своих целях эту возможность, не используя LiveDrive, можно использовать "AUD_EXT" разъемы, находящиеся на большинстве 10kx плат (хотя, немного специального знания и опыта все же не помешает).

На большинстве 10kX плат, "передний" аналоговый выход сгенерирован AC97 кодеком, в то время как тыловой канал проходит через I2S кодек. По этой причине (I2S выход вообще превосходит AC97 выход), kX драйвер меняет 'передние' и 'тыловые' колонки по умолчанию. Обратите внимание, что в случае Audigy и Audigy2 плат, I2S кодек используется для выхода на 'Передние' колонки, а AC97 кодек используется для записи только от встроенных аналоговых разъемов. Однако, все же рекомендуется менять передние и тыловые колонки, потому что выходной сигнал от AC97 кодека (даже приглушенный) все еще связан с 'Передним' выходом платы (и это воздействует на качество звука).

Лучший способ понять все это и использовать в своих интересах состоит в том, чтобы не смотреть на 10k1 и 10k2 платы как на аудио платы с передними и тыловыми выходами и все, а просто как на чип с 4 каналами стерео выхода (которыми они фактически и являются). Никто не говорит вам, что вы ДОЛЖНЫ использовать "зеленый" разъем для подключения передних динамиков; вы можете точно также использовать его для выхода на наушники, и использовать "черный" (тыловой) разъем как выход на аудио систему (в клубе, используйте зеленый разъем для наушников, черный вставляйте в аудио и, теперь вы диджей с 2 отдельными звуковыми каналами). Зачем использовать черный разъем для аудио системы? Это просто - черный (тыловой) канал использует I2S кодек, и таким образом производит лучший звук ..., ну и аудитория заслуживает лучшего :-).

Вторая часть Эпилога - это часть с выходами записи. Эти выходы (RecL/R и 16 ASIO каналов записи) используются для записи аудиопотоков на ваш PC. Если, например, вы выведите аудиопотоки на RecL/R порты, Вы сможете записать аудио на жесткий диск, используя стандартную программу "Звукозапись". Вы также можете использовать 16 ASIO каналов для записи данных при помощи, например, программы Cubase, или использовать ASIO каналы, чтобы подать данные в процессоры эффектов SpinAudio/DSound. Таким образом, порты эпилога в основном являются входящими соединениями к вашим программам (в противоположность FXbus, который является выходом из ваших программ).

4. Routing

Возвращаясь назад к воображаемой "стойке", вам должно быть уже ясно, что из себя представляет устройство Routing (маршрутизатор). Это - центральная часть микшера. Устройство Routing микширует сигналы с выходов FXBus и пролога и отправляет их на входы эпилога, используя настройки панели управления kX Микшера (то есть фэйдеры). Имеются также две группы специальных входов FX, которые используются для добавления специальных эффектов к звуку. Однако обычно, эти два FX посыла микшируются только с реальными выходами, не затрагивая каналы записи. Обратите внимание, что вы можете регулировать уровень записи с добавлением эффектов на вкладке 'Запись' окна kX Микшера.

НО (и в этом все преимущество kX), вы совершенно не обязаны использовать все объекты по умолчанию! Вы можете настроить объекты и эффекты DSP так, как вам хочется, или использовать несколько разных настроек, в зависимости от ваших потребностей, которые вы можете сохранять и загружать. Например, подключите гитару во вход LineIn2 вашего LiveDrive. Очистите окно DSP и загрузите только объекты Prolog и Epilog (найдете в разделе "Стандартные" в меню вставки эффектов). Соедините выход LineIn2 объекта Prolog с передними колонками (Analog Front) объекта Epilog, получилось прямое соединение. Протяните другую 'линию' от того же выхода LineIn2 ко входу RecL/R объекта Epilog, и теперь вы можете играть на гитаре и записывать ее в масштабе реального времени. Возможно, вы захотите добавить эквалайзер или компрессор между прологом и эпилогом - хорошая идея!

5. ASIO Routing

ASIO - название драйвера "API" (аппаратно-программный интерфейс), разработанного фирмой Steinberg с целью позволить драйверам достичь более низкого времени ожидания. Это означает, что вы можете получить на своих компьютерах процесс обработки аудио данных (например, аудиосигнал с некоторой программы на PC, или входной сигнал с вашей звуковой платы и выход на вашу звуковую систему), всё - с задержкой (необходимой для расчётов) столь же низкой, как почти в реальном масштабе времени. Таким образом, при игре на подключенной в линию гитаре, вы можете обрабатывать звук различными эффектами почти в реальном масштабе времени.

kX ASIO драйвер поддерживает прохождение аудио потоков через 16 каналов входа и выхода со временем ожидания в 2.66 ms на быстрой и хорошо-настроенной системе, как для записи, так и для воспроизведения.

ASIO Входы

Мы уже объясняли, где находятся ASIO входы - это 16 последних каналов на Эпилоге, и вы можете использовать входы ASIO в любом приложении, контролировать их, добавлять эффекты, производить запись на жесткий диск, или выводить на те же самые ASIO драйвера - к любому другому выходу, но тогда вы потеряете преимущество низкого времени ожидания, которое является главной особенностью ASIO драйвера.

ASIO Выходы

У вас есть 16 ASIO выходов. По умолчанию, эти 16 каналов отображены один к одному в объекте FXBus, так, 1-ый канал ASIO выхода соответствует 1-му каналу FXBus (фактически - это FXBus0). Итак, возвращаясь к нашим гитарным экспериментам в DSP, соедините LineIn2 на Прологе с каналами ASIO записи, скажем, с последними двумя (они предложены только потому, что есть маленькая проблема с платами SB006x, которые неспособны использовать 2-ой и 3-ий ASIO каналы - смотрите дополнительную информацию в разделе FAQ). Теперь сигнал с вашей гитары идет на 2 последних ASIO входа. Запустите SpinAudio ASIO FX Processor, чтобы добавить некоторые эффекты - входной сигнал с гитары, проходя через программу, будет на последних двух ASIO каналах. Вернемся к воображаемой стойке, теперь вы должны вернуть сигнал, выходящий из SpinAudio в DSP, чтобы пустить его на реальный выход (как, например, в нашем случае на "фронтальные колонки + рекордер "). Сигнал из из программы выходит на первые 2 ASIO канала, который мы получаем на первых 2 выходах объекта FXBus. Теперь, протяните виртуальные кабели от первых двух каналов объекта FXBus к передним колонкам объекта Epilog в окне DSP (и снова к рекордеру, или к другому ASIO входу). Вы можете делать столько соединений, сколько вам захочется, но имеете в виду, что каждое "соединение" к и от DSP, используя ASIO входы и выходы, добавляет время ожидания (обратите внимание, что соединения в kX DSP вообще не затрагивают время ожидания - вы можете иметь их столько, сколько хотите). Добавьте и включите эффекты в SpinAudio; теперь поиграйте на гитаре; поздравляю, вы только что завершили вашу первую ASIO маршрутизацию с использованием разных эффектов! :-)

6. Окно kX Router

Новые пользователи иногда находят окно kX Router запутывающим, частично потому что оно не имеет никакого отношения к объекту Routing окна DSP, и все там связано с объектом FXBus. Если вы посмотрите на окно маршрутизации, вы увидите, что все выходы, генерируемые программным обеспечением, располагаются слева в виде раскрывающегося дерева. Там вы увидите Wave 0/1, 4/5, 6/7 и 8/9 - они соответствуют 4 устройствам волнового выхода, шины 4/5, 6/7 и 8/9 - это, по существу, каналы DirectSound/AC3, передние/тыловые колонки и центр/субвуфер скопированные с шины 0/1, являющейся "стандартным" волновым выходом. Также, в этом списке вы найдете выходы AC3 (и DirectSound, как упомянуто выше), два синтезатора и выходы ASIO.

Как все это касается объекта FXBus?

Хорошо, объект FXBus имеет свою собственную внутреннюю маршрутизацию/микширование, и все программные выходы направляются к одному из выходов FXBus. Обычно, стерео пара wave 0/1 направлена на каналы 0 и 1 (и также на каналы 13 и 14 для добавления эффектов). Выходы ASIO обычно отображаются один к одному в объекте FXBus (канал ASIO 1 = FXBus 1), Синтезатор выходит на каналы FXBus 2 и 3, и т.д., и т.д. Вы можете изменить любой из этих параметров, но значения по умолчанию обычно прекрасно подходят для большинства целей, примером специальной установки было бы добавление множителя, для микширования эффектов с определенными выходами (подобно стандартному Реверу/Хорусу на каналах 13/14).

Итак: наш краткий обзор работы kX и ASIO подошел к концу - удачи вам с драйверами и экспериментами в DSP :-) - это лучший способ учиться!

-- написано Мата Хари
-- (незначительные исправления kX Team)


Skins

Скины

кХ микшер может использовать различные графические оболочки (скины)

Архитектура кХ скинов была разработана в соответствии с потребностью создания различных кХ скинов. Основная процедура создания скинов такова:

  • Если вы не собираетесь добавлять или перемещать какие-либо органы управления, вы можете просто создать свой собственный .zip файл с изменёнными .jpg и/или .gif изображениями, и создать собственный kxskin.ini файл с единственной частью, названной '[skin]', в которой содержится Ваш новый скин. Не забудьте добавить новый kxskin.ini в Ваш zip архив. Ваш новый zip файл может быть расположен где угодно на вашем винчестере. Его имя не может быть kxskin.zip и вы можете заменить 'GUID' новым, сгенерированным кХ микшером (Settings->Generate GUID). (GUID означает Глобальный Уникальный Идентификатор).
  • Если Ваш скин требует изменения размеров и расположений окон, Вам придётся создать более подробный kxskin.ini файл. Сверяйтесь с прилагаемым kxskin.ini примером для болшей информации. Однако, если некоторые настройки были упущены в вашем kxskin.ini, они будут автоматически вызваны из default kxskin.ini, поставляемого с kX микшером. То есть, вам необходимо только описать Ваши собственные настройки в Вашем kxskin.ini файле (включая минимальную '[skin]' часть). Обратите внимание, что изображения (.jpg/.gif files) и wave файлы (.wav) теперь автоматически берутся из default kxskin.zip когда используется другой скин (начиная с версии 3514).
  • В основном имена Wave и файлов изображений, назначенные kxskin.ini не могут быть изменены, так же вы не можете изменить текстовые строки (фактически вы можете осуществить это в Вашем kxskin.ini). Однако, если Вы планируете локализовать kX микшер, пожалуйста, известите и свяжитесь с нами.
  • Когда Вы создадите Ваши собственные изображения, они должны быть упакованы вместе с вашим собственным kxskin.ini файлом, в zip архив с уникальным именем и уникальным GUID. Чтобы использовать скин, просто кликните 'Skin'->'Add Skin'.
  • Обратите внимание, что название скина должно быть уникальным.
  • Чтобы использовать скины Вы должны использовать версию кХ драйвера не менее 3509.
  • Начиная с версии 3521 вы можете использовать RAR вместо ZIP. Однако, лучше использовать цельные архивы, потому, что это может улучшить общую производительность.
  • Начиная с версии 3523 информация о локализации сохраняется в отдельный lang.ini file. Не вкладывайте этот файл в Ваш собственный скин-архив.
  • Обратите внимание, что все файлы, не найденные в Вашем архиве будут автоматически вызываться из default skin.
Если Вы заинтересованы в создании Ваших собственных скинов - или уже имеете готовый - напишите нам.