Compare It! документация - Добро пожаловать в Compare It!

Начало
Compare It! документация
Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Welcome to Compare It! 3.0 Добро пожаловать в Compare It! 3.0

Compare It! - это мощный инструмент визуального сравнения и объединения файлов.

  • О программе Compare It!
  • Установка и удаление Compare It!
  • Что нового?
  • Быстрый старт
  • Основной пользовательский интерфейс Compare It!
  • Иллюстрация окна приложения Compare It!
© 2005, Grig Software, Все права защищены
Browser Based Help. Published by chm2web software.


Compare It! документация - Альтернативное сравнение строк

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Альтернативное сравнение строк

Что такое Альтернативное сравнение строк?

Это новый алгоритм сравнения, разработанный для упрощения чтения изменённых строк. Мы назвали его "альтернативным", потому что точность может быть снижена для получения более читаемого результата.

Как это может помочь мне?

Есть несколько примеров, в которых Вы можете увидеть преимущества альтернативного сравнения:

  • Использование ограничения слов:
    Альтернативное | Стандартное
    Field is NULL | Field is NULL
    Field is NOT NULL | Field is NOT NULL
  • Повтор последовательностей:
    Альтернативное | Стандартное
    00001000 10101010 | 00001000 10101010
    00010000 10100110 | 00010000 10100110
  • Использование синтаксической информации (в этом случае C++):
    Альтернативное | Стандартное
    MyFunc(A[1]); | MyFunc(A[1]);
    MyFunc(A[2], A[1]); | MyFunc(A[2], A[1]);

Хорошо, но почему это необязательно?

К сожалению альтернативное сравнение не удовлетворяет всех пользователей, в ходе бета-тестирования мы обнаружили, что некоторые люди довольны результатами, другие - нет. В этом случае стандартное сравнение лучше для обычного текста; в другом случае программисты/web-разработчики находят альтернативный алгоритм очень полезным для сравнения исходного кода. Так что мы решили сделать эту возможность необязательной, чтобы большее число людей могло тестировать это.

Мы надеемся, что обратная связь с Вами найдёт лучшее применение альтернативному сравнению, которое должно стать более мощным в будущем. Если у Вас есть мысли по улучшению результатов сравнения, сообщите нам Ваше мнение!

Как мне переключать это?

Вы можете включить или отключить альтернативное сравнение в общих настройках программы, страница Сравнение строк.


Compare It! документация - Дополнительные функции

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Дополнительные функции
  • Добавление ярлыков к внешнему приложению
  • Альтернативное сравнение
  • Автоматическое резервное копирование
  • Использование командной строки
  • Файл конфигурации
  • Режим "Только изменения"
  • Произвольный синтаксис файлов
  • Определение диапазона столбцов
  • Поддержка списка файлов
  • Игнорировать различия
  • Ручное сопоставление
  • Перемещённые секции
  • Поддержка файла результата
  • Поддержка Unicode
  • Использование Compare It! с менеджером файлов
  • Использование Постоянных выражений
  • Использование подстрок Постоянных выражений
  • Поддержка файлов Word
  • Поддержка файлов Zip
  • Расширенное диалоговое окно Выбрать файлы


Compare It! документация - Автоматическое резервное копирование

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Автоматическое резервное копирование

Что такое папка для резервного копирования?

Compare It! поддерживает автоматическое резервное копирование в указанную папку.

Как только Вы включите эту возможность и выберите папку для резервного копирования, Compare It! будет копировать каждый файл в эту папку перед его перезаписью. Так как, вероятно, Вы будете сохранять один и тот же файл много раз, то ему будет каждый раз назначаться новое имя по правилу:

filename.ext.YYYYMMDD-HHMMSS.N.ext

где

  • filename.ext есть имя оригинального файла
  • YYYY-MM-DD есть текущая дата
  • HH:MM:SS есть текущее время
  • N будет 1 или 2, в зависимости от того, в какой панели Compare It! был файл - в исходной или конечной.

Новинка: Обратите внимание на дополнительное расширение, добавленное в конец имени файла резервной копии. В старшей версии имя файла заканчивается номером панели (1 имя 2). Добавленное расширение позволяет использование подсветки синтаксиса, также, как сортировка файлов в менеджере файлов.

Для предотвращения сохранения слишком многих неиспользуемых файлов резервных копий Compare It! будет автоматически удалять устаревшие файлы через указанное на странице Общие диалогового окна Настройки.

Использование относительного пути для резервного копирования

Вместо использования одной папки для резервного копирования всех файлов Вы можете создавать подпапки для резервного копирования в каждой папке, где расположены Ваши файлы. Чтобы это сделать, просто определите имя папки без пути к ней, подобно "Backup", вместо "C:\Backup".


Compare It! документация - Режим Только изменения

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Режим Только изменения

Режим Только изменения обеспечивает просмотр всех различий, найденных между файлами без необходимости передвижения между изменениями. В этом режиме все идентичные строки скрываются, остаются несколько контекстных строк. Заданное по умолчанию количество контекстных строк - 5, но Вы можете изменить это в настройках. Этот подход минимизирует количество данных, которые Вы должны увидеть для просмотра изменений.

Compare It! отображает этот значок [image] в заголовке панели, когда режим Только изменения активен.

Вы можете получить тот же результат в отчёте или распечатать используя опцию Печатать только изменения.

Переключение режима Только изменения:

  • Выберите Вид > Только изменения.

Правка в режиме Только изменения

Из-за характера режима Только изменения, есть несколько ограничений на правку файла. В этом режиме Вы можете выполнять только операции объединения блок/строка, типа Различие/строку в исходный файл и так далее; Вы можете использовать панель Объединение для объединения. Стандартная правка не позволяет избежать конфликтов с обычным режимом.


Compare It! документация - Определение диапазона столбцов

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Определение диапазона столбцов File Open Dialog

Compare It! может работать с указанными столбцами строк текста.

Есть несколько простых примеров:

1-5 | сравнение только первых 5-ти символов
5-15 | сравнение только первых 10-ти символов, начиная с 5-го.
15+ | сравнение только оставшейся части строки, начиная с 15-го символа (первые 14 символов игнорируются)

В случае необходимости Вы можете использовать более лучший подход. Например, задание диапазона столбцов 2-4,6,8+ будет преобразовывать строки 1234567890 в 2346890 для сравнения.

Смотрите также

Настройки: Сравнение

© 2005, Grig Software, Все права защищены File Open Dialog


Compare It! документация - Использование командной строки

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Использование командной строки

В этом разделе показаны примеры того, как Вы можете использовать Compare It! в командной строке.

Синтаксис

wincmp3.exe [ first_file second_file [result_file] /i=UserName] [опции]

Где:

  • first_file и second_file это сравниваемые файлы
  • result_file это имя файла результата
  • /i=UserName это имя пользователя многопользовательской конфигурации
  • опции поясняются ниже:

    Опция | Описание
    /1 Использование отдельного образца.
    Если эта опция задана, Compare It! найдёт выполняющийся образец и передаст новые параметры для образца вместо открытия дополнительного окна.
    /n | Отображение номеров строк
    /h | Переключение в горизонтальный режим разбиения панелей
    /r | Режим Только чтения, режим правки отключен. Вы можете также использовать /R1, /R2 чтобы запретить редактирование только одного файла.
    /=Alias Позволяет Вам изменять имя видимого файла.
    Example: wincmp3.exe file1.txt /=Old file2.txt /=New
    /P | Печать файла и выход из программы
    /G | Генерация отчёта и выход из программы
    /L | Использование списка файлов для печати или отчётов. Смотрите для подробностей.

Дополнительные опции печати и генерации отчёта

Доступны несколько дополнительных опций для выполнения печати и генерации отчёта. Эти опции могут быть определены следующим образом: /P:N2

Следующие опции печати/отчёта доступны:

    Опция | Описание
C | Использовать цвета (только при печати)
E | Удаление файла отчёта в случае, если файлы идентичны
I | Добавить навигацию (только для HTML-отчёта)
L | Альбомная ориентация (только для печати)
N | Включить номера строк
S | Включить статистику
W | Перенос слов (только для печати)
A | Генерация текстового отчёта в формате Same
B | Генерация текстового отчёта в формате Composite
H | Генерация текстового отчёта в формате HTML2
M | Генерация текстового отчёта в формате Merged
T | Генерация текстового отчёта в формате Unix diff
U | Генерация текстового отчёта в формате Unix diff Unified

Номер в конце команды означает "печатать только изменения" с указанным числом контекстных строк.

Для выбора файла отчёта Вы должны определить его после опции /G , как показано в следующем примере.

wincmp3.exe file1.dat file2.dat /G:SN3 c:\report.htm

Эта команда генерирует отчёт сравнения в c:\report.htm, включая статистику и номера строк, и только 3 контекстных строки вокруг блоков различий.

Выбор принтера для использования

При печати с применением командной строки, Вы также можете выбрать принтер для использования. Чтобы задать имя принтера, поместите это после /P команды:

wincmp3.exe file1.dat file2.dat /P:CN3 "Имя моего принтера"

Также смотрите:
Объединённый отчёт


Compare It! документация - Сравнение файлов

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Сравнение файлов

Compare It! позволяет Вам использовать разные методы выбора файлы для сравнения:

  • Командная строка
    Просто переадйте имена 2-х файлов как параметры и Compare It! откроет их.
    Также смотрите: Автозавершение имён файлов
  • Если выполнять без параметров, то Compare It! позволяет Вам выбрать исходный и конечный файлы используя диалог Сравнить файлы.
    Вы также можете в любое время выбрать файлы, нажимая CTRL + O.
  • Перетаскивайте файлы в окно приложения Compare It! для их сравнения: один за другим или сразу оба файла.
  • Используйте режим Выбрать файлы, доступный нажатием CTRL + SHIFT + O
  • Вы можете выбрать сравниваемую недавно пару файлов выбором Файл > Последние файлы и далее указывая конкретную пару файлов.

Как только Вы выбрали файлы для сравнения, Compare It! сравнит их и покажет результаты. Сравнение не будет длиться долго в случае, если Ваши файлы небольшие. Например, сравнение 2-х системных реестров, экспортированных в файлы по 5 Мб каждый, производится не более, чем за 10 секунд.

Просмотр различий

После того, как процесс сравнения завершён, два сравниваемых файла появляются в исходной и конечной панелях. Различия подсвечиваются разными цветами.

Смотрите Горячие клавиши и кнопки панели инструментов для подробностей по выполнению действий в Compare It! используя горячие клавиши клавиатуры и кнопки панели инструментов.


Compare It! документация - Файл конфигурации

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Файл конфигурации Changes only mode

Compare it! сохраняет все параметры своих настроек в отдельном файле конфигурации. Это означает, что никаких изменений в Вашей системе не производится. Файл конфигурации называется wincmp3.ini и хранится в той же папке, что и исполняемый файл приложения, wincmp3.exe.

Многопользовательская конфигурация

Для работы с Compare It! в многопользовательской среде, Вы должны передать в командной строке имя пользователя следующим образом: /i=UserName.

Compare It! создаст и будет использовать новый файл конфигурации, названный UserName.ini. Для проверки имени файла текущей конфигурации, нажмите и удерживайте клавишу CTRL , и откройте диалоговое окно Настройки.

Вниманию пользователей старших версий

До версии 2.0 использовался файл конфигурации, расположенный в папке Windows. Вы можете переместить этот файл в Вашу папку с Compare It! , чтобы Вы могли легко брать Compare It! с собой со всеми Вашими настройками.

Использование системного реестра для хранения настроек

Хранение настроек в файле конфигурации - хороший выбор для персонального использования, но для корпорации может потребоваться хранение всех настроек в системном реестре, позволяя истинное многопользовательское сотрудничество. Другая проблема с файлом конфигурации может быть с ограничением доступа в офисных системах.

Для включения использования системного реестра, поместите файл wincmp3.reg с любым содержанием в папку, куда установлен Compare It!.


Compare It! документация - Произвольный синтаксис в файлах

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Произвольный синтаксис в файлах Changes only mode

Compare It! может использовать подсветку синтаксиса для упрощения чтения результатов сравнения для исходного кода файлов. Поддержка синтаксиса для C++, C#, Java, Delphi и HTML встроена, но Вы можете добавить Ваши собственные файлы синтаксиса для других языков. По умолчанию расширение для этих файлов - chl. Формат файлов языка совместим с файлами, используемыми редактором ConTEXT.

Использование произвольного синтаксиса в файлах:

  1. Создайте произвольно язык определения файла.
  2. Поместите файл в (с расширением .chl) в новую папку "Syntax".
  3. Следуйте инструкциям в Настройки: Фильтры файлов для добавления произвольного синтаксиса в файле.

Формат произвольного синтаксиса в файлах

Файл синтаксиса - это простой текстовый файл с парой ключ/значение, разделёнными двоеточием (:). Есть типовой пример:

Language:               CSharp
Filter:                 CSharp files (*.cs)|*.cs
CaseSensitive:          1
LineComment:            //
BlockCommentBeg:        /*
BlockCommentEnd:        */

Этот формат совместим с файлами, используемыми редактором ConTEXT (бесплатен). Если Вы нуждаетесь в файле синтаксиса для дополнительного языка, убедитесь, что Вы посетили этот сайт, имеющий коллекцию многих языков.

В настоящее время поддерживается только ограниченный набор клавиш. Этот список будет расти в будущем:

  • CaseSensitive - ключевые слова с учетом регистра символов (1/0)
  • LineComment - последовательность для начала комментария, оканчивающегося строкой
  • BlockCommentBeg/BlockCommentEnd, BlockCommentBeg2/BlockCommentEnd2 - блокировка комментариев
  • KeyWords1, KeyWords2, KeyWords3 - список ключевых слов, разделённых пробелами, может продолжаться на нескольких строках:
    KeyWords1:              as new break switch finally case fixed throw
                        catch for try checked foreach typeof goto lock
  • StringBegChar - символ ограничения строк
  • CharSymbol - символ для ограничения отдельного символа
  • UsePreprocessor - использовать ли препроцессор (1/0)
© 2005, Grig Software, Все права защищены Changes only mode


Compare It! документация - О программе Compare It!

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
О программе Compare It!

Compare It! - мощный инструмент визуального сравнения и объединения файлов, позволяющий Вам сравнивать и работать с разными версиями одного и того же текстового файла. Двухпанельное сравнение с подсветкой цветом кода облегчает задачу обнаружения различий между двумя файлами.

Основные возможности

  • Панель краткого обзора помогает Вам видеть полное изображение произведённых изменений.
  • Различия отображаются в пределах строк.
  • Мощный редактор имеет функции автоматического переноса слов, подсветки синтаксиса, отмены, поиска & замены и закладок.
  • Поддерживаются текстовые файлы Windows/DOS, UNIX, и Mac.
  • Возможность сравнивать файлы MS Word и Excel.
  • Доступна Unicode-версия для полной поддержки национальных шрифтов.
  • Вы можете произвольно настроить цвета, шрифты, опции сравнения файлов и строк, и даже фильтры для диалогового окна Выбрать файл.
  • Compare It! имеет уникальные возможности для взаимодействия с Вашим менеджером файлов.
  • Навигация и объединение имеют разное основание. Вы можете использовать Ваши мышь или клавиатуру для различных выполнения действий.
  • Compare It! имеет удобное дополнение к диалоговому окну Выбрать файлы.
  • Многопользовательская поддержка.
  • Compare It! прост в установке, удалении, перемещении - берите с собой.
  • Вы можете выполнять печать результатов сравнения и создавать HTML и текстовые отчёты с разными опциями.
  • Поддержка Конвертеров позволяет Вам выполнять сравнение не только текстовых файлов.
  • Поддержка Zip-архивов позволяет вам сравнивать файл с его копией, находящейся в архиве.

Хотите большего?

Прочитайте раздел будущих выпусков, и не стесняйтесь отправлять мне Ваши хорошие идеи.


Compare It! документация - Генерация отчётов сравнения

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Генерация отчётов сравнения

Для хранения, публикации или распространения результатов сравнения Вы должны генерировать отчёт. Compare It! поддерживает несколько форматов отчётов:

  • Отчёт HTML обеспечивает Вас визуальным представлением сравнения, подобно оригинальному двухпанельному виду. Для минимизации размера файла один и тот же текст даётся в отдельном столбце.
    Этот формат включает действующую подсветку изменений.
  • Отчёт HTML2 подобен отчёту HTML report, но тот же самый текст даётся в двух столбцах, делая выходной просмотр полностью идентичным панелям сравнения.
  • Отчёт Unix diff - normal - это текстовый отчёт, идентичный произведённому в утилите UNIX diff, которая признана стандартом для сравнения файлов в мире разработки программного обеспечения.
    Этот отчёт включает только изменённые строки с номерами строк.
  • Отчёт Unix diff - unified - это также текстовый отчёт, включает несколько контекстных строк наряду с изменениями.
  • Отчёт Same - это обычный текстовый файл, включающий общую часть сравниваемых файлов.
  • Отчёт Merged может произвольно включать одинаковые и/или изменённые блоки обоих файлов в любом порядке. С этим отчётом Вы можете сохранить, например, все изменения из исходного файла, или объединить файл с изменениями обоих сторон, и так далее. Подробности
  • Composite - этот отчет повторяет структуру отчета, генерируемого Windiff: оба файла объединяются в один, измененные блоки помечаются специальным образом.

Вы используете диалоговое окно Отчёт сравнения для определения настроек и генерации отчетов.

Генерация отчёта:

  1. Выберите Файл > Отчёт.
  2. В диалоговом окне Отчёта сравнения определите настройки Вашего отчёта используя нижеприведённую информацию.
    Примечание: Выбираете Вы в зависимости от типа отчёта, некоторые настройки могут быть недоступны.

    Поле | Описание
    Выбрать файл отчёта (F2) | Определите здесь конечный файл.
    Формат отчёта | Позволяет Вам выбрать формат для сообщения.
    Добавить навигацию | Отчёт HTML может включать навигацию по элементам в тексте, позволяя быстро переходить от одного различия к другому. Выберите эту опцию для включения элементов навигации в отчёт.
    Печатать номера строк | Выберите печать номеров строк в левой стороне отчёта. Эту опцию строго рекомендуется использовать со следующей.
    Статистика | Включение информации об общем количестве изменённых, добавленных или удалённых строк.
    Печатать только изменения | Позволяет Вам печатать только различающиеся строки наряду несколькими контекстными строками. Вы можете использовать поле контекстных строк для определения количества печатаемых контекстных строк.
    Открыть после создания | Выберите эту опцию для открытия файла отчёта после его создания Compare It!.
  3. Нажмите Создать!

Создание отчёта в пакетном режиме

Вы также можете создать отчёт сравнения без запуска Compare It!. Все опции отчёта могут быть определены с помощью командной строки так же, и результат будет тот же, что и при нажатии на кнопку создать. СмотритеSee Командная строка для чтения подробностей.

Создание множества файлов отчётов

Compare It! поддерживает список файлов, так что Вы можете создавать множество отчётов одним запросом программы. Подробности.

Создание отчёта PDF

В то время как Compare It! непосредственно не поддерживает pdf-отчётов, Вы всё же можете создавать двухпанельные pdf используя дополнительные инструменты. Мы тестировали несколько таких утилит и получили наилучший результат с этими программами:

  • PDF Creator, http://sourceforge.net/projects/pdfcreator - freeware, opensource.
  • PDF Factory, http://www.fineprint.com/products/pdffactory - shareware, 50$

В обоих этих приложениях в систему добавляется виртуальный принтер, Вы должны только выполнить печать через этот принтер для того, чтобы создать pdf-файл. Имя файла может быть выбрано после того, как печать произведена. Попробуйте сначала первую (бесплатную), но вторая (платная) гораздо более удобна в пользовании.


Compare It! документация - Расширенное диалоговое окно Выбрать файл

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Расширенное диалоговое окно Выбрать файл

Compare It! добавляет несколько новых возможностей к стандартному диалогу Windows Открыть файл для того, чтобы поднять Вашу производительность:

  • Панель заголовка диалогового окна отображает источник - какой файл выбирается: исходный ("Выбрать первый файл") или конечный ("Выбрать пару для ...").
  • Область выше раскрывающегося списка дисков содержит следующее:
    • Индикатор текущего каталога, показывающий Вам полный путь к текущей папке.
    • Кнопка для быстрого выбора одного из недавно используемых каталогов, здесь отображается список из 10 последних использовавшихся исходных и конечных каталогов.
  • Вы можете определить Ваши собственные фильтры файлов для использования их в раскрывающемся списке файлов.
    Смотрите Настройки: Фильтры файлов для подробностей.
  • Режим выбора списка файлов (подробно, значки, большие значки) запоминается - Вы не должны выбирать каждый раз ваш любимый режим.


Compare It! документация - Установки опций печати

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Установки опций печати

Вы используете диалоговое окно опций Печати для того, чтобы задать Compare It! определённые параметры настройки печати Ваших отчётов.

Установка опций печати:

  1. Выберите в меню Файл > Настройки печати, закладка Общие.
  2. Используйте поля отметки для того, чтобы задать Ваши параметры настройки используя следующую информацию:

    Выбор | Действие
    Использовать цвета | Печать Вашего сообщения в цвете. Если Вы выполняете чёрно-белую печать, то изменения отображаются полужирным шрифтом.
    Перенос по словам | Включение автоматического переноса слов для печати.
    Печатать номера строк | Печать на левой стороне листа номеров строк. Если Вы используете эту опцию, то мы рекомендуем, чтобы Вы также использовали опцию Печатать только изменения.
    Альбомная ориентация | Печать в режиме альбомной ориентации листа.
    Статистика | Включение следующей информации в Ваш отчёт: общее количество изменённых, добавленных или удалённых строк.
    Печатать только изменения | Печать только различающихся строк наряду с несколькими контекстными строками. Вы также можете использовать поле контекстных строк для определения желательного количества печатаемых контекстных строк.
  3. Нажмите кнопку OK.


Compare It! документация - Просмотр статистики сравнения

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Просмотр статистики сравнения

Если Вам нужна статистика по найденным различиям, Compare It! посчитает общее количество добавленных, удалённых и изменённых строк. Вы можете включить эту статистику в версию для печати и добавить их к HTML-отчёту.

Вы также можете просмотреть статистику без генерации отчёта.

Для просмотра статистики:

  • Выберите Файл > Статистика.
    Появится диалоговое окно статистики сравнения.

Статистическая информация подсвечивается, так что Вы можете нажать кнопку Копировать для копирования её в буфер обмена.


Compare It! документация - Правка файлов

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Правка файлов

Встроенный редактор

Встроенный в Compare It! редактор имеет большинство стандартных функций правки, так что Вы найдёте его простым в обращении. Для понимания, как Compare It! показывает в панелях содержание исходного и конечного файлов, пожалуйста посмотрите раздел Виртуальные строки.

Подсветка синтаксиса

Для упрощения работы с файлами, содержащими исходные коды, Compare It! поддерживает подсветку синтаксиса. В настоящее время встроена поддержка только для C++, C#, Java, Delphi и HTML языков. Чтобы расширить этот список, Вы можете использовать произвольный синтаксис в файлах. Для отключения подсветки синтаксиса выберите Настройки > Включить синтаксис, или нажмите клавишу F11.

Перенос слов

Вы можете включить режим автоматического переноса слов выбором Вид > Перенос по словам, или нажатием CTRL + W.

Отображение пустых мест

Чтобы видеть изменения в пустых местах, типа пробелов и табуляции, Вы можете включить отображение этих символов. Выберите Вид > Показать пробелы для включения этого режима.

Bookmark icon Закладки

Вы можете использовать закладки для хранения текущей позиции курсора и быстрого возврата к этой позиции позже. Закладки отображаются в пользовательском интерфейсе как голубые прямоугольники, это показано выше.

Добавление закладки:

  1. Переместите курсор в строку, для которой Вы хотите сделать закладку.
  2. Нажмите CTRL + F2.

Удаление закладки:

  1. Переместите курсор в строку закладки.
  2. Нажмите CTRL + F2.

Переход к следующей закладке:

  • Нажмите F2.

Поиск

Используйте CTRL + F3 для поиска текста в текущей позиции курсора, F3 для поиска следующего вхождения и SHIFT + F3 для поиска предыдущего вхождения. Вы также можете нажать CTRL + F для изменения параметров поиска, например, - ввода ограничений слов и учёта регистра символов при поиске.

Замена

Compare It! также поддерживает функцию замена. Используйте CTRL + R для того, чтобы открыть диалог Заменить.

Регулярные выражения

Вы можете использовать регулярные выражения в обоих функциях - Найти и Заменить.

Буфер обмена

Редактор полностью поддерживает все операции с буфером обмена, так что Вы можете использовать стандартные комбинации горячих клавиш для копирования, вставки и вырезания фрагментов текста.


Compare It! документация - Часто задаваемые вопросы

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Часто задаваемые вопросы

Вопрос. Может ли Compare It! сравнивать папки?
Ответ. Сам Compare It! не может непосредственно сравнивать папки, но это превосходно выполняется с Synchronize It!, который и нацелен на точную синхронизацию папок. Synchronize It! также поддерживает архивы и сессии, и с лёгкостью взаимодействует с Compare It!

Вопрос. Почему я не могу редактировать файлы?
Ответ. Удостоверьтесь, что режим Правка включен (клавиша F9). Кроме того, проверьте значок, отображаемый в области панели заголовка окна; это покажет возможную причину состояния для файла - аттрибут только для чтения (read-only).

Вопрос. Как можно быстро удалить строку с помощью Compare It!
Ответ. Нажмите CTRL + Y.

Вопрос. Почему нажатие клавиши ESC закрывает приложение? Я не хочу этого!
Ответ. Некоторые люди (включая меня :-) находят эту возможность полезной. Вы можете легко отключить это, изменив горячие клавиши клавиатуры.


Compare It! документация - Поддержка сравнения папок

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Поддержка сравнения папок File lists support

Compare It! может автоматически создавать отчёты сравнения для множества файлов в разных папках.
Для настоящего визуального сравнения папок и их синхронизации смотрите Synchronize It!

Сравнение файлов в папках:

Учитывая две папки и маску файлов, Compare It! распечатает или создаст отчёты сравнения для всех соответствующих файлов в этих папках. Файлы с одинаковым размером и датой рассматриваются как идентичные и пропускаются. При печати такие файлы также не будут учитываться. Для пропуска создания одинаковых файлов отчётов, используйте /G:E опцию. Для сканирования подпапок используйте параметры /R командной строк.

Примеры:

wincmp3.exe c:\docs\ d:\backup\ /P:CN3 | Печать цветных отчётов для всех различающихся файлов в папках c:\docs и d:\backup.
wincmp3.exe c:\docs\ d:\backup\ /M "*.txt" /P:CN3 | Печать цветных отчётов для всех различающихся текстовых файлов.

Повтор структуры папок с отчётами

Как альтернатива множеству файлов отчётов в отдельной папке, Compare It! может повторить оригинальную структуру папок, давая имена файлам отчётов после оригинального файла. Это может использоваться для автоматического объединения множества файлов, в случае, если Вы имеете строгое правило объединения.
Для включения этой возможности, задайте название существующей папки как имя файла отчёта.

Предположим, оригинальные папки следующие:

c:\docs\general.txt | d:\backup\general.txt
c:\docs\january\report.txt | d:\backup\january\report.txt
c:\docs\february\report.txt | d:\backup\february\report.txt

Используйте Compare It! для создания множества отчётов в папке c:\reports :

wincmp3.exe c:\docs\ d:\backup\ /G:CN3 c:\reports

В результате папка отчётов будет включать:

c:\reports\general.txt.htm
c:\reports\january\report.txt.htm
c:\reports\february\report.txt.htm

Обратите внимание, что все типы отчётов HTML добавляют расширение ".htm" к именам файлов.

Также смотрите:
Поддержка командной строки
Создание отчёта и печать

© 2005, Grig Software, Все права защищены File lists support


Compare It! документация - Будущие выпуски

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Будущие выпуски

Следующие возможности запланированы в будущих выпусках Compare It!

  • Сравнение 3-х файлов
  • Интеграция с Microsoft SourceSafe
  • Полная поддержка произвольного синтаксиса в файлах

Если у Вас есть любые другие идеи для введения в программу новых возможностей, не стесняйтесь отправлять их автору.


Compare It! документация - Общая информация

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Общая информация
  • Условно-бесплатное ПО
  • Как зарегистрироваться?
  • Гарантия и лицензия
  • Будущие выпуски
  • Другие продукты


Compare It! документация - Использование Compare It!

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Использование Compare It!
  • Сравнение файлов
  • Объединение файлов
  • Правка файлов
  • Настройки
  • Печать и создание отчётов
  • Горячие клавиши клавиатуры, Кнопки панели инструментов, Команды меню


Compare It! документация - Игнорировать различие

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Игнорировать различие

Если Вы некоторое время работаете в Compare It! с одной парой файлов, то Вы можете захотеть скрыть уже просмотренный изменённый блок, чтобы не просматривать его много раз снова. В этом случае Вам нужна возможность Игнорировать это различие.

После того, как выбранное различие игнорируется (или скрывается), то это будет тот же самый текст; команда Найти следующее/Предыдущее различие не остановилась бы на нём; соответствующая метка также исчезла бы из панели Краткого обзора. Вы можете всё же идентифицировать такой изменённый блок по жёлтому полю.

Подобно закреплению Ручное сопоставление, метка Игнорировать это различие остаётся и после выполнения команды обновить, но будет утеряна при закрытии Compare It! или выборе других файлов для их сравнения.

Установка метки Игнорировать это различие:

Если текущая строка располагается в пределах изменённого блока, выберите команду меню Объединение > Игнорировать это различие > Установить пометку, или нажмите горячую клавишу CTRL + K.

Удаление метки Игнорировать это различие:

Если текущая строка располагается в пределах изменённого блока, выберите команду меню Объединение > Игнорировать это различие > Удалить пометку, или нажмите горячую клавишу CTRL + L.
Вы можете также удалить все такие метки одной командой: Объединение > Игнорировать это различие > Удалить все

Навигация по игнорируемым блокам:

Есть три специальных команды для того, чтобы помочь Вам в перемещении между игнорируемыми блоками, в меню Объединение > Игнорировать это различие:

  • Найти первый - переход к первому игнорируемому блоку в файле;
  • Найти следующий - переход к следующему игнорируемому блоку, начиная с текущей строки;
  • Найти предыдущий - переход к предыдущему игнорируемому блоку, начиная с текущей строки.


Compare It! документация - Как зарегистрироваться

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Как зарегистрироваться

Для Compare It! есть несколько лицензий (для домашнего и коммерческого использования), цены начинаются от 300 рублей, со значительными скидками при покупке нескольких лицензий.

Цена лицензии включает:

  • Неограниченную поддержку по электронной почте;
  • минимум 1 год бесплатных обновлений;
  • значительный скидки при обновлении лицензии.

Основной способ покупки для жителей России и СНГ - использование системы SoftKey. Наши партнеры поддерживают множество различных способов оплаты, включая безналичный расчет (для организаций), банковский перевод и популярные электронные системы платежей для частных лиц.

Купить Онлайн

Приглашаем Вас посетить www.grigsoft.ru для полной информации о возможных методах приобретения Compare It!, текущих акциях и специальных предложениях.


Compare It! документация - Установка и удаление Compare It!

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Установка и удаление Compare It!

Compare It! не использует системный реестр Вашей Windows и никаких дополнительных DLL, поэтому установка и удаление Compare It! очень просты.

Установка или удаление Compare It! с инсталлятором

  • Для установки запустите wssetup.exe и следуйте указаниям.
  • Для удаления используйте функцию Установка и удаление программ в панели управления Windows.

Установка или удаление других версий Compare It!

  • Для установки распакуйте файл оригинального архива (Вам может быть необходим инструмент, подобный WinZip) в любую папку. Вы можете создать новую папку для Compare It! (и, необязательно, для Synchronize It!) или использовать любую существующую папку.
  • Для удаления программы удалите вручную следующие файлы:

    • wincmp3.exe
    • wincmp3.ini
    • wincmp3.chm

Примечание: Если Вы производили многопользовательскую установку, то Вы также должны удалить и файлы конфигураций других пользователей.


Compare It! документация - Горячие клавиши клавиатуры, кнопки панели инструментов, команды меню

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Горячие клавиши клавиатуры, кнопки панели инструментов, команды меню

Этот раздел перечисляет основные (по умолчанию) горячие клавиши клавиатуры, которые Вы можете использовать в Compare It! Кроме того, здесь приведены эквивалентные кнопки панели инструментов и команды меню, которые Вы можете использовать для выполнения тех же самых действий.

Примечание: Вы можете корректировать настройку горячих клавиш клавиатуры для того, чтобы удовлетворить Ваши предпочтения. Смотрите Произвольная настройка горячих клавиш клавиатуры для подробностей.

Примечание: В любое время Вы можете проверить полный список текущих горячих клавиш в меню Справка > Список клавиш.

Порядок в приведённой ниже таблице соответствует порядку кнопок на панели инструментов. Смотрите другие горячие клавиши горячей клавиатуры и опции меню, которые не имеют эквивалентных кнопок на панели инструментов.

Кнопка | Описание | Горячая клавиша | Команда меню
Compare files | Открытие диалогового окна Сравнить файлы выбора файлов для их сравнения. | CTRL + O | Файл > Сравнить файлы
Select files | Открытие диалогового окна Выбрать файлы выбора файлов для их сравнения. | CTRL + SHIFT + O | Файл > Выбрать файлы
Save all | Сохранение всех изменений в обоих файлах. | CTRL + S | Файл > Сохранить все
Print | Печать отчёта. | CTRL + P | Файл > Печать
Print preview | Предварительный просмотр Вашего отчёта в окне предпросмотра перед выполнением печати. |  | Файл > Предварительный просмотр
Switch edit mode | Переключение между режимами правка и только чтение для исходного и конечного файлов. | F9 | Правка > Режим редактирования
Undo | Отмена Вашего последнего действия. | CTRL + Z | Правка > Отменить
Find combo box | Переход в поле Найти. | CTRL + D |
Find next | Найти следующее. | F3 | Правка > Найти, нажмите кнопку Найти следующее
Previous difference | Перемещение к предыдущему различию. | F7 or ALT + UP ARROW | Вид > Предыдущее различие
Next difference | Перемещение к следующему различию. | F8 or ALT + DOWN ARROW | View > Следующее различие
Difference to destination | Копирование различий в файл назначения. | ALT + RIGHT ARROW | Объединение > Копировать >>
Line to destination | Копирование строки в файл назначения. | CTRL + ALT + RIGHT ARROW | Объединение > Строку в файл назначения
Move to next difference after edit | Перемещение к следующему различию после выполнения операции правки. |  | Настройки > Перейти к следующему
Line to source | Копирование строки в исходный файл. | CTRL + ALT + LEFT ARROW | Объединение > Строку в исходный файл
Difference to source | Копирование различий в исходный файл. | ALT + LEFT ARROW | Объединение > Копировать <<
Rescan files | Обновление сравнения. | F5 | Вид > Пересканировать
Options | Установка опций программы. |  | Настройки > Настройки
Help | Доступ к контекстной справке | F1 | Справка > Справка

Вы можете произвольно настроить стандартную панель инструментов выбрав в меню пункт Настройки > Панель инструментов....

В панели инструментов могут быть размещены дополнительные кнопки:

Кнопка | Описание | Горячая клавиша | Команда меню
Paste | Вставка текста из буфера обмена в панель окна редактора. | CTRL + V | Правка > Вставить
Copy | Копирование выделенного текста в буфер обмена. | CTRL + C | Правка > Копировать
Copy Diff | Копирование текущего блока изменений в буфер обмена. |  | Правка > Копировать различие
Cut | Удаление текущего выделенного элемента и размещение его в буфере обмена. | CTRL + X | Правка > Вырезать
Show line number | Переключение отображения номеров строк. |  | Вид > Номера строк
Horizontal view | Переключение на горизонтальное размещение. | CTRL + H | Вид > По горизонтали
Switch sides | Смена местами левой и правой панелей. | CTRL + I | Вид > Поменять стороны
Changes only | Переключение в режим Только изменения. |  | Вид > Только изменения
Regular expressions usage | Переключение на использование Постоянных выражений. |  | Настройки > Настройки > Сравнение
Regular expressions... | Choose Regular expressions to use. |  |
WWW | Визит на домашнюю страницу Compare It!. |  | Справка > Домашняя страница

Другие горячие клавиши

Описание | Горячая клавиша | Команда меню
Перемещение к следующей закладке. | F2 | Правка > Следующая закладка
Переключение между активными панелями | F6 or TAB |
Активизация меню | F10 |
Выход из Compare It! | ALT + F4 or ESC | Файл > Выход
Переход к следующему изменению с той же строке | ALT + F8 | Вид > Следующее изменение
Переход к предыдущему изменению в той же строке | ALT + F7 | Вид > Предыдущее изменение
Включение закладки | CTRL + F2 | Правка > Включить закладку
Найти элемент под курсором или выделенным | CTRL + F3 |
Найти предыдущее | SHIFT + F3 |
Отображение контекстного меню | SHIFT + F10 или правый клик мышью |
Включение/Отключение подсветки синтаксиса | F11 | Настройки > Включить синтаксис
Переключение использования Игнорировать | CTRL + F11 | Настройки > Ничего не игнорировать
Open Открытие диалогового окна Найти | CTRL + F | Правка > Найти
Открытие диалогового окна Заменить | CTRL + R | Правка > Заменить
Вставка символа TAB в редактор | CTRL + TAB |
Переход в строку номер | CTRL + G | Вид > Перейти к строке
Смена местами файлов в панелях | CTRL + I | Вид > Поменять стороны
Переключение на горизонтальное/вертикальное размещение | CTRL + H | Вид > По горизонтали


Compare It! документация - Поддержка списков файлов

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Поддержка списков файлов Enchanced File Open dialog

Для быстрой генерации множества отчётов файлов сравнения или распечатки Вы можете использовать возможность Compare It! работать со списками файлов.

Использование списков файлов:

Вам будут необходимы два файла, один - с именами исходного файла, другой - с именами с именами конечного файла. Это должен быть обычный текстовый файл с полными путями к файлам.

Пример:

list1.txt | list2.txt
c:\My documents\file1.txt c:\My documents\file2.txt c:\Work\report.htm | d:\back\file1.txt d:\back\file2.txt d:\back\report.htm

Тогда Вы можете вызвать Compare It! с опцией командной строки /L. Так как списки файла поддерживаются только для выполнения печати или генерации отчёта, Вы должны использовать /P или /G вместе с /L. Смотрите опции командной строки для чтения подробностей об этих командах.

Пример:

wincmp3.exe list1.txt list2.txt /L /P:CN3

Этот запрос выполнит печать отчёта сравнения для всех пар файлов в данных списках.

Как Compare It! обрабатывает пары файлов?

Первый файл из list1 сравнивается с первым файлом из list2 и так далее. Если один из файлов не существует, пара пропускается.

Как Compare It! обрабатывает множество файлов отчётов?

Для генерации отчёта Вы определяете имя файла отчёта с командой /G. Это имя будет изменяться для множества отчётов, добавляя число перед расширением:

c:\reports\report.html
превратится в
c:\reports\report001.html
c:\reports\report002.html
c:\reports\report003.html
...
© 2005, Grig Software, Все права защищены Enchanced File Open dialog


Compare It! документация - Основной пользовательский интерфейс Compare It!

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Основной пользовательский интерфейс Compare It!

Прочитайте этот раздел для ознакомления с пользовательским интерфейсом Compare It! и терминологией, используемой в этой справке.

Окно приложения Compare It! разделено на пять областей: панель меню, панель инструментов, и три панели содержания.

  • Вы используете команды панели меню для выполнения различных действий в Compare It!
  • Кнопки панели инструментов и помечаемые поля дают Вам быстрый доступ к функциям без необходимости использования команд меню.
  • Три панели панели содержания упомянуты как Панель краткого обзора и Исходная и конечная панели.

Click here to see an illustration of the Compare It! application window.

Панель краткого обзора

Панель краткого обзора используется для отображения полных изменений в файле. Используются одинаковые цвета панелей исходного и конечного файлов, так что Вы можете быстро определить типы найденных различий.

Обратите внимание на чёрный прямоугольник, представляющий Вашу текущую позицию в файле. Вы можете кликнуть в панели краткого обзора для перехода к этой позиции в файле.

Совет: Правый клик кнопкой мыши в панели краткого обзора используется для прямого перехода к ближайшему различию. Это может быть очень полезно в огромных файлах, когда одно изменение иожет быть представлено строкой высотой 1 пиксел.

Исходная и конечная панели

Исходная панель, размещающаяся слева, показывает исходный файл. Конечный файл показывается в правой, конечной панели.

Заголовок исходной и конечной панелей отображает имя файла, открытого в панели. Цвет заголовка панели соответствует стандартному цвету активного/пассивного окна в Вашей системе, так что Вы можете легко увидеть - какая панель является активной.

Compare It! может показывать значок в области заголовка исходной и конечной панелей для отображения следующей информации:

  • Red Shield Файл имеет аттрибут только для чтения (read-only).
  • Blue Shield Compare It! функционирует в режиме только для чтения.
  • Archive file Файл был извлечён из архива. Смотрите поддержка Zip-файлов для получения дополнительной информации.
  • Converted file Файл был преобразован в текстовый вид конвертором.
  • Changes only Включен режим только изменения.
  • Unicode file Этот файл включает символы Unicode. Смотрите поддержка Unicode для получения дополнительной информации.

Кроме того, один или более значков могут быть показаны в правом углу заголовка панели для уведомления Вас о непосредственном воздействии на сравнение:

  • Для обработки файла используются регулярные выражения;
  • Используется диапазон столбцов.

Совет: Для редактирования исходного или конечного файла в другом приложении, нажмите на заголовке панели и перетащите его в другое приложение.

Совет: Вы можете кликнуть на заголовке панели правой кнопкой мыши для отображения всплывающего меню со свойствами системных файлов.

Виртуальные строки

Для хранения синхронизации сравниваемых файлов, Compare It! использует концепцию виртуальных строк. Эти строки не представлены в файле, они используются только для быстрого поиска Вами различий. Виртуальные строки отображаются как штриховка, это показано ниже. Если Вам не нравится штриховка, Вы можете отключить её, настроив цвета текста и фона в Настройки/Цвета.

Несколько примеров использования виртуальных строк:

  • Виртуальные строки добавляются в исходный файл для соответствия строк в конечном файле или других путей, при добавлении строк в конечный файл для соответствия добавляемых строк в исходном файле.
  • Виртуальные строки автоматически добавляются во время редактирования файла. Например, как только Вы добавляете одну строку в исходный файл (помечается значком карандаша), виртуальная строка вставляется в конечный файл.

Использование цвета

Compare It! использует разные цвета для визуальной идентификации произведённых изменений. По умолчанию Compare It! использует следующие стандартные цвета: голубой для изменённых строк, зелёный для строк, существующих только в исходном файле, и красный для строк, существующих только в конечном файле.

Вы можете изменить эти цвета для удовлетворения Ваших предпочтений.

Панель Объединение

Панель Объединение в исходной и конечной файловых панелях используется для пометки изменённых строк, и в конечной панели, где показывается значок стрелки, позволяющий Вам копировать текущие различия между исходным и конечным файлами. Обратите внимание, что Вы не можете использовать эти стрелки для копирования одиночных строк, если в текущем различии не только одна строка.

  • Copy current difference from source to target Кликните по этому значку для копирования текущих различий из исходного файла в конечный
  • Copy current difference from target to source Кликните по этому значку для копирования текущих различий из конечного файла в исходный
  • Copy current difference from target to source Этот значок появляется рядом с каждой изменённой строкой после того, как Вы использовали выше один значок "копировать".

    • при нажатой клавише CTRL
  • Insert current difference from source after target Кликните по этому значку для вставки текущих различий из исходного файла после изменённой секции в конечном файле
  • Insert current difference from target after source Кликните по этому значку для вставки текущих различий из конечного файла после изменённой секции в исходном файле

    • при нажатой клавише SHIFT
  • Insert current difference from source before target Кликните по этому значку для вставки текущих различий из исходного файла перед изменённой секцией в конечном файле
  • Insert current difference from target before source Кликните по этому значку для вставки текущих различий из конечного файла перед изменённой секцией в исходном файле

    • при нажатых клавишах CTRL + SHIFT
  • Delete current difference from source Кликните по этому значку для удаления текущих различий из исходного файла
  • Delete current difference from target Кликните по этому значку для удаления текущих различий из конечного файла

Строка состояния

В дополнение к стандартной информации о состоянии, строка состояния позволяет Вам переключать режимы правки для исходного или конечного файлов, или для обоих. Выберите или очистите соответствующий флажок в строке состояния.

Примечание: Используйте эти переключатели для защиты файлов индивидуально от редактирования. Если Вы хотите переключить режим правка для приложения, используйте кнопку на панели инструментов Режим правка.

Также строка состояния подсказывает, какие цвета используются для кодирования типа изменений, и выводит количество блоков изменений каждого типа:
Примечание: Удерживая CTRL Вы можете видеть общее число измененных строк, аналогичное данным в Статистике.

Панель информации о файле

Информационная панель обеспечивает Вас дополнительной информацией о каждом файле: дата изменения, текущая строка курсора и столбец, а также тип файла. Тип файла объединяет два индикатора - стиль CRLF и тип текста.

Стиль CRLF

Исторически текстовые файлы на различных платформах используют разные специальные символы для пометки последней строки - это называется стиль CRLF. Compare It! способен обработать все такие окончания (также при сохранении файлов), и Вы можете видеть стиль CRLF для файла в информационной панели следующим образом:
  • WIN - платформа Windows, последовательность CRLF (символы #13#10);
  • UNIX - платформа Unix, только LF (#10);
  • MAC - платформа Macintosh, только CR (#13);
  • WN2 - этот стиль не используется, однако я видел такую кодировку на Windows;
  • UKN - неизвестный стиль - используется, если файл состоит из одной строки.
Одиночный файл может, конечно, включать объединение разных окончаний; особенно, если он редактировался на разных платформах. В этом случае Compare It! покажет сначала региональный стиль окончания.

Стиль текста

Вторая часть типа файла - индикатор стиль текста, который может быть одним из этих:
  • TXT - обычный (plain) текст;
  • UNI - текст Unicode, также big- или little-endian;
  • UTF - UTF8, специальный тип кодировки Unicode.


Compare It! документация - Иллюстрация главного окна приложения Compare It!

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Иллюстрация главного окна приложения Compare It!

Следующее изображение показывает пример окна приложения Compare It!.

Compare It! Application Window


Compare It! документация - Ручное сопоставление

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Ручное сопоставление

В редких случаях движок сравнения может ошибочно сообщить о соответствии строк. Это может произойти, если файл имеет много дублирующихся строк. Для коррекции этой проблемы Вы можете выполнить ручное сопоставление.

Ручное сопоставление двух строк:

  1. Для каждой строки - переведите курсор в эту строку, щёлкните правой кнопкой мыши и выберите Ручное сопоставление > Установить закрепление вручную.
    Закрепление отображается в пользовательском интерфейсе красным полем с номером, который позволяет без проблем использовать множество закреплений.
  2. Повторите шаг 1 для каждого набора строк, которым Вы хотите установить ручное сопоставление.
    Примечание: Вы можете установить до 25 закреплений вручную.
  3. Выберите Вид > Пересканировать для обновления сравнения файлов.
    Строки с одинаковыми номерами закреплений будут рассматриваться как идентичные во время сравнения.

Другие команды, доступные из подменю Ручное сопоставление:

Команда | Описание
Удалить закрепление | Удаление закрепления из текущей строки.
Показать совпадения | Поиск пары закрепления в другом файле.
Следующее закрепление | Поиск следующего закрепления в том же файле.
Удалить все закрепления | Удаление всех ручных закреплений в обоих файлах.


Compare It! документация - Объединение файлов

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Объединение файлов

Режим редактирования

Compare It! может работать в режимах редактирование или только чтение (read-only). Для переключения из режима редактирования в режим только чтение, нажмите F9 или используйте кнопку на панели инструментов Режим редактирования.

Редактирование, основанное на различиях

Хотя Compare It! имеет встроенный редактор, являющийся мощным средством, для обычной правки, Вам он будет необходим редко, так как Вы можете выполнять редактирование, основанное на различиях. Этот тип редактирования поможет Вам копировать изменённые блоки из одного файла в другой единственным щелчком мыши или нажатием клавиши.

Копирование различий из исходной панели в конечную:

  • Используйте клавиши ALT + LEFT ARROW / ALT + RIGHT ARROW или кнопки панели инструментов.
    -или-
    Выберите команду Копировать из всплывающего меню.
    -или-
    Кликните по соответствующему значку в панели Объединение.

Копирование одной изменённой строки:

  • Используйте клавиши CTRL + ALT + LEFT ARROW / CTRL + ALT + RIGHT ARROW или кнопки панели инструментов.

Добавление изменённого блока строк во второй файл:

  • Чтобы вставить блок после текущей секции, нажмите и удерживайте клавишу CTRL и кликните по соответствующему значку в панели Объединение.
    -или-
    Чтобы вставить блок перед текущей сессией, нажмите и удерживайте клавишу SHIFT и кликните по соответствующему значку в панели Объединение.

Копирование изменённого блока строк в буфер обмена:

  • Щёлкните правой кнопкой мыши или нажмите SHIFT + F10 для отображения контекстного меню, выберите и нажмите Копировать различие.

Замена файлов

Иногда после просмотра изменений Вы можете пожелать сохранить один файл вместо их объединения.

Замена конечного (правого) файла:

  1. Выберите конечный файл, кликнув по его панели.
  2. Выберите Файл > Заменить правый файл.
    Появится диалоговое окно подтверждения. Это диалоговое окно отображает информацию об имени и полном пути к файлу, который Вы хотите перезаписать поверх.
  3. Для замены конечного файла и выхода из Compare It!, нажмите Да.
    -или-
    Для замены конечного файла без выхода из Compare It!, нажмите Нет.
    -или-
    Для отмены операции замены, нажмите Отмена.

Для замены исходного (левого) файла:

  1. Выберите исходный файл, кликнув по его панели.
  2. Выберите Файл > Заменить левый файл.
    Появится диалоговое окно подтверждения. Это диалоговое окно отображает информацию об имени и полном пути к файлу, который Вы хотите перезаписать поверх.
  3. Для замены исходного файла и выхода из Compare It!, нажмите Yes.
    -или-
    Для замены исходного файла без выхода из Compare It!, нажмите Нет.
    -или-
    Для отмены операции замены, нажмите Отмена.

Пересканирование файлов

После того, как Вы сделали изменения, Вы можете обновить (пересканировать - произвести сравнение заново) файлы для уменьшения запутанных областей.

Для пересканирования файлов:

  • Нажмите F5.
    -или-
    Выберите Вид > Пересканировать.
    -или-
    Нажмите кнопку Пересканировать на панели инструментов.


Compare It! документация - Перемещённые секции

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Перемещённые секции

Compare It! может выполнить необязательное отображение соответствующих перемещённых секций, подобное тому, как это делает известный WinDiff.

Включение/отключение соответствующих перемещённых секций:

  1. Выберите Настройки > Настройки.
    Появится диалоговое окно Настройки.
  2. В окне Настройки выберите Сравнение.
  3. Отметьте Искать перемещённые секции для включения или отключения этой возможности.

Работа с перемещёнными секциями

Overview Bar displaying Moved Sections | Когда найдена перемещённая секция, Вы можете увидеть и определить её на панели краткого обзора, где блоки соединены между собой тонкими линиями, так что Вы видите их расположение.
Moved Sections in panes | Когда на экране видна только одна перемещённая секция, Вы увидите, что она отмечена пунктирной линией, соединённой с отрезкомo. Прямое соединение линии показывает Вам полное соответствие размещённому блоку.
Moved Sections in panes | Когда на экране видны обе перемещённые секции, они соединяются между собой и Вы сразу видите соответствие. Если строка в пределах перемещённой секции, она будет соединена твёрдой, а не пунктирной линией. Это поможет Вам, когда видны в одно и то же время много линий соединения.

Быстрый переход к соответствующей секции:

Выберите в меню Объединение > Показать перемещённое,
или
выберите в всплывающем меню элемент Показать перемещённое.

Изменение цвета соединительной линии:

  1. Выберите Настройки > Настройки.
    Появится диалоговое окно Натсройки.
  2. В окне Настройки нажмите на страницу Цвета.
  3. Используйте раскрывающийся список Цвет перемещённой секции для выбора нужного цвета.


Compare It! документация - Сравнение файлов Word с помощью Compare It!

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Compare doc files Сравнение файлов Word с помощью Compare It! Using RegExp substrings Excel files comparison

Compare It! может сравнивать файлы Microsoft Word 97 (файлы .doc) или выше, преобразовывая их в текстовый формат. Вам необязательно устанавливать MS Office/Word - Compare It! преобразовывает самостоятельно. Пожалуйста обратите внимание, что текст только извлекается, без форматирования - так что Вы не увидите изменений в форматировании.

Из-за характера файлов .doc, каждый абзац представлен как одиночная строка в конечном текстовом файле. В то время как вы можете использовать способность Compare It! автопереноса на новую строку, этот формат всё же неудобен, так что Вы можете выполнить с Compare It! автоматический перенос слов в преобразованном файле двумя путями:

  • перенос по позиции - перенос слов после 80 символа, подобно тому, как это делает Word. Недостаток этого способа - запутанное сравнение, если так как причина многих изменений - разный перенос.
  • перенос по предложениям - перенос после точки ('.'). Это уникальный режим переноса, необычный поначалу, но фактически самый простой для сравнения. Вы определённо должны попробовать этот режим.

Как с любыми преобразованными файлами, Вы не можете редактировать или объединять файлы .doc - сравнение файлов доступно только для чтения и Вы ограничены только возможностью просмотра изменений.

Управление автоматическим преобразованием файлов Word

  1. Выберите в меню Настройки > Настройки, закладка Общие.
  2. Используйте поле Конвертировать .doc файлы для включения этой возможности.
  3. Используйте поле Перенос по позиции для определения - должен ли быть выполнен перенос слов в тексте в ходе преобразования.

С настройками по умолчанию Compare It! выполнит сравнение файлов .doc с опцией "Перенос по позиции".

Какое различие между встроенным переносом слов и переносом файлов .doc?

С стандартным переносом слов (меню Вид > Перенос по словам), нумерация строк не изменяется - Вы только увидите, что перенос текста производится в панели по ширине. Вы можете включать или отключать этот режим динамически, Вы можете изменять размеры панели и перестраивать текст. С переносом файлов .doc, текстовые строки могут быть реально нарушены в нескольких строках, изменяя общее количество строк в файле. Вы не можете изменять перенос без пересканирования файла.

DocWrap

Теперь возможность "Переноса по предложениям" также доступна для всех файлов - используйте меню Вид > Doc Wrap. Однако обратите внимание, что так как в таком режиме форматирование текста значительно изменяется, возможность редактировать файл автоматически отключается.

© 2005, Grig Software, Все права защищены Using RegExp substrings Excel files comparison


Compare It! документация - Сравнение Excel файлов с помощью Compare It!

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Compare xls files Сравнение Excel файлов с помощью Compare It! Excel files comparison

Compare It! теперь может сравнивать файлы Microsoft Excel 97 (.xls) и более поздних версий. При этом файлы конвертируются в текстовый формат. Для этого не надо иметь установленный Excel - Compare It! делает это независимо. Поскольку извлекается только текст, без форматирования - вы не сможете обнаружить изменения в форматировании.

Несколько рабочих листов объединяются на одной странице, табличная структура сохраняется по возможности.

Чтобы облегчить восприятие, для таких файлов автоматически выбирается моноширинный шрифт.

Как и со всеми конвертируемыми файлами, редактировать\объединять .xls файлы невозможно, Ваши возможности ограничены анализом различий.

Как сравнить Excel файлы без конвертирования

Так как сравнение таких файлов "как есть" не дает сколько-нибудь разумного результата, Вы не сможете совсем отключить конверсию. Тем не менее, вы всегда можете вернуться к сравнению файлов в изначальном виде с помощью команды меню Вид > Смотреть как > Текст

© 2005, Grig Software, All Rights Reserved Excel files comparison


Compare It! документация - Настройки: Цвета

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Настройки: Цвета

Вы можете определить текст и цвета фона для разных типов информации, отображаемой в Compare It! Вы также можете устанавливать разные аттрибуты шрифта для лучшего визуального определения изменений.

Установка опций цвета и аттрибутов текста:

  1. Выберите меню Настройки > Настройки.
    Появится диалоговое окно Настройки.
  2. В окне Настройки нажмите на Цвета.
  3. В списке Элемент выберите тип информации, для которого Вы хотите определить настройку цвета.
  4. Используйте раскрывающиеся списки Текст и Фон для выбора цветов.
    Текстовое поле выше раскрывающегося списка Текст показывает Вам пример текста и фона, когда Вы делаете изменения.
  5. Выберите желаемые аттрибуты шрифта, Вы можете выбрать полужирный, курсив, зачёркнутый, подчеркнутый.
  6. Шаги 3 - 5 повторяются для настройки каждого элемента.

Вы можете также установить цвет для Перемещённой секции, соединяющей строки.

Примечание: Нажмите кнопку По умолчанию для сброса всех настроек в стандартные настройки цветовой палитры.

Примечание: Использование аттрибутов шрифта полужирный/курсив может не работать с некоторыми шрифтами.

Совет: Если Вы не любите штриховку, используемую для идентификации виртуальных строк, Вы можете установить тот же самый цвет для текста и фона виртуальных строк.


Compare It! документация - Настройки: Сравнение

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Настройки: Сравнение

Вы используете страницу Сравнение диалогового окна Настройки для установки опций сравнения для файлов и строк в файлах.

После того, как Вы установите опции сравнения, Вы должны обновить сравнение файлов для того, чтобы заданные опции вступили в силу.

Сравнение файлов

Установка опций сравнения файлов:

  1. Выберите в меню Настройки > Настройки.
    Появится диалоговое окно Настройки.
  2. В окне Настройки нажмите на страницу Сравнение.
  3. Используйте поля отметки под Игнорировать пробелы для определения пробелов, которые Compare It! должен игнорировать во время выполнения сравнения:

    Выбор | Игнорирование пробелов
    все | все пробелы
    в начале строки | в начале строки
    в конце строки | в конце строки
    между слов | между символами между слов
    многократные | разное количество пробелов
  4. Для игнорирования специальных escape-символов, подобно Form Feed (0x0C), отметьте опцию Игнорировать специальные символы.
  5. Чтобы игнорировать добавленные пустые строки во время сравнения отметьте опцию Игнорировать вставленные пустые строки.
  6. Для того, чтобы игнорировать переносы строк отметьте опцию Игнорировать переносы строк.
  7. Чтобы игнорировать во время сравнения регистр символов, отметьте опцию Игнорировать регистр.
  8. Если Вы определите значение (N) в поле Минимальная длина совпадающих строк, то строки длины менее N не будут нарушать блок изменённых строк.
    Это может быть полезно для программистов, в противном случае установите это значение в 0.
  9. Если Вы используете постоянные выражения, чтобы игнорировать части строк в файлах, отметьте опцию Использовать постоянные выражения.
    Появится диалоговое окно Постоянные выражения. Используйте это диалоговое окно для добавления или удаления постоянных выражений.
  10. Для того,чтобы задать столбцы строк для сравнения (например, игнорировать первые 5 символов) отметьте опцию Использовать диапазон столбцов и введите число в поле.
    Смотрите Определение диапазона столбцов для подробностей.
  11. Вы можете также разрешить обнаружение Перемещенных блоков.
  12. Механизм частичного соответствия по умолчанию используется только в небольших блоках. Здесь Вы можете указать полный поиск, что улучшит результат сравнения, но уменьшит его скорость.

Сравнение строк

Точное сравнение может быть больше запутанным, чем полезным. Пример:

This is sample string
And here is another one

Эти строки полностью различны, но сравнение покажет Вам некоторые одинаковые символы. Вы можете использовать две опции для сравнения для сравнения строк, чтобы избежать такой результат.

Установка опций сравнения строк:

  1. Выберите Настройки > Настройки.
    Появится диалоговое окно Настройки.
  2. В окне Настройки нажмите на страницу Сравнение строк.
  3. Для того, чтобы автоматически использовать сравнение строк отметьте опцию Использовать сравнение строк.
  4. Используйте поле Минимум совпадающих символов для установки минимального количества символов, принимающих участие в сравнении.
  5. Используйте поле Минимальный процент совпадающих строк для отключения сравнения сильно различающихся строк, если процент идентичных фрагментов меньше указанного.
    В вышеприведённом примере строки имеют длину (21 + 23) = 44 символов, общая длина соответствующих фрагментов составляет (5 * 2) = 10, и есть только около 23% соответствия.
  6. Если отметить опцию Использовать альтернативное сравнение, то Вы сможете включить алгоритм Альтернативное сравнение строк.


Compare It! документация - Настройки: Конверторы

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Настройки: Конверторы

Что такое конвертор?

Иногда вы можете сравнивать не текстовые файлы. Если Вы пробуете это сделать с Compare It!, то Вы не получите приемлемого результата сравнения. Однако во многих случаях такие файлы могут быть представлены как обычные текстовые файлы.
Например, файлы базы данных могут быть просмотрены как список данных в колонках, текст из документа текстового процессора может быть извлечён с минимумом форматирования и так далее.

Программы, которые могут выполнять такие преобразования (из не текстовых данных в текстовый вид), называются конверторами. Если у Вас есть такая программа, то очевидным будет преобразовать ваши файлы в текст перед сравнением в Compare It!. Однако повторять этот шаг вручную для множества файлов - утомительная задача, отнимающая много времени.

Другой пример, для которого программа-конвертор может быть полезна, состоит в предварительной обработке текстовых файлов. Посмотрите сравнение XML-файлов с подобным содержанием, но различным форматированием. Конвертер может произвести некоторое стандартное форматирование XML для упрощения сравнения файлов.

Как Compare It! может Вам помочь?

Вы можете задать Compare It! выполнить автоматическую предварительную обработку файлов некоторого типа указанной программой-конвертором. Любая программа, которая может выполнять преобразование формата автоматически без помощи пользователя, может использоваться для автоматической предварительной обработки с Compare It!

Определение конвертора:

  1. Выберите в меню Настройки > Настройки.
    Появится диалоговое окно Настройки.
  2. В окне Настройки нажмите на страницу Конверторы.
  3. Нажмите кнопку Добавить.
  4. В поле Имя можно ввести (необязательно) имя конвертора.
  5. Используйте поле Шаблон для определения типа файлов, которые автоматически будет обрабатывать этот конвертор.
  6. В поле Команда используйте кнопку обзор для выбора программы-конвертора.
  7. Используйте поле Аргументы для задания параметров для конвертора.
    Метки {$Source_File - исходный файл} и {$Converted_File - преобразованный файл} будут заменены соответствующими именами файлов с полным путём.

Примечание: Вы не можете редактировать преобразованные файлы в Compare It!, сохранение файла в текстовом виде уничтожит исходный файл. Если файл был преобразован, то Compare It! покажет значок "выполнено преобразование" Converter applied в заголовке панели исходного или конечного файла.

Где найти конверторы?

Первое место для поиска конверторов - наш сайт. У нас есть несколько готовых конверторов:

  • LineSorter - сортировка строк перед сравнением;
  • Dfm2Text - преобразование из файлов форм Delphi/Builder;
  • Bin2Hex - преобразование двоичных (бинарных) файлов (*.exe, *.dll) в читаемый шестнадцатиричный вид. Полезно для сравнения двоичных файлов одного размера;

Следующий Ваш шаг в поиске конверторов - поиск в основных поисковых системах. Предлагаем Вам поискать конвертор из формата баз данных dbf в текст. Попробуйте искать сочетания dbftotxt, dbftotext, dbf2txt, dbf2text. Для широко распространённых форматов файлов есть много шансов, что такой инструмент существует.

Наконец Вы можете войти в контакт с нами и запросить о разработке конвертора. Мы исследуем возможность преобразования нужного Вам формата и попробуем это сделать за разумную цену.


Compare It! документация - Настройки: Редактор

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Настройки: Редактор

Установка опций редактора:

  1. Выберите в меню Настройки > Настройки.
    Появится диалоговое окно Настройки.
  2. В окне Настройки нажмите на страницу Редактор.
  3. Чтобы установить размер табуляции для редактора, введите число в поле Табуляция.
  4. Используйте поля отметки для правки других опций используя нижеизложенную информацию:

    Выбор | Действие
    Удалить пробелы в конце строки | Удаление пробелов в конце строк при загрузке файла.
    Виртуальные пробелы в редакторе | Возможность "виртуальных пробелов" позволяет Вам перемещать курсор после окончания строки.
    Сохранить пробелы, без табуляции | Замена символов табуляции пробелами при сохранении файла.
    Циклический поиск | Выполнение непрерывного поиска в файлах. Когда Вы производите поиск, то поисковый движок будет продолжать циклически обходить файл для нахождения вхождений. Строка состояния информирует Вас о прохождении конца файла во время выполнения поиска.
    Отметить пропуск текущей строки | Отметка пропуска текущей строки выполняется с помощью прямоугольной рамки для упрощения визуальной идентификации.
    Использовать колёсико для горизонтальной прокрутки в левой панели | Используется колёсико мыши для горизонтальной прокрутки в левой панели.
    Состояние режима Правка Вы можете задать состояние режима Правка после запуска:
    - Запуск всегда в режиме Правка;
    - Запуск всегда в режиме Только чтение;
    - Сохранять состояние режима Правка: восстанавливать режим Правка, как это было при последнем испозовании Compare It!.
    Не редактировать файлы с аттрибутом read-only | Вы не сможете редактировать файлы с аттрибутом только для чтения (read-only).
    Область выделения | Использовать ли область выделения в редакторе.
  5. Нажмите расположенную ниже надписи Шрифт кнопку настройки шрифта (она отображает текущий используемый шрифт) для того, чтобы определить шрифт по умолчанию для редактора.
  6. Фиксированный шрифт - эта кнопка позваляет настроить альтернативный шрифт.

Установка альтернативного шрифта для печати:

Чтобы напечатать на одной странице больше информации или сделать распечатываемое более читаемым, Вы можете выбрать другой шрифт для печати. Выберите в меню Файл > Настройки печати, закладка Дополнительно.

Использование художественного шрифта для подсветки различий.

Compare It! позволяет Вам установить полужирный/курсив/зачёркнутый аттрибуты шрифта для подсветки изменений, также как для других секций файла. Проверьте Цвета для настройки этих опций страницы.


Compare It! документация - Настройки: Фильтры файлов

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Настройки: Фильтры файлов

Вы можете установить произвольно фильтры, используемые Compare It! при доступе к диалоговому окну Выбрать файлы.

Добавление файла в фильтр:

  1. Выберите в меню Настройки > Настройки.
    Появится диалоговое окно Настройки.
  2. В окне Настройки нажмите на страницу Фильтры файлов.
  3. Нажмите кнопку Добавить.
  4. В поле Имя введите описание для этого типа файлов.
    Это описание Вы будете видеть открывающемся списке типов файлов в диалоговом окне Выбрать файлы.
  5. В поле Шаблон определите маску одного или нескольких типов файлов.
    Вы можете использовать пробел, запятую или точку с запятой в качестве разделителя.
  6. В открывающемся списке Синтаксис выберите значение.
    -или-
    Для определения произвольного языка из раскрывающегося списка Синтаксис выберите Пользователя и используйте кнопку обзора, располагающуюся ниже поля Синтаксис, для выбора файла синтаксиса.
  7. Установите Использовать моноширинный шрифт, если вы хотите всегда использовать такой шрифт для этого типа файлов.

Удаление файла из фильтров:

  1. Выберите в меню Настройки > Настройки.
    Появится диалоговое окно Настройки.
  2. В окне настройки нажмите на страницу Фильтры файлов.
  3. Выберите фильтр, который хотите удалить, и нажмите кнопку Удалить.

Перемещение файла в фильтрах:

  1. Выберите в меню Настройки > Настройки.
    Появится диалоговое окно Настройки.
  2. В окне настройки нажмите на страницу Фильтры файлов.
  3. Выберите фильтр, котрый хотите переместить и используйте кнопки вверх/вниз для перемещения элемента в списке.


Compare It! документация - Настройки: Общие

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Настройки: Общие Options: File Filters

Установка общих настроек:

  1. Выберите в меню Настройки > Настройки.
    Появится диалоговое окно Настройки.
  2. В поле настроек выберите закладку Общие.
  3. Из списка При старте установите желаемый способ выбора файлов при старте.
  4. Для изменения количества строк в контексте для режима Только Изменения, используйте соответствующее поле для правки этого значения.
  5. Для включения поддержки автоматического резервного копирования, выберите и отметьте поле Использовать резервную папку, воспользуйтесь кнопкой обзор для выбора папки, и определите срок хранения (дней) файлов резервных копий.
  6. Вы можете также изменить и опции для Обработки файлов MS Word (.doc).
  7. Вы также можете переключать использование всплывающих сообщений для предупреждений "Файлы те же самые". Вы можете найти этот вид сообщений очень полезным, так как не требуется никаких дополнительных нажатий клавиш для их закрытия.

Примечание: Опции "Использовать ESC для выхода" и "Использовать ALT+Arrows для перемещения" (доступные в более ранних версиях) больше не поддерживаются. Теперь Вы можете произвольно настроить все горячие клавиши клавиатуры.

© 2005, Grig Software, Все права защищены Options: File Filters


Compare It! документация - Настройки: Клавиатура

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Настройки: Клавиатура

Вы можете изменить все горячие клавиши клавиатуры, используемые в Compare It! для того, чтобы удовлетворить Ваши желания.

Произвольная настройка горячих клавиш клавиатуры:

  1. Выберите в меню Настройки > Настройки.
    Появится диалоговое окно Настройки.
  2. В окне Настройки нажмите на страницу Клавиатура.
  3. В списке Команды выберите команду.
    Текущая комбинация клавиш отображается в списке Текущие клавиши.
  4. Кликните в поле Новое сочетание клавиш и нажмите одиночную клавишу или сочетание клавиш, которой Вы хотите назначить команду.
    Если новая горячая клавиша уже назначена для другой команды, Compare It! покажет это под Уже использовано для как только Вы нажмёте одиночную клавишу или сочетание клавиш.
  5. Нажмите кнопку Назначить для того, чтобы назначить горячую клавишу для выполнения определённой команды.

Удаление горячей клавиши клавиатуры:

  1. В списке Команды выберите команду.
  2. В списке Текущие клавиши выберите горячую клавишу.
  3. Нажмите кнопку Удалить.

Сброс всех горячих клавиш клавиатуры в состояние по умолчанию:

  • Нажмите кнопку Сбросить все.


Compare It! документация - Настройки: Язык

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Настройки: Язык

Используйте эту страницу диалогового окна Настройки для выбора языка интерфейса Compare It!

Каждый язык хранится в отдельном файле, обычно называемом язык.dic.

Дополнительные языки доступны на нашем web-сайте. После загрузки языкового пакета распакуйте нужный язык в папку установленного Compare It!. Файл языка должен иметь расширение .dic, тогда он появится в списке Доступные языки диалогового окна Настройки.

Установка языка:

  1. Выберите в меню Настройки > Настройки.
    Появится диалоговое окно Настройки.
  2. В окне Настройки нажмите на страницу Язык.
  3. В списке Доступные языки выберите нужный язык.
  4. Нажмите кнопку OK.
  5. Перезапустите Compare It!

Примечание: Создайте первым перевод для Вашего родного языка и получите бесплатную лицензию!


Compare It! документация - Настройки

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Настройки
  • Общие
  • Фильтры файлов
  • Сравнение
  • Редактор
  • Цвета
  • Язык
  • Клавиатура
  • Конверторы


Compare It! документация - Другие продукты

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Другие продукты

Если Вы нашли Compare It! полезным, Вы также должны попробовать дружественную программу, направленную на синхронизацию папок: Synchronize It!

Здесь приведён список возможностей, которые Вы найдёте в Synchronize It!

  • Синхронизация архивов.
  • Произвольная настройка цвета, проектов, конфигураций, фильтров и так далее.
    Ваши ежедневные задачи Synchronize It! выполнит лучше всех.
  • Встроенная опция сравнения двоичных (бинарных) файлов гарантирует идентичность файлов.
  • Пользовательские инструменты сравнения, просмотра и архивации.
  • Удобная навигация в панели списка файлов с поиском и выбором незаметного.
  • Подобно Compare It!, программа Synchronize It! стала shareware начиная с версии 2.0. Но Вы не должны оплачивать две программы! Купите Compare It! и Ваш регистрационный ключ будет действовать также и для Synchronize It! !


Compare It! документация - Частичное совпадение

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Частичное совпадение

Эта версия Compare It! включает экспериментальный движок Частичное совпадение. Это может быть использовано для визуальной центровки подобий, но не соответствующих строк, упрощая просмотр различий.

Однако такое соответствие может занимать длительное время, особенно для огромных различающихся блоков, так что оно автоматически применяется только для малых (10 строк и менее) секций. Вы можете вручную вызвать анализ частичного совпадения нажатием клавиши F4, или выбором в меню элемента Объединение > Частичное совпадение.

Игнорирование переноса строки

Другой функцией, подобной частичному сопоставлению, является способность игнорировать переносы строки.

Иногда это лучше обработки длинных строк, Вы можете вручную перенести по словам длинную строку в несколько коротких в новой версии Вашего файла. Compare It! может игнорировать такие изменения, если Вы выбрали соответствующую опцию в Настройки > Сравнение.


Compare It! документация - Печать и генерация отчётов

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Печать и генерация отчётов
  • Настройки печати : Общие
  • Настройки печати : Поля
  • Настройки печати : Дополнительно
  • Генерация отчёта сравнения
  • Просмотр статистики сравнения


Compare It! документация - Настройки печати: Дополнительно

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Настройки печати: Дополнительно

Для того, чтобы печатать больше на одной странице или сделать распечатываемое более читаемым, Вы можете выбрать альтернативный шрифт для печати. Вы можете также отключить печать заголовка (с датой) и колонтитула (с номером страницы) для того, чтобы освободить немного свободного места для данных.

Выбор шрифта для печати:

  1. Выберите Файл > Настройки печати, закладка Дополнительно.
  2. Отметьте поле Использовать для печати другой шрифт для включения этой возможности; далее нажмите кнопку шрифта (которая показывает текущий используемый шрифт) для изменения шрифта, применяемого при печати.

Отключение печати Заголовка/Колонтитула:

  1. Выберите Файл > Настройки печати, закладка Дополнительно.
  2. Используйте поля Заголовок и Колонтитул для управления этими элементами страницы.


Compare It! документация - Настройки печати: Поля

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Настройки печати: Поля

На этой закладке Вы можете изменить поля, используемые для печати.
Обратите внимание, что фактические поля на напечатанной странице могут быть больше, чем указанные, в зависимости от параметров настройки Вашего принтера.

Установка опций полей:

  1. Выберите Файл > Настройки печати, закладка Поля.
  2. Выберите Вашу обычную единицу измерения: сантиметры или дюймы
  3. Установите желаемые значения для левого/правого/верхнего/нижнего полей. Изображение страницы поможет Вам увидеть, как выглядят эти края.
    или
    Вы можете быстро выбрать одно из трёх предварительно заданных значений полей нажатием на соответствующую кнопку:
    Нажатие | Действие
    Без полей | Установки всех полей в значение 0
    Маленькие | Установки всех полей в значение 0.5 см (0.2 дюйма)
    С подшивкой | Установки верхнего, нижнего и правого полей в значение 0.5 см (0.2 дюйма), а также левого поля в значение 2.5 см (1 дюйм)


Compare It! документация - Быстрый старт

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Быстрый старт

Compare It! удобен в использовании. Это раздел объясняет основные шаги.

Использование Compare It!

  1. Выберите два файла.
    Вы можете это сделать следующими путями:
    • Если Вы используете двухпанельный менеджер файлов, то Вы можете запустить Compare It! нажимая на именах двух файлов как параметрах. Смотрите Использование Compare It! с менеджером файлов для чтения подробностей.
    • Если Вы используете Проводник Windows, то Вы можете перетащить (drag-and-drop) в открытое окно Compare It! файлы, которые хотите сравнить.
    • Вы можете выбрать файлы для сравнения в расширенном диалоговом окне Выбрать файлы используя Файл > Выбрать файлы.
    После того, как Вы выбрали файлы для сравнения, Compare It! производит их сравнение и показывает Вам различия в двух панелях и подсвечивает код цветом.
  2. Для правки файлов включите режим Правки (нажатием на клавиатуре клавиши F9).
    Теперь Вы можете изменять ваши файлы или объединять их различия. Попробуйте горячие клавиши ALT + ARROW (UP, DOWN, LEFT, RIGHT) для навигации по изменениям и копирования изменений из одного файла в другой.

Эти шаги подробно описаны в Сравнении файлов.


Compare It! документация - Замена подстрок регулярными выражениями

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Замена подстрок регулярными выражениями Compare doc files

Регулярные выражения дают Вам возможность делать сложные поисковые запросы. Однако, когда начинается операция замены, Вы можете почувствовать ограниченные возможности, так как Вам требуется замена сложного выражения для поиска простым текстом. Это - тот случай, где Вам на помощь придут подстроки.

Пример

Вместо чтения скучной теории давайте поработаем с типовой проблемой сравнения. Представим, что у нас есть оригинальный документ, содержащий множество дат формата: September 12, 2003; September 25, 2002 и так далее. (Для упрощения в этом приммере мы будем работать только с September). Ваш коллега сделал некоторые изменения, и среди прочего, изменил формат даты как 12.09.2003; 25.09.2002.
Так для нас появилась проблема - нужно игнорировать изменение формата даты.
Первый подход может быть простым - замена всех дат на пустые строки, мы можем сделать это, используя регулярное выражение "September \d{1,2},\d{4}". Однако в этом случае мы пропустим изменения, сделанные непосредственно по дате. Мы нуждаемся в комбинировании заменяемых строк из соответствующих частей поисковых выражений, то есть из подстрок.

Шаг 1: Пометка подстрок
Для пометки подстрок в поисковом запросе, мы используем круглые скобки: "September (\d{1,2}),(\d{4})". Подстроки пронумерованы 1,2,... поскольку они появляются в исходном выражении. В нашем случае строка September 12, 2003 будет соответствовать, подстрока #1 = "12", подстрока #2 = "2003".

Шаг 2: Использование подстрок
Для вставки найденных подстрок в заменяемую строку, используйте переменные $1, $2,... . Суммируем эту информацию, здесь выражения поиск/замена игнорируют изменение формата даты:
Поиск: September (\d{1,2}),(\d{4})
Замена: $1.09.$2

Где я могу использовать это?

Вы можете использовать этот подход в случаях, когда регулярные выражения используются в Compare It! для замены:
  • В ходе предварительной обработки файла перед сравнением;
  • В обычной операции Поиск и замена.
© 2005, Grig Software, Все права защищены Compare doc files


Compare It! документация - Поддержка файла результата

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Поддержка файла результата

Поддержка файла результата была добавлена для поддержки некоторых версий систем управления. Его имя можно пропускать как третий параметр для включения команды Сохранить как результат в меню Файл. Эта команда сохраняет файл в активной панели как файл результата.


Compare It! документация - Использование объединённого отчёта

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Использование объединённого отчёта

Объединённый отчёт - это специальный тип отчёта, который может использоваться для объединения частей сравниваемых файлов в результирующем текстовом файле. Типовые применения включают извлечение той же самой части, автоматическое объединение по одному правилу, и так далее.

Структура объединённого отчёта

Объединённый отчёт - это обычный текст, включающий указанные части оригинальных файлов. При создании такого отчёта Compare It! разбивает оригинальные файлы на части и секции согласно результату сравнения:

Левый файл: | [идентичное] | [различное] | [идентичное] | -- | [идентичное] | [слева] | ...
Правый файл: | [идентичное] | [различное] | [идентичное] | [справа] | [идентичное] | -- | ...
 | [ секция | 1 ] | [ секция | 2 ] | [ секция | 3 ] | ...

Комбинация одинаковых и различающихся блоков есть секция. Обратите внимание, что первая секция файла может состоять из одного изменённого блока (в случае, если файл начинается с изменений); точно так же, если в конце файла та же строка, последняя секция будет включать только одинаковый блок.

Для настройки объединённого отчёта, Вы определяетет блоки и порядок для включения в отчёт для каждой секции. Здесь описываются все блоки, которые Вы можете комбинировать:
Идентичный текст [S] | Идентичная секция - блок текста между двумя изменениями
Различие в исходном [L] | Изменённый блок из исходного (левого) файла
Различие в конечном [R] | Изменённый блок из конечного (правого) файла
Только исходный [A] | Блок, существующий только в исходном файле
Только конечный [B] | Блок, существующий только в конечном файле
Символы в круглых скобках используются для командной строки, смотрите ниже.

Создание отчёта просто: Compare It! сканирует сравниваемые файлы и для копии каждой секции выбирает строки для файла отчёта.

Использование командной строки для создания объединённого отчёта

Как все другие типы отчётов, объединённый отчёт может быть создан из командной строки, без помощи пользователя. Для создания отчёта с уже установленными опциями, просто введите
wincmp3.exe file1 file2 /G:M report_file .

Но Вы можете также определить конфигурацию в командной строке, используя ярлыки, описанные в таблице:
wincmp3.exe file1 file2 /G:M+SLAB report_file .

Давайте посмотрим, что будет включено в отчёт:

  1. Идентичные строки включаются в отчёт (S);
  2. Из 2-х изменённых блоков, только левая (исходная) часть копируется (L), правый блок отвергается;
  3. При вхождении только исходного блока, он копируется в отчёт (A);
  4. Только конечный блок также копируется в отчёт (B).

Результат, файл отчёта, - это исходный файл с добавленными строками из конечного.

Также смотрите:
Использование командной строки


Compare It! документация - Добро пожаловать в Compare It!

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Welcome to Compare It! 3.0 Добро пожаловать в Compare It! 3.0

Compare It! - это мощный инструмент визуального сравнения и объединения файлов.

  • О программе Compare It!
  • Установка и удаление Compare It!
  • Что нового?
  • Быстрый старт
  • Основной пользовательский интерфейс Compare It!
  • Иллюстрация окна приложения Compare It!


Compare It! документация - Обновления и поддержка

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Обновления и поддержка FAQ

Отправляйте пожалуйста запросы технической поддержки, идеи и отчёты об ошибках по адресу электронной почты support@grigsoft.ru.

Также всегда добро пожаловать к участию в нашем форуме поддержки [image] http://www.grigsoft.ru/forum/.

Коммерческие предложения отправляйте на адрес sales@grigsoft.ru.

Для получения любой информации о новых версиях и других хороших новостей посетите домашнюю страницу автора: http://www.grigsoft.ru/.

Примечание: Послания от зарегистрированных пользователей имеют приоритет. Проблемы, найденные ими в приложении, исправляются в первую очередь, и их идеи о дальнейшем развитии программы будут реализованы быстрее. Пожалуйста вставляйте регистрационное имя в Ваше сообщение, если это имеется.

© 2005, Grig Software, Все права защищены FAQ


Compare It! документация - Добавление ярлыков внешних приложений

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Добавление ярлыков внешних приложений

Вы можете использовать команду Настроить в меню инструментов для добавления ярлыка одного или более внешнего приложения.

Добавление ярлыка другого приложения:

  1. Выберите Инструменты > Настроить.
    Появится диалоговое окно Настройка.
  2. В поле Инструменты нажмите на Add Tool.
  3. В поле Имя введите имя приложения так, как Вы хотите видеть его в меню Инструменты.
  4. В поле Команда используйте кнопку обзора для выбора исполняемого файла приложения.
  5. Используйте Параметры и кнопку выбора для определения начальных параметров выполнения приложения.
  6. Нажмите кнопку Закрыть.
    Ярлык для приложения теперь появится как пункт в меню Инструменты.

Удаления ярлыка другого приложения:

  1. Выберите Инструменты > Настроить.
    Появится диалоговое окно Настройка.
  2. В поле Инструменты выберите ярлык, который хотите удалить и нажмите Remove Tool.
  3. В диалоге подтверждения выполнения операции удаления нажмите кнопку Да.
  4. Нажмите кнопку Закрыть.
    Ярлык удаляется из меню Инструменты.

Открытие сравниваемого файла в ассоциированном с этим типом файлов приложении:

Вы можете также установить инструмент запуска связанного с текущим файлом приложения (например, MS Word для файлов .doc). Вместо конфигурирования множества инструментов для разных типов файлов, Вы можете загрузить небольшое приложение WinStart с нашей страницы дополнений. Если оно сконфигурировано как "winstart.exe {$ActivePath}", то запустится соответствующее приложение для обработки сравниваемого файла.


Compare It! документация - Поддержка Unicode

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Поддержка Unicode

Если Вы испытываете проблемы с именами файлов, содержащими национальные символы или полностью национальный язык, то Вы должны попробовать Unicode-версию Compare It! Unicode - специальный путь кодирования символов, используется для отображения таких языков, как Японский, Корейский, Китайский, и некоторых европейских языков.

Unicode полностью поддерживается в Microsoft Windows NT, Windows 2000, и Windows XP. Поэтому Compare It! Unicode будет корректно работать только на этих системах.

Вы можете загрузить самую последнюю Unicode-версию из Grig Software http://www.grigsoft.com.

Стандартная (не-Unicode) версия Compare It! поддерживает "упрощённый" Unicode. Она может только обнаруживать и преобразовывать текст Unicode в "обычный" текст и сохранять его для возврата к нему позже. Это должно прекрасно работать, если никаких реальных 2-байтовых Unicode символов не используется. Обратите внимание, что даже при столкновении с такими символами Compare It! загрузит текст, но откажется сохранить его во избежание потери данных. Если это происходит, то в заголовке окна появится красный значок Red icon, Unicode .

А моя версия какая?

Чтобы понять, является ли Ваша версия Unicode, посмотрите Помощь > О программе. Unicode-версия будет иметь строчку "Compare It! Unicode" в верху формы.


Compare It! документация - Использование регулярных выражений

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Использование регулярных выражений Using fixed font Using RegExp substrings

Обычно, когда Вы ищете подстроки в строке, соответствие должно быть точным. Так, если Вы ищете подстроку "abc" то отыскиваемая строка должна точно содержать эти символы в той же последовательности для соответствия найденного.

Мы можем расширить этот вид поиска для выполнения поиска без учёта регистра, где подстрока "abc" найдёт подобия "Abc", "ABC" и так далее. То есть регистр символов игнорируется, но последовательность символов должна быть точно такой же. Иногда поиска без учёта регистра символов недостаточно. Например, если мы хотим найти цифры, то мы ищем каждую цифру независимо. Это тот случай, когда регулярные выражения придут на помощь.

Регулярные выражения - это текстовые образцы, используемые для поиска соответствия строк. Регулярные выражения - это строки, содержащие смесь обычного текста и специальных символов для того,чтобы указать - что делать. Здесь приведено краткое руководство по использованию регулярных выражений перед тем, как перейдём к коду для обработки регулярных выражений.

Синтаксис регулярных выражений

Литеры
Все символы литер, кроме: ".", "*", "?", "+", "(", ")", "{", "}", "[", "]", "^" и "$". Эти символы литер располагаются перед "\". Литеры - это символы, соответствующие самим себе.

Подстановочные знаки
Символ точки "." соответствует любому одиночному символу.

Повторы
Повторы - выражения, повторяемые произвольное число раз.
Выражение, сопровождаемое * может быть повторено любое число раз, включая ноль.
Выражение, сопровождаемое + может быть повторено любое число раз, но по крайней мере - один.
Выражение, сопровождаемое ? может быть повторено только ноль или один раз.
Когда необходимо определить минимальное или максимальное явных повторов, может быть использован оператор {}, таким образом "a{2}" есть символ "a" точного повтора дважды, "a{2,4}" представляет собой символ "a" повтора от 2 до 4 раз, и "a{2,}" представляет собой символ "a" повтора не менее двух раз без ограничения сверху. Обратите внимание, что не должно быть никакого пустого пространства внутри {}, и нет ограничения верхнего значения низкой или высокой границей.

    Примеры:
    "ba*" будет соответствовать всем "b", "ba", "baaa" и так далее.
    "ba+" будет соответствовать "ba" или "baaaa" , но не "b".
    "ba?" будет соответствовать "b" или "ba".
    "ba{2,4}" будет соответствовать "baa", "baaa" и "baaaa".

Круглые скобки
Круглые скобки () обычно используются для группировки элементов вместе с подвыражениями. Например, выражение "(ab)*" соответствовало бы всей строке "ababab".

Альтернативы
Альтернативы выходят, когда выражение может соответствовать одному или другому подвыражению, каждая альтернатива отделяется "|". Кадая альтернатива - есть возможно большее предыдущее подвыражение; это - противоположное от операторов повторов поведение.

    Примеры:
    "a(b|c)" может соответствовать "ab" или "ac".
    "abc|def" может соответствовать "abc" или "def".

Наборы
Набор - это набор символов, которые могут соответствовать любому одиночному символу, являющемуся членом набора. Наборы разграничиваются "[" и "]" и могут содержать литеры, символы диапазона, и символы классов. Набор начинается с "^", содержит дополнение следующих элементов.

    Примеры:
    Символы литер:
    "[abc]" будет соответствовать также "a", "b", или "c".
    "[^abc]" будет соответствовать любому символу, кроме "a", "b", или "c".

    Символы диапазонов:
    "[a-z]" будет соответствовать любому символу в диапазоне от "a" до "z".
    "[^A-Z]" будет соответствовать любому символу, кроме диапазона от "A" до "Z".

Классы символов
Класс символов - это специальная последовательность для упрощения общеиспользуемых типов символов. Доступные классы:

Класс | Описание | Эквивалент
\w | Любой символ в слове - все алфавитно-цифровые символы плюс символ подчёркивания. | [a-zA-Z_]
\s | Любой пустой символ (пробел или табуляция). |
\d | Любая цифра. | [0-9]
\l | Любой символ в нижнем регистре. | [a-z]
\u | Любой символ в верхнем регистре. | [A-Z]

Версия этих классов в верхнем регистре означает НЕ, например, \S не символ пробела.

Обобщение синтаксиса элементов регулярных выражений

Следующая таблица суммирует синтаксис элементов, используемых в регулярных выражениях.

Символ | Описание
^ | Начало строки. Выражение "^A" будет соответствовать "A" только в начале строки.
^ | Символ (^) сразу после левой скобки ([) имеет разные значения. Он используется для исключения символов в пределах скобок из соответствующих конечных строк. Выражение "[^0-9]" указывает, что конечный символ не должен быть цифрой.
$ | Знак доллара ($) будет соответствовать концу строки. Выражение "abc$" будет соответствовать подстроке "abc" только, если это в конце строки.
| | Символ разделения (|) разрешает любое выражение на этой стороне для соответствующей конечной строки. Выражение "a|b" будет соответствовать "a" также, как и "b".
. | Точка будет соответствовать (.) любому символу.
* | Звёздочка (*) указывает, что символ слева от неё должен в выражении соответствовать 0 или большему количеству раз.
+ | Знак плюс (+) подобен звёздочке, но должно быть по меньшей мере одно соответствие символа слева от знака + в выражении.
? | Вопросительный знак (?) соответствует символу слева от него 0 или 1 раз.
() | Круглые скобки действуют на порядок пробы образца и также служат как конечное выражение, которое может быть использовано при замене соответствующей подстроки другим выражением.
[] | Квадратные скобки ([ и ]) включают набор символов, указывающих на то, что любой из включенных символов может соответствовать конечному символу.
{N} | Повторы выражения точно N раз.
{N, M} | Повтор выражения от N до M раз.
{N, } | Повтор выражения N или более раз.

Благодарности

Я хотел бы поблагодарить Dr John Maddock за описание и выполнение движка обработки регулярных выражений.

© 2005, Grig Software, Все права защищены Using fixed font Using RegExp substrings


Compare It! документация - Использование Compare It! с менеджером файлов

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Использование Compare It! с менеджером файлов Using fixed font

Автозавершение имён файлов

Compare It! имеет возможность, упрощающую его использование из менеджера файлов (FM). Вы можете передать имя каталога как второй параметр вместо передачи полного имени второго файла. Это позволяет Вам вызвать Compare It! из менеджера файлов без необходимости выбора конечного файла в длинном списке каталогов.

Синтаксис: wincmp3.exe d:\dir\dir2\dir3\file.ext e:\archive\month

Compare It! будет пробовать найти второй файл в следующей последовательности:

e:\archive\month\file.ext
e:\archive\month\dir3\file.ext
e:\archive\month\dir2\dir3\file.ext
e:\archive\month\dir\dir2\dir3\file.ext

Если file.ext не найден, Compare It! сообщит, что не найти конечный файл невозможно.

Как я могу это использовать?

Вы можете получить больше от Compare It! и Вашего менеджера файлов, если Ваш менеджер файлов поддерживает выполнение внешних инструментов с заданными параметрами. В этом случае, Вы можете задать одну команду для сравнения файлов с одинаковыми именами файлов, и другую для сравнения файлов, используя возможность Автозавершения. Кроме того, Compare It! имеет два разных значка, которые Вы можете использовать в Вашем Compare It! для этих команд. Ниже приведён пример конфигурации для Total Commander:

Сравнение файлов с одинаковыми именами: %p%n %t

Сравнение файлов с разными именами: %p%n %t%m

где:

  • %p есть путь к активной панели
  • %t есть путь к неактивной панели
  • %n есть текущее имя файла
  • %m есть имя неактивного файла.

Использование Compare It! из Проводника Windows

Если Вы пользуетесь Windows Explorer, Вы можете создать ярлык для Compare It! в Вашем каталоге SendTo (Отправить в). Теперь Вы можете выделить два файла, щёлкнуть правой кнопкой и выбрать Отправить в > Compare It! для сравнения выбранных файлов с помощью Compare It!
Вы также можете выделить один файл, щёлкнуть правой кнопкой и выбрать Отправить в > Compare It!, и Compare It! сам запросит Вас выбрать второй файл.

Ярлыки в папке Отправить виспользуются для передачи параметров часто используемым приложениям напрямую из Проводника Windows. В зависимости от Вашей операционной системы Вы можете найти эту папку здесь:
Windows XP: .\Documents and Settings\Administrator\SendTo
Windows NT: .\WINNT\Profiles\Administrator\SendTo
Windows 95: .\Windows\SendTo

Вы можете отправлять файлы в Compare It! с командой "Отправить в" даже один за другим. Compare It! поймёт такой двойной запрос и сравнит файлы.

Использование Compare It! с Total Commander

На нашем web-сайте Вы найдёте подробную статью об эффективном использовании Compare It! совместно с Total Commander: http://www.grigsoft.com/art_totcmd.htm

Использование Compare It! с FAR

Менеджер FAR может вызывать внешнее приложение из пользовательского меню, доступного нажатием клавиши F2. Вы можете использовать эту командную строку для конфигурации сравнения выделенных файлов в активной и неактивной панелях: wincmp3.exe !.! !#!\!.!
© 2005, Grig Software, Все права защищены Using fixed font


Compare It! документация - Гарантия и лицензия

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Гарантия и лицензия

Стандартная гарантия (точнее ее отсутствие) для Условно-Бесплатного ПО

Автор не несет ответственности за абсолютно любые проблемы, включая потери данных, произошедшие вследствии использования этой программы. Максимальный ущерб, который автор может возместить, без исключений, равен сумме, которую Пользователь уплатил Автору за программу. При этом Пользователь теряет любые права на использование данной программы.

Лицензия

Compare It! доступен в нескольких типах лицензий.

Домашнее использование | Эта лицензия дает права одному частному лицу использовать программу на своем компьютере для целей не связанных с коммерческой деятельностью. Допольнительно, в связи с характером программы, разрешено ее использование еще на одном компьютере этим же лицом.
Бизнес-лицензия | Разрешает использование программы на одном компьютере в организации или дома, при проведении коммерческой деятельности.
Лицензия на несколько компьютеров | Эта лицензия позволяет использовать Compare It! в офисе на указанном количестве компьютеров.

Распространение

Пробная версия может свободно распространятся (включая реальные носители), при условии сохранения целостности авторского пакета.

Продажа или иное распространение зарегистрированной копии запрещено. В этом случае Автор оставляет за собой право аннулировать данное соглашение и заблокировать купленный ключ без возвращения денег.

Все права на данную программу принадлежат Автору(Grig Software).


Compare It! документация - Условно-бесплатное ПО

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Условно-бесплатное ПО

Начиная с версии 2.0, Compare It! стала условно-бесплатной (shareware) программой. Чтобы доработать ее до уровня лидеров рынка, в программу было вложено много сил и времени, поэтому я недеюсь Вы поймете и примите мое решение.

Как зарегистрироваться? Сколько стоит?

Статус условно-бесплатной программы означает, что Вы можете бесплатно пользоваться программой на протяжении 30 дней. За это время Вы сможете полностью оценить ее возможности и решить, подходит ли она для Ваших нужд. По истечении испытательного срока Вы должны либо удалить программу, либо оплатить регистрацию. После оплаты Вы получите лицензионный ключ, разрешающий дальнейшее использование.

Зачем мне регистрироваться?

Незарегистрированная версия Compare It! по истечении месяца запретит редактирование файлов. После регистрации Вы сможете использовать программу без ограничений. Запросы от зарегистрированных пользователей имеет приоритет при обращении в техническую поддержку.

Если вы зарегистрируетесь сейчас, вы также получите ключ к другой нашей программе - Synchronize It!. Таким образом Вы покупаете две программы по цене одной.

Наконец, своими деньгами вы поддержите авторов, помогая им продолжать развитие понравившейся Вам программы.

Как зарегистрироваться?


Compare It! документация - Что нового?

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Что нового?

В этом разделе перечислены усовершенствования, которые были выполнены в каждой последующей версии Compare It!

Версия 3.85

  • Строка состояния включает число различных блоков;
  • Новая возможность - DocWrap;
  • Область выделения сейчас можно убрать;
  • Теперь при редактировании файлов на удаленных компьютерах у них сохраняются дополнительные атрибуты;
  • Добавлено меню для панели Строки+;
  • Поддержка систем с несколькими мониторами;
  • Поддерживаемые типы файлов теперь авто-определяются - xls, doc, pdf, rtf;
  • Множество мелких исправлений и улучшений.

Версия 3.81

  • Поддержка PDF и MIF файлов.

Версия 3.8

  • Поддержка rtf файлов;
  • Новая панель Строки+ для облегченного просмотра длинных строк;
  • Возможность быстро изменять размер шрифта клавишами Ctrl + Plus, Ctrl + Minus;
  • Импорт\экспорт настроек;
  • Возможность настраивать встроенные конвертеры аналогично внешним.

Версия 3.75

  • Добавлена возможность постоянного использования механизма Частичного соответствия для всего файла;
  • Новой правило использования RegExp - Игнорировать строки не соответствующие выражению;
  • Добавлены параметры коммандной строки: /r1, /r2, /xls, /doc;
  • Теперь можно не показывать предложение выбрать файлы для сравнения при старте;
  • Новый отчет - Composite, аналогичный WinDiff;
  • Подчеркнутый шрифт может использоваться для выделения различий;
  • Добавлена возможность печати выделенного фрагмента и текущей страницы;
  • Новая возможность - Метка изменений, сигнализирующая о наличии изменений за пределами видимой части строки (полезна для длинных строк);
  • Статистика теперь включает число совпадающих строк.

Версия 3.7

  • Поддержка файлов MS Excel (*.xls);
  • Улучшенный HTML отчет с использованием CSS;
  • Расширены возможности применения RegExp;
  • Можно спрятать Обзорную панель;
  • Для разных типов файлов можно указать использование пропорциональных или моноширинных (фиксированных) шрифтов;
  • Кроме того, можно быстро переключить текущий тип шрифта;
  • Теперь можно изменять цвета подсветки синтаксиса;
  • Можно быстро переключить использование конвертора;

Версия 3.55

  • Добавлена возможность игнорировать переносы строки;
  • Добавлен экспериментальный движок частичного соответствия;
  • Печать может включать информацию о файле (дата, размер, тип);
  • Различные мелкие исправления и усовершенствования.

Версия 3.53

  • Исправлена ошибка с автопереносом слов в предпросмотре перед печатью;
  • Добавлен список горячих клавиш в меню Справка.

Версия 3.52

  • Исправлена ошибка с предпросмотром перед печатью;
  • Добавлен индикатор типа файла в Строку состояния;
  • Уведомление о разных CRLF-окончаниях, даже если файлы одинаковые.

Версия 3.51

  • Улучшены качество и скорость переноса слов;
  • Исправлены другие ошибки;

Версия 3.5

  • Добавлена поддержка для любых шрифтов, без ограничения их ширины;
  • Улучшена функция Поиск и замена;
  • Добавлена возможность Игнорировать различия;
  • Необязательный новый движок Альтернативное сравнение строк;
  • Использование RegExp (последовательностей) улучшено с заменами подстрок;
  • Относительный путь может быть использован для папки резервного копирования;
  • Необязательное использование всплывающих сообщений для уведомлений;

Версия 3.3

  • Ограниченная поддержка файлов [image] MS Word;
  • Добавлена поддержка подсветки синтакиса для HTML;
  • Заголовок/колонтитул могут быть отключены для печати;
  • Увеличено максимальное количество закреплений для функции Ручное сопоставление до 25;
  • Другие мелкие усовершенствования и исправленные ошибки;

Версия 3.2

  • Добавлены новые отчёты : HTML2, Тот же самый, Объединённый;
  • Поддержка списка файлов для печати и генерации задач отчёта;
  • Генерация отчёта сравнения для множества файлов в папках;
  • Добавлена опция определения количества контекстных строк для режима Только изменения;
  • Объединение теперь возможно в режиме Только изменения;
  • Улучшено обнаружение перемещённых секций;
  • Контекстное меню отображающее свойства системного файла, доступно правым кликом по заголовку файла;
  • Добавлена Опция использования колёсика мыши в левой панели для горизонтальной прокрутки;

Версия 3.1

  • Обнаружение и отображение перемещённых секций;
  • Добавлена возможность определения полей печати;
  • Добавлена возможность использовать полужирный/курсив/перечёркнутый аттрибуты шрифта наряду с цветами;
  • Добавлено использование альтернативных последовательностей (regexp);
  • Имена файлов теперь включаются в заголовок для упрощения навигации;
  • Добавлена опция игнорирования специальных escape-символов;
  • Исправлены случайные ошибки и сделаны мелкие усовершенствования

Версия 3.04

  • Возможен возврат назад произвольной настройки панели инструментов;
  • Добавлена опция управления режимом Правка при запуске программы;
  • Необязательный альтернативный шрифт для печати;
  • Необязательная защита файлов с аттрибутом только для чтения (read-only);
  • Исправление ошибок

Версия 3.03

  • Добавлена возможность выбора принтера и опций печати из окна предпросмотра перед печатью.
  • Исправление ошибок

Версия 3.02

  • Исправление ошибок
  • Выбор имени принтера для печати из командной строки.
  • Опция для маркировки текущей строки.

Версия 3.01

  • Исправление ошибок
  • При создании отчёта в пакетном режиме Вы можете выбрать удаление отчёта, если файлы точно такие же. Смотрите командная строка для чтения подробностей.

Версия 3.0

  • Необязательное использование системного реестра для хранения настроек
  • Исправление ошибок

Версия 3.0, Beta 3

  • Поддержка произвольного синтаксиса в файлах
    Совместимость с бесплатным редактором ConTEXT
  • Теперь также доступна и Unicode-версия

Версия 3.0, Beta 2

  • Поддержка Zip-архива
    Смотрите для подробностей Поддержка Zip-файла
  • Поиск и замена
  • Поддержка ручного соответствия
  • Список последних использовавшихся файлов
  • Режим "Игнорировать Nothing"
  • Опция отключения подстветки синтаксиса
  • Дальнейшее усовершенствование редактора и его работы

Версия 3.0, Beta

  • Новый, точный и полный возможностей движок правки
  • Поддержка автопереноса слов
  • Подсветка синтаксиса
  • Кнопка отображения панели объединения обозначена как Панель объединения
  • Поддержка конверторов
  • Панель Строка состояния отображает позицию курсора и дату файла
  • Фильтр вида (отображение только изменений)

Версия 2.89

  • Поддержка в поиске постоянных выражений
  • Исправлено множество ошибок

Версия 2.87

  • Генерация HTML-отчёта
  • Печать в пакетном режиме и генерация отчёта, смотрите командная строка для подробностей
  • Поддержка каталога для резервного копирования, смотрите Автоматическое резервное копирование для подробностей
  • Статистика различий может быть включена в отчёт и распечатана, смотрите Настройки печати для подробностей
  • Несколько мелких усовершенствований интерфейса
  • Исправлена странная ошибка с окраской строки в Windows 95

Версия 2.85

  • Опция игнорирования вставки пустых строк, смотрите Опции сравнения для подробностей
  • Редактор Постоянных выражений теперь обнаруживает неверно сформированные выражения
  • Функция поиска текста улучшена
  • Печать с альбомной ориентацией листа
  • Множество усовершенствований движка сравнения
  • Визуальная индикация при применении постоянных выражений
  • Новое меню Объединение с обычными командами объединения

Версия 2.83

  • Скорость обработки больших файлов улучшена
  • Исправлено несколько ошибок с работой горячих клавиш и движка сравнения

Версия 2.82

  • Скорость работы Unicode-версии улучшена

Версия 2.82, Beta 2

  • Постоянные выражения теперь могут быть индивидуально включены/отключены
  • Необязательная кнопка панели инструментов для быстрой правки постоянных выражений
  • Исправлены ошибки редактирования в Unicode-версии

Версия 2.82, Beta

  • Произвольная настройка горячих клавиш клавиатуры
  • Добавлена Unicode-версия
  • Улучшения движка сравнения строк

Версия 2.8 Final

  • Диапазон столбцов для сравнения
  • Выбор команды в всплывающем меню для быстрого выбора секции текущего текста
  • Новые команды отключения строк: /n, /r, /h, /=Alias
  • Шрифт поля Найти отражается, если параметры поиска текста действительны (смотрите Найти и Заменить для подробностей)
  • Печать с переносом слов
  • Диалог опций был перепроектирован

Версия 2.8, Beta

  • Быстрое сравнение огромных файлов (более 1 Мб)
  • Печать с переменными опциями (смотрите Настройки печати для подробностей)
  • Исправлено несколько ошибок интерфейса
  • Опция "Режим правки по умолчанию" была удалена - теперь Compare It! восстанавливает последний использованный режим правки.

Версия 2.75

  • Исправлены некоторые ошибки
  • Поддержка простого Unicode
  • Поддержка колёсика мыши (используйте CTRL для перехода между изменениями)
  • Найти следующее изменение в строке (ALT + F7/ALT + F8)

Версия 2.70

  • Новый движок сравнения
  • Улучшена поддержка постоянных выражений
  • Необязательная кнопка панели инструментов для отключения постоянных выражений
  • Возможность отключения горизонтального вида разделения
  • Возможность отключения сторон
  • Исправлена команда Вставить
  • Игнорирование пустых мест и пробелов
  • ESC для закрытия приложения теперь необязательно
  • Усовершенствованный редактор

Версия 2.61

  • Исправлены проблемы с редактором постоянных выражений
  • Добавлена поддержка \s, \S для постоянных выражений

Версия 2.6

  • Произвольные инструменты
  • Поддержка файлов с одиночным LF как концом строки
  • Поддержка постоянными выражениями игнорирования частей строк
  • Немного усовершенствований интерфейса

Версия 2.51

  • Исправлена ошибка с утечкой ресурсов при загрузке огромного файла
  • Теперь вы можете перетащить файл используя заголовок панели

Версия 2.5

  • Многоязычный интерфейс
  • Возможно отображение номеров строк
  • Некоторые усовершенствования интерфейса

Версия 2.0

  • /1 командную строку отключает
  • Если выполняется работа с одиночным файлом как параметром, Compare It! запросит второй файл
  • Режим "Выбрать файлы"
  • Несколько мелких усовершенствований
  • Произвольная панель инструментов

Версия 2.0, Beta

  • Отображение изменений в пределах строки
  • Поддержка файлов UNIX/MAC/DOS
  • Улучшенный редактор
  • Многопользовательская поддержка


Compare It! документация - Поддержка дополнительных форматов файлов

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Поддержка дополнительных форматов файлов Сравнение Excel файлов

В дополнение к офисным форматам (doc, rtf, xls), Compare It! может работать и с некоторыми другими не-текстовыми файлами. Здесь вы найдете описание таких форматов и возможных тонкостей работы с ними.

Поддержка всех дополнительных форматов может быть отключена в меню Настройки > Конверторы.

Сравнение PDF файлов

Для сравнения PDF файлов используется дополнительная библиотека расширения, которую вы можете бесплатно скачать с нашего сайта. После загрузки просто распакуйте pdftotext.dll в каталог с Compare It! ( обычно C:\Program Files\Compare It!).

Как и другие сконвертированные файлы, pdf документы не могут редактироваться в Compare It!

Поддержка MIF файлов

MIF (Makers Interchange Format) - формат используемый для описания документов Adobe FrameMaker в текстовом виде. MIF используется для обмена данными между FrameMaker и другими приложениями. Так как данный формат является текстовым, он не требует специальной обработки. Однако русский текст в таком файле кодируется особым образом, значительно усложняя работу с ним. Compare It! теперь умеет не только самостоятельно раскодировать русский текст в mif файлах для сравнения, но и возвращать код к исходному виду при сохранении. Таким образом, поддержка MIF файлов позволяет полное редактирование документов в панелях сравнения!

© 1996-2005, Grig Software, All Rights Reserved Сравнение Excel файлов


Compare It! документация - Поддержка zip-файлов

Добро пожаловать в Compare It!
О программе Compare It!
Установка и удаление Compare It!
Что нового в этой версии?
Быстрый старт
Основной пользовательский интерфейс
Иллюстрация окна приложения
Использование Compare It!
Сравнение файлов
Объединение файлов
Правка файлов
Установка настроек
Общие
Фильтры файлов
Сравнение
Правка
Цвета
Язык
Клавиатура
Конвертеры
Отчёт и печать
Настройки печати
Настройки печати: Поля
Настройки печати: Дополнительно
Отчёт сравнения
Статистика сравнения
Горячие клавиши, кнопки панели инструментов, команды меню
Дополнительные функции
Добавление ярлыков для внешних приложений
Альтернативное сравнение
Автоматическое резервное копирование
Использование командной строки
Файл конфигурации
Режим Только изменения
Произвольный синтаксис в файлах
Определение диапазона столбцов
Расширенное окно Открыть файл
Поддержка списка файлов
Сравнение папок
Игнорирование различия
Ручное соответствие
Объединённый отчёт
Перемещённые секции
Частичное соответствие
Поддержка файла результата
Поддержка Unicode
Использование Compare It! с менеджерами файлов
Использование регулярных выражений
Использование подстрок регулярных выражений
Сравнение файлов Word
Сравнение Excel файлов
Сравнение файлов других форматов
Поддержка Zip-файлов
Общая информация
Что такое Shareware?
Как зарегистрироваться?
Гарантия и лицензия
Будущие выпуски
Другие продукты
Часто задаваемые вопросы
Обновления и поддержка
Поддержка zip-файлов Compare excel files

Теперь Вы можете сравнивать обычный файл с другой его версией, находящейся в файле zip-архива.

Например, если Вы имеете файл zip-архива, имеющий имя archive.zip, который содержит копию файла file.dat, то Вы можете использовать следующую команду для сравнения файлов.

wincmp3.exe file.dat archive.zip

Compare It! показывает результаты сравнения в стандартном интерфейсе, и заголовок панели содержит этот значок: Archive file для отображения, что файл был извлечён из файла архива.

Вы не можете редактировать файл, извлечённый из файла архива.

© 2005, Grig Software, Все права защищены Compare excel files