Introduction

 Elcomsoft.com » Password Recovery Software » Advanced PDF Password Recovery » Help

Introduction

 Top Next

Advanced PDF Password Recovery (APDFPR) is a program to decrypt protected Adobe Acrobat PDF files, which have "user" and/or "owner" passwords set, preventing the file from opening or editing, printing, selecting text and graphics etc. With the Standard edition of the program, if only "owner" password is set, password recovery is not needed at all, but the file is being decrypted instantly (so all restrictions are being removed). Professional edition can also recover "User" password using brute-force and dictionary attacks, or instantly from the "Owner" password; also, it supports the "key search" attack to decrypt PDF files with 40-bit encryption redardless the password length, guaranteed. In addition, it is able to clean PDF files from JScript code, form fields and digital signatures. Enterprise edition also includes an improved version of "key search" attack – it is shipped with a DVD that contains special Thunder tablestm that allow to decrypt all 40-bit PDF files in just minutes instead of days.

The program that is licensed to you is absolutely legal and you can use it provided that you are the legal owner of all files or data you are going to recover through the use of our software or have permission from the legitimate owner to perform these acts. Any illegal use of our software will be solely your responsibility. Accordingly, you affirm that you have the legal right to access all data, information and files that have been hidden.

You further attest that the recovered data, passwords and/or files will not be used for any illegal purpose. Be aware password recovery and the subsequencial data decryption of unauthorized or otherwise illegally obtained files may constitute theft or another wrongful action and may result in your civil and (or) criminal prosecution.

Get more information about Advanced PDF Password Recovery
Get full version of Advanced PDF Password Recovery

(c) 2007 ElcomSoft Co.Ltd.


Requirements and limitations

Requirements and limitations

 Previous Top Next

Requirements

· Windows 2000, Windows XP, Windows Server 2003 or Vindows Vista
· about 6 megabytes of free space on hard disk (4 gigabytes for Enterprise version)

Limitations

· PDF files protected using Digital Rights Management (DRM) technology or 3rd party plugins such as FileOpen cannot be decrypted. If you try to start to decrypt such file, APDFPR shows the message like:

· Brute-force attack is effective for short passwords only, usually up to 7-8 chars. Recovering longer ones will take too much time (months, years) even on a very fast computer. In most cases, dictionary attack really helps (to find long passwords), but if the password is well-selected (e.g. the combination of letters, digits and special chars, or concatenation of two or more words etc), it cannot be recovered at all. Fortunately, if only "owner" password is set, there is no need to recover it at all – the document can be decrypted (instantly) anyway; and for files with "user" password that use 40-bit encryption, you can use Key search attack.

· The program tries to process corrupted files (and on success, shows the number of non-critical errors ignored), but sometimes, it is not possible. You can fix most of such problems simply by opening your file in Adobe Acrobat (full version, not the Reader) and just saving it without making any changes.


About PDF encryption

About PDF encryption

Adobe Acrobat features two levels of password protection.

Protecting document with access restriction ("owner", so-called "security" or "master") password does not affect a user's ability to open and view the PDF file, but prevents user from editing (changing) the file, printing it, selecting text and graphics (and copying them into the Clipboard), adding/changing annotations and form fields etc (in any combination). If the file is protected this way, you open it in Adobe Acrobat Reader (again, the password is not required for that) and select File | Properties menu item, Security, Show Details, the following information is shown (for example):

Fortunately, there is no need to recover that password at all: instead, we can remove it (decrypt the file), so the resulting document will not have any restrictions. That's exactly what APDFPR does. However, such decryption possible only if "user" password (see below) is not set or known.

Also, there are "open" (so-called "user") passwords. If one is set, the file is encrypted with strong RC4 algorithm, and cannot be opened at all, if the password or encryption key is not known. APDFPR can recover (try to recover) this password, too, but time-consuming dictionary and brute-force attacks are required. In addition, APDFPR allows to run this attacks to recover "owner" password, because to decrypt the file, either "user" or "owner" password is needed. Even if both passwords are very long and complex, it is still possible to decrypt the file using Key search attack, which tries all possible 40-bit RC4 keys. It takes a few days to complete, but the success is guaranteed. However, if you have pre-computed hash tables (shipped with APDFPR Enterprise), that process takes just a few minutes.

Note that when the file is being saved in Acrobat and the "user" password is set, the "owner" password is being set automatically to the same value (but can be changed manually, of course). That's because PDF file cannot have only "user" password: in any case, it has either "owner" password, or both "owner" and "user" passwords (which could be the same or different). Please take that in mind when selecting Advanced options.

Finally, PDF files can be protected using Digital Rights Management (DRM) technology or 3rd party plugins such as FileOpen. APDFPR does not support such ones, i.e. cannot decrypt them at all.

Please note that Acrobat versions 5.0 and later can create PDF files with improved security level: 56..128-bit RC4 encryption (look at New feature highlights document on Adobe web site). For such files, "owner" protection can be recovered instantly as for Adobe Acrobat 4.0 (and older versions), but brute-force and dictionary attacks are much slower; and "key search" attack is not available at all.

When brute-force or dictionary atack starts, APDFPR provides additional information what kind of security handler is being used; log window will contain a record like:

05.04.2002 13:05:51 - File "C:My Documents\test.pdf" opened.

05.04.2002 13:06:14 - Handler: Acrobat Standard (Standard) 40-bit security v.1.

or

05.04.2002 13:05:51 - Handler: Acrobat Standard (Standard) 128-bit security v.2.

PDF files (even not encrypted ones) may also contain additional objects such as JScript code, form fields and digital signatures; sometimes they are being used for document protection. APDFPR allows to remove them as well.


Encrypted PDF file

Encrypted PDF file

Just enter the name of the PDF document you'd like to get the password for. Use the Open button on program toolbar, [File] | [Open File] menu item or F3 key to pick the file from the list. Alternatively, you can use drag'n'drop – just drag the file (with a mouse) from Windows Explorer, and drop it to the APDFPR window.

If Start attack on file select option is enabled, the program analyses the encryption used. If only "owner" password is set, or any of the passwords ("user" or "owner") is known, and you just need to remove restrictions from the file, you can decrypt the file immediately. If the "user" password is set but now known, you have to select other options and start the attack – consult next chapters for more informations.

If the file is encrypted using any security method other than standard, APDFPR will display an error message (that this kind of encryption is not supported), and write a corresponding record to the log file. If the file is corrupted, or could not be opened for some other reason, an appropriate error message will be shown. For more information, please refer to Error messages chapter.

If the file is not encrypted at all, but contains JScript code, form fields or digital signatures, the program offers to remove any of these elements:

Please note that if the file is password protected or restricted and contain such elements, it should be processed in two steps: you have to decrypt it first, and then load the file APDFPR again to remove digital signatures and/or other stuff.


Type of attack

Type of attack

Brute-force or dictionary attack. Brute-force, Mask, Dictionary and Key search attacks are available.


Brute-force range options

Brute-force range options

Instructs the program what characters have been used in the password. You can choose from all capital letters, all small letters, all digits, all special symbols and the space, or all printable (includes all of the above). The special characters are:

!@#$%^&*()_+-=<>,./?[]{}~:;`'|"\

Alternatively, you can define your own character set (charset). Just mark the "User-defined" checkbox and click on "Custom charset…" (at the right of the option). In the input window, enter all chars of your password range; for example: if you remember that your password was entered in the bottom keyboard row ("zxcv...") - your password range should be "zxcvbnm,./" (or in caps: "ZXCVBNM<>?"). You can also define both of these: "zxcvbnm,./ZXCVBNM<>?". In addition, you can load and save custom charsets, or combine them using the "Add charset from file..." button.


Start from password

Start from password

This option may help, for example, if you know the first character(s) of the password. For example, if you're sure that the small letters have been used (from 'a' to 'z'), the length is 5, and the password definitely starts with 'k', than type 'kaaaa' here. Please also note, that if you press the "Stop" button when APDFPR is working, the program writes the current password to this window ("Start from password"). It can be used later to restart the program from the same point.

Please note that the program verifies the passwords according to the following character order:

· CAPITAL letters: 'A'..'Z'
· the space
· small letters: 'a'..'z')
· digits: '0'..'9'
· special characters: !@#$%^&*()_+-=<>,./?[]{}~:;`'|"\

You can also use End at field to set the password APDFPR should stop at. It might be useful if you attack the same document on a few computers, and so can split the whole password range onto a few parts.


Password mask

Password mask

If you already know some characters in the password, you can specify the mask to decrease the total number of passwords to be verified. At the moment, you can set the mask only for fixed-length passwords, but doing this can still help.

For example, you know that the password contains 8 characters, starts with 'x', and ends with '99'; the other symbols are small or capital letters. So, the mask to be set is "x?????99", and the charset has to be set to All caps and All small. With such options, the total number of the passwords that APDFPRwill try will be the same as if you're working with 5-character passwords which don't contain digits; it is much less than if the length were set to 8 and the All Printable option were selected. In the above example, the '?' chars indicate the unknown symbols.

If you know that the password contains an occurrence of the mask character '?', you can choose a different mask character to avoid having one character, '?', represent both an unknown pattern position and a known character. In this case, you could change the mask symbol from '?' to, for example, '#' or '*', and use a mask pattern of "x######?" (for mask symbol '#') or "x******?" (for mask symbol '*'). Select the mask symbol on Advanced Options page.


Password length

Password length

This is one of the most important options affecting checking time. Usually, you can test all short passwords in just a few minutes; but for longer passwords, you have to have patience and/or some knowledge about the password (including the character set which has been used, or even better – the mask).

The minimum length cannot be set to a value greater than maximum length, of course.

If the minimum and maximum lengths are not the same, the program tries the shorter passwords first. For example, if you set minimum=3 and maximum=7, the program will start from 3-character passwords, then try 4-character ones and so on – up to 7. While APDFPR is running, it shows the current password length, as well as the current password, average speed, elapsed and remaining time, and total and processed number of passwords (Program status). All of this information except average speed and elapsed time, which are global, is related only to the current length.


Dictionary options

Dictionary options

Simply select the desired wordlist file. In addition, you can select an option Smart mutations or Try all possible upper/lower case combinations – it may really help if you're not sure about the register the password has been typed in. For example, let's assume that the next word in the wordlist is "PASSword" (the case, actually, doesn't matter here). With the second option enabled, the program will just try all possible combinations, like:

password

passworD

passwoRd

passwoRD

passwOrd

…

PASSWORd

PASSWORD

However, checking all such combinations takes a lot of time: in the example above, APDFPR will check 2^8 words (i.e. 256) instead of one. With smart mutations, you can eliminate a number of "virtually impossible" combinations, and here are all the words which will be checked:

PASSword | (as is)
passWORD | (reversed)
password | (all lower case)
PASSWORD | (all upper case)
Password | (first uppercase, rest lowercase)
pASSWORD | (first lower case, rest uppercase)
PaSSWoRD | (elite: vowels in lc, others in uc)
pAsswOrd | (noelite)
PaSsWoRd | (alt/1)
pAsSwOrD | (alt/2)

So, it makes only 10 combinations for each word.

The Start line # option allows you to start an attack from a given line (in the wordlist); if you interrupt the attack, the "current" line number will be written there (and saved to the project file, of course).

A small but very effective wordlist is included into APDFPR distribution: english.dic (about 240,000 words); German and Russian wordlists are also included. An extended English dictionary (over 2,600,000 words), as well as the dictionaries for more than 20 other languages are available at our Password Recovery Software page.


Key search

Key search

If the PDF file has both user and owner passwords and they are long and complex, you have nothing to do but try this attack. It tries all possible RC4 encryption keys until it finds the right one, and allows to decrypt the file using that key – the resulting PDF file will have no security at all. That method gives 100% success.

In PDF 1.2/1.3 files (Acrobat 4.x or older), the key length in 40 bits, and so the total number of keys is 2^40, or 1,099,511,627,776. All key space is divided into 65,536 blocks, with 16,777,216 in a block; the whole recovery process takes about 30 days on old and slow PIII-450 computer, and just 3-5 days on modern Intel Core 2 Duo processors.

You have to select the block to start from (Start from block input box) and ending block (End at block box); both values could be from 0 to 65536. During the attack, the program shows the number of the current block, time elapsed, average speed (in keys per second), number of keys already processed and the total number of keys. When the key is found, the program shows it and ask you to decrypt the file; if you already know the key, just put it into the Document key input box and press Decrypt button at the right.

With the Enterprise version of APDFPR, you can seriously speed-up this attack by enabling Use pre-computed hash tables option; press Select user hashes directory button at the right and browse for the folder where the tables are located. This folder should contain the following folders/files (Thunder tablestm):

0\t00_l17000.data

0\t00_l17000.index

1\t01_l17000.data

1\t01_l17000.index

2\t02_l17000.data

2\t02_l17000.index

3\t03_l17000.data

3\t03_l17000.index

4\t04_l17000.data

4\t04_l17000.index

5\t05_l17000.data

5\t05_l17000.index

missing.bin

It is NOT recommended to use the tables directly from DVD (shipped with Enterprise version) because of very slow DVD drive performance. You can copy the DVD contents to the hard drive, or even better, to USB flash drive. USB flash drives have relatively low performance when reading files, but much better (than hard drive) random seek time, while this parameter is the most important for this attack.

With hash tables on hard drive, this attack takes from 10 to 30 minutes to complete; on USB flash drives – from just a few seconds and up to 10-15 minutes (worst case). Tthis option also provides guaranteed recovery.

Finally, please note that Adobe Acrobat 5.0 and later (including the latest version, 8.0) can create PDF files with improved security level: 56..128-bit RC4 encryption (PDF 1.4 specification; look at New feature highlights document on Adobe server), and so that attack is not applicable to them (you will get an error message).


Auto-save

Auto-save

If you'd like APDFPR to save its state periodically, please check the appropriate option, and select the time (in minutes) between saves. If you do that, APDFPR will create and periodically update a restore file named "~apdfpr.axr" (that's the default – you can change it) in the same folder where your document is located (also by default; you can select any other folder to save that file to). This file is similar to one created when using the "Save setup" button. Even if your computer stops responding (or if power fails), you'll be able to restore breaking the password from the last saved state. Instead of using the default settings (the name of the file and the folder it will be saved to), you can also select your own settings. Enabling this option is strongly recommended.


Other options

Other options

Priority: background or high. If you want to start APDFPR as a "background" process, which will work only when the CPU is in an idle state, you may select "Background". If you want to increase performance, select "High", but be aware that this will decrease the performance of *all other* applications running on your computer.

Minimize to tray: if this option is enabled, the program window will disappear from the Windows desktop when you press the "minimize" button in the top-right corner of the window (or you select an appropriate item in the system menu). The small icon will be created in the "tray" area of the task bar (near the system clock). Just double-click on that icon to restore the window.

Log to apdfpr.log: when enabled, the program saves all information displayed in the status window into the log-file (apdfprp.log).

Progress bar update interval: allows to set an interval (in milliseconds) between progress bar and status window updates; the default is 500 (a reasonable value). By selecting the higher value (3000, for example), you can get slightly better recovery speed.

Start attack on file select:when this option is enabled (default), the program analyses the file immediately when you open it, and advises what to do next.

Language: the program has multi-language interface. Just select the appropriate language from the drop-down box. English is the default.


Advanced options

Advanced options

Search for: Any password, User password or Owner password. Select this option to instruct the program which particular password to search for; look at About PDF encryption chapter first. And here are a few recommendations for different cases:

· Your file is not encrypted at all. It doesn't matter what do you select: when you try to run the attack, the program will note you that it is nothing to do.
· Your file has only "owner" password set. You'll get a notification message that the file can be decrypted now, but you can still search for the original password. Select to search for Owner password only; you can also search for Any password, but the speed will be lower.
· Your file has both "user" and "owner" passwords set, and they're the same (typically, you don't know that in advance, but as noted above, the "owner" password is set to the same value as "user" one just by default). The best solution here is to search for User password only, as far as it is the fastest.
· Both "user" and "owner" passwords are set, but they're different. You can search for any of them, or for both at the same time. Please take in mind that searching for User password is the fastest, for Owner password – almost two time slower, and for Any password – the slowest. So that's up to you what to select. There is a chance that one of these passwords is much shorter/simpler than the other one, but again, you don't know that in advance. We'd recommend to set Any password first (for example, with the dictionary attack, and up to 4-5 chars with brute-force attack), and then look for User password, but in extended range (e.g. up to 7 chars).

Mask symbol: used for Mask attack.

Use code optimized for: (Non-MMX processors / Intel PII/PIII/Celeron / AMD Athlon / Intel P4 SSE2): force APDFPR to use the code specially optimized for the given CPUs. The program detects your CPU and tries to select the proper code automatically, but you may want to play with that option if you've got any other CPU. Please note that if you have Intel Core, Core Duo or Core 2 Duo computer, the best speed is achieved with Intel PII/PIII/Celeron setting.


Save and Read setup

Save and Read setup

You can save your current APDFPR setup into a specified file (with extension AFR). When you select the [File] | [Save Project] or [Save Project as...] menu item, the "Save file" dialog appears. Just select a file name (e.g. "mydoc.afr"), or select an existing AFR-file for overwriting. You can read your setup later – simply select [File] | [Open Project].

Alternatively, you can use drag'n'drop – just drag the previously saved afr-file (with a mouse) from Windows Explorer, and drop it onto the APDFPR window. If all the settings are correct, the attack will be started immediately.


Benchmark

Benchmark

If you would like to estimate how long the Brute-force or Mask attack will take, or test APDFPR's speed on a particular document, use the benchmark feature. Just select all the desired options, then press the Benchmark button (next to Stop). The program will work for about 10 seconds, and display some statistics afterwards:

Here you can see the total number of passwords (according to the options you set), average program speed, and estimated time. Please note that real time might be slightly different, because the speed of the program depends on how many other applications are running at the same time.


Recovering process

Recovering process

When all of the options are selected, all you have to do is press the Start button on the toolbar (or F9 key) and wait. During the attack, you'll be able to see the Program status – number of passwords already tried, elapsed and estimated time, etc.

Please note that you can stop the recovering process at any time (Stop button or F10 key), to continue it later (or just save the project). Consult the Start from password and Save and Read setup chapters for further details.


Program status

Program status

When the recovering process is in progress – the current password, average speed, elapsed time, remaining time, total number of password of given length, and number of passwords already processed are displayed:

For key search attack using pre-computech hash tables, it is not possible to estimate the time due to the nature of this method, so only elapsed time is shown (however, this attack usually takes a few minutes):


The password is...

The password is…

When (if) the password is found, the program shows it, as well as the number of passwords which have been tested, and the program speed:

The last line displays the password in HEX form – it might be useful if the password, for example, contains some non-English characters which cannot be displayed correctly on your system (due to missing fonts, etc.).

Pressing the small button at the right of the password (in "normal" or HEX form) copy the password into the Clipboard. Alternatively, you can save the password to a file.

The program also shows the "type" of the password which has been found – "user" or "owner". And from that window, you can decrypt/unprotect the file immediately (using the recovered password, doesn't matter what particular one): press the Decrypt now button for that (you'll be prompted for target file name).

If all possible passwords in the given range have been tried without success (without finding a valid one), the message looks like:

If you stopped recovery by pressing the "Stop" button, the current step of the brute-force attack is saved in the "Start from" field (for key search attack, in "Start block"). Now you can press the "Start" button again. Recovery will be continued from this step.

With the key search attack, the password is not recovered at all, but the program shows the file encryption key – to remove the password (and so the protection) from the given file, simply press Decrypt now button:


What to start from

What to start from

If you have no idea how long the password is and what characters it may contain, just run the dictionary-based attack first. If it fails, try brute-force attack up to 5-7 characters (depending on your computer speed, character set, PDF version etc); to estimate the speed of your computer (on your particular PDF file with the given settings), just use the Benchmark feature.

If brute-force attack also fails, you can try to use other (larger) wordlists and/or play with brute-force attack settings. But if your file uses 40-bit encryption, it is recommended to run the Key search attack – with it, success (decryption) is guaranteed, though it may take a few days. Using the pre-computer hash tables (available with APDFPR Enterprise), though, decryption is being done in just a few minutes.


Command line

Command line

You can run APDFPR with command-line parameters. You can use command-line switches for either batch processing (to remove restrictions from PDF files, when 'user' password is empty or known, or to perform attacks on ''user' or 'owner' passwords (for single file).

Batch processing

For batch processing, the command line looks like the following:

apdfpr.exe -batch src_path [dest_path] [options]

Please note that -batch parameter is mandatory here; without it, the command line will be parsed the different way (for user/owner password recovery, see below).

src_path | Path for source file(s); wildcards are allowed.
dest_path | The location of the folder to put decrypted files to (must already exist). If not specified, source path is used.
-b | Create backup copies of files being decrypted. Ignored if dest_path is not equal to src_path.
-p=xxx | If the program encounters the file which is locked from opening (with "user" password set), it tries to decrypt it using the given password ("xxx").
-q | Quiet mode; ignores the files with "user" password, if one specified in -p option doesn't match, or -p option is not supplied at all.
-t | Maintain the decrypted file date/time same as the original.
-l=log_path | Creates a log file ("log_path"; should be a file name).
-w | Close program when all files are processed, main window is not being shown at all; last error is being returned (or just 0 if no errors occurred).

The parameters enclosed in square brackets are optional; the only mandatory parameter is the source path.

If src_file starts with @ character, it is treated as a name of the file that contains a list of PDF documents to be processed (one per line).

If source or destination path contain spaces, it has to be included in double quotes.

The password may contain any special characters, but they have to be represented in hex form with % prefix. For example, the space is represented as 20 in hex, so if the password is "my pass", the appropriate command line option would be:

-p=my%20pass

The % character itself should be replaced with %25.

-w option could be used if you would like to execute APDFPR from your own software, but want the main program window not to appear on the screen (please note that if -p or -q option is not specified, but file with user password will be encountered, the program will still prompt for the password). When all files specified in the command line will be processed, APDFPR terminates with an appropriate error code.

-l option instructs the program to create a log file (describing all the program is doing, error messages etc). If the file already exists, APDFPR appends to it (writes at the information at the end). If the path to the file contains spaces, it should be shielded with double quotes (see examples below). Please note that if you select src_path as *.*, log file could not be created in the same folder where the source file are, because the name of the log file will also match the given mask, and so APDFPR will try to process it as a PDF file. Just use the mask like *.PDF, and/or create the log file in a different folder.

Examples:

apdfpr.exe doc??.pdf

apdfpr.exe "c:\my documents\manuals\*.pdf" "c:\my documents\decrypted\" –q

apdfpr.exe @list.txt -b -p=LockSmith -w –l="C:\Program Files\apdfpr_log.txt"

User/owner password recovery

Generally, the syntax is:

apdfpr.exe [switches] [pdf-filename]

If you already have the "project" (e.g. saved from past attack), you can use the project name instead of PDF file name:

apdfpr.exe [switches] [afr-filename]

The switches are separated with / or - characters. If the switch is followed by some data (e.g., filename, starting password, etc.) which contains these characters: space, semicolon, slash or dash, it must be enclosed in (single or double) quotes.

Switch | Description | Default
/a:b|m|d | attack type (brute-force, mask, dictionary) | brute-force
/pass:u|o|a | password to find (user, owner, any) | user
/nommx | don't use MMX instructions | disabled
/c:csdepa | character set (caps, small, digits, special, space, all) | caps
/u:chars | user-defined charset |
/sf:pass | start from password |
/m:mask | mask |
/ms:C | mask symbol | ?
/min:N | minimum password length | 1
/max:N | maximum password length | 5
/d[:filename] | dictionary filename |
/sm | smart mutations | disabled
/ac | try all possible upper/lower case combinations | disabled
/sl:N | start from line N | 0
/autosave:N | autosave every N minutes; 0 means disabled | 5
/aname:filename | autosave filename |
/adir:dir | autosave directory |
/idle | run at idle priority | enabled
/high | run at high priority | disabled
/dontstart | don't start the attack, just load/set the parameters |
/minimize | minimize the program after starting the attack |
/smartexit[:filename] | when the attack is completed, write all statistics, including the password (if found) to the given file (default "cmdline_stats.txt"), and close the program | disabled

Examples:

apdfpr.exe /a:b /pass:u /c:cs /min:3 /max:7 /smartexit test.pdf

(brute-force attack; user password; small and capital letters; length from 3 to 7; save and exit when done)

apdfpr.exe /a:b /u:12345abcde test.pdf

(brute-force attack with "12345abcde" character set; length: from 1 to 5)

apdfpr.exe /a:m /pass:a /c:d /m:june???? /sf:june1000 /high test.pdf

(mask attack with ""june????" mask; any password; charset: digits; high priority)

apdfpr.exe /d:english.dic /sm /dontstart test.pdf

(dictionary attack; dictionary: "english.dic"; smart mutations; convert words from ANSI to OEM; don't start)

If the parameter is the afr-file, the program will immediately load all the settings from it (ignoring the other settings supplied in the command line, except /dontstart, /minimize and /smartexit), and run the attack.


Error messages

Error messages

When there is a problem with PDF files you're trying to decrypt, APDFPR shows some kind of error message which looks like:

Can't open file C:\My documents\report.pdf. Error 105

Here is the explanation of the error codes:

 | Error code | Error description
0 | PDFERR_OK | No errors
1 | PDFERR_NO_STARTXREF | No reference to objects table
2 | PDFERR_BAD_STARTXREF | Invalid reference to objects table
3 | PDFERR_NOREF | No objects table
4 | PDFERR_BAD_XREF | Invalid objects table
5 | PDFERR_NO_TRAILER | No document trailer
6 | PDFERR_BAD_TRAILER | Invalid document trailer
7 | PDFERR_NO_OBJ | Cannot find object
8 | PDFERR_BAD_OBJ | Invalid object format
9 | PDFERR_NO_ENDOBJ | Cannot find the end of the object
10 | PDFERR_UNEXPECTED_LEX | Unexpected lexem encountered
11 | PDFERR_NAME_EXPECTED | No name
12 | PDFERR_NO_TRAILER_DICT | No trailer dictionary
13 | PDFERR_NO_STREAM_DICT | No stream dictionary
14 | PDFERR_NO_STREAM_LEN | No stream length
15 | PDFERR_BAD_STREAM_LEN | Invalid format of stream length
16 | PDFERR_NO_ENDSTREAM | Cannot find the end of the stream
20 | PDFERR_NO_LEX | Lexem not found
21 | PDFERR_UNK_LEX | Unknown lexem encountered
30 | PDFERR_BAD_NUMBER | Invalid number format
31 | PDFERR_BAD_STRING | Invalid string format
32 | PDFERR_BAD_HEXSTR | Invalid hexadecimal string format
33 | PDFERR_BAD_NAME | Invalid name format
34 | PDFERR_BAD_KEYWORD | Invalid keyword format
35 | PDFERR_UNK_KEYWORD | Unknown keyword
101 | PDFERR_ALREADY_OPENED | Document already loaded
102 | PDFERR_CANT_OPEN | Cannot open document
103 | PDFERR_CANT_CREATE_MAP | Cannot map file
104 | PDFERR_CANT_MAP_VIEW | Cannot view file map
105 | PDFERR_NO_HEADER | No PDF file header
1001 | PDFERR_NO_ENCRYPT | Document is not encrypted
1002 | PDFERR_NO_PDEF | Document is not loaded
1003 | PDFERR_BAD_REF | Wrong reference to Encryption Object
1004 | PDFERR_BAD_OBJ | Invalid Encryption Object
1005 | PDFERR_WRONG_FILTER | Unsupported Encryption Filter
1006 | PDFERR_WRONG_VER | Unsupported Encryption Version
1007 | PDFERR_WRONG_REV | Unsupported Encryption Revision
1008 | PDFERR_WRONG_OWNER | Invalid OwnerKey format
1009 | PDFERR_WRONG_USER | Invalid UserKey format
1010 | PDFERR_WRONG_PERM | Invalid Permissions format
1011 | PDFERR_NO_ID | Cannot find DocumentID
1012 | PDFERR_BAD_ID | Invalid DocumentID format


Contacting us

Contacting us

For technical support, please contact us through the web form located at:

http://www.crackpassword.com/support/support.php

For all other requests (general questions, sales, legal), please use another form:

http://www.elcomsoft.com/company.html

Please write in English language only.


Where to get the latest version

Where to get the latest version

The latest version of APDFPR is always available from our web page at http://www.elcomsoft.com/apdfpr.html.

Other password recovery products (for ZIP and RAR archives, all versions of Microsoft Office and some other Microsoft software, Lotus SmartSuite, Corel WordPerfect Office, Intuit Quicken and QuickBooks, ICQ and other instant messengers, Eudora and other email clients), Windows 2000/XP/2003/Vista Encrypting File System on NTFS, Windows NT/2000/XP/2003/Vista user passwords, Windows PWL/RAS/dial-up/VPN/shares/asterisked passwords) are available at http://www.elcomsoft.com/prs.html.

If you'd like to receive notifications about new releases of APDFPR, please subscribe to our Password Recovery Software mailing list at http://maillist.elcomsoft.com.


Copyright and license

Copyright and license

NOTICE TO USER:

THIS IS AN AGREEMENT GOVERNING YOUR USE OF ELCOMSOFT SOFTWARE, FURTHER DEFINED HEREIN AS "PRODUCT," AND THE LICENSOR OF THE PRODUCT IS WILLING TO PROVIDE YOU WITH ACCESS TO THE PRODUCT ONLY ON THE CONDITION THAT YOU ACCEPT ALL OF THE TERMS AND CONDITIONS CONTAINED IN THIS AGREEMENT. BELOW, YOU ARE ASKED TO ACCEPT THIS AGREEMENT AND CONTINUE TO INSTALL OR, IF YOU DO NOT WISH TO ACCEPT THIS AGREEMENT, TO DECLINE THIS AGREEMENT, IN WHICH CASE YOU WILL NOT BE ABLE TO INSTALL OR OPERATE THE PRODUCT. BY INSTALLING THIS PRODUCT YOU ACCEPT ALL THE TERMS AND CONDITIONS OF THIS AGREEMENT.

This Electronic End User License Agreement (the "Agreement") is a legal agreement between you (either an individual or an entity), the licensee, and ElcomSoft Co. Ltd. and its affiliates (collectively, the "Licensor"), regarding the Licensor's software, as applicable pursuant to a valid license, you are about to download and/or other related services, including without limitation a) all of the contents of the files, disk(s), CD-ROM(s) or other media with which this Agreement is provided and including all forms of code, such as source code and object code, (the "Software"), b) all successor upgrades, modified versions, modified modules, revisions, patches, enhancements, fixes, modifications, copies, additions or maintenance releases of the Software, if any, licensed to you by the Licensor (collectively, the "Updates"), and c) related user documentation and explanatory materials or files provided in written, "online" or electronic form (the "Documentation" and together with the Software and Updates, the "Product"). You are subject to the terms and conditions of this End User License Agreement whether you access or obtain the Product directly from the Licensor, or through any other source. For purposes hereof, "you" means the individual person installing or using the Product on his or her own behalf; or, if the Product is being downloaded or installed on behalf of an organization, such as an employer, "you" means the organization for which the Product is downloaded or installed, then the person accepting this agreement represents hereby that such organization has authorized such person to accept this agreement on the organization's behalf. For purposes hereof the term "organization," without limitation, includes any partnership, limited liability company, corporation, association, joint stock company, trust, joint venture, labor organization, unincorporated organization, or governmental authority.

By accessing, storing, loading, installing, executing, displaying, copying the Product into the memory of a Client Device, as defined below, or otherwise benefiting from using the functionality of the Product ("Operating"), you agree to be bound by the terms and conditions of this Agreement. If you do not agree to the terms and conditions of this Agreement, the Licensor is unwilling to license the Product to you. In such event, you may not Operate or use the Product in any way.

BEFORE YOU PRESS THE "I AGREE" BUTTON, PLEASE CAREFULLY READ THE TERMS AND CONDITIONS OF THIS AGREEMENT, AS SUCH ACTIONS ARE A SYMBOL OF YOUR SIGNATURE AND BY CLICKING ON THE "I AGREE", YOU ARE CONSENTING TO BE BOUND BY AND ARE BECOMING A PARTY TO THIS AGREEMENT AND AGREE THAT THIS AGREEMENT IS ENFORCEABLE LIKE ANY WRITTEN NEGOTIATED AGREEMENT SIGNED BY YOU. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS AGREEMENT, CLICK THE "CANCEL" BUTTON AND THE PRODUCT WILL NOT BE INSTALLED ON YOUR CLIENT DEVICE, AS SUCH TERM IS DEFINED BELOW. For your reference, you may refer to the copy of this Agreement that can be found in the Help for the Software. You may also receive a copy of this Agreement by contacting Licensor at: info@elcomsoft.com.

1. Proprietary Rights and Non-Disclosure.

1.1. Ownership Rights. You agree that the Product and the authorship, systems, ideas, methods of operation, documentation and other information contained in the Product, are proprietary intellectual properties and or the valuable trade secrets of the Licensor and are protected by civil and criminal law, and by the law of copyright, trade secret, trademark and patent of the Russian federation, other countries and international treaties. You may use trademarks only insofar as to identify printed output produced by the Product in accordance with accepted trademark practice, including identification of trademark owner's name. Such use of any trademark does not give you any rights of ownership in that trademark. The Licensor and its suppliers own and retain all right, title, and interest in and to the Product, including without limitations any error corrections, enhancements, Updates or other modifications to the Software, whether made by Licensor or any third party, and all copyrights, patents, trade secret rights, trademarks, and other intellectual property rights therein. Your possession, installation or use of the Product does not transfer to you any title to the intellectual property in the Product, and you will not acquire any rights to the Product except as expressly set forth in this Agreement. All copies of the Product made hereunder must contain the same proprietary notices that appear on and in the Product. Except as stated herein, this Agreement does not grant you any intellectual property rights in the Product and you acknowledge that the license granted under this Agreement only provides you with a right of limited use under the terms and conditions of this Agreement.

1.2. Source Code and Modifications. You acknowledge that the source code for the Product is proprietary to the Licensor and constitutes trade secrets of the Licensor. You agree not to modify, or create derivative works based upon the Product in whole or in part nor reverse engineer, decompile, disassemble the source code of the Product in any way.

1.3. Registration Code File and Confidential Information. You agree that, unless otherwise specifically provided herein or agreed by the Licensor in writing, the Product, including the specific design and structure of individual programs and the Product, including without limitation the Registration Code File provided to you by the Licensor and/or its authorized resellers or distributors, constitute confidential proprietary information of the Licensor. For purposes hereof, "Registration Code" shall mean a unique key identification file or a combination of unique electronic characters provided to you by the Licensor confirming the purchase of the license from the Licensor, which may carry the information about the license and the number of permitted users, and enabling the full functionality of the Product in accordance with the license granted under this Agreement. You agree not to transfer, copy, disclose, provide or otherwise make available such confidential information in any form to any third party without the prior written consent of the Licensor. You agree to implement reasonable security measures to protect such confidential information, but without limitation to the foregoing, shall use best efforts to maintain the security of the Registration Code provided to you by the Licensor and/or its authorized resellers or distributors.

2. Grant of License.

2.1. License. The Licensor grants you the following rights ("License") and you hereby agree and accept such License:

a). Trial Version. If you have received, downloaded and/or installed a trial version of the Product and are hereby granted an evaluation license for the Software and you may Operate the Product only for evaluation purposes and only during the single applicable evaluation period of thirty (30) days, unless otherwise indicated, from the date of the initial installation. Following this test period of thirty (30) days or less, if you wish to continue to use the Product, you must register. To register you have to pay for the fully functional version. Upon payment we provide the Registration Code to you. Any use of the Product for other purposes or beyond the applicable evaluation period is strictly prohibited, provided however that, subject to the restrictions contained herein, you may copy and distribute a trial version of the Software without any modifications whatsoever to any third party subject to this Agreement and further provided that you have no technical support rights during the trial period. The unregistered (trial) version may be freely distributed, provided that the distribution package is not modified. No person or company may charge a fee for the distribution of the Product without written permission from the copyright holder.

b). Grant of License. Unless otherwise specifically indicated under a valid license (e.g. volume license) granted by the Licensor, once registered you are granted a non-exclusive and non-transferable license to install one (1) copy of the Product and during the term of your license, subject to the payment of the applicable fees and your compliance with the terms hereof, this Agreement permits you or any of your employees to Operate one copy of the specified version of the Product, for internal purposes only, on one computer, workstation, or other electronic device of which the software was designed (each a "Client Device"). If you have purchased multiple licenses for the Product, then the number of multiple licenses shall determine the number of copies of the Product you may have and the number of Client Devices on which you may Operate the Product. If the Product is licensed as a suite or bundle with more than one specified software product, this license applies to all such specified software products, subject to any restrictions or usage terms specified on the applicable price list or product packaging that apply to any of such software products individually. Additionally, Licensor reserves the right to provide for specific terms and conditions in the purchased licenses and such terms may be embedded in Registration Code specifying other terms, conditions and restrictions of Operating of the Product. The Licensor reserves all rights not expressly granted herein.

c). Limitations on Personal License. With the purchase of a personal License, the Licensee may operate the Product as set forth in the Agreement for non-commercial purposes in a non-business or non-commercial environment. Use of the Product in a corporate, governmental or business environment requires the purchase of a business license.

d). Site License. With the acquisition of a Site License, the Licensee may install and use the Product on an unlimited amount of CPUs within one office in one geographic location. Within these limitations, the Licensee may install the Product as a "Network" Product and run the software from any networked computer on your LAN, provided those computers are located exclusively within one office at one geographic location.

e). Volume Use. If the Product is licensed with volume license terms specified in the applicable product invoicing or packaging for the Product, you may make use and install as many additional copies of the Product on the number of Client Devices as the volume license terms specify. You must have a reasonable mechanism in place to ensure that the number of Client Devices on which the Product has been installed does not exceed the number of licenses you have obtained.

f). Multiple Environment Product; Multiple Language Product; Dual Media Product; Multiple Copies; Bundles. If the Product supports multiple platforms or languages, if you receive the Product on multiple media, if you otherwise receive multiple copies of the Product, or if you received the Product bundled with other software, the total number of your Client Devices on which all versions of the Product are installed may not exceed the number of licenses you have obtained from the Licensor. You may not rent, lease, sublicense, lend or transfer any versions or copies of the Product you do not use.

2.2. Back-up Copies. You can make one (1) copy the Product for backup and archival purposes, provided, however, that the original and each copy is kept in your possession or control, and that your installation and use of the Product does not exceed that which is allowed in this Section 2.

2.3. Prohibitions. You may not use, copy, emulate, clone, rent, lease, sell, modify, decompile, disassemble, otherwise reverse engineer, or transfer the licensed program, or any subset of the licensed program, except as provided for in this Agreement. Any such unauthorized use shall result in immediate and automatic termination of this license and may result in criminal and/or civil prosecution. Neither ElcomSoft binary code nor source may be used or reverse engineered to re-create the program algorithm, which is proprietary, without written permission of Licensor. All rights not expressly granted here are reserved by ElcomSoft Co. Ltd.

2.4. Special Provisions Applicable to Password Recovery Programs. The Licensor has a strict return policy due to the nature of our products. If the software is unable to recover (or remove, or change) a password, a copy of the unrecovered file must be sent to the Licensor for evaluation. If the password is recovered, you will be either able to keep the software and receive the password to the file (or unprotected copy of the file), or refund can be made and the end user will need to pay for the in-house recovery in order to receive the password. If the Licensor is unable to recover the password, a full refund will be made. This subsection is applicable only to situations when password recovery or removal is guaranteed without brute-force or dictionary attacks.

2.5. Registration Code. Registration Code provided by the Licensor constitutes the confidential proprietary information of the Licensor. ElcomSoft Registration Code file may not be distributed, except as stated herein, outside of the area of legal control of the person or persons who purchased the original license, without written permission of the copyright holder. You may not give away, sell or otherwise transfer your Registration Code to a third party. Doing so will result in an infringement of copyright. ElcomSoft Co. Ltd retains the right of claims for compensation in respect of damage which occurred by your giving away the registration code. This claim shall also extend to all costs which ElcomSoft Co. Ltd incurs in defending itself.

2.6. Transfers. Under no circumstances shall Licensee sell, rent, lease, license, sublicense, publish, display, distribute, or otherwise transfer to a third party the Software, any copy thereof, in whole or in part, without Licensor's prior written consent, unless otherwise provided for in this Agreement.

2.7. Acceptance of Licensing Terms. Installing and using the Product signifies acceptance of these terms and conditions of the License. If you do not agree with the terms of the license you must remove all Product files from your storage devices, including any back-up or archival copy, and cease to use the Product.

2.8. Material Terms and Conditions. Licensee specifically agrees that each of the terms and conditions of this Section 2 are material and that failure of Licensee to comply with these terms and conditions shall constitute sufficient cause for Licensor to immediately terminate this Agreement and the License granted under this Agreement. The presence of this Section 2.7 shall not be relevant in determining the materiality of any other provision or breach of this Agreement by either party.

2.9. Term and Termination. The term of this Agreement ("Term") shall begin when you download, access or install the Product or pay the applicable license fees (whichever is earlier) and shall continue for the term specified in your order. Without prejudice to any other rights, this Agreement will terminate automatically if you fail to comply with any of the limitations or other requirements described herein. Upon any termination or expiration of this Agreement, you must immediately cease use of the Product and destroy all copies of the Product.

2.10. No Rights Upon Termination. Upon termination of this Agreement you will no longer be authorized to Operate or use the Product in any way.

3. Support and Updates.

3.1. Terms of Support. During the one-year period you are entitled to technical services and support for the Product which is provided to you by Licensor during the regular business hours (GMT+ 03:00), except for locally-observed holidays, and includes the support provided through a special technical support section of the Licensor's site (the "Site") and email support@elcomsoft.com. During such period of one year e-mail support is unlimited and includes technical and support questions and patch fixes.

3.2. Updates. During the one-year period, you may download Updates to the Product when and as the Licensor publishes them on the Site, or through other online services. If the Product is an Update to a previous version of the Product, you must possess a valid license to such previous version in order to use the Update. You may continue to use the previous version of the Product on your Client Device after you receive the Update to assist you in the transition to the Update, provided that: (i) the Update and the previous version are installed on the same Client Device; (ii) the previous version or copies thereof are not transferred to another party or Client Device unless all copies of the Update are also transferred to such party or Client Device; (iii) you acknowledge that any modification that you made to the Product may be lost, altered, distorted or destroyed rendering such modifications, Product or the part thereof inoperable or non-usable; and (iv) you acknowledge that any obligation the Licensor may have to support the previous version of the Product may be ended upon availability of the Update. Except for the rights to free Updates during the one-year period, as further defined herein, nothing in this Agreement shall be construed as to grant you any rights or licenses with regard to the new releases of the Product or to entitle you to any new release. This Agreement does not obligate the Company to provide any Updates. Notwithstanding the foregoing, any Updates that you may receive become part of the Product and the terms of this Agreement apply to them (unless this Agreement is superseded by a succeeding agreement accompanying such Update or modified version of the Product).

4. Restrictions.

4.1. No Transfer of Rights. You may not transfer any rights pursuant to this Agreement nor rent, sublicense, lease, loan or resell the Product. You may not permit third parties to benefit from the use or functionality of the Product via a timesharing, service bureau or other arrangement, except to the extent such use is specified in the application price list, purchase order or product packaging for the Product. Except as otherwise provided in Section 1.2 hereof, you may not, without the Licensor's prior written consent, reverse engineer, decompile, disassemble or otherwise reduce any party of the Product to human readable form nor permit any third party to do so, except to the extent the foregoing restriction is expressly prohibited by applicable law. Notwithstanding the foregoing sentence, decompiling the Software is permitted to the extent the laws of your jurisdiction give you the right to do so to obtain information necessary to render the Software interoperable with other software; provided, however, that you must first request such information from the Licensor and the Licensor may, in its discretion, either provide such information to you (subject to confidentiality terms) or impose reasonable conditions, including a reasonable fee, on such use of the Software to ensure that the Licensor's and its affiliates' proprietary rights in the Software are protected. Except for the modification permitted under Section 1.2, you may not modify, or create derivative works based upon the Product in whole or in part.

4.2. Proprietary Notices and Copies. You may not remove any proprietary notices or labels on the Product. You may not copy the Product except as expressly permitted in Section 2 above.

4.3. Compliance with Law. You agree that in Operating the Product and in using any report or information derived as a result of Operating this Product, you will comply with all applicable international, national, state, regional and local laws and regulations, including, without limitation, privacy, trademark, patent, copyright, export control and obscenity law and you shall not use the Product for unethical or illegal business practices or in violation of any obligation to a third party in using, operating, accessing or running any of the Product and shall not knowingly assist any other person or entity to so violate any obligation to a third party.

4.4. Additional Protection Measures. Solely for the purpose of preventing unlicensed use of the Product, the Software may install on your Client Device technological measures that are designed to prevent unlicensed use, and the Licensor may use this technology to confirm that you have a licensed copy of the Product. The update of these technological measures may occur through the installation of the Updates. The Updates will not install on unlicensed copies of the Product. If you are not using a licensed copy of the Product, you are not allowed to install the Updates. The Licensor will not collect any personally identifiable information from your Client Device during this process.

5. WARRANTIES AND DISCLAIMERS.

5.1. Limited Warranty. The Licensor warrants that for 90 days (the "Warranty Period") from the date the Registration Code is provided to you by Licensor, the media on which Product has been provided will be free from defects in materials and workmanship and that the Software will perform substantially in accordance with the Documentation or generally conform to the Product's specifications published by the Licensor. Non-substantial variations of performance from the Documentation do not establish a warranty right. THIS LIMITED WARRANTY DOES NOT APPLY TO UPDATES AS APPLIED TO ANY MODIFIED PRODUCT, WHETHER OR NOT SUCH MODIFICATION IS PERMISSIBLE HEREUNDER, TRIAL AND EVALUATION VERSIONS, UPDATES, PRE-RELEASE, TRYOUT, PRODUCT SAMPLER, OR NOT FOR RESALE (NFR) COPIES OF PRODUCT. This limited warranty is void and your support right terminate if the defect has resulted from accident, abuse, or misapplication or any modification, whether or not such modification is permitted hereunder. No warranty is made as to the integrity, protection or safekeeping of any modification to the Products made by you upon installation of any of the Updates. To make a warranty claim, you must return the Product to the location where you obtained it along with proof of purchase within such sixty (60) day period of the license fee you paid for the Product. THE LIMITED WARRANTY SET FORTH IN THIS SECTION GIVES YOU SPECIFIC LEGAL RIGHTS. YOU MAY HAVE ADDITIONAL RIGHTS WHICH VARY FROM JURISDICTION TO JURISDICTION.

5.2. Customer Remedies. The Licensor and its suppliers' entire liability and your exclusive remedy for any breach of the foregoing warranty shall be at the Licensor's option: (i) return of the purchase price paid for the license, if any, (ii) replacement of the defective media in which the Product is contained, or (iii) correction of the defects, "bugs" or errors within reasonable period of time. You must return the defective media to the Licensor at your expense with a copy of your receipt. Any replacement media will be warranted for the remainder of the original warranty period.

5.3. NO OTHER WARRANTIES. EXCEPT FOR THE FOREGOING LIMITED WARRANTY, AND FOR ANY WARRANTY, CONDITION, REPRESENTATION OR TERM TO THE EXTENT TO WHICH THE SAME CANNOT OR MAY NOT BE EXCLUDED OR LIMITED BY LAW APPLICABLE TO YOU IN YOUR JURISDICTION, THE PRODUCT IS PROVIDED "AS-IS" WITHOUT ANY WARRANTY WHATSOEVER AND THE LICENSOR MAKES NO PROMISES, REPRESENTATIONS OR WARRANTIES, WHETHER EXPRESSED OR IMPLIED, WHETHER BY STATUTE, COMMON LAW, CUSTOM, USAGE OR OTHERWISE, REGARDING OR RELATING TO THE PRODUCT OR CONTENT THEREIN OR TO ANY OTHER MATERIAL FURNISHED OR PROVIDED TO YOU PURSUANT TO THIS AGREEMENT OR OTHERWISE. YOU ASSUME ALL RISKS AND RESPONSIBILITIES FOR SELECTION OF THE PRODUCT TO ACHIEVE YOUR INTENDED RESULTS, AND FOR THE INSTALLATION OF, USE OF, AND RESULTS OBTAINED FROM THE PRODUCT. THE LICENSOR MAKES NO WARRANTY THAT THE PRODUCT WILL BE ERROR FREE OR FREE FROM INTERRUPTION OR FAILURE, OR THAT IT IS COMPATIBLE WITH ANY PARTICULAR HARDWARE OR SOFTWARE. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, LICENSOR DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY, NON-INFRINGEMENT OF THIRD PARTY RIGHTS, INTEGRATION, SATISFACTORY QUALITY OR FITNESS FOR ANY PARTICULAR PURPOSE WITH RESPECT TO THE PRODUCT AND THE ACCOMPANYING WRITTEN MATERIALS OR THE USE THEREOF. SOME JURISDICTIONS DO NOT ALLOW LIMITATIONS ON IMPLIED WARRANTIES, SO THE ABOVE LIMITATION MAY NOT APPLY TO YOU. YOU HEREBY ACKNOWLEDGE THAT THE PRODUCT MAY NOT BE OR BECOME AVAILABLE DUE TO ANY NUMBER OF FACTORS INCLUDING WITHOUT LIMITATION PERIODIC SYSTEM MAINTENANCE, SCHEDULED OR UNSCHEDULED, ACTS OF GOD, TECHNICAL FAILURE OF THE SOFTWARE, TELECOMMUNICATIONS INFRASTRUCTURE, OR DELAY OR DISRUPTION ATTRIBUTABLE TO VIRUSES, DENIAL OF SERVICE ATTACKS, INCREASED OR FLUCTUATING DEMAND, AND ACTIONS AND OMISSIONS OF THIRD PARTIES. THEREFORE, THE LICENSOR EXPRESSLY DISCLAIMS ANY EXPRESS OR IMPLIED WARRANTY REGARDING SYSTEM AND/OR SOFTWARE AVAILABILITY, ACCESSIBILITY, OR PERFORMANCE. THE LICENSOR DISCLAIMS ANY AND ALL LIABILITY FOR THE LOSS OF DATA DURING ANY COMMUNICATIONS AND ANY LIABILITY ARISING FROM OR RELATED TO ANY FAILURE BY THE LICENSOR TO TRANSMIT ACCURATE OR COMPLETE INFORMATION TO YOU.

5.4. LIMITED LIABILITY; NO LIABILITY FOR CONSEQUENTIAL DAMAGES. YOU ASSUME THE ENTIRE COST OF ANY DAMAGE RESULTING FROM YOUR USE OF THE PRODUCT AND THE INFORMATION CONTAINED IN OR COMPILED BY THE PRODUCT, AND THE INTERACTION (OR FAILURE TO INTERACT PROPERLY) WITH ANY OTHER HARDWARE OR SOFTWARE WHETHER PROVIDED BY THE LICENSOR OR A THIRD PARTY. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT WILL THE LICENSOR OR ITS SUPPLIERS OR LICENSORS BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, LOSS OF DATA, LOSS OF GOODWILL, WORK STOPPAGE, HARDWARE OR SOFTWARE DISRUPTION IMPAIRMENT OR FAILURE, REPAIR COSTS, TIME VALUE OR OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OR INABILITY TO USE THE PRODUCT, OR THE INCOMPATIBILITY OF THE PRODUCT WITH ANY HARDWARE SOFTWARE OR USAGE, EVEN IF SUCH PARTIES HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT WILL LICENSOR'S TOTAL LIABILITY TO YOU FOR ALL DAMAGES IN ANY ONE OR MORE CAUSE OF ACTION, WHETHER IN CONTRACT, TORT OR OTHERWISE EXCEED THE AMOUNT PAID BY YOU FOR THE PRODUCT. THIS LIMITATION OF LIABILITY SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY TO THE EXTENT THAT APPLICABLE LAW PROHIBITS SUCH LIMITATION. FURTHERMORE, BECAUSE SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.

6. Indemnification

6.1. Indemnification for Violations. Your Operating of the Product, your accessing your account with Licensor and your entering into this Agreement constitutes your consent and agreement to defend, indemnify and hold harmless Licensor and its affiliated companies, employees, contractors, officers and directors from any claim or demand, including reasonable attorney's fees arising out of your use of the Product in violation of this Agreement.

SPECIAL PROVISION APPLICABLE TO U.S. PERSONS AND ENTITIES.

7. U.S. Government-Restricted Rights.

7.1. Notice to U.S. Government End Users. The Product and accompanying Documentation are deemed to be "Commercial Items," as that term is defined at 48 C.F.R. §2.101, consisting of "Commercial Computer Software" and "Commercial Computer Software Documentation," respectively, as such terms are used in 48 C.F.R. §12.212 or 48 C.F.R. §227.7202, as applicable. Consistent with 48 C.F.R. §12.212 or 48 C.F.R. §§227.7202-1 through 227.7202-4, as applicable, the Commercial Computer Software and Commercial Computer Software Documentation are being licensed to U.S. Government end users (a) only as Commercial Items and (b) with only those rights, including any use, modification, reproduction, release, performance, display or disclosure of the Product and accompanying Documentation, as are granted to all other end users pursuant to the terms and conditions herein. Unpublished-rights reserved under the copyright laws of the United States.

7.2. Export Restrictions. You acknowledge and agree that the Product may be subject to restrictions and controls imposed by the Export Administration Act and the Export Administration Regulations of the United States (the "Acts"). You agree and certify that neither the Product nor any direct product thereof is being or will be used for any purpose prohibited by the Acts. You may not Operate, download, export, or re-export the Product (a) into, or to a national or resident of, any country to which the United States has embargoed goods, or (b) to anyone on the United States Treasury Department's list of Specially Designated Nationals or the U.S. Commerce Department's Table of Deny Orders. By downloading or using the Product, you are representing and warranting that you are not located in, under the control of, or a national or resident of any such country or on any such list. You acknowledge that it is your sole responsibility to comply with any and all government export and other applicable laws and that the Licensor has no further responsibility for such after the initial license to you. You warrant and represent that neither the U.S. Commerce Department, Bureau of Export Administration nor any other U.S. federal agency has suspended, revoked or denied your export privileges.

8. Your Information and the Licensor's Privacy Policy

8.1. Privacy Policy. You acknowledge receipt of and agree to the Licensor's privacy statement which is made available to you in connection with installation and is set forth in full at http://www.elcomsoft.com/privacy.html. You hereby expressly consent to the Licensor's processing of your personal data (which may be collected by the Licensor or its distributors) according to the Licensor's current privacy policy as of the date of the effectiveness hereof which is incorporated into this Agreement by reference. By entering into this Agreement, you agree that the Licensor may collect and retain information about you, including your name and email address. The Licensor employs other companies and individuals to perform certain functions on its behalf. Examples include fulfilling orders, delivering packages, sending postal mail and e-mail, removing repetitive information from customer lists, analyzing data, providing marketing assistance, processing credit card payments, and providing customer service. They have access only to personal information needed to perform their functions, but may not use it for other purposes. The Licensor publishes a privacy policy on its web site and may amend such policy from time to time in its sole discretion. You should refer to the Licensor's privacy policy prior to agreeing to this Agreement for a more detailed explanation of how your information will be stored and used by the Licensor. If "you" are an organization, you will ensure that each member of your organization (including employees and contractors) about whom personal data may be provided to the Licensor has given his or her express consent to the Licensor's processing of such personal data. Personal data will be processed by the Licensor or its distributors in the country where it was collected.

8.2. Public Announcements. The Licensor may identify you to the public as a customer of the Licensor and describe in a customer case study the services and solutions delivered by the Licensor to you. The Licensor may also issue one or more press releases, containing an announcement of the execution and delivery of this Agreement and/or the implementation of the Product by you. Nothing contained in this Section shall be construed as an obligation by you to disclose any of your proprietary or confidential information to any third party. In addition, you may opt-out from this Section by writing an opt-out request to the Licensor at info@elcomsoft.com.

9. Miscellaneous.

9.1. Governing Law; Jurisdiction and Venue. This Agreement shall be governed by and construed and enforced in accordance with the laws of the Russian Federation without reference to conflicts of law rules and principles. To the extent permitted by law, the provisions of this Agreement shall supersede any provisions of the Uniform Commercial Code as adopted or made applicable to the Products in any competent jurisdiction. This Agreement shall not be governed by the United Nations Convention on Contracts for the International Sale of Goods, the application of which is expressly disclaimed and excluded. The courts within the Russian Federation shall have exclusive jurisdiction to adjudicate any dispute arising out of this Agreement. You agree that this Agreement is to be performed in the Russian Federation and that any action, dispute, controversy, or claim that may be instituted based on this Agreement, or arising out of or related to this Agreement or any alleged breach thereof, shall be prosecuted exclusively in the courts in of the Russian Federation and you, to the extent permitted by applicable law, hereby waive the right to change venue to any other state, county, district or jurisdiction; provided, however, that the Licensor as claimant shall be entitled to initiate proceedings in any court of competent jurisdiction.

9.2. Period for Bringing Actions. No action, regardless of form, arising out of the transactions under this Agreement, may be brought by either party hereto more than one (1) year after the cause of action has occurred, or was discovered to have occurred, except that an action for infringement of intellectual property rights may be brought within the maximum applicable statutory period.

9.3. Entire Agreement; Severability; No Waiver. This Agreement is the entire agreement between you and Licensor and supersedes any other prior agreements, proposals, communications or advertising, oral or written, with respect to the Product or to subject matter of this Agreement. You acknowledge that you have read this Agreement, understand it and agree to be bound by its terms. If any provision of this Agreement is found by a court of competent jurisdiction to be invalid, void, or unenforceable for any reason, in whole or in part, such provision will be more narrowly construed so that it becomes legal and enforceable, and the entire Agreement will not fail on account thereof and the balance of the Agreement will continue in full force and effect to the maximum extent permitted by law or equity while preserving, to the fullest extent possible, its original intent. No waiver of any provision or condition herein shall be valid unless in writing and signed by you and an authorized representative of Licensor provided that no waiver of any breach of any provisions of this Agreement will constitute a waiver of any prior, concurrent or subsequent breach. Licensor's failure to insist upon or enforce strict performance of any provision of this Agreement or any right shall not be construed as a waiver of any such provision or right.

9.4. Contact Information. Should you have any questions concerning this Agreement contact us at legal@elcomsoft.com.

© 1998-2007 ElcomSoft Co. Ltd. All rights reserved. The Product, including the Software and any accompanying Documentation, are copyrighted and protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties.


Registration

Registration

Fully registered version of APDFPR costs $49 (Standard edition), $99 (Professional edition) or $999 (Enterprise edition); see help file for differences between editions. Please note that for Standard edition, the Licensee may operate the Product as set in the License Agreement for non-commercial purposes in a non-business or non-commercial environment only (personal license). Use of the Product in a corporate, government or business environment requires the purchase of the Professional or Enterprise edition (business license).

You can place an order online using the following order form:

http://www.elcomsoft.com/purchase/buy.php?product=apdfpr_n

Please note that there are some small processing charges for orders placed by fax, by check/money order or with back/wire transfer. European customers are also charged VAT. The prices listed above are valid for orders placed in US dollars only.

More information about all payment options is available at ordering page on ElcomSoft web site:

http://www.elcomsoft.com/order.html?product=apdfpr_n

On payment approval (for online orders, usually within a few minutes), we'll send you the registration key which will remove all limitations of the unregistered version.


Limitations of unregistered version

Limitations of unregistered version

 Previous Top

Unregistered (trial) version decrypts only first 10% pages (but at least one page) of the documents, and replaces all other pages with blank (empty) ones; with a brute-force attack, passwords longer than 4 characters cannot be recovered; some dictionary-attack options are disabled; "Use pre-computed hash tables" option is not available.