Introduction

Top Next

Advanced Archive Password Recovery (or ARCHPR) is a program to recover lost or forgotten passwords to archives (compressed files) of the following types:

· ZIP/PKZip/WinZip
· ARJ/WinARJ
· ACE/WinACE (1.x)
· RAR/WinRAR

The key features of ARCHPR are:

· The program has a convenient user interface
· The program is very fast: for ZIP, brute-force attack speed is up to fifteen million passwords per second on modern CPUs like Pentium 4 (Prescott)
· Guaranteed decryption (usually, within the hour) of many WinZip archives (created in versions 8.0 and below, with 5+ encrypted files) is available; it works regardless the password complexity and length
· The program can work with archives containing only one encrypted file
· Archives created by various software packages are supported
· Self-extracting archives are supported
· The program is customizable: you can set the password length (or length range), the character set to be used to generate the passwords, and a couple of other options
· You can select the custom character set for brute-force attack (non-English characters are supported)
· Dictionary-based attack (with word mutations) is available
· The "brute-force with mask" attack is available
· Very fast known-plaintext attack is available (ZIP and ARJ only)
· You can interrupt the program at any time, and resume from the same point later
· The program can work in the background, using the CPU only when it is in idle state

Please note, however, that for the password is not stored anywhere in the archive (ZIP/RAR/ARJ/ACE file), and so it cannot be just extracted or decrypted. Instead, ARCHPR can recover it by trying different passwords: all possible combinations in a given range, or from a wordlist, etc. ARCHPR can test as many as fifteen million passwords per second (for ZIP archives), and so the likelihood of finding a valid one is very high. There is still no guarantee that the password will be recovered, but here the human factor plays its role: most people use short and/or easy to remember passwords. We estimate the success rate as 90-95%. See Passwords and encryption and Known bugs and liminations for more information.

The program that is licensed to you is absolutely legal and you can use it provided that you are the legal owner of all files or data you are going to recover through the use of our software or have permission from the legitimate owner to perform these acts. Any illegal use of our software will be solely your responsibility. Accordingly, you affirm that you have the legal right to access all data, information and files that have been hidden.

You further attest that the recovered data, passwords and/or files will not be used for any illegal purpose. Be aware password recovery and the subsequencial data decryption of unauthorized or otherwise illegally obtained files may constitute theft or another wrongful action and may result in your civil and (or) criminal prosecution.


Requirements

Previous Top Next

· Windows 98, Windows ME, Windows NT 4.0, Windows 2000, Windows XP or Windows Server 2003
· about 4 megabytes of free space on hard disk
· about 34 megabytes of free memory for ZIP known plaintext attack
· about 260 megabytes of free memory to process RAR 2.9 and 3.x archives


Passwords and encryption

The password encryption in ZIP/ARJ/RAR/ACE is very strong, and if the password is long enough and well selected, there is no way to recover it in a reasonable time. In most cases, only brute-force and dictionary attacks are available.

Dictionary attack is the most effective one – with it, the program tries every word in a dictionary (wordlist) until the password is found. This method is popular because it is well known that many people use common words as passwords. Dictionaries with hundreds of thousands of words, as well as specialist, technical and foreign language dictionaries are available, as are lists of thousands of words that are often used as passwords such as "qwerty", "abcdef" etc.

If you have completed a dictionary attack, but some passwords still have not been recovered, you have to follow up with a brute-force attack. In this attack, the program tries to guess the password by trying every single combination of characters until the password is found. For example, the program might follow a sequence like this:

"aaaaaaaa"
"aaaaaaab"
"aaaaaaac" ...

until the password is found. Obviously, this method will take time: for an eight-character alpha password there are 200 Billion combinations to be checked. But with modern computers this sort of attack doesn't take as long as you might think. The brute force attack is the slowest method of password attack, but can often be successful on short and simple passwords.

There are also some special notes about every file format.

ZIP

There are a few different encryption algorithms for ZIP archives. ARCHPR supports two of them: the traditional PKWARE encryption (used in most ZIP-compatible compression utilities; see Application Notes - .ZIP File Format Specification) and Advanced Encryption Technology (used in WinZip 9.0 and 10.0 beta).

For archives that use traditional encryption, ARCHPR recovery speed is about 15 million passwords per second (on Pentioum 4 CPU), and so the "practical limit" for brute-force attack is about 10 characters. In addition, the "known-plaintext" attack is available: in most cases, it doesn't recover the password, but allows to get the encryption keys, and the archive can be decrypted so you will not need the password to get in. This attack usually takes 10-15 minutes (and the time does not depend on the password length). Unfortunately, it is not always applicable.

Also, due to the weakness of WinZip (versions up to 8.0) implementation of ZIP encryption algorythm, guaranteed recovery is available for many WinZip archives (with 5 or more encrypted files). As for known-plaintext attack, ARCHPR finds the decryption keys, so the password don't even needed. This attack is also very fast and takes maximum a few hours (in most cases – 15-20 minutes).

For ZIP files with advanced encryption technology, known-plaintext attack is not available, and brute-force attack works at just a few hundred passwords per second.

ARJ

ARJ encryption is simpler than ZIP one. In addition to brute-force and dictionary attacks, the known-plaintext attack is also supported; in contrary to ZIP, it allows to get the password instead of just decrypting the file). The practical limit for brute-force attack is 7-8 characters.

RAR

For RAR 2.0..2.8 archives, ARCHPR can try a few thousand passwords per second. RAR 2.9/3.x encryption is even better (see UnRAR sources for details)– recovery speed is extremely low, just a few passwords per second. So for such archives, brute-force attack is almost useless, and only dictionary attack is more or less effective.

ACE

For ACE 1.x archives, the the speed is just a few hundred passwords per second. ACE 2.x archives are not supported at all. The reason is: ACE 2.x decompression algorithm is proprietary (i.e. source code is not available); we have tried to implement password testing through unacev2.dll shipped with WinACE, but unfortunately, it contains many bugs, causing unexpected crashes – even WinACE itself crashes on some valid archives when particular password is supplied. Please don't ask us to add ACE 2.x support – we will not do that until decompression algorithm will be publically available, or at least the above mentioned DLL will be free of bugs.


Password-encrypted file

Just enter the name of the ZIP/ARJ/RAR/ACE archive you'd like to get the password for. Use the "Browse" button (or F3 key) to select it, or press the "recent files" button (with a small down arrow) to pick from the list (if you've used ARCHPR on your target archive before). Alternatively, you can use drag'n'drop – just drag the file (with a mouse) from Windows Explorer, and drop it to the ARCHPR window. If all the settings are correct, the attack will be started immediately.


Type of attack

The way how ARCHPR will try to find the password for a given archive; you can select from Brute-force, Mask, Dictionary and Plaintext attacks (last one – for ZIP and ARJ archives only). Besides, Guaranteed WinZip attack is available (for WinZip 8.0 and below archives with 5 or more encrypted files), and there is also the special Password from keys attack, that could be used in addition to Brute-force and Plaintext attacks on ZIP archives (read the next chapters for details).


Brute-force range options

Instructs the program what characters have been used in the password. You can choose from all capital letters, all small letters, all digits, all special symbols and the space, or all printable (includes all of the above). The special characters are:

!@#$%^&*()_+-=<>,./?[]{}~:;`'|"\

Alternatively, you can define your own character set (charset). Just mark the "User-defined" checkbox and click on "Custom charset…" (at the right of the option). In the input window, enter all chars of your password range; for example: if you remember that your password was entered in the bottom keyboard row ("zxcv...") - your password range should be "zxcvbnm,./" (or in caps: "ZXCVBNM<>?"). You can also define both of these: "zxcvbnm,./ZXCVBNM<>?". In addition, you can load and save custom charsets, or combine them using the "Add charset from file..." button.

Just a note about "Convert to OEM encoding" option in the "User Defined Charset" option. Be sure to select it if the password contains any non-English characters, and the archive has been created by a DOS-based compression utility (like PKZIP, for example). Otherwise, the password will not be found.


Start from password

This option may help, for example, if you know the first character(s) of the password. For example, if you're sure that the small letters have been used (from 'a' to 'z'), the length is 5, and the password definitely starts with 'k', than type 'kaaaa' here. Please also note, that if you press the "Stop" button when ARCHPR is working, the program writes the current password to this window ("Start from password"). It can be used later to restart the program from the same point.

Please note that the program verifies the passwords according to the following character order:

· CAPITAL letters: 'A'..'Z'
· the space
· small letters: 'a'..'z')
· digits: '0'..'9'
· special characters: !@#$%^&*()_+-=<>,./?[]{}~:;`'|"\

You can also use End at field to set the password ARCHPR should stop at. It might be useful if you attack the same archive on a few computers, and so can split the whole password range onto a few parts.


Password mask

If you already know some characters in the password, you can specify the mask to decrease the total number of passwords to be verified. At the moment, you can set the mask only for fixed-length passwords, but doing this can still help.

For example, you know that the password contains 8 characters, starts with 'x', and ends with '99'; the other symbols are small or capital letters. So, the mask to be set is "x?????99", and the charset has to be set to All caps and All small. With such options, the total number of the passwords that ARCHPR will try will be the same as if you're working with 5-character passwords which don't contain digits; it is much less than if the length were set to 8 and the All Printable option were selected. In the above example, the '?' chars indicate the unknown symbols.

If you know that the password contains an occurrence of the mask character '?', you can choose a different mask character to avoid having one character, '?', represent both an unknown pattern position and a known character. In this case, you could change the mask symbol from '?' to, for example, '#' or '*', and use a mask pattern of "x######?" (for mask symbol '#') or "x******?" (for mask symbol '*'). Select the mask symbol on Advanced Options page.


Password length

This is one of the most important options affecting checking time. Usually, you can check all 4-character (and shorter) passwords in a few minutes; but for longer passwords, you have to have patience and/or some knowledge about the password (including the character set which has been used, or even better – the mask).

The minimum length cannot be set to a value greater than maximum length, of course.

If the minimum and maximum lengths are not the same, the program tries the shorter passwords first. For example, if you set minimum=3 and maximum=7, the program will start from 3-character passwords, then try 4-character ones and so on – up to 7. While ARCHPR is running, it shows the current password length, as well as the current password, average speed, elapsed and remaining time, and total and processed number of passwords (Program status). All of this information except average speed and elapsed time, which are global, is related only to the current length.


Dictionary options

Simply select the desired dictionary file. In addition, you can select an option Smart mutations or Try all possible upper/lower case combinations – it may really help if you're not sure about the register the password has been typed in. For example, let's assume that the next word in dictionary is "PASSword" (the case, actually, doesn't matter here). With the second option enabled, the program will just try all possible combinations, like:

password
passworD
passwoRd
passwoRD
passwOrd
…
PASSWORd
PASSWORD

However, checking all such combinations takes a lot of time: in the example above, ARCHPR will check 2^8 words (i.e. 256) instead of one. With smart mutations, you can eliminate a number of "virtually impossible" combinations, and here are all the words which will be checked:

PASSword | (as is)
passWORD | (reversed)
password | (all lower case)
PASSWORD | (all upper case)
Password | (first uppercase, rest lowercase)
pASSWORD | (first lower case, rest uppercase)
PaSSWoRD | (elite: vowels in lc, others in uc)
pAsswOrd | (noelite)
PaSsWoRd | (alt/1)
pAsSwOrD | (alt/2)
So, it makes only 10 combinations for each word.

The Start line # option allows you to start an attack from a given line (in the dictionary); if you interrupt the attack, the "current" line number will be written there (and saved to the project file, of course).

The Convert to OEM encoding option can be used if: the dictionary is in ANSI coding, but the ZIP archive has been created with a DOS archiver (like PKZIP), and so the actual password is in OEM coding. Changing that option doesn't make any difference if all the words in the dictionary contain latin letters only.

The small, but really effective dictionary is included into ARCHPR distribution: english.dic (about 240,000 words). Other ones are available from Password Recovery Software page on our site.


Known plaintext attack (ZIP)

Introduction

ZIP files have a strong encryption algorithm. First, the password isn't stored anywhere in a password-protected archive. The ZIP archiver converts the password you've entered into three 32-bit encryption keys, and then uses them to encrypt the whole archive. Because of this, the total complexity of the ZIP attack is 2^96, i.e., we would have to try all possible key combinations. This is really a lot – even using all the computers in the world, it is not possible to check all of them, unfortunately… However, this algorithm isn't as strong as the DES, RSA, IDEA, and similar algorithms. One of the ways of breaking ZIP protection is using known-plaintext attack. If you're interested in the details of attack, find the paper "A Known Plaintext Attack on the PKZIP Stream Cipher" by Eli Biham and Paul Kocher. ARCHPR's implementation of plaintext attack is very close to that paper, with some minor modifications.

Having an encrypted file created by the ZIP archiver, and the same file in unencrypted form, we can make some calculations and retrieve the encryption keys used to protect that file. Usually, a ZIP archive contains several files and all of them have the same password (and therefore the same encryption keys). This means that if we get the encryption keys for one of these files, we'll be able to unprotect all the others! Furthermore, it won't take as much time as trying all possible combinations of encryption keys. To perform plaintext attack, all you need is one file from the archive, compressed by the same archiver and by the same method as an encrypted one.

Selecting the correct archiver is a bit complex, however; unfortunately, the ZIP file format doesn't contain any data which might help to identify the archiver. In fact, you may need to try several archivers (of course, only if you don't remember which particular utility you've used). A good check that the plain file is correct is the size difference between it and the encrypted file: the encrypted file must be exactly 12 bytes larger. Also, the files must have the same CRC and uncompressed sizes. ARCHPR automatically checks these conditions for selected files, so all you need to do is to create a "plain" ZIP archive.

Description

To perform plaintext attack you need to:

· Find an unencrypted file which also exists in the password-protected archive.
· Compress it with the same method and the same ZIP archiver as used in the encrypted archive. Note that this is required because ARCHPR checks file sizes and file checksums. (You can, however, use plaintext attack on a partial file; see the description below).
· Run ARCHPR, select encrypted archive, then select "plaintext" attack and browse for archive with unencrypted file.

After that, ARCHPR will check the files, and if there are matching ones, the attack is started.

There are two stages in "plaintext" attack, plus two password search additions (note that timings are estimated for Intel Celeron working at 366 MHz):

1. Keys reduction cycle. At this stage, ARCHPR needs about 34 megabytes of (virtual) memory. This cycle takes from one to three minutes (depending on the size of the plaintext). If you haven't got enough physical memory, it may take a bit more time. After this stage, ARCHPR will free most of that memory and work with only 2-4 megabytes. Please also note that the time required to complete this stage cannot be estimated, and so for the first few minutes the progress indicator will read 0%, after that it'll start to increase rapidly.

2. Searching matching keys. This is the main stage of "plaintext" attack. Now you can see how much time you need (worst case) to recover the archive. Depending on the size of the plaintext, this stage can take from 5 minutes to several hours. At that stage, you can stop the attack at any time without risk; the program will write a resume value into the Start from field (and save it into the project file, of course). Note that the first stage (keys reduction cycle) will be performed again upon resuming (but it only takes a few minutes).

When ARCHPR finds valid keys, it tries to find the password correlated with them. Due to some reasons, the password search can be easily done for 9 characters long (and shorter) passwords with any symbols, and passwords with up to 10 printable symbols – during a couple of minutes.

If ARCHPR can retrieve the password, it'll display the standard statistics message with it, if it can't – with encryption keys only. Please note that in most cases you don't need the original password because having encryption keys you can easily decrypt the ZIP archive so it will not require the password to unzip it.

Attack on partial file

Sometimes ZIP archives (where the one is password-protected and the second isn't) may differ in size. For example, WinZip can create such ones if the source file almost cannot be compressed. Encrypted files has 12 bytes at least, so when WinZip starts the compression routine, it may select another method to keep compression ratio good. But note that it is very unusual case. However, you can perform plaintext attack on such files anyway – just keep in password-protected archive only one file (that will be attacked); of course, backup your original files first. And keep only one file in "plaintext" archive as well. Run the attack, and ARCHPR will ask for confirmation for "partial" attack. Click 'Yes' and select the number of bytes to use as plaintext. Because we don't know how many bytes can be the same, it's good idea to start from 1-3Kb (it most cases it's enough) and decrease this number if ARCHPR won't be able to find encryption keys.

Current version notes

1. "Plaintext" file must be at least 12 bytes long.
2. "Plaintext" attack can be saved on the second stage only; after restarting, the first stage will be performed (again) anyway.
3. No time estimation for the first stage. But you can expect that it'll take a few minutes.
4. In any case, you need about 34 megabytes of RAM. If you don't have so much RAM, you need enough space on the for swap file on the disk (and patience – using virtual RAM will greatly decrease the performance). So, we recommend to use the "known plaintext" attack with at least 40-48 megabytes of RAM.

Test results

Here are the results (benchmarks) of "known plaintext" attack for the different files (on Intel Celeron 366MHz with 64MB RAM).

File size (bytes) | Stage #1 time | Stage #2 time
16 | 20s | 2d 12h
32 | 33s | 8h 30m
64 | 38s | 3h 30m
128 | 45s | 1h 45m
256 | 52s | 42m
512 | 52s | 20m
1024 | 52s | 8m
2048 | 1m 5s | 5m 30s
4096 | 1m 5s | 4m
8192 | 1m 14s | 4m
16384 | 1m 30s | 4m
32768 | 2m 10s | 4m


Known plaintext attack (ARJ)

ARJ files have relatively strong encryption algorithm. The password isn't stored anywhere in password protected archive. However, this algorithm isn't as strong as DES, RSA, IDEA and similar ones, and one of the ways of breaking ARJ protection is using known-plaintext attack.

Having encrypted file created by ARJ archiver, and the same file in unencrypted form, we can make some calculations and retrieve password. Usually, ARJ archive contains several files, and all of them has the same password. To perform plaintext attack, all you need is one file from archive, compressed with the same method as an encrypted one.

To perform plaintext attack you need to:

· Find unencrypted file which also exists in password-protected archive.
· Compress it with the same method as in encrypted archive. Note that this is strongly needed because ARCHPR checks file sizes and checksums of files.
· Run ARCHPR, select encrypted archive, then select "plaintext" attack and browse for archive with unencrypted file.

After that, ARCHPR will check the files, and if there are matching ones, the password will be displayed immediately.


Guaranteed WinZip attack

That's the most powerful attack available in ARCHPR. It works similarly to known-plaintext attack described above, but doesn't require you to have any files from the archive. However, the archive itself should have at least 5 encrypted (password-protected) files, and have to be created with WinZip or any other ZIP archiver based on Info-ZIP sources.

Please note that only WinZip versions 8.0 and below are vulnerable for this particular attack (because of using weak random number generator). In version 8.1, the hole has been fixed, and so for archives created with this version (as well as newer ones) you will not be able to use this attack at all.

Just select the archive file name, Guaranteed WinZip attack from Type of attack drop-down box, and press Run; no other options needed. If the archive has been created with some other archiver, or contains less than 5 files, ARCHPR will show an error message.

The attack consists of three stages: first two are for searching the encrypted keys (needed to decrypt the archive), and the last one searches for the actual password (up to 10 characters).

Usually, first stage takes just a few minutes (the program may show Estimated remaining time as a few hours, but actually, that's the theoretical maximum, and in most cases it is MUCH faster). Second one is from 10 to 30 minutes, and the last stage (where the password itself is being recovered) is 2-3 minutes only. For the second stage, the time estimation is also not very accurate (to make it better, it would be needed to perform a lot of additional operations, while ARCHPR does its best to recover keys/password as fast as possible).

That attacks works in most cases (as already noted, for WinZip files only), and even if the password is very long (so it could not be found during the 3rd stage), ARCHPR will be able to decrypt the whole archive, so you will not need to supply a password to extract files from it. However, in some very rare cases (the probability is 1/256, i.e. 0,4% only), WinZip may create ZIP archives this attack fails on. ARCHPR identifies such archives and prints a warning message into the log window; actually, this message does not mean that the ARCHPR will definitely fail, but if first stage will be completed but no encryption keys found – sorry, you're out of luck. Just try the other attacks.


Password from keys

As noted above, Known-plaintext and Guaranteed WinZip attacks try to recover the encryption keys first. Once they're there, the archive could be decrypted so no password is needed at all. However, they also search for passwords (just in case) that are up to 10 characters long.

If you already have the encryption keys and would like to recover the [longer] password itself, select this attack from drop-down Type of attack box. The keys should be entered on Plain-text tab (if Plain-text attack just finished, they are already there), and other options such as character set (Range tab) and password length (Length tab) – as for Brute-force attack. The recommended minimum password length is 11 (as far as if you have got the keys with ARCHPR and not from any other source, shorter passwords have been already tried), the "practial" maximum value is 14-15, depending on the character set. End at value is not supported for this attack at all; as for Start from – you have to be careful. Actually, there is no need to recover first 6 characters of the password – they're calculated based on the "tail" of the password (7th char and up). So starting password should already start with 6 asterisks, and "meaningful" positions start with 7. The program starts to search for correct combinations from the end; for example, for 11-character passwords containing small letters, the order is:

******aaaaa
******baaaa
...
******zaaaa
******zbaaa
******zzaaa
...
******zzzzz

Please take that in mind when selecting the starting password manually.


Auto-save

If you'd like ARCHPR to save its state periodically, please check the appropriate option, and select the time (in minutes) between saves. If you do that, ARCHPR will create and periodically update a restore file named "~archpr.axr" (that's the default – you can change it) in the same folder where your archive is located (also by default; you can select any other folder to save that file to). This file is similar to one created when using the "Save setup" button. Even if your computer stops responding (or if power fails), you'll be able to restore breaking the password from the last saved state. Instead of using the default settings (the name of the file and the folder it will be saved to), you can also select your own settings. Enabling this option is strongly recommended.


Other options

Priority: background or high. If you want to start ARCHPR as a "background" process, which will work only when the CPU is in an idle state, you may select "Background". If you want to increase performance, select "High", but be aware that this will decrease the performance of *all other* applications running on your computer.

Minimize to tray: if this option is enabled, the program window will disappear from the Windows desktop when you press the "minimize" button in the top-right corner of the window (or you select an appropriate item in the system menu). The small icon will be created in the "tray" area of the task bar (near the system clock). Just double-click on that icon to restore the window.

Log to archpr.log: when enabled, the program saves all information displayed in the status window into the log-file (archpr.log).

Progress bar update interval: allows to set an interval (in milliseconds) between progress bar and status window updates; the default is 500 (a reasonable value). By selecting the higher value (3000, for example), you can get slightly better recovery speed.

Register: press this button to register your copy of ARCHPR (if you've got the registration code already, of course).

Update: press this button (when you're connected to the Internet) to see if there a new version of ARCHPR on our site. Note: the program uses Microsoft Internet Explorer proxy settings.

Language: the program has multilingual interface. Just select the appropriate language from the drop-down box. English is the default.


Advanced options

Use known start of the file for stored archives (hex): if your archive contains only one encrypted file, and this file is stored (i.e. not compressed), using that option is a solution to get much better recovery speed. But you have to know from 1 to 4 bytes this file starts from. There are a lot of well-known signatures, though: for example, 'MZ' (hex: 4D 5A) for executable files, 'PK' (hex: 50 4B 03 04) for ZIP files, D0 CF 11 E0 (hex) for OLE compound documents (like MS Word/Excel files) etc.

Always use WinZIP optimized attack engine if probability is greater than XX%: if your archive has been created with WinZIP (or other Windows-based ZIP tool based on the same sources -- there are many such tools) and contains at least five encrypted files, there is some good news: the speed of brute-force attack can be about three times better! ARCHPR tries to recognize such a situation automatically, but unfortunately, a ZIP file doesn't store any information about the archiver. So the program calculates the "probability" value (it depends on the number of files in the archive and other factors). If it is greater than 50%, ARCHPR suggests you to use this (optimized) attack each time you start the recovery process. You can set this option (selecting the appropriate percentage as well) for your convenience, so the optimized engine will (or will not) be used automatically. 85% is the good value to use, but you can set a higher value, if you're not sure.

Mask symbol: used for Mask attack.


Save and Read setup

You can save your current ARCHPR setup into a specified file (with extension AXR). When you press the "Save setup" button (or F2 key), the "Save file" dialog appears. Just select a file name (e.g. "myarch.axr"), or select an existing AXR-file for overwriting. You can read your setup later – simply press the "Read setup" button.

Alternatively, you can use drag'n'drop – just drag the previously saved axr-file (with a mouse) from Windows Explorer, and drop it onto the ARCHPR window. If all the settings are correct, the attack will be started immediately.


Benchmark

If you would like to estimate how long the Brute-force or Mask attack will take, or test ARCHPR's speed on a particular archive, use the benchmark feature. Just select all the desired options, then press the Benchmark button (next to Stop). The program will work for about 10 seconds, and display some statistics afterwards:

benchmark

Here you can see the total number of passwords (according to the options you set), average program speed, and estimated time. Please note that real time might be slightly different, because the speed of the program depends on how many other applications are running at the same time.


Recovery process

When all of the options are selected, all you have to do is press the Start button on the toolbar (or F9 key) and wait. During the attack, you'll be able to see the Program status – number of passwords already tried, elapsed and estimated time, etc.

Please note that you can stop the recovering process at any time (Stop button or F10 key), to continue it later (or just save the project). Consult the Start from password and Save and Read setup chapters for further details.

In Known plaintext attack, you can stop the process at any time as well, but resuming is possible only if you do that on second stage ("searching for keys") only, but the first stage should be performed again anyway. The first stage takes a few minutes, however (in contrary to the second one, which may take 2-3 days in some cases). Note: resuming known-plaintext attack is available in registered version only.


Program status

When the recovering process is in progress – the current password, average speed, elapsed time, remaining time, total number of password of given length, and number of passwords already processed are displayed:

status


The password is...

The password is…

When (if) the password is found, the program shows it, as well as the number of passwords which have been tested, and the program speed:

found

The last line displays the password in HEX form – it might be useful if the password, for example, contains some non-English characters which cannot be displayed correctly on your system (due to missing fonts, etc.).

Pressing the small button at the right of the password (in "normal" or HEX form) copy the password into the Clipboard. Alternatively, you can save the password to a file.

If all possible passwords in the given range have been tried without success (without finding a valid one), the message looks like:

notfound

If you stopped recovery by pressing the "Stop" button, the current step of the brute-force attack is saved in the "Start from" field. Now you can press the "Start" button again. Recovery will be continued from this step.


Known bugs and limitations

· When the files in the archive are stored (without compression, only with encryption), the performance might be lower than expected (especially on large files), because decrypting the whole file is required (unless you know the first few bytes of the encrypted file).
· If the archive contains two or more encrypted files, the program assumes that all of them are encrypted with the same password (see Files with different passwords topic for a workaround).
· The program does not support ZIP archives that use dclimplode compression method (available in PKWARE Date Compression Library)
· The program does not support ZIP archives that use PPMd and bzip2 compression methods (available in WinZip 10.0 beta)
· The program does not support Strong Encryption Specification (EFS) (available in PKZip 5 and above)


Files with different passwords

If the files inside the ZIP archive have been encrypted with different passwords, ARCHPR might not be able to find the correct password. The workaround is to (1) make a backup copy of your archive; (2) remove all files from the archive except those which definitely have the same password (perhaps just one file); and (3) run ARCHPR on the resulting archive. When (if) ARCHPR finds the correct password, create another new archive, keeping the next portion of files which have the same password. If all the files have different passwords, you're in trouble – too much time for recovering them will be required; but that's the only thing you can do.


What to start from

If you have no idea how long the password is and what characters it may contain, just run the dictionary-based attack first. If it fails, try brute-force with the following options (character set and password length range):

Charset | Length | Passwords | Time (approx.)
All printable | 1..6 | 742,912,032,768 | 14 hours
Digits, small/capital, space | 7 | 3,938,980,724,736 | 3 days
Digits, small letters, space | 8 | 3,512,479,514,624 | 3 days
Digits, capital letters, space | 8 | 3,512,479,514,624 | 3 days
Digits | 9..11 | 1,110,999,957,504 | 1 day
Small letters, space | 9 | 7,625,596,993,536 | 6 days
Capital letters, space | 9 | 7,625,596,993,536 | 6 days

The third column shows the total number of possible password combinations (with the given charset and password length); and the last column shows the maximum time required for recovery of the password, assuming that the speed is 15,000,000 passwords per second (the performance of a computer with Pentium 4 3GHz CPU on ZIP archives with three or more files using traditional encryption, and at least one is inflated).

For archives of other types (or ZIP archives that use AES encryption etc. – i.e. when the speed is worse), you will have to run a benchmark in advance, and find the proper options (especially the password range) experimentally.


Dictionary-based attacks

As noted above, dictionary-based attack is *very* effective, so please try it first. Moreover, if you know the "structure" of the password (for example, the characters at some positions), it is recommended that you create your own dictionary based on the rules you have. There are a lot of dictionary generators around; some (developed by third parties) are available from our Password Recovery Software page:

http://www.elcomsoft.com/prs.html

The password generator may also help if you "almost" remember the password. You might have missed one or two characters, or typed an extra one, or just missed a few characters – some generators allow "mutating" the password and can print/save all similar ones (creating a new wordlist or dictionary, which can be used with ARCHPR).


Command line

You can run ARCHPR with command-line parameters. The syntax is:

ARCHPR [switches] [zip/arj/ace/rar-filename]

or

ARCHPR [switches] [axr-filename]

The switches are separated with / or - characters. If the switch is followed by some data (e.g., filename, starting password, etc.) which contains these characters: space, semicolon, slash or dash, it must be enclosed in (single or double) quotes.

Switch | Description | Default
/a:b|m|d | attack type (brute-force, mask, dictionary) | brute-force
/c:csdepa | character set (caps, small, digits, special, space, all) | caps
/u:chars | user-defined charset |
/oem | convert to OEM (for user-defined charset and dictionary attack) | disabled
/sf:pass | start from password |
/endat:pass | end at password |
/usewz:X | use optimized WinZip attack |
/useknownstart:XX | use known bytes in stored file (from 1 to 4 hex values, no spaces) |
/p[:filename] | plaintext filename |
/m:mask | mask |
/ms:C | mask symbol | ?
/min:N | minimum password length | 1
/max:N | maximum password length | 5
/oem | convert to OEM (for user-defined charset and dictionary attack) | disabled
/useknownstart:XX | use known bytes in stored file (from 1 to 4 hex values, no spaces) |
/d[:filename] | dictionary filename |
/sm | smart mutations | disabled
/ac | try all possible upper/lower case combinations | disabled
/sl:N | start from line N | 0
/autosave:N | autosave every N minutes; 0 means disabled | 5
/aname:filename | autosave filename |
/adir:dir | autosave directory |
/idle | run at idle priority | enabled
/high | run at high priority | disabled
/dontstart | don't start the attack, just load/set the parameters |
/minimize | minimize the program after starting the attack |
/smartexit[:filename] | when the attack is completed, write all statistics, including the password (if found) to the given file (default "cmdline_stats.txt"), and close the program | disabled
Examples:

archpr.exe /a:b /c:cs /min:3 /max:7 /smartexit test.zip
(brute-force attack; small and capital letters; length from 3 to 7; save and exit when done)

archpr.exe /a:b /u:12345abcde test.ace
(brute-force attack with "12345abcde" character set; length: from 1 to 5)

archpr.exe /a:m /c:d /m:june???? /sf:june1000 /high test.rar
(mask attack with ""june????" mask; charset: digits; high priority)

archpr.exe /d:english.dic /sm /oem /dontstart test.zip
(dictionary attack; dictionary: "english.dic"; smart mutations; convert words from ANSI to OEM; don't start)

archpr.exe /a:p /p:plain.arj test.arj
(known plaintext attack)

If the parameter is the axr-file, the program will immediately load all the settings from it (ignoring the other settings supplied in the command line, except /dontstart, /minimize and /smartexit), and run the attack.


Unexpected crash

We've tried to make ARCHPR as reliable as possible, but on some specific archives it may still crash (after a few hours or even days of continuous operation). However, if you have the Auto-save option enabled, it is safe – the program will restart automatically (from the last-saved point). In addition, it will create a special dump file (in the same folder where archpr.exe is located), in the form:

CrashLog XXX, YYY.log

where XXX indicates the crash date, and YYY the crash time. The file contains information which will really help us to fix the problem (the crash address, registers map, stack dump, process list, memory map, etc.) – so, if you should ever get that dump (an appropriate message will be written into the message log), please send it to us, and we'll do our best to make ARCHPR even better.

To test the functionality described above, press Ctrl-Alt-Shift-F12 – the program will simulate an exception by causing a division by zero.


Contacting us

For technical support, please contact us at support@elcomsoft.com. In the subject of your mail, please write "ARCHPR x.y" (where x.y is the version number), followed by "problem", "suggestion" or whatever else.


Where to get the latest version

The most current version of ARCHPR is always available at:

http://www.elcomsoft.com/archpr.html

Other password recovery products (for Microsoft Office and other Microsoft applications: Word, Excel, Access, PowerPoint, Outlook, Outlook Express, Internet Explorer, Visio, VBA, MS Backup, MS Project, MS Mail, MS Schedule+; Lotus Organizer, Lotus 1-2-3, Lotus WordPro, Lotus Approach; Corel WordPerfect, Paradox and QuattroPro; ACT! from Symantec and Best Software; Intuit Quicken and QuickBooks; Adobe Acrobat PDF; most popular email clients and instant messengers; Windows 2000/XP/2003 Encrypting File System on NTFS; Windows NT/2000/XP user passwords; Windows PWL/RAS/dial-up/VPN/shares/asterisked passwords) are available at:

http://www.elcomsoft.com/prs.html


Copyright and license

NOTICE TO USER:

THIS IS AN AGREEMENT GOVERNING YOUR USE OF ELCOMSOFT SOFTWARE, FURTHER DEFINED HEREIN AS "PRODUCT," AND THE LICENSOR OF THE PRODUCT IS WILLING TO PROVIDE YOU WITH ACCESS TO THE PRODUCT ONLY ON THE CONDITION THAT YOU ACCEPT ALL OF THE TERMS AND CONDITIONS CONTAINED IN THIS AGREEMENT. BELOW, YOU ARE ASKED TO ACCEPT THIS AGREEMENT AND CONTINUE TO INSTALL OR, IF YOU DO NOT WISH TO ACCEPT THIS AGREEMENT, TO DECLINE THIS AGREEMENT, IN WHICH CASE YOU WILL NOT BE ABLE TO INSTALL OR OPERATE THE PRODUCT. BY INSTALLING THIS PRODUCT YOU ACCEPT ALL THE TERMS AND CONDITIONS OF THIS AGREEMENT.

This Electronic End User License Agreement (the "Agreement") is a legal agreement between you (either an individual or an entity), the licensee, and ElcomSoft Co. Ltd. and its affiliates (collectively, the "Licensor"), regarding the Licensor's software, as applicable pursuant to a valid license, you are about to download and/or other related services, including without limitation a) all of the contents of the files, disk(s), CD-ROM(s) or other media with which this Agreement is provided and including all forms of code, such as source code and object code, (the "Software"), b) all successor upgrades, modified versions, modified modules, revisions, patches, enhancements, fixes, modifications, copies, additions or maintenance releases of the Software, if any, licensed to you by the Licensor (collectively, the "Updates"), and c) related user documentation and explanatory materials or files provided in written, "online" or electronic form (the "Documentation" and together with the Software and Updates, the "Product"). You are subject to the terms and conditions of this End User License Agreement whether you access or obtain the Product directly from the Licensor, or through any other source. For purposes hereof, "you" means the individual person installing or using the Product on his or her own behalf; or, if the Product is being downloaded or installed on behalf of an organization, such as an employer, "you" means the organization for which the Product is downloaded or installed, then the person accepting this agreement represents hereby that such organization has authorized such person to accept this agreement on the organization's behalf. For purposes hereof the term "organization," without limitation, includes any partnership, limited liability company, corporation, association, joint stock company, trust, joint venture, labor organization, unincorporated organization, or governmental authority.

By accessing, storing, loading, installing, executing, displaying, copying the Product into the memory of a Client Device, as defined below, or otherwise benefiting from using the functionality of the Product ("Operating"), you agree to be bound by the terms and conditions of this Agreement. If you do not agree to the terms and conditions of this Agreement, the Licensor is unwilling to license the Product to you. In such event, you may not Operate or use the Product in any way.

BEFORE YOU PRESS THE "I AGREE" BUTTON, PLEASE CAREFULLY READ THE TERMS AND CONDITIONS OF THIS AGREEMENT, AS SUCH ACTIONS ARE A SYMBOL OF YOUR SIGNATURE AND BY CLICKING ON THE "I AGREE", YOU ARE CONSENTING TO BE BOUND BY AND ARE BECOMING A PARTY TO THIS AGREEMENT AND AGREE THAT THIS AGREEMENT IS ENFORCEABLE LIKE ANY WRITTEN NEGOTIATED AGREEMENT SIGNED BY YOU. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS AGREEMENT, CLICK THE "CANCEL" BUTTON AND THE PRODUCT WILL NOT BE INSTALLED ON YOUR CLIENT DEVICE, AS SUCH TERM IS DEFINED BELOW. For your reference, you may refer to the copy of this Agreement that can be found in the Help for the Software. You may also receive a copy of this Agreement by contacting Licensor at: info@elcomsoft.com.

1. Proprietary Rights and Non-Disclosure.
1.1. Ownership Rights. You agree that the Product and the authorship, systems, ideas, methods of operation, documentation and other information contained in the Product, are proprietary intellectual properties and or the valuable trade secrets of the Licensor and are protected by civil and criminal law, and by the law of copyright, trade secret, trademark and patent of the Russian federation, other countries and international treaties. You may use trademarks only insofar as to identify printed output produced by the Product in accordance with accepted trademark practice, including identification of trademark owner's name. Such use of any trademark does not give you any rights of ownership in that trademark. The Licensor and its suppliers own and retain all right, title, and interest in and to the Product, including without limitations any error corrections, enhancements, Updates or other modifications to the Software, whether made by Licensor or any third party, and all copyrights, patents, trade secret rights, trademarks, and other intellectual property rights therein. Your possession, installation or use of the Product does not transfer to you any title to the intellectual property in the Product, and you will not acquire any rights to the Product except as expressly set forth in this Agreement. All copies of the Product made hereunder must contain the same proprietary notices that appear on and in the Product. Except as stated herein, this Agreement does not grant you any intellectual property rights in the Product and you acknowledge that the license granted under this Agreement only provides you with a right of limited use under the terms and conditions of this Agreement.
1.2. Source Code and Modifications. You acknowledge that the source code for the Product is proprietary to the Licensor and constitutes trade secrets of the Licensor. You agree not to modify, or create derivative works based upon the Product in whole or in part nor reverse engineer, decompile, disassemble the source code of the Product in any way.
1.3. Registration Code File and Confidential Information. You agree that, unless otherwise specifically provided herein or agreed by the Licensor in writing, the Product, including the specific design and structure of individual programs and the Product, including without limitation the Registration Code File provided to you by the Licensor and/or its authorized resellers or distributors, constitute confidential proprietary information of the Licensor. For purposes hereof, "Registration Code" shall mean a unique key identification file or a combination of unique electronic characters provided to you by the Licensor confirming the purchase of the license from the Licensor, which may carry the information about the license and the number of permitted users, and enabling the full functionality of the Product in accordance with the license granted under this Agreement. You agree not to transfer, copy, disclose, provide or otherwise make available such confidential information in any form to any third party without the prior written consent of the Licensor. You agree to implement reasonable security measures to protect such confidential information, but without limitation to the foregoing, shall use best efforts to maintain the security of the Registration Code provided to you by the Licensor and/or its authorized resellers or distributors.
2. Grant of License.
2.1. License. The Licensor grants you the following rights ("License") and you hereby agree and accept such License:
a). Trial Version. If you have received, downloaded and/or installed a trial version of the Product and are hereby granted an evaluation license for the Software and you may Operate the Product only for evaluation purposes and only during the single applicable evaluation period of thirty (30) days, unless otherwise indicated, from the date of the initial installation. Following this test period of thirty (30) days or less, if you wish to continue to use the Product, you must register. To register you have to pay for the fully functional version. Upon payment we provide the Registration Code to you. Any use of the Product for other purposes or beyond the applicable evaluation period is strictly prohibited, provided however that, subject to the restrictions contained herein, you may copy and distribute a trial version of the Software without any modifications whatsoever to any third party subject to this Agreement and further provided that you have no technical support rights during the trial period. The unregistered (trial) version may be freely distributed, provided that the distribution package is not modified. No person or company may charge a fee for the distribution of the Product without written permission from the copyright holder.
b). Grant of License. Unless otherwise specifically indicated under a valid license (e.g. volume license) granted by the Licensor, once registered you are granted a non-exclusive and non-transferable license to install one (1) copy of the Product and during the term of your license, subject to the payment of the applicable fees and your compliance with the terms hereof, this Agreement permits you or any of your employees to Operate one copy of the specified version of the Product, for internal purposes only, on one computer, workstation, or other electronic device of which the software was designed (each a "Client Device"). If you have purchased multiple licenses for the Product, then the number of multiple licenses shall determine the number of copies of the Product you may have and the number of Client Devices on which you may Operate the Product. If the Product is licensed as a suite or bundle with more than one specified software product, this license applies to all such specified software products, subject to any restrictions or usage terms specified on the applicable price list or product packaging that apply to any of such software products individually. Additionally, Licensor reserves the right to provide for specific terms and conditions in the purchased licenses and such terms may be embedded in Registration Code specifying other terms, conditions and restrictions of Operating of the Product. The Licensor reserves all rights not expressly granted herein.
c). Limitations on Personal License. With the purchase of a personal License, the Licensee may operate the Product as set forth in the Agreement for non-commercial purposes in a non-business or non-commercial environment. Use of the Product in a corporate, governmental or business environment requires the purchase of a business license.
d). Site License. With the acquisition of a Site License, the Licensee may install and use the Product on an unlimited amount of CPUs within one office in one geographic location. Within these limitations, the Licensee may install the Product as a "Network" Product and run the software from any networked computer on your LAN, provided those computers are located exclusively within one office at one geographic location.
e). Volume Use. If the Product is licensed with volume license terms specified in the applicable product invoicing or packaging for the Product, you may make use and install as many additional copies of the Product on the number of Client Devices as the volume license terms specify. You must have a reasonable mechanism in place to ensure that the number of Client Devices on which the Product has been installed does not exceed the number of licenses you have obtained.
f). Multiple Environment Product; Multiple Language Product; Dual Media Product; Multiple Copies; Bundles. If the Product supports multiple platforms or languages, if you receive the Product on multiple media, if you otherwise receive multiple copies of the Product, or if you received the Product bundled with other software, the total number of your Client Devices on which all versions of the Product are installed may not exceed the number of licenses you have obtained from the Licensor. You may not rent, lease, sublicense, lend or transfer any versions or copies of the Product you do not use.
2.2. Back-up Copies. You can make one (1) copy the Product for backup and archival purposes, provided, however, that the original and each copy is kept in your possession or control, and that your installation and use of the Product does not exceed that which is allowed in this Section 2.
2.3. Prohibitions. You may not use, copy, emulate, clone, rent, lease, sell, modify, decompile, disassemble, otherwise reverse engineer, or transfer the licensed program, or any subset of the licensed program, except as provided for in this Agreement. Any such unauthorized use shall result in immediate and automatic termination of this license and may result in criminal and/or civil prosecution. Neither ElcomSoft binary code nor source may be used or reverse engineered to re-create the program algorithm, which is proprietary, without written permission of Licensor. All rights not expressly granted here are reserved by ElcomSoft Co. Ltd.
2.4. Special Provisions Applicable to Password Recovery Programs. The Licensor has a strict return policy due to the nature of our products. If the software is unable to recover (or remove, or change) a password, a copy of the unrecovered file must be sent to the Licensor for evaluation. If the password is recovered, you will be either able to keep the software and receive the password to the file (or unprotected copy of the file), or refund can be made and the end user will need to pay for the in-house recovery in order to receive the password. If the Licensor is unable to recover the password, a full refund will be made. This subsection is applicable only to situations when password recovery or removal is guaranteed without brute-force or dictionary attacks.
2.5. Registration Code. Registration Code provided by the Licensor constitutes the confidential proprietary information of the Licensor. ElcomSoft Registration Code file may not be distributed, except as stated herein, outside of the area of legal control of the person or persons who purchased the original license, without written permission of the copyright holder. You may not give away, sell or otherwise transfer your Registration Code to a third party. Doing so will result in an infringement of copyright. ElcomSoft Co. Ltd retains the right of claims for compensation in respect of damage which occurred by your giving away the registration code. This claim shall also extend to all costs which ElcomSoft Co. Ltd incurs in defending itself.
2.6. Transfers. Under no circumstances shall Licensee sell, rent, lease, license, sublicense, publish, display, distribute, or otherwise transfer to a third party the Software, any copy thereof, in whole or in part, without Licensor's prior written consent, unless otherwise provided for in this Agreement.
2.7. Acceptance of Licensing Terms. Installing and using the Product signifies acceptance of these terms and conditions of the License. If you do not agree with the terms of the license you must remove all Product files from your storage devices, including any back-up or archival copy, and cease to use the Product.
2.8. Material Terms and Conditions. Licensee specifically agrees that each of the terms and conditions of this Section 2 are material and that failure of Licensee to comply with these terms and conditions shall constitute sufficient cause for Licensor to immediately terminate this Agreement and the License granted under this Agreement. The presence of this Section 2.7 shall not be relevant in determining the materiality of any other provision or breach of this Agreement by either party.
2.9. Term and Termination. The term of this Agreement ("Term") shall begin when you download, access or install the Product or pay the applicable license fees (whichever is earlier) and shall continue for the term specified in your order. Without prejudice to any other rights, this Agreement will terminate automatically if you fail to comply with any of the limitations or other requirements described herein. Upon any termination or expiration of this Agreement, you must immediately cease use of the Product and destroy all copies of the Product.
2.10. No Rights Upon Termination. Upon termination of this Agreement you will no longer be authorized to Operate or use the Product in any way.
3. Support and Updates.
3.1. Terms of Support. During the one-year period you are entitled to technical services and support for the Product which is provided to you by Licensor during the regular business hours (GMT+ 03:00), except for locally-observed holidays, and includes the support provided through a special technical support section of the Licensor's site (the "Site") and email support@elcomsoft.com. During such period of one year e-mail support is unlimited and includes technical and support questions and patch fixes.
3.2. Updates. During the one-year period, you may download Updates to the Product when and as the Licensor publishes them on the Site, or through other online services. If the Product is an Update to a previous version of the Product, you must possess a valid license to such previous version in order to use the Update. You may continue to use the previous version of the Product on your Client Device after you receive the Update to assist you in the transition to the Update, provided that: (i) the Update and the previous version are installed on the same Client Device; (ii) the previous version or copies thereof are not transferred to another party or Client Device unless all copies of the Update are also transferred to such party or Client Device; (iii) you acknowledge that any modification that you made to the Product may be lost, altered, distorted or destroyed rendering such modifications, Product or the part thereof inoperable or non-usable; and (iv) you acknowledge that any obligation the Licensor may have to support the previous version of the Product may be ended upon availability of the Update. Except for the rights to free Updates during the one-year period, as further defined herein, nothing in this Agreement shall be construed as to grant you any rights or licenses with regard to the new releases of the Product or to entitle you to any new release. This Agreement does not obligate the Company to provide any Updates. Notwithstanding the foregoing, any Updates that you may receive become part of the Product and the terms of this Agreement apply to them (unless this Agreement is superseded by a succeeding agreement accompanying such Update or modified version of the Product).
4. Restrictions.
4.1. No Transfer of Rights. You may not transfer any rights pursuant to this Agreement nor rent, sublicense, lease, loan or resell the Product. You may not permit third parties to benefit from the use or functionality of the Product via a timesharing, service bureau or other arrangement, except to the extent such use is specified in the application price list, purchase order or product packaging for the Product. Except as otherwise provided in Section 1.2 hereof, you may not, without the Licensor's prior written consent, reverse engineer, decompile, disassemble or otherwise reduce any party of the Product to human readable form nor permit any third party to do so, except to the extent the foregoing restriction is expressly prohibited by applicable law. Notwithstanding the foregoing sentence, decompiling the Software is permitted to the extent the laws of your jurisdiction give you the right to do so to obtain information necessary to render the Software interoperable with other software; provided, however, that you must first request such information from the Licensor and the Licensor may, in its discretion, either provide such information to you (subject to confidentiality terms) or impose reasonable conditions, including a reasonable fee, on such use of the Software to ensure that the Licensor's and its affiliates' proprietary rights in the Software are protected. Except for the modification permitted under Section 1.2, you may not modify, or create derivative works based upon the Product in whole or in part.
4.2. Proprietary Notices and Copies. You may not remove any proprietary notices or labels on the Product. You may not copy the Product except as expressly permitted in Section 2 above.
4.3. Compliance with Law. You agree that in Operating the Product and in using any report or information derived as a result of Operating this Product, you will comply with all applicable international, national, state, regional and local laws and regulations, including, without limitation, privacy, trademark, patent, copyright, export control and obscenity law and you shall not use the Product for unethical or illegal business practices or in violation of any obligation to a third party in using, operating, accessing or running any of the Product and shall not knowingly assist any other person or entity to so violate any obligation to a third party.
4.4. Additional Protection Measures. Solely for the purpose of preventing unlicensed use of the Product, the Software may install on your Client Device technological measures that are designed to prevent unlicensed use, and the Licensor may use this technology to confirm that you have a licensed copy of the Product. The update of these technological measures may occur through the installation of the Updates. The Updates will not install on unlicensed copies of the Product. If you are not using a licensed copy of the Product, you are not allowed to install the Updates. The Licensor will not collect any personally identifiable information from your Client Device during this process.
5. WARRANTIES AND DISCLAIMERS.
5.1. Limited Warranty. The Licensor warrants that for 90 days (the "Warranty Period") from the date the Registration Code is provided to you by Licensor, the media on which Product has been provided will be free from defects in materials and workmanship and that the Software will perform substantially in accordance with the Documentation or generally conform to the Product's specifications published by the Licensor. Non-substantial variations of performance from the Documentation do not establish a warranty right. THIS LIMITED WARRANTY DOES NOT APPLY TO UPDATES AS APPLIED TO ANY MODIFIED PRODUCT, WHETHER OR NOT SUCH MODIFICATION IS PERMISSIBLE HEREUNDER, TRIAL AND EVALUATION VERSIONS, UPDATES, PRE-RELEASE, TRYOUT, PRODUCT SAMPLER, OR NOT FOR RESALE (NFR) COPIES OF PRODUCT. This limited warranty is void and your support right terminate if the defect has resulted from accident, abuse, or misapplication or any modification, whether or not such modification is permitted hereunder. No warranty is made as to the integrity, protection or safekeeping of any modification to the Products made by you upon installation of any of the Updates. To make a warranty claim, you must return the Product to the location where you obtained it along with proof of purchase within such sixty (60) day period of the license fee you paid for the Product. THE LIMITED WARRANTY SET FORTH IN THIS SECTION GIVES YOU SPECIFIC LEGAL RIGHTS. YOU MAY HAVE ADDITIONAL RIGHTS WHICH VARY FROM JURISDICTION TO JURISDICTION.
5.2. Customer Remedies. The Licensor and its suppliers' entire liability and your exclusive remedy for any breach of the foregoing warranty shall be at the Licensor's option: (i) return of the purchase price paid for the license, if any, (ii) replacement of the defective media in which the Product is contained, or (iii) correction of the defects, "bugs" or errors within reasonable period of time. You must return the defective media to the Licensor at your expense with a copy of your receipt. Any replacement media will be warranted for the remainder of the original warranty period.
5.3. NO OTHER WARRANTIES. EXCEPT FOR THE FOREGOING LIMITED WARRANTY, AND FOR ANY WARRANTY, CONDITION, REPRESENTATION OR TERM TO THE EXTENT TO WHICH THE SAME CANNOT OR MAY NOT BE EXCLUDED OR LIMITED BY LAW APPLICABLE TO YOU IN YOUR JURISDICTION, THE PRODUCT IS PROVIDED "AS-IS" WITHOUT ANY WARRANTY WHATSOEVER AND THE LICENSOR MAKES NO PROMISES, REPRESENTATIONS OR WARRANTIES, WHETHER EXPRESSED OR IMPLIED, WHETHER BY STATUTE, COMMON LAW, CUSTOM, USAGE OR OTHERWISE, REGARDING OR RELATING TO THE PRODUCT OR CONTENT THEREIN OR TO ANY OTHER MATERIAL FURNISHED OR PROVIDED TO YOU PURSUANT TO THIS AGREEMENT OR OTHERWISE. YOU ASSUME ALL RISKS AND RESPONSIBILITIES FOR SELECTION OF THE PRODUCT TO ACHIEVE YOUR INTENDED RESULTS, AND FOR THE INSTALLATION OF, USE OF, AND RESULTS OBTAINED FROM THE PRODUCT. THE LICENSOR MAKES NO WARRANTY THAT THE PRODUCT WILL BE ERROR FREE OR FREE FROM INTERRUPTION OR FAILURE, OR THAT IT IS COMPATIBLE WITH ANY PARTICULAR HARDWARE OR SOFTWARE. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, LICENSOR DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY, NON-INFRINGEMENT OF THIRD PARTY RIGHTS, INTEGRATION, SATISFACTORY QUALITY OR FITNESS FOR ANY PARTICULAR PURPOSE WITH RESPECT TO THE PRODUCT AND THE ACCOMPANYING WRITTEN MATERIALS OR THE USE THEREOF. SOME JURISDICTIONS DO NOT ALLOW LIMITATIONS ON IMPLIED WARRANTIES, SO THE ABOVE LIMITATION MAY NOT APPLY TO YOU. YOU HEREBY ACKNOWLEDGE THAT THE PRODUCT MAY NOT BE OR BECOME AVAILABLE DUE TO ANY NUMBER OF FACTORS INCLUDING WITHOUT LIMITATION PERIODIC SYSTEM MAINTENANCE, SCHEDULED OR UNSCHEDULED, ACTS OF GOD, TECHNICAL FAILURE OF THE SOFTWARE, TELECOMMUNICATIONS INFRASTRUCTURE, OR DELAY OR DISRUPTION ATTRIBUTABLE TO VIRUSES, DENIAL OF SERVICE ATTACKS, INCREASED OR FLUCTUATING DEMAND, AND ACTIONS AND OMISSIONS OF THIRD PARTIES. THEREFORE, THE LICENSOR EXPRESSLY DISCLAIMS ANY EXPRESS OR IMPLIED WARRANTY REGARDING SYSTEM AND/OR SOFTWARE AVAILABILITY, ACCESSIBILITY, OR PERFORMANCE. THE LICENSOR DISCLAIMS ANY AND ALL LIABILITY FOR THE LOSS OF DATA DURING ANY COMMUNICATIONS AND ANY LIABILITY ARISING FROM OR RELATED TO ANY FAILURE BY THE LICENSOR TO TRANSMIT ACCURATE OR COMPLETE INFORMATION TO YOU.
5.4. LIMITED LIABILITY; NO LIABILITY FOR CONSEQUENTIAL DAMAGES. YOU ASSUME THE ENTIRE COST OF ANY DAMAGE RESULTING FROM YOUR USE OF THE PRODUCT AND THE INFORMATION CONTAINED IN OR COMPILED BY THE PRODUCT, AND THE INTERACTION (OR FAILURE TO INTERACT PROPERLY) WITH ANY OTHER HARDWARE OR SOFTWARE WHETHER PROVIDED BY THE LICENSOR OR A THIRD PARTY. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT WILL THE LICENSOR OR ITS SUPPLIERS OR LICENSORS BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, LOSS OF DATA, LOSS OF GOODWILL, WORK STOPPAGE, HARDWARE OR SOFTWARE DISRUPTION IMPAIRMENT OR FAILURE, REPAIR COSTS, TIME VALUE OR OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OR INABILITY TO USE THE PRODUCT, OR THE INCOMPATIBILITY OF THE PRODUCT WITH ANY HARDWARE SOFTWARE OR USAGE, EVEN IF SUCH PARTIES HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT WILL LICENSOR'S TOTAL LIABILITY TO YOU FOR ALL DAMAGES IN ANY ONE OR MORE CAUSE OF ACTION, WHETHER IN CONTRACT, TORT OR OTHERWISE EXCEED THE AMOUNT PAID BY YOU FOR THE PRODUCT. THIS LIMITATION OF LIABILITY SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY TO THE EXTENT THAT APPLICABLE LAW PROHIBITS SUCH LIMITATION. FURTHERMORE, BECAUSE SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.
6. Indemnification
6.1. Indemnification for Violations. Your Operating of the Product, your accessing your account with Licensor and your entering into this Agreement constitutes your consent and agreement to defend, indemnify and hold harmless Licensor and its affiliated companies, employees, contractors, officers and directors from any claim or demand, including reasonable attorney's fees arising out of your use of the Product in violation of this Agreement.
SPECIAL PROVISION APPLICABLE TO U.S. PERSONS AND ENTITIES.
7. U.S. Government-Restricted Rights.
7.1. Notice to U.S. Government End Users. The Product and accompanying Documentation are deemed to be "Commercial Items," as that term is defined at 48 C.F.R. §2.101, consisting of "Commercial Computer Software" and "Commercial Computer Software Documentation," respectively, as such terms are used in 48 C.F.R. §12.212 or 48 C.F.R. §227.7202, as applicable. Consistent with 48 C.F.R. §12.212 or 48 C.F.R. §§227.7202-1 through 227.7202-4, as applicable, the Commercial Computer Software and Commercial Computer Software Documentation are being licensed to U.S. Government end users (a) only as Commercial Items and (b) with only those rights, including any use, modification, reproduction, release, performance, display or disclosure of the Product and accompanying Documentation, as are granted to all other end users pursuant to the terms and conditions herein. Unpublished-rights reserved under the copyright laws of the United States.
7.2. Export Restrictions. You acknowledge and agree that the Product may be subject to restrictions and controls imposed by the Export Administration Act and the Export Administration Regulations of the United States (the "Acts"). You agree and certify that neither the Product nor any direct product thereof is being or will be used for any purpose prohibited by the Acts. You may not Operate, download, export, or re-export the Product (a) into, or to a national or resident of, any country to which the United States has embargoed goods, or (b) to anyone on the United States Treasury Department's list of Specially Designated Nationals or the U.S. Commerce Department's Table of Deny Orders. By downloading or using the Product, you are representing and warranting that you are not located in, under the control of, or a national or resident of any such country or on any such list. You acknowledge that it is your sole responsibility to comply with any and all government export and other applicable laws and that the Licensor has no further responsibility for such after the initial license to you. You warrant and represent that neither the U.S. Commerce Department, Bureau of Export Administration nor any other U.S. federal agency has suspended, revoked or denied your export privileges.
8. Your Information and the Licensor's Privacy Policy
8.1. Privacy Policy. You acknowledge receipt of and agree to the Licensor's privacy statement which is made available to you in connection with installation and is set forth in full at http://www.elcomsoft.com/privacy.html. You hereby expressly consent to the Licensor's processing of your personal data (which may be collected by the Licensor or its distributors) according to the Licensor's current privacy policy as of the date of the effectiveness hereof which is incorporated into this Agreement by reference. By entering into this Agreement, you agree that the Licensor may collect and retain information about you, including your name and email address. The Licensor employs other companies and individuals to perform certain functions on its behalf. Examples include fulfilling orders, delivering packages, sending postal mail and e-mail, removing repetitive information from customer lists, analyzing data, providing marketing assistance, processing credit card payments, and providing customer service. They have access only to personal information needed to perform their functions, but may not use it for other purposes. The Licensor publishes a privacy policy on its web site and may amend such policy from time to time in its sole discretion. You should refer to the Licensor's privacy policy prior to agreeing to this Agreement for a more detailed explanation of how your information will be stored and used by the Licensor. If "you" are an organization, you will ensure that each member of your organization (including employees and contractors) about whom personal data may be provided to the Licensor has given his or her express consent to the Licensor's processing of such personal data. Personal data will be processed by the Licensor or its distributors in the country where it was collected.
8.2. Public Announcements. The Licensor may identify you to the public as a customer of the Licensor and describe in a customer case study the services and solutions delivered by the Licensor to you. The Licensor may also issue one or more press releases, containing an announcement of the execution and delivery of this Agreement and/or the implementation of the Product by you. Nothing contained in this Section shall be construed as an obligation by you to disclose any of your proprietary or confidential information to any third party. In addition, you may opt-out from this Section by writing an opt-out request to the Licensor at info@elcomsoft.com.
9. Miscellaneous.
9.1. Governing Law; Jurisdiction and Venue. This Agreement shall be governed by and construed and enforced in accordance with the laws of the Russian Federation without reference to conflicts of law rules and principles. To the extent permitted by law, the provisions of this Agreement shall supersede any provisions of the Uniform Commercial Code as adopted or made applicable to the Products in any competent jurisdiction. This Agreement shall not be governed by the United Nations Convention on Contracts for the International Sale of Goods, the application of which is expressly disclaimed and excluded. The courts within the Russian Federation shall have exclusive jurisdiction to adjudicate any dispute arising out of this Agreement. You agree that this Agreement is to be performed in the Russian Federation and that any action, dispute, controversy, or claim that may be instituted based on this Agreement, or arising out of or related to this Agreement or any alleged breach thereof, shall be prosecuted exclusively in the courts in of the Russian Federation and you, to the extent permitted by applicable law, hereby waive the right to change venue to any other state, county, district or jurisdiction; provided, however, that the Licensor as claimant shall be entitled to initiate proceedings in any court of competent jurisdiction.
9.2. Period for Bringing Actions. No action, regardless of form, arising out of the transactions under this Agreement, may be brought by either party hereto more than one (1) year after the cause of action has occurred, or was discovered to have occurred, except that an action for infringement of intellectual property rights may be brought within the maximum applicable statutory period.
9.3. Entire Agreement; Severability; No Waiver. This Agreement is the entire agreement between you and Licensor and supersedes any other prior agreements, proposals, communications or advertising, oral or written, with respect to the Product or to subject matter of this Agreement. You acknowledge that you have read this Agreement, understand it and agree to be bound by its terms. If any provision of this Agreement is found by a court of competent jurisdiction to be invalid, void, or unenforceable for any reason, in whole or in part, such provision will be more narrowly construed so that it becomes legal and enforceable, and the entire Agreement will not fail on account thereof and the balance of the Agreement will continue in full force and effect to the maximum extent permitted by law or equity while preserving, to the fullest extent possible, its original intent. No waiver of any provision or condition herein shall be valid unless in writing and signed by you and an authorized representative of Licensor provided that no waiver of any breach of any provisions of this Agreement will constitute a waiver of any prior, concurrent or subsequent breach. Licensor's failure to insist upon or enforce strict performance of any provision of this Agreement or any right shall not be construed as a waiver of any such provision or right.
9.4. Contact Information. Should you have any questions concerning this Agreement contact us at legal@elcomsoft.com.

© 1998-2004 ElcomSoft Co. Ltd. All rights reserved. The Product, including the Software and any accompanying Documentation, are copyrighted and protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties.


Registration

Fully registered version of Advanced Archive Password Recovery costs $60 (personal license) or $120 (business license).

Limitations on personal license: with the purchase of a personal License, the Licensee may operate the Product as set in the License Agreement for non-commercial purposes in a non-business or non-commercial environment only. Use of the Product in a corporate, governmental or business environment requires the purchase of business license.

You can place an order online using the following order form:

http://www.elcomsoft.com/purchase/buy.php?product=archpr&ref=DOC

Please note that there are some small processing charges for orders placed by fax, by check/money order or with back/wire transfer. European customers are also charged VAT. The prices listed above are valid for orders placed in US dollars only.

More information about all payment options is available at ordering page on ElcomSoft web site:

http://www.elcomsoft.com/order.html?product=archpr

On payment approval (for online orders, usually within a few minutes), we'll send you the registration key which will remove all limitations of the unregistered version.


Limitations of unregistered version

An unregistered version of ARCHPR has the following limitations:

· passwords longer than 5 (for ZIP and ARJ) or 3 (for RAR and ACE) characters cannot be recovered
· some dictionary attack options are disabled
· Password from keys attack is not available
· in ZIP known-plaintext and guaranteed WinZip attacks:
· the decryption keys are not shown, and only the first file from an archive can be decrypted
· attack cannot be resumed


Acknowledgements

Previous Top

Many people have helped make ARCHPR what it is, by making suggestions, helping test, reporting bugs, etc., but particular thanks goes to the following individuals: Irina Katalova, Alexander Katalov Jr, Dmitry Sklyarov, Alexander Volok, Marco D'Amato, John Taylor, Paolo Viappiani, Darren Parker, Richard J. Sherin. And the special thanks to Al Anway for correcting the documentation.

This product includes cryptographic software written by Eric Young.


.topic 11706
Fully registered version of Advanced Archive Password Recovery costs $60 (personal license) or $120 (business license).

Limitations on personal license: with the purchase of a personal License, the Licensee may operate the Product as set in the License Agreement for non-commercial purposes in a non-business or non-commercial environment only. Use of the Product in a corporate, governmental or business environment requires the purchase of business license.

You can place an order online using the following order form:

http://www.elcomsoft.com/purchase/buy.php?product=archpr&ref=DOC

Please note that there are some small processing charges for orders placed by fax, by check/money order or with back/wire transfer. European customers are also charged VAT. The prices listed above are valid for orders placed in US dollars only.

More information about all payment options is available at ordering page on ElcomSoft web site:

http://www.elcomsoft.com/order.html?product=archpr

On payment approval (for online orders, usually within a few minutes), we'll send you the registration key which will remove all limitations of the unregistered version.