Punto SWITCHER

Программа Punto Switcher предназначена для автоматического переключения раскладки клавиатуры. Иногда Вы забываете переключить раскладку с русской на английскую и получаете, например, «Цштвщцы» вместо «Windows» и, наоборот, не переключив раскладку клавиатуры с английского на русский, Вы получаете «Hjccbz» вместо «Россия». Теперь о переключателе клавиатуры можно просто забыть, переключение будет производиться АВТОМАТИЧЕСКИ!

Кроме этого, Punto Switcher делает много других полезных вещей, о которых Вы узнаете после ознакомления со справкой.


Внимание!

Punto Switcher является бесплатной программой без каких-либо ограничений. Совершенствование программы Punto Switcher базируется исключительно на обратной связи с пользователями, и мы ждём ваших отзывов по адресу support@punto.ru


Быстрый старт

Punto Switcher переключает раскладку (язык) автоматически, просто набирайте текст! Иногда переключение происходит сразу после набора нескольких букв, иногда программа ожидает окончания набора слова. Вот несколько правил для быстрого начала работы с программой:

Отмена и обратная конвертация - если программа произвела нежелательную конвертацию слова, просто нажмите клавишу BREAK (она обычно крайняя справа - в верхнем ряду клавиатуры) или INSERT (находится как правило над кнопкой Delete). Также Вы можете нажав BREAK конвертировать последнее слово в другую раскладку в любой момент.

Временное отключение - чтобы отключить программу на какое-то время, щёлкните по значку в системном лотке (в правом нижнем углу) и в появившемся меню выберите "Выключить". Цвет фона индикатора сменится на серый. Также допускается использование горячих клавиш.

Пользовательские правила переключения. Программа работает, используя принцип невозможности сочетаний некоторых букв для русского и английского языков. В русском языке, например, слово не может начинаться с буквы «Ь». Punto Switcher следит за тем, какие буквы на клавиатуре набираются и, если программа видит недопустимое сочетание, происходит переключение раскладки. Мы использовали словарь из нескольких миллионов слов для того, чтобы определить невозможные сочетания. Если же вдруг произойдет переключение, там, где оно не требуется (или наоборот), вы можете расширить словарь Punto Switcher в соответствии со своими потребностями (подробнее см. "Исключения в грамматике" и "Словарь пользователя").

Пароли и предотвращение переключения. Punto Switcher не переключает раскладку в стандартных системных окнах ввода паролей. Однако, в Internet Explorer и некоторых других программах, где используются нестандартные окна ввода паролей, раскладка будет переключаться. В этом случае Вы можете в конце ввода пароля нажать на любую курсорную клавишу или при нажатии Enter удерживайте клавишу Shift, и переключения не произойдёт. Это же правило можно использовать не только с паролями, а везде, где переключение не нужно.


Команды меню

По нажатию правой кнопки мыши:

Выключить/включить - временная отмена/разрешение автоматического переключения раскладки.

Разрешить звуки - временное включение/выключение всех звуков. Полезно при запуске игр и т.д.

Вести дневник - активизирует Punto Diary.

Список быстрой вставки - показывает / скрывает список быстрой вставки слов.

Буфер обмена:

  • В другую раскладку - перевод буфера обмена из символов латиницы в кириллицу и наоборот.
  • Транслитерация - представление кириллического текста буфера обмена символами латиницы;
  • Обратная транслитерация - обратный процесс (однозначного соответствия может не быть);

См. также "горячие клавиши".

Проверка орфографии - проверка орфографии буфера обмена средствами MS Word. Операция может быть длительной на медленных ПК. Исправленный текст помещается в буфер обмена.

Слова-исключения - быстрый доступ к добавке исключений.

Просмотр дневника - вызов программы просмотра дневника.

Параметры - вызов одноименного диалога.

Системные свойства - отображение системного диалога "Языки и раскладки".

О программе - вывод информации о версии и разработчиках.

Справка - отображение данной справки.

Выход - завершение работы программы.

По нажатию левой кнопки:

Список автозамены (отключаемый) - вставка любого слова из автозамены в позицию курсора.

Список языков - переключение языка в текущей программе.

Выключить/включить - то же, что в меню правой кнопки.


Список быстрой вставки

Список быстрой вставки позволяет Вам быстро заполнять формы в Интернет-броузере, таблицы Excel и другие документы с наличием часто повторяющихся фрагментов текста.

Введите нужные фрагменты текста в список автозамены, и вызовите окно быстрой вставки слов. Поместите курсор в то место, куда Вы хотите вставить текст, и щелкните по нужному пункту списка.

Опция "Прозрачный список" доступна только для пользователей систем Windows 2000 и старше и позволяет сделать окно списка полупрозрачным.


Замена стандартного переключателя

Punto Switcher выводит в панель задач индикатор раскладки клавиатуры. Это полнофункциональный индикатор, по виду аналогичный стандартному. Вы можете убрать из системного лотка стандартный индикатор, воспользовавшись Панелью Управления. Индикатор имеет серый фон, когда PS выключен. Красный цвет индикатора сигнализирует о возможной опечатке. Возможны небольшие отличия от показаний стандартного индикатора при щелчках в области системного лотка (System Tray), однако, это вызвано не ошибками в PS, а особенностями реализации стандартного переключателя раскладки.

Punto Switcher может показывать плавающий индикатор, который можно поместить в любое место экрана. Плавающий индикатор может быть закреплен на экране, для этого щелкните по нему правой кнопкой мыши и выберите "Закрепить индикатор".


Конвертация выделенного текста

Выделите текст и нажмите:

Shift + Break или Shift + F12 - перевод выделенного текста в другую раскладку (Русский <-> Английский).

Alt + Break или Shift + F12- принудительная инверсия регистра символов выделенного фрагмента ("пРИВЕТ" -> "Привет").

Alt + Scroll Lock - транслитерация выделенного текста ("Привет" -> "Privet").

См. также "Горячие клавиши"


Словарь пользователя

Вы сами можете составлять и редактировать пользовательский словарь, для этого имеется редактор словаря. Редактор словаря позволяет добавлять, просматривать и удалять Ваши пользовательские правила. Вы можете вносить как исключения, так и расширения словаря, поставляемого с программой. Просто выделите или добавьте нужный пункт, и выставьте его атрибуты.

Ручное редактирование:

Пользовательский словарь хранится в файле USER.DIC, который должен находиться в каталоге программы. Вот правила для составления словаря:

1) Каждое правило записывается в отдельной строке.

2) Если Вы просто написали сочетание букв, то при наборе слова, в которое входит это сочетание, оно будет переведено в другую раскладку. Пример: ghj.

При наборе ghjuhfvvf, ghjatccbjyfk эти слова будут переведены в "программа", "профессионал".

3) Необязательные дополнительные атрибуты, позволяющие модифицировать правило, записываются в начале строки и начинаются со знака подчёркивания (_). Атрибуты представляют собой латинские буквы "P", "B", "C" и "E", которые могут комбинироваться между собой.

Назначение атрибутов:

P - указанное в правиле сочетание и набранное на клавиатуре должны совпадать (без учёта регистра). Пример: _P еру

При вводе "еру" будет заменено на "the", но "ерунда" останется.

B - данное сочетание должно находиться в начале вводимого слова. Пример: _B vjcr

Все слова, начинающиеся с vjcr, например, "Vjcrdf", "vjcrjdcrbq" будут переведены в "Москва", "московский".

C - данный атрибут означает, что заданное сочетание должно проверяться с учётом регистра. Важно: если в правиле регистр не важен, оно должно быть написано строчными буквами, если же имеет место проверка с учётом регистра (присутствует атрибут "С"), то сочетание должно быть написано так, как оно должно вводится. Пример:

_PC ГЫФ

При вводе слово "ГЫФ" будет конвертироваться в "USA", в то время как "гыф" и "агыф" и тому подобное - не будет.

E - данный атрибут может комбинироваться с остальными и означает, что при вводе данного сочетания конвертации не произойдёт (так создаются исключения).

Словарь может создаваться с помощью диалога "Исключения в грамматике" или редактированием файла USER.DIC в текстовом редакторе (если он не существует, создайте его).


Замечания по поводу занимаемой памяти

Если Вы работаете в системах Windows NT, то наверняка обращаете внимание на показания Диспетчера Задач (Task Manager). В них Punto Switcher может занимать от 2,5 до 6 Мб памяти, однако реально память расходуется более экономно. Ядро программы и память, выделенная под словарь, занимают около 800 КБайт.

Совет: отключение звуков позволит существенно снизить расход памяти.


Полезные советы

 | Совет
1. | Чтобы эффективно использовать Punto Switcher, настройте и используйте горячие клавиши.
2. | Самый быстрый способ исправления уже набранного фрагмента текста - выделить его с помощью стрелок, удерживая Ctrl и Shift, а затем нажать горячие клавиши.
3. | Добавьте в автозамену слова, которые Вы часто пишете - e-mail адреса, инициалы, название фирмы и т.д. После этого Вы можете либо использовать сокращённые варианты этих слов, либо по горячей клавише выводить меню, в котором они будут содержаться, и вставлять длинные фразы одним щелчком мыши!
4. | Вы можете убрать стандартный индикатор языка, щёлкнув по нему правой кнопкой мыши, выбрав "Свойства" и сбросив флажок "Отображать индикатор языка на панели задач". PS способен полностью заменить его.
5. | Переключение раскладки по одной клавише очень удобно, например, по "правому Ctrl". Включить его можно на вкладке "Общие".
6. | Вы можете убрать индикатор PS с панели задач, освободив место или и установить плавающий индикатор.
7. | Те, кто стремятся сократить расход памяти, могут отключить звуки.
8. | Для того, чтобы настроить правила транслитерации PS под себя, отредактируйте текстовый файл translit.dat, находящийся в каталоге PS.
9. | При навигации по справке выделяйте пункты курсорными клавишами, и нажимайте Enter для их отображения.
10. | Если озвучивание клавиш мешает Вам в некоторых программах, Вы можете временно выключить все звуки.
11. | При установке новой версии PS перепишите файлы, оставшиеся в каталоге программы от прошлой версии, в каталог новой версии. Это сохранит Ваш пользовательский словарь, списки автозамены и программ-исключений.


Благодарности

Над программой Punto Switcher работали и работают:

Сергей Москалев (Москва)

Михаил Морозов (Сан-Диего)

Александр Коуров (Печоры)

Дмитрий Долгов (Санкт-Петербург)

Спасибо всем, кто прислал нам замечания об ошибках и особенно - советы по дальнейшему развитию программы. Всем приславшим нам письма будут приходить уведомления о выходе новых версий!

Особая благодарность Сергею Быкову, автору программы RusLat, за полезную информацию.

Благодарим Вячеслава Родионова (real_kenny) (Ангарск), указавшему нам путь решения некоторых проблем с Windows Vista

Спасибо за помощь!

Фарберу Вячеславу, пос. Кокошкино, Московская область.

Павлову Р.В., г. Москва.

Семёнову П., г. Серпухов.

Швецу Д.Я., г. Новосибирск.

Букреевой С.Л., пос. Краснообск, Новосибирская область.

Юсовой Виктории, г. Санкт-Петербург.

Никитову П.Ю., г. Тверь пос. Химинститута.

Вайнберг Диане, г. Москва (компания CRN).

Трефняку Василию, г. Москва.

Захаренко Денису, п. Верхне-Брянский, Смоленская область.


Возможные проблемы и их решение

№ п/п | Проблема | Причина | Решение
1. | Программа не работает в Windows Vista, например, в IE7 | Необходимо отключить UAC. | Отключение UAC при помощи программы msconfig. Войдите в меню Пуск-Выполнить и напечатайте msconfig в окошке, затем нажмите на клавиатуре клавишу Ввод (Enter). Затем выберите вкладку Tools в разделе System Configuration. Найдите функцию Disable UAC и выберите её. Перезагрузите компьютер.
2. | Программа пытается соединиться с Интернет. | Включена проверка обновлений. | Выключите эти опции, если они вам не нужны.
3. | Программа блокирует некоторые клавиши на клавиатуре. | В горячих клавишах выбрана эта клавиша без Ctrl, Alt, Shift или Windows. | Настройте горячие клавиши.
4. | Конвертация выделенного текста не работает в некоторых программах. | Программы не поддерживают копирование в буфер обмена по Ctrl+C и вставку по Ctrl+V. | Если возможно, настройте данную программу на данные комбинации.
5. | Программа не запускается, не выдавая никаких сообщений, или выдаёт сообщение "Несовпадение версий correct.dll и ps.exe". | Возможно, при установке поверх предыдущей версии не была перезаписана correct.dll. | Удалите текущую версию программы и переустановите программу.
6. При наборе текста происходит двойное нажатие Enter или Tab. Особенности реализации приложения.

Попробуйте выяснить, какие приложения конфликтуют с Punto Switcher, посмотрите, что загружается с ним при старте системы.

Если конфликт не обнаруживается, поставьте в диалоге "Параметры" на вкладке "Устранение проблем" флажок "Не переводить по Tab и Enter".
7. Переключение раскладки происходит не всегда, или не исправляется первая буква. Конфликт с переключателями типа RusLat или Switch It!, другими программами типа Lingvo или Socrat.

Оставьте тот переключатель, который Вас больше устраивает. В случае других программ напишите разработчикам этих программ и разработчикам PS.

Попробуйте также поменять положение переключателя "Альтернативный перехват клавиатуры" на вкладке "Устранение проблем".
8. | Не происходит переключение раскладки в FAR и других консольных приложениях. | Эта возможность реализована только для систем NT. | Подумайте о переходе на современные ОС.
9. | Нет переключения раскладки в консоли по Tab и Enter. | Переключение по Tab и Enter работает только в графическом интерфейсе. | PS не ориентирован на работу в консоли. Некоторая её поддержка введена по просьбам пользователей.
10. | Не происходит автоматическое переключение раскладки в DOS приложениях Windows NT, индикатор показывает смену раскладки, но язык ввода не меняется. | Поддерживаются только консольные 32-разрядные приложения. В случае DOS - приложений меняется текущая раскладка эмулятора DOS, но не программы. | Времена DOS ушли навсегда. Punto Switcher не будет поддерживать DOS-приложения.
11. | Программа не запускается из автозагрузки или запускается, но не работает. | Снимите в параметрах флажок "Запускаться при старте" и поместите ярлык программы в Автозагрузку вручную. Попробуйте также поменять положение переключателя "Альтернативный перехват клавиатуры".
12. | Punto Switcher часто исправляет сокращения, которые Вы используете. | Отсутствие этих сокращений в словаре. | Попробуйте занести их в словарь и послать разработчикам. Также можно включить опцию "Не исправлять аббревиатуры".
13. | Другая проблема. | Напишите письмо разработчикам.


Обратная связь

Замечания по поводу обнаруженных в программе ошибок, своё мнение и советы просим присылать по адресу: support@punto.ru

Мы будем благодарны любым Вашим замечаниям!

Веб-сайт программы: http://www.punto.ru


Проверка обновления

Мы понимаем, что нет предела совершенству, и надеемся постоянно улучшать правила и саму программу. Поэтому мы предусмотрели возможность легкого обновления Punto Switcher.

Проверка наличия новой версии: щелкните на ссылке "Проверить обновление" в окне "О программе" или проверьте его прямо сейчас.

Когда вы выбираете "Проверить обновление", Вы попадаете на домашнюю страничку Punto Switcher. Если версия программы более новая, есть смысл ее установить. Также мы настоятельно рекомендуем использовать опцию автоматической проверки обновления.


Параметры

Диалог параметров вызывается щелчком по индикатору правой кнопкой мыши, пункт "Параметры". В левой половине окна находится дерево, при выборе ветвей которого отображаются различные вкладки диалога. Параметры по умолчанию вполне разумны, однако, Вы можете настроить Punto Switcher под свои привычки. Мы постарались сделать процесс настройки максимально простым.


Общие

Запускаться при старте - если в этом разделе стоит галочка, то программа будет запускаться вместе с Windows.

Проверять обновления - когда эта опция включена, программа периодически, когда вы находитесь в Интернет, один раз в два дня проверяет домашнюю страничку программы Punto Switcher на наличие обновления, и, если оно найдено, предлагает загрузить новую версию. Если вы не имеете доступа к Интернет, то проверка не производится.

Разрешить слежение за буфером обмена - при включении опции PS запоминает 15 последних текстов буфера. Позже они могут быть выбраны из меню и вставлены в приложение. Назначьте горячую клавишу для показа меню истории буфера обмена.

Менять цвет значка при опечатках - при включении данной опции Punto Switcher будет окрашивать свой значок в ярко-красный цвет и производить звук когда, по его мнению, произошла опечатка. Это не замена проверке орфографии, и будет обнаружена далеко не каждая опечатка, но если PS всё же её обнаружил, то она с большой вероятностью имеет место.

Не исправлять аббревиатуры - эта опция может пригодиться, если Вы часто вводите слова-аббревиатуры или сокращения, и Punto Switcher напрасно переключает раскладку. Альтернативный путь - ввести эти слова как исключения, или послать их разработчикам.

Исправлять две прописные буквы в начале слова - при наборе такого слова, в том числе и в другой раскладке, оно будет автоматически исправлено.

Исправлять случайное нажатие CAPS LOCK - если включен CAPS LOCK, и набрано слово со строчной первой буквой и прописными остальными, оно будет автоматически исправлено.

Не показывать значок в системном лотке - при старте Punto Switcher не будет выводить значок в системный лоток. Для показа значка запустите программу ещё раз.

Вывести плавающий индикатор - при выборе этой опции индикатор текущей раскладки можно будет перемещать мышкой по экрану. Установите его в удобное положение, и при следующем запуске программы он будет находиться там же. Чтобы не дублировать индикаторы, выводимые PS, Вы можете выбрать опцию Не показывать значок в системном лотке. Плавающий индикатор может быть закреплен на экране, для этого щелкните по нему правой кнопкой мыши и выберите "Закрепить индикатор".

Скрывать плавающий индикатор после смены раскладки - плавающий индикатор будет виден в течение двух секунд после смены раскладки. Эта опция поможет Вам освободить дополнительное экранное пространство.

Отображать всплывающие подсказки - включает вывод всплывающих подсказок при автозамене и коррекции случайного нажатия Caps Lock или коррекции двух первых прописных букв.

Использовать Scroll Lock как Caps Lock - если Вы выберите переключение раскладки по Caps Lock, то Scroll Lock сможет заменить её.

Не отключать горячие клавиши при выключенном PS - если Вам мешает то, что горячие клавиши срабатывают, когда выключена автокоррекция языка (например, в играх), включите эту опцию. Punto Switcher будет "выключаться" полностью.

Показывать полезные советы (только для 2000/XP) - при включенной опции в данных ОС через минуту после запуска PS будет показано всплывающая подсказка с полезным советом.

При входе в меню с клавиатуры включать язык меню - при нажатии клавиши Alt, если в окне есть стандартное меню, будет проанализирован язык символов меню, и на основании анализа включена соответствующая раскладка. Опция полезна для ускорения доступа к меню по горячим клавишам (так как отпадает необходимость переключать раскладку). Если в программе используется нестандартное меню, опция работать не будет.

Показывать результаты конвертирования буфера - показ результатов конвертирования буфера обмена в отдельном всплывающем окне.

Переключение раскладки по... - раскладка клавиатуры будет переключаться при нажатии на клавишу, которую можно выбрать из списка. Поддерживаются обе Ctrl и обе Shift, а также Caps Lock. Раскладку переключает лишь короткое нажатие, Вы можете удержать клавишу, чтобы избежать переключения (исключение - Caps Lock).

Только русский/английский - при использовании нескольких раскладок, основными из которых являются русская и английская, Вы можете сделать так, что по выбранной клавише будет происходить переключение только между этими двумя раскладками, а, к примеру, по Ctrl + Shift будет происходить перебор всех раскладок.

Единая раскладка - для всех приложений в системе раскладка клавиатуры будет одинаковой, такой, какой Вы её последний раз выбрали при помощи PS. Опция работает лишь при переключении раскладки по одной клавише. При активизации приложения Punto Switcher включит требуемую раскладку за Вас.

Разрешить ... - включение режима "Левый Shift - русская, правый Shift - английская раскладка" и т.п. Другие раскладки в текущей версии не поддерживаются.


Автозамена

Здесь Вы можете задать сокращения, которые Punto Switcher будет "разворачивать" за Вас. К примеру, "СНП" можно будет автоматически преобразовывать в "С наилучшими пожеланиями". При наборе сокращённого слова рядом появится подсказка, показывающая полную фразу (ее появление можно отключить). Слова могут разворачиваться по нажатию Enter, Tab или пробел.

Флажок "Быстрая вставка слов из автозамены через меню левой кнопки мыши" позволяет показать список полных фраз по щелчку левой кнопки мыши на значке программы. При этом Вы можете вставить длинную фразу в текст одним щелчком мыши! Также можно воспользоваться горячей клавишей.

Флажок "Заменять даже при наборе в другой раскладке" активизирует автозамену, даже если Вы набираете сокращение на другом языке.


Горячие клавиши

Все горячие клавиши являются полностью настраиваемыми (за исключением комбинаций с Break, жёстко заданными из-за особенностей реализации). Вы можете задать любую клавишу в комбинации с Shift, Ctrl, Alt или Windows. Отключить любую комбинацию можно, нажав Backspace в поле её ввода.

  1. Включить / выключить автокоррекцию раскладки - данная комбинация эквивалентна команде "Включить / выключить" в меню.
  2. Показать историю буфера обмена - вывод меню, каждая строка которого соответствует тексту буфера обмена, который запомнил PS. Запоминается 15 последних текстов. Выберите строку для вставки ее в приложение.
  3. Сменить раскладку буфера обмена - буфер обмена будет переведён из символов английского языка в русские и наоборот.
  4. Показать / скрыть Список Быстрой Вставки - аналог команды Список быстрой вставки в главном меню.
  5. Записать выделенный текст в дневник - запись в Дневник текста выделенного текста. Опция полезна для собирания текстовой информации в одном месте. Сброс текста в дневник сопровождается кратковременным изменением цвета индикатора на зеленый.
  6. Записать выделенный текст в буфер обмена - то же, что предыдущая опция, но запись буфера обмена.
  7. Включить / выключить все звуки - иногда включенное озвучивание клавиш может мешать Вам, к примеру, в играх. Нажатие этой клавиши временно выключит все звуки. Повторное нажатие восстановит их.
  8. Показать меню быстрой вставки слов - при нажатии комбинации выводится меню, содержащее полные фразы, введённые Вами в диалоге "Автозамена". Выберите фразу, и она вставится в текст!
  9. Транслитерация буфера обмена - кириллические символы буфера обмена будут переведены в латиницу по правилам, хранящимся в файле translit.dat. Вы можете редактировать его при необходимости изменения правил транслитерации.
  10. Обратная транслитерация буфера обмена - преобразование текста из транслита в кириллицу.
  11. Быстрый вызов диалога "Параметры" - вызывает диалог "Параметры". Может быть полезно некоторым пользователям.
  12. Быстрый вызов диалога "Автозамена" - вызывает диалог "Параметры", с активной вкладкой "Автозамена".
  13. Система: свернуть окно - быстрое сворачивание активного окна.
  14. Система: развернуть / восстановить окно" - быстрая максимизация или восстановление активного окна.

Также Вы можете использовать следующие сочетания:

Break или F12 - отмена переключения или принудительное переключение раскладки.

Shift+Break или Shift+F12 - перевод выделенного текста в другой язык (цштвщцы - windows).

Alt+Break или Alt+F12 - инвертирование регистра выделенного текста (пРИВЕТ ВСЕМ - Привет всем).


Звуки

Вы можете озвучить индивидуально каждое событие в Punto Switcher. Поддерживается воспроизведение WAV-файлов и встроенный динамик, на котором можно воспроизводить звуки разной частоты.

Нажатие клавиш (русский, английский) - часто при использовании лэптопа можно заметить, что клавиши не производят привычного клика, как это бывает на больших клавиатурах. Если эта опция включена, Вы услышите негромкий клик при каждом нажатии на клавишу. Допускается задавать различные звуки для русской и английской текущих раскладок, можно задать и один звук, выбрав один и тот же файл.

Автоматическое переключение раскладки - когда вы печатаете, не глядя на экран, а так поступают многие, и происходит автоматическое переключение раскладки, вы слышите сигнал переключения.

Опечатка - при включении данной опции Punto Switcher будет издавать звуковой сигнал тогда, когда, по его мнению, произошла опечатка. Это не замена проверки орфографии, и звуковой сигнал будет издаваться не при каждой опечатке, но если Вы всё же его услышали, то опечатка наверняка имеет место.

Переключение на русский - звуковой сигнал при ручной активизации русской раскладки.

Переключение на английский - звуковой сигнал при ручной активизации английской раскладки.

Отмена конвертации (BREAK) - звуковой сигнал при нажатии BREAK.

Конвертирование выделения (SHIFT + BREAK) - звуковой сигнал при конвертировании выделенного текста.

Конвертирование буфера обмена, исправление двух прописных букв, исправление случайного нажатия CAPS LOCK и др. - звуковой сигнал при данных операциях.

Punto Switcher поставляется с ограниченным набором звуков для сокращения объёма поставки. Мы рекомендуем Вам самостоятельно задать индивидуальные звуки для каждого пункта. Взять их Вы можете из стандартных тем Windows.


Устранение проблем

Если Punto Switcher часто напрасно переключает раскладку при редактировании ранее введённых слов (исправляет окончания, к примеру), установите галочки в строках с нужными клавишами. Если непосредственно перед вводом слова были нажаты эти клавиши, Punto Switcher не будет переключать раскладку. Однако, возможно снижение общего показателя качества автоматического переключения. Выберите то, что Вам удобнее.

Не реагировать на набор слов на других языках - если Вы используете какие-либо раскладки клавиатуры помимо "Русский" и "Английский, США", то при наборе слов на других языках Punto Switcher может некстати переключать раскладку. Выбор этой опции заставляет PS отслеживать ввод только на двух основных для него языках. См. также "Утилита настройки раскладок".

Не переводить по Tab и Enter - включите эту опцию, если у Вас Punto Switcher вызывает двойное нажатие Enter, или есть проблемы с функцией "Автотекст" в WinWord.

Прекращать слежение за системой при выключенном PS - включите, если вы замечаете, что выключенный PS сильно нагружает процессор, например, в играх с интенсивным использованием клавиатуры. Учтите, что горячие клавиши конвертации текста в этом случае работать не будут.


Грамматика

Данный диалог используется для того, чтобы указать программе, на каких словах нужно переключать раскладку, а на каких наоборот, не нужно.

В первом случае включите галочку "Переводить слово в другую раскладку", во втором снимите её. Введите слово, которое вызвало проблемы, и укажите необходимы значения. Будьте внимательны, желательно выделить из слова характерную часть без окончания и т.д. и добавить именно это сочетание. Подумайте, может ли это сочетание быть в начале слова, в произвольном месте. Лучшее решение - послать слово, вызвавшее проблему, разработчикам, чтобы оно было добавлено в словарь следующих версий.

"Учитывать регистр" - при анализе будут различаться прописные и строчные буквы.

"Послать сочетание разработчикам" - при включенном флажке, при нажатии на кнопку "Добавить", запустится почтовая программа. Вам останется только вставить текст письма из буфера обмена и отправить письмо разработчикам.

"Показывать это окно при отмене переключения" - как только Вы нажмёте клавишу отмены автоматического переключения, откроется окно добавления исключений.

См. также "Словарь пользователя".


Программы

В этот список Вы можете поместить программы, в которых Вы всё время выключаете PS. Когда одна из таких программ станет активной, Punto Switcher выключится автоматически.

Вы можете задавать программы по файлу приложения или заголовку окна, для чего выберите соответствующую вкладку.

На вкладке "По файлу приложения" при нажатии кнопки "Добавить" появляется всплывающее меню. Кнопка "Обзор" позволяет выбрать нужную программу в стандартном диалоге. Пункт "Запущенные программы" содержит список текущих процессов, что удобно при добавлении запущенной программы.

На вкладке "По заголовку окна" при нажатии на кнопку "Добавить" появляется новый пункт в списке заголовков окон. Введите требуемый заголовок окна или его часть, и, когда окно с таким заголовком станет активным, PS выключится автоматически. Регистр символов в заголовке окна учитывается.

Кнопка "Изменить" позволяет отредактировать выделенный пункт списка.


Параметры Дневника

Выбор опции "Вести дневник" включает запись набираемых на клавиатуре текстов в дневник Punto Switcher (аналогична одноименной опции в меню значка программы).

Вы можете включить автосохранение в Дневнике содержимого буфера обмена, включив соответствующую опцию.

Опция "Не сохранять в дневнике записи, которые содержат менее..." предназначена для фильтрации содержимого дневника, ведь, как правило, одиночные слова и короткие фразы не содержат осмысленной информации. Если строка записи дневника (записью считаются слова, набранные без переключения в другое окно) содержит меньшее количество слов, она не будет внесена в дневник. По умолчанию в дневник не вносятся одиночные слова (менее двух). Эта же опция может предотвратить нежелательную запись паролей в дневник.

Опция "Не вести дневник в программах - исключениях" выключает Дневник в тех программах, которые заданы в списке исключений.

Кнопка "Просмотр дневника" вызывает программу просмотра.


Дневник Punto Diary

Начиная с версии 2.0, в Punto Switcher встроена возможность ведения дневника, состоящего из информации, набираемой на клавиатуре. Дневник создан с целью помочь Вам в организации, хранении и упорядочивании личной информации.


Назначение

Дневник Punto Diary разработан с целью помочь Вам сохранить и упорядочить текстовую информацию, которую Вы ежедневно набираете на клавиатуре и не сохраняете. Это может быть полезно для цитирования в будущем: забытого разговора, переписки в форумах и чатах, восстановления текста после сбоя редактора или необратимого изменения документа и т.д.

Предоставляются следующие возможности:

  • Запись в дневник информации, набираемой на клавиатуре;
  • Запись выделенного текста в дневник нажатием горячих клавиш;
  • Выборочный просмотр информации за любой период;
  • Удаление и редактирование записей;

Дневник может быть отключен по желанию пользователя. Пользователь сам выбирает с какого колличества слов дневник будет запоминать текст и вносить его в Дневник.


Работа с дневником

При включении дневника Punto Switcher отслеживает ввод с клавиатуры и записывает его в файл на диске. Запись производится при смене активного окна. Каждая запись включает имя приложения, в котором был набран текст и дату набора. Заголовок окна и другие данные не включаются в дневник для обеспечения приватности.

Для включения дневника установите флажок "Вести дневник" в меню или одноименный флажок на вкладке "Дневник" в диалоге "Параметры".

Опция "Не сохранять в дневнике записи, которые содержат менее..." предназначена для фильтрации содержимого дневника, ведь, как правило, одиночные слова и короткие фразы не содержат осмысленной информации, а часто являются паролями. Если запись дневника (слова, набранные без переключения в другое окно) содержит меньшее количество слов, она не будет внесена в дневник. По умолчанию в дневник не вносятся одиночные слова (менее двух).

Кнопка "Просмотр дневника" вызывает программу просмотра.

Интерфейс программы выполнен в виде календаря, в котором Вы можете выделить мышью день или диапазон дней. В нижней части окна программы будут показаны записи дневника за выделенные дни.

Назначение кнопок программы просмотра:

"Сохранить как" - сохранение текущей информации, показанной в окне просмотра, в файл формата HTML;

"Поиск" - вызывает стандартное окно поиска текста в текущем документе;

"Удалить показанные записи" - удаление из дневника информации, которая в данный момент показана в окне просмотра;

"Очистить Дневник" - удаление всех записей;

"Закрыть" - выход из программы просмотра;

"Показать весь дневник" - просмотр всех записей дневника. Календарь в этом случае становится неактивным.

Для полного использования дневника Вы можете выбрать горячую клавишу "Записать выделенный текст в дневник".


Утилита настройки раскладок

Данная программа призвана помочь пользователям, у которых установлены раскладки клавиатуры, отличные от "Английский (США)" и "Русский". Они могут указать, какие раскладки Punto Switcher должен использовать вместо вышеприведённых. См. подробное описание.


Утилита настройки раскладок

Программа запускается из главного меню (кнопка "Пуск" -> "Программы"), группы "Punto Switcher". После запуска Вы увидите список раскладок, установленных в Вашей системе. Если у Вас установлены языки "Английский (США)" и "Русский", в строке состояния будет предупреждение о ненужности настройки. Мы советуем Вам внять ему.

Если же у Вас действительно есть проблема с раскладками, по очереди выделите пункты списка и укажите, какую раскладку использовать вместо русской, а какую вместо английской. В остальных пунктах поставьте переключатель в положение "Не использовать". После этого нажмите кнопку "Применить", и перезапустите Punto Switcher.

Вы можете попробовать установить, к примеру, украинскую раскладку вместо русской. К сожалению, текущая версия привязана к двум языкам - русскому и английскому и мы не гарантируем корректное переключение при использовании других языков.